Introduzione

 Top Next

Grazie per aver scelto Hard Disk Sentinel, un'applicazione necessaria per controllare i dischi. Infatti viene monitorato il loro stato di salute e la loro temperatura.

In particolare, può prevedere possibili problemi o degrado delle prestazioni.

Tutto questo al fine di evitare spiacevoli perdite di dati: ovvero tempo e denaro.

Si prega di leggere questa documentazione con attenzione.

Nei vari capitoli vengono descritte tutte le caratteristiche e le funzionalità di Hard Disk Sentinel.

Note:

Agl'Utenti esperti/avanzati si consiglia l'utilizzo della guida in inglese per evitare errate interpretazioni dovute a traduzione imprecisa.

In caso di errata traduzione, refusi, o dubbi, potete contattarmi a questo indirizzo.

Traduzione del 30.04.2008: Hard Disk Sentinel vers. 2.40

Tradotto da Luciano


Hard disks

 Top Previous Next

Il sistema dischi di un computer, in pratica, è composto da uno o più unità fisiche. Le testine di lettura/scrittura, che non appoggiano sulla superficie del disco ma 'volano' su di essa, effettuano le operazioni di lettura,scrittura e cancellazione.

Per ottimizzare l'utilizzo dello spazio del disco, i dati sono memorizzati in piccolissime unità di superficie del disco. Un qualsiasi danneggiamento ( anche microscopico) della superficie aumenta di molto il pericolo di non poter accedere ai dati su di esse memorizzate. Per limitare questi inconveniente e per preservarlo dall'umidità, il disco è chiuso ermeticamente.

Non sempre le operazioni del disco si completano senza errori. E' possibile che certe porzioni (settori) della superficie del disco non siano più leggibili o scrivibili a causa, appunto, di piccoli danneggiamenti. In questo caso, il disco segna questi settori come non utilizzabili e in modo che, in futuro, non siano più utilizzati per qualsiasi operazioni di lettura o di scrittura. Se avvengono errori di lettura su un settore, il disco tenta più volte di leggere e di copiare i dati in zone speciali di riserva. Dopo il completamento del processo, tutte le operazioni future al settore/i danneggiato verranno deviate verso la zona di riserva. L'area con problematiche non verrà più utilizzata fino a una nuova formattazione.

Tutte questi tentativi, sono trasparenti all'utente ovvero non riceve nessun allarme ma di fatto lo stato del disco è degradato fino a raggiungere la perdita di dati.

Altri fattori che creano il degrado del disco sono l'alta temperatura, l'alimentazione non corretta, shock meccanici le vibrazioni. Molti di questi problemi possono essere catturati con l'ausilio di Hard Disk Sentinel e quindi prevenire problemi irreparabili.

S.M.A.R.T.

S.M.A.R.T. (Self-Monitoring Analysis and Reporting Technology) è stato introdotti dall' IBM® per poter monitorare lo stato dei dischi usando diversi metodi e unità. Un disco ATA può offrire fino a 30 valori (attributi) di misurazione. Molti di questi attributi hanno un' impatto diretto o indiretto sullo stato di salute del disco, altri offrono solo informazioni di carattere statistico.

Oggi tutti i moderni dischi seriali IDE, ATA/SCSI offrono la tecnologia S.M.A.R.T. E' da mettere in evidenza che non si tratta di uno standard, infatti alcuni parametri hanno un significato diverso da produttore a produttore. Per questo è necessario un software di analisi neutro, come Hard Disk Sentinel, per monitorare lo stato dei dischi ( vedi anche sezione : metodo di calcolo ).

La maggioranza degli attributi sono usati da tutti i produttori e hanno (quasi) sempre il medesimo significato. Per questo è possibile, per esempio, controllare la temperatura o il tempo di funzionamento di quasi tutti i dischi. Questi e molti altri attributi sono controllati da Hard Disk Sentinel.

Quando è rilevato un problema si dovrebbe provvedere immediatamente al salvataggio dei dati. Purtroppo non sempre si fa in tempo a eseguire l'operazione di backup: ecco perché è necessario, grazie al monitoraggio degl'attributi S.M.A.R.T., avere informazioni sullo stato di salute del disco il più presto possibile prima che sia ...troppo tardi.

Note: qualche controller dischi o unità, non sono in gradi di esaminare i valori S.M.A.R.T.. In questi casi, lo stato di salute, la temperatura o altri valori non possono essere determinati .Si prega di contattare il produttore del controller per verificare se è necessario un aggiornamento del firmware. Non è possibile determinare lo stato S.M.A.R.T. di unità esterne USB/Firewire e di dischi RAID.


Funzionalità dell'applicazione

Le principali funzionalità di Hard Disk Sentinel sono descritte in queste sezioni:

•

La finestra di stato.

•

Icone in systray.

•

Icone disco

•

Menù veloce.

•

Finestra principale.

•

Configurazione

•

Configurazione delle operazioni (disponibile solo nella versione PROFESSIONAL)


Finestra di stato

Dopo l'installazione e l'avvio del programma, questa finestra viene visualizzata automaticamente sullo schermo nell'angolo in alto a destra . Essa contiene il modello, la temperatura e la condizione di dischi installati. Per poter avere sempre in vista le informazioni dei dischi, la finestra è sempre in primo.

•

Quando si posiziona il mouse su questa finestra, viene evidenziata una piccola icona nell'angolo in alto a destra: cliccando sui di essa con il tasto sinistro la finestra di stato viene chiusa.

•

Se si clicca con il tasto sinistro dentro la finestra di stato, viene visualizzata la lista dei dischi logici ( partizioni ) con il relativo spazio usato/libero. Ora se si clicca su una partizione, viene aperta automaticamente la relativa finestra di gestione del computer. Il successivo click sulla finestra di stato, chiude la lista delle partizioni.

•

Tenendo cliccato il tasto sinistro dentro la finestra, è possibile spostarla in un'altra posizione dello schermo. Di default, la finestra non può essere mossa fuori dallo schermo ma questa limitazione può essere rimossa qui.

•

Con un doppio (sinistro) click, si apre la finestra la finestra principale - sezione avvisi.

•

Usando il tasto destro, sull'icona in systray viene proposto il menù veloce.

Nota:

Si può scegliere quali informazioni visualizzare nella finestra di stato. Se si effettuano modifiche riguardo il tipo dei parametri da visualizzazione, queste verranno prese in considerazione solo quando verrà riattivata di nuovo la finestra di stato.


Icone in systray

In basso a destra dello schermo (vicino all'orologio), c'è l'icona di Hard Disk Sentinel. Essa può visualizzare lo stato dei dischi. Dopo l'installazione, è mostrata un'icona con la temperatura per ogni disco (ovviamente se il disco può fornire questo attributo!). L'applicazione fornice la temperatura tramite vari colori / a seconda del valore: fino a 40 gradi Celsius in verde, tra i 40 e 50 in giallo, oltre in rosso. Le soglie e colori possono essere variati a seconda delle preferenze dell'Utente.

Quando ci sono due o più dischi, non è chiaro a quali si riferiscono le temperature: per togliere ogni dubbio passare con il mouse sull'icona in systray in questo modo verrà evidenziato il numero, il modello, a temperatura e lo stato del disco a cui si riferiva.

Se si fa un doppio click con il tasto sinistro sull'icona in systray si apre la finestra principale di Hard Disk Sentinel con tutti i dettagli dei dischi installati.

Mentre cliccando con il tasto destro sull'icona, viene aperto il menù veloce con le funzioni più usate.


Icone disco

Tramite le icone relative alle partizioni, Hard Disk Sentinel visualizza costantemente lo stato dei dischi (stato di salute che può essere eccellente, buono, pessimo) e lo spazio usato. In questo modo, da un'applicazione ( per esempio: risorse del computer ) si può tener sott'occhio velocemente e facilmente lo stato del disco.

Questa caratteristica è particolarmente utile nel caso si disponga di più partizioni logiche o se non viene utilizzata la finestra d stato. La barra è suddivisa virtualmente in 16 gradazioni ovvero una gradazione rappresenta 1/16 dello spazio totale della partizione. Quando lo spazio usato va oltre certi livelli la barra passa da verde a giallo quindi a rosso.

Nota: Il controllo dello spazio usato dipende dall'impostazione delle soglie dello spazio usato . E' possibile impostare una soglia per ogni unità logica. Più alta è la soglia impostata, più rapidamente la barra raggiungerà la zona gialla rossa.

Nella parte destra, in basso, è visualizzato un simbolo che rappresenta lo stato del disco. Di default, questo simbolo è verde se lo stato è maggiore del 50%. Tra il 25% e il 50% diventa giallo con un punto esclamativo, infine se il valore è minore del 25% il simbolo diventa rosso. Si evidenzia che tali soglie possono essere configurate.

Nota: Si ricorda che il simbolo dello stato del disco è visualizzato solo con quei dischi che supportano la tecnologia S.M.A.R.T. in particolare la gestione dello stato. Con le unità esterne (USB/Firewire) o con i dischi remoti, è possibile visualizzare solo le informazioni relative allo spazio. (Questa opzione è disabilitata di default ma può essere abilitata nella sezione controllo disco nella Configurazione. Lo stato di salute non viene gestito in ambiente Windows 98/98SE/ME.

Per poter visualizzare lo stato corrente dei dischi è necessario controllare periodicamente lo stato di salute e lo spazio usato. In caso di unità lente ( per esempio, particolari tipi di card readers o di unità di rete) il tempo di acquisizione dei attributi può essere eccessivo causando un rallentamento dell'applicazione o del sistema operativo. In questi casi, questa opzione dovrebbe essere totalmente o parzialmente disabilitata per queste unità. Questo può essere configurata nella sezione controllo disco.

Hard Disk Sentinel dovrebbe essere sempre attivo in modo da poter visualizzare ovvero controllare lo stato dei dischi e lo spazio usato. Se Hard Disk Sentinel non è attivo, ovviamente queste informazioni non possono essere visualizzate.


Menù veloce

Questo menù è visualizzato se si fa un click (tasto destro) sulla finestra di stato o sull'icona in systray. Con questo menù è possibile:

•

Visualizzare/ nascondere la finestra di stato (vedi configurazione).

•

Aprire la finestra di configurazione per impostare le opzioni del programma.

•

Visualizzare l'andamento della temperatura del disco.

•

Visualizzare informazioni dettagliate degl' hard disk.

•

Visualizzare la guida.

•

Visualizzare le info riguardo l'applicazione quali: versione installata, il nome dell'Utente registrato, un link al sito del Produttore di Hard Disk Sentinel e il nome e l'indirizzo email di chi ha effettuato la traduzione dell'interfaccia.

•

Abilitare /disabilitare gli avvisi acustici nella sessione corrente. Se nella finestra degl'allarmi sono stati abilitati gli avvisi acustici, allorché succede un evento (per esempio, alta temperatura, spazio libero basso, ecc) l'applicazione emette un suono acustico. Opzione: l'allarme acustico può essere continuo fino a quando l'Utente, messo al corrente del problema, disabilita l'allarme con questo menù breve o tramite il pulsante apposito nella finestra principale. Usando questa opzione, gli allarmi sono disabilitati per questa sessione. Dopo il riavvio dell'applicazione, gli allarmi acustici sono ripristinati di nuovo. Si consiglia di usare questa opzione invece di disabilitare gli avvisi acustici nella pagina allarmi

•

Chiudere Hard Disk Sentinel. L'applicazione viene chiusa e termina il monitoraggio dello stato dei dischi.

Nota: Al prossimo rivvio, l'applicazione analizza i cambiamenti avvenuti dopo l'ultima esecuzione. In sintesi, anche se Hard Disk Sentinel viene eseguito di tanto in tanto, esso può verificare ugualmente lo stato dei dischi e il loro eventuale degrado.


Finestra principale

Dalla finestra principale di Hard Disk Sentinel è possibile accedere a tutte le funzionalità e funzioni tramite degli appositi menù o pulsanti .

Il menù principale ha le seguenti opzioni:

•

File: da questo è possibile chiudere Hard Disk Sentinel.

•

Menù: è possibile selezionare quale finestra di informazioni dell'hard disk si vuole visualizzare.

•

Report: è possibile salvare o inviare via email un report completo in formato testo o HTML. Per le impostazione riguardanti l'email (destinatario, mittente ecc. ) si rimanda alla relativa finestra.

•

Configurazione: tramite questo menù è possibile impostare tutte le opzioni del programma.

•

Guida: viene visualizzata la guida corrente o le info relative al programma.

Quando si pone il mouse su un pulsante, la funzione relativa viene mostrata. Tramite i pulsanti è possibile effettuare le seguenti funzioni:

•

re-esaminare lo stato di tutti gli hard disks, indipendentemente dalla frequenza di controllo impostato.

•

abilitare / disabilitare glia allarmi.

•

nascondere o mostrare la finestra di stato.

•

salvare un report completo. Nella finestra messaggi (rif. configurazione) si può impostare il formato di salvataggio ( testo o HTML).

•

inviare un report completo via e-mail. Nella finestra messaggi (rif. configurazione) si può impostare il formato di salvataggio ( testo o HTML)

•

aprire a finestra configurazione.

•

disabilitare/abilitare gli allarmi sonori per la sessione corrente. Se è impostato l'opzione "Ripeti avviso acustico", tramite questo pulsante è possibile confermare o disabilitare gli allarmi acustici.

•

aprire la guida corrente.

•

visualizza le info del programma.

Nella parte sinistra della finestra, in alto sono riportati i dischi fisici installati mentre in basso sono visualizzate le partizioni logiche. Le linee di divisione tra queste aree (pannelli) possono essere personalizzare (spostate) a piacimento. Se si clicca con il tasto sinistro un'unità fisica o logica, vengono visualizzate le relative informazioni dettagliate sulla parte destra.

Il pannello contenente la lista delle unità viene aggiornata in continuazione per questo i valori della temperatura, condizione o dello spazio libero rispecchiano esattamente i valori reali.

Nota:

L'applicazione memorizza la posizione dei vari pannelli per cui la prossima volta che viene aperta la finestra principale, i pannelli hanno già le dimensioni desiderate.

Sul pannello di destra sono visualizzate informazioni dei dischi fisici o delle partizione logiche


Informazioni dischi fisici

Vengono riportate diverse informazioni relative al disco fisico. E' possibile visualizzarle, selezionando la tab relativa nella finestra principale

.

· Sommario
· Temperatura
· S.M.A.R.T.
· Informazioni
· Avvisi
· Prestazioni
· Allarmi


Sommario

Sono visualizzate le prestazioni e lo stato del disco selezionato. (se si clicca sui uno dei due link di sinistra, si può esaminare il metodo di calcolo)

Nel box sottostante sono riportate (eventualmente) delle note riguardanti lo stato del disco che sono frutto dell'elaborazione, effettuata da Hard Disk Sentinel, degl'attributi S.M.A.R.T.. Esso contiene, infatti, il numero dei problemi successi durante il funzionamento dell' hard disk, i problemi di spin up, gli errori di trasferimento dati ecc. Lo sfondo dell'icona circolare può essere verde, giallo o rosso a seconda dello stato. Si consiglia la lettura di queste note con una certa regolarità.

Nella parte centrale è riportato da quanto tempo è in uso il disco e la durata stimata. La metodologia di calcolo della durata stimata è descritta in appendice.

Nella parte sottostante, è visualizzato l'andamento dello stato del disco. Hard Disk Sentinel salva i valori di stato e li usa poi per la costruzione del grafico. Se l'applicazione e' usata da molto tempo è possibile,spostando la barra di scorrimento, vedere lo stato in un determinato momento. Infine usando l'icona (floppy) in alto sulla sinistra del grafico è possibile salvare l'andamento in formato BMP o JPG.


Temperatura

Su questa cartella è possibile esaminare la temperatura corrente, la media e la massima.

In base al valore della temperature, viene generato un testo di segnalazione. In caso di alta temperatura, l'applicazione segnala vari suggerimenti.

In molti casi è possibile che i sensori della temperatura dell'hard disk non siano precisi. Si raccomanda di eseguire una calibrazione della temperatura ( un messaggio è visualizzato fino a quando lo scostamento della temperatura,per questo hard disk, è pari a 0.

Nella parte sottostante, è visualizzato gli andamenti della temperatura del disco. Hard Disk Sentinel salva,giornalmente, i valori della temperatura e li usa poi per la costruzione del grafico. Se l'applicazione e' usata da molto tempo è possibile,spostando la barra di scorrimento, vedere la temperatura in un determinato momento . Infine usando l'icona (floppy) in alto sulla sinistra del grafico è possibile salvare l'andamento in formato BMP o JPG.


S.M.A.R.T.

Questo capitolo contiene dettagli ad alto contenuto tecnico per cui la traduzione è molto delicata.

Per questo si consiglia agl'Utenti esperti di leggere la versione originale in inglese qui.

Nella finestra S.M.A.R.T. (Self-Monitoring Analysis and Reporting Technology) è riportata la lista degli attributi S.M.A.R.T. relativa all'hard disk IDE o Seriale ATA. Tutti i dischi possono fornire fino a 30 diversi attributi che riflettono lo stato dei dischi. La lista degl'attributi è definita dal produttore e non sempre sono esattamente gli stessi per questo ci sono alcuni parametri che sono legati al fornitore.

Da sinistra a destra, la lista inizia con il numero dell'attributo, esso ha un valore tra 0 e 255. Se l'attributo ha un impatto diretto sullo stato del disco, Hard Disk Sentinel lo evidenzia con un marchio (a sinistra del numero) verde se è OK oppure rosso se l'attributo ( X) è critico.

Quindi c'è il nome dell'attributo. La maggioranza degl'attributi sono comuni a tutti i produttori ma, come detto, ce ne possono essere alcuni per i quali il produttore non rilascia valori o significato.

La colonna della Soglia contiene il valore di guardia. Se la colonna Valore contiene un valore minore della soglia significa che l'attributo non è corretto. E se l'attributo è critico viene visualizzata un'icona rossa con una X posizionata all'inizio della riga. Nella colonna Val. peggiore, è visualizzato il valore peggiore dell'attributo.

Nella colonna Stato di questo attributo può essere riportato uno di questi codici:

•

OK: se ha un valore uguale o maggiore della soglia. Ciò significa nessun problema.

•

OK (Always passing): la soglia è zero oppure ha un valore troppo basso. Di solito questa dicitura significa che l'attributo non è critico ma ha solo una funzione statistica.

•

Fail: se un attributo ha superato la soglia (valore minore della soglia).

•

Usage limit exceeded: se un non-critico attributo ha superato la soglia (valore minore della soglia).

Nella colonna Data sono riportati i valori (in esadecimale) rilevati dai sensori dell'hard disk e dipendono dal produttore. Questi valori non sono elaborati dal disco.

Nella colonna Scostamento, è possibile impostare un valore (positivo o negativo). Hard Disk Sentinel, in fase di elaborazione di questo attributo aggiungerà o toglierà questo scostamento. Per esempio questa funzione può essere usata durante la calibrazione della temperatura. Si può impostare lo scostamento in questi modi:

•

Usando le icone - e + : la variazione è di una unità.

•

Cliccando sul numero tra le icone +/- , si apre una finestra nella quale è possibile impostare direttamente lo scostamento.

•

Una volta selezionato l'attributo, premere INVIA per impostare il nuovo scostamento.

Nota: Si consiglia di usare il secondo o il terzo metodo.

Tramite la colonna Applica si può abilitare/disabilitare l'attributo. Se viene disabilitato esso non influisce più sullo stato del disco e sullo stato delle prestazioni. Variazioni (degrado) di attributi non selezionati non vengono registrati nella cartella[****]avvisi. Per questo si sconsiglia vivamente di NON disabilitate la gestione degl'attributi.

Attenzione: Se si usa lo scostamento non a ragion veduta, ovviamente gli hard disk possono visualizzare valori scorretti. Solo Utenti esperti possono effettuare queste operazioni.

Nota: E' possibile variare lo scostamento è applica solo nella versione registrata. Se si usa una versione non registrata le modifiche a questi due parametri sono ignorate al prossimo riavvio dell'applicazione.

Sotto il nome dell'attributo c'è una piccola descrizione del medesimo. La lista completa degl'attributi S.M.A.R.T. conosciuti sono descritti qui..

Tramite il tasto destro del mouse, è possibile copiare l'intera ara degl'attributi negli appunti. Più tardi è possibile copiare gli appunti in un file di testo o in un'e-mail o in un documento.

Grafico attributi

Nella parte sottostante, vengono visualizzati i grafici dell'andamento dei vari attributi S.M.A.R.T. selezionati. Gli estremi del grafico sono a sinistra la prima misurazione (data di installazione) e a destra il momento corrente. Tutte le atre date intermedie sono generate automaticamente.

A destra del grafico, si trovano il tipo di parametro. Ci sono vari tipi di parametri in relazione al loro utilizzo::

•

Critico: significa che ha avuto un impatto sullo stato di salute dell' hard disk (es. numero di settori spostati nell'area di riserva).

•

Statistico: questo valore non ha effetto diretto o indiretto sullo stato (es. numero di cicli di accensione).

•

Prestazioni: il valore ha un impatto sulle prestazioni (es. power on time, tempo di seek).

•

Tasso di errori: normalmente sono attributi di errori correggibili che non hanno effetto diretto sullo stato di salute del disco (es. errori di seek).

•

Contatore eventi: contatore che viene incrementato in caso di nuovi eventi o di problemi (es. nuovi settori rovinati).

•

Auto diagnosi: un valore che viene monitoraggio continuo.

Valori sul grafico

E' possibile visualizzare due valori sul grafico. In modo standard è visualizzato l'andamento del campo data ovvero dei valori rilevati dal disco. Si può anche cambiare questo tipo di visualizzazione nella configurazione : sezione opzioni avanzate. La differenza tra le due modalità è descritta qui

Data

Questo valore incrementa in caso di problemi a causa di problemi sul disco (per esempio, numero di settori danneggiati). Il grafico ideale se l'andamento è graduale.

Nella colonna Data è visualizzato il valore raw misurato. Questo valori sono i dati prelevati dal disco e non sono elaborati dallo stesso. Al contrario la colonna Valore contiene il valore elaborato in dipendenza dai valori del produttore. Questi valori sono visualizzati in formato esadecimale. E' possibile visualizzare in formato decimale tramite il tasto destro dl mouse nella tabella S.M.A.R.T..

Tramite la colonna Scostamento, è possibile definire lo scostamento (positivo o negativo). Hard Disk Sentinel sottrae o aggiunge questo numero al valore dell'attributo in fase di valorizzazione. Questa funzione per esempio può essere usata per calibrare la temperatura .

Ci sono ari modo per effettuare la modifica:

•

Usando le icone - e + : il numero viene variato di unità in unità.

•

Cliccando sulla casella appare una finestra in cui impostare il nuovo valore.

Nota: si raccomanda di impostare direttamente il numero di scostamento e quindi pigiare il tasto INVIO.

Tramite la colonna Applica si può abilitare/disabilitare l'attributo. Se viene disabilitato l'attributo, esso non viene visualizzato e non appare nello stato e nelle prestazioni : eventuali variazioni dell'attributi disabilitati non vengono registrati nella finestra[****]avvisi. Per questo si raccomanda di NON disabilitare gli attributi.

Attenzione: Usando lo scostamento e l'opzione applica, può' essere visualizzato uno scorretto stato del disco per questo si consiglia queste opzioni solo a utenti esperti.

Nota: variazioni dello scostamento sono possibili solo nella versione registrata. Se il prodotto non è registrato, al prossimo riavvio dell'applicazione le modifiche andranno perse.

E' presente una piccola descrizione dell'attributo. Tramite il tasto destro è possibile modificare la visualizzazione. La lista completa dei parametri S.M.A.R.T. è descritta nella lista in appendice.

Usando il tasto destro del mouse è possibile copiare l'intera pagina negl'appunti per poi incollarla in un documento o in un'email.

Valore produttore

Tramite questa opzione è possibile controllare l'andamento dei parametri legati al produttore. Questo valore decrementa nel caso in caso di problemi fino a raggiungere la soglia.Se l'attributo è critico e se la soglia è raggiunta, il disco ha dei problemi M.A.R.T. e il disco andrebbe sostituito immediatamente. In questo caso, il fornitore dovrebbe sostituire il disco nei termini specificati nella garanzia.

La parte iniziale blu del diagramma rappresenta valori rilevati mentre la fucsia rappresenta la previsione. Sulla parte bassa del grafico viene evidenziata la soglia con colore giallo.

Per esempio (rif. diagramma sopra), si nota che la prima misurazione è avvenuta il 28 Ottobre 2006. In questo momento il valore dell'attributo "Reallocated sectors" era 100. Il 9 Novembre 2006, questo valore si è ridotto a 95 a causa di più settori riallocati. Se questo trend avrà lo stesso andamento si prevede che raggiungerà la soglia (36) il 31 Marzo 2007. Ci significa che in questa data ( o prima ) il disco dovrebbe essere sostituito.

La differenza tra i due metodi è descritta qui.

Note Per i dischi SCSI, pannello S.M.A.R.T. contiene le informazioni statistiche fornite dai dischi SCSI (per esempio: byte totali di lettura/scrittura, numero di errori di lettura/scrittura ecc).

Il grafico sotto la lista può essere usato per vedere l'andamento degli attributi specifici.

Cliccando tra la finestra S.M.A.R.T. e quella del grafico è possibile ridimensionare le relative dimensioni.


S.M.A.R.T originale

S.M.A.R.T.

 Top Previous Next

S.M.A.R.T.

On the S.M.A.R.T. (Self-Monitoring Analysis and Reporting Technology) page the list of S.M.A.R.T. attributes are displayed for the selected IDE or Serial ATA hard disk. All hard disks can store up to 30 different attributes to reflect the actual hard disk status. The list of the attributes is defined by the manufacturer - so not all hard disks contain all attributes. The list is fixed, it is not possible to add or remove attributes after the hard disk leaves the factory. The list may vary on different hard disks of the same manufacturer but same type hard disks usually have same attribute lists.

From left to right, the list begins with the identifier (number), it can be between 0 and 255. If the attribute directly affects hard disk health status and it can reach a critical level, Hard Disk Sentinel displays a green tick mark (attribute OK) or red X (attribute is not correct) before the number.

Then the name of the attribute is displayed - if it is not unknown. Most attributes are widely used by all (or almost all) manufacturers but the value and meaning of some attributes are unknown because the manufacturer does not release such information.

The Threshold column contains the threshold value for the attribute. If the Value column contains a number which is smaller than the threshold, the attribute is not correct. If the attribute is a critical one, the red X is displayed in this case at the start of this line. In the Worst column, the worst value ever measured is displayed.

In the Status column the current status of the attribute is displayed. It can be:

· OK: the value is same or greater than the threshold. There is no problem.
· OK (Always passing): the threshold is zero so it is not possible to have smaller value. Usually displayed for the attributes indicating only statistical information.
· Fail: for a critical attribute the value exceeded the threshold (value is smaller than threshold).
· Usage limit exceeded: for a non-critical attribute the value exceeded the threshold (value is smaller than threshold).

In the Data column the raw measured values are displayed. These values are not evaluated by the hard disk. In contrast, the Value column contains an evaluated number which depends on the manufacturer and the hard disk. These values are displayed in hexadecimal format. It is possible to select decimal values from the menu displayed after a right click on the S.M.A.R.T. table.

When examining the disk condition and calculating health value, it is recommended to check the raw values because this way it is possible to have an objective, manufacturer-independent status of the hard disks.

In the Offset column, it is possible to specify an offset value (positive or negative). Hard Disk Sentinel will add (subtract) this number for the attribute when evaluate it. This can be used for example during the temperature calibration procedure. There are many options to set the offset value:

· By using - and + icons: the number decreases or increases by one.
· By clicking on the number between the icons: the number can be specified directly in a small window.
· If the correct attribute is selected, the + and - buttons and the ENTER can be used to specify the offset value.

Note: it is recommended to specify the offset directly by clicking on the number or by pressing ENTER.

The checkbox in the Apply column can be used to enable/disable the attribute. If an attribute is disabled, it does not count into the health and performance values. Changes (degradations) of disabled attributes will not be saved into the hard disk log. Because of these, disabling any attribute is NOT recommended.

Attention: by using the offsets and the Apply options, the hard disk status may be incorrectly or imprecisely displayed. Only advanced users should modify any of these options.

Note: changes of the offsets and Apply options will be saved only in the registered version. If the unregistered version is used, the changes in such options are automatically discarded when the application is re-started.

A text description (with the meaning and importance of the attribute) is displayed in as hint when the mouse is moved over an attribute. After a right click on the table, a pop up menu is displayed with option to keep this description visible for each attributes. The complete list of known S.M.A.R.T. attributes is described in the appendix.

By using the right mouse button, it is possible to copy the information displayed in the table to the clipboard. Later it is possible to paste this information into a text file, e-mail or document.

Attribute graph

Under the table, the graphical history of the currently selected S.M.A.R.T. attribute is displayed. On this graph it is possible to examine how the attribute changed. The two endpoints of the graph reflect the first measured value (installation day) and the most recent (current) value of the attribute. All other days between these two dates are selected automatically.

Next to the graph, the status flags of the attribute are displayed. All attributes may have one or more status flags. They indicate the main purpose of the attribute. These can be:

· Critical: the value may decisively affect the health status of the hard disk (eg. number of sectors moved to spare area).
· Statistical: the value does not affect directly or indirectly the status (eg. number of power cycles).
· Performance: the value may affect performance or speed (eg. power on time, seek time).
· Error-rate: usually correctable attributes where the value does not affect directly the health of the hard disk (eg. seek error rate).
· Event count: counter value, increases when some events or problems occur (eg. new bad sector is found).
· Self Preserving: the value of the attribute is under continuous monitoring.

Attribute graph views

It is possible to display two different kind of numbers. By default, the Display data field is selected, so the raw, manufacturer-independent numbers are displayed. The default mode can be selected on the advanced options configuration page. The differences between the methods are described here.

Display data field

These values increase in case of a problem because they actually contain the number of problems (for example, number of bad sectors) or events. The graph is ideal if the trend is stagnating.

Many attributes (for example, power on time, drive power cycle count, etc.) are always increasing. This will make the trend of the graph for these attributes to increase also, but it is completely normal. For some (especially statistical) attributes, the number can be very high and then it can fall, it is normal also. The graph is important for the critical attributes (for example reallocated, bad sector count) where the analysis of the previous values can reveal problematic days or period in the lifetime of the disk.

Display vendor specific values

By examining the number of the numbers in the "Value" column, it is possible to check the trend of the manufacturer-dependent values. These values decrease in case of a problem until they reach the threshold value for the attribute. If the attribute is critical and the threshold is reached, the disk has S.M.A.R.T. problem, at this point the hard disk should be immediately replaced. At this point, the manufacturers should replace the disk under the terms of warranty.

A dark blue line connects the real measured values. At the bottom of the graph, the threshold is displayed with a yellow line.

If the trend is decreasing, a purple line connects the last measured value with the threshold. This line is drawn based on the previous values (blue line). It indicates an estimated degradation of the hard disk in the future: if the attribute value will be decreased as before, the threshold exceed date (when the value will reach the threshold level) can be easily read.

For example (please see image above), it is possible to read that the hard disk is first examined on 28 Oct 2006. At that time, the value of the Reallocated sectors was 100. On 9 Nov 2006, this value is only 95 (because of many Reallocated sectors, the value changed from 100 to 95). If this trend will continue, this attribute will reach its threshold (36) on 31 Mar 2007 (it is displayed on the right side also so it is easier to read). It means on this date (or sooner) the hard disk must be replaced because of the increasing number of hard disk errors.

The differences between the two methods are described here.

Note for SCSI hard disks, the S.M.A.R.T. panel contains the statistical information provided by the SCSI hard disk (for example: total bytes read/written, number of read/write errors etc). The graph under the list can be used to examine the trend of any such attribute.

Click between the S.M.A.R.T. table and the graph and drag the mouse to resize the panels.


Informazioni

In questa finestra vengono riportati dettagli dell'hard disk per esempio il produttore, il modello, la revisione (interna) e il numero di serie dell'hard disk per poter identificare e verificare l'hard disk.

Sono anche visualizzate le unità logiche (partizioni), ciò può essere utile in caso siano installati più dischi fisici.

Usando il tasto destro è possibile copiarle negl'appunti.

Dischi IDE, Serial ATA

I dischi IDE e ATA seriale sono controllati e identificati tramite interfaccia ATA. Hard Disk Sentinel intercetta e visualizza le caratteristiche fisiche (per esempio: il numero di settori, il numero totale dei settori, l'error correction bytes, ecc). E' utile controllare la Dimensione del buffer , ovvero la dimensione della cache interna del disco. Per migliorare le prestazioni è consigliabile usare dischi con una grande dimensione del buffer.

Sono evidenziati i valori attuali e massimi di Ultra DMA. Quest'ultima determina la velocità massima e teorica tra il disco e l'host. Ovviamente più alta è meglio è.

Se l'attuale modo Ultra DMA è (0), il sistema non usa il modo di trasferimento Ultra DMA e lavora solo in modo PIO ( I/O programmato). In questo caso le prestazioni del sistema si riducono drasticamente poiché il processore deve attendere che ogni operazione di lettura/scrittura si concluda. Si consiglia di verificare la configurazione e di eliminare eventuali errori (per esempio ricablare gli hard disks / le unità ottiche o usare nuovi cavi). Ultra DMA mode 33 (2) significa che sono usati i vecchi cavi IDE con soli 40 fili anziché nuovi cavi IDE a 80 fili. Si sconsiglia di usare cavi circolari o troppo lunghi

Nota: Su qualche controller o sistema è possibile che il disco operi in modo PIO ma che il modo Ultra DMA non sia selezionato: questa situazione la si nota in questa finestra.

Nota: Hard Disk Sentinel controlla che le informazioni e i checksum ATA siano corrette.Se non sono corretti è possibile che qualche volere non sia riportato correttamente dal disco (per esempio il valori delle prestazioni, il modo di trasferimento UDMA e le proprietà ATA seriale) :ecco i simboli usati:

Gestione acustica

E' possibile vedere e modificare le opzioni acustiche, ovviamente se il disco lo permette. Livelli acustici alti permettono prestazioni massime. Impostando invece livelli più bassi, il disco è più silenzioso ma le prestazioni si riduco ( il sistema di posizionamento più lento è più lento....). Le impostazioni acustiche non impattano sulla velocità di rotazione.

Le più importanti caratteristiche ATA sono visualizzate, inoltre possono essere controllati varie funzioni (per esempio security mode, power management, ecc).

S.M.A.R.T. Dettagli

I risultati e i dettagli del test vengono visualizzate in questa sezione. Il test può essere avviato tramite Clicca per avviare il test. La durata stimata de test viene visualizzata (è il produttore che fornisce questa stima) anche se, in pratica, può durare molto di più. Il test Short controlla i componenti principali del disco (testine, servo, electtronica). Il test Extended e il Conveyance (se supportato) esegue test specifici del disco. Il test Extended controlla tutta la superficie del disco per cui è un'ottimo test per verificare se ci sono aree difettose. Per questo si consiglia di effettuare questo test periodicamente.

Durante il test viene visualizzata una finestra contenente l'avanzamento della verifica. Quando il test è terminato l'esito (positivo o negativo - in quest'ultimo caso anche la parte interessata tipo il servo, elettronica, testine, etc.) è visualizzato. Durante il test l hard disk può essere utilizzato. In questa fase, normalmente, il led HDD è spento ma si nota che il disco sta lavorando. Le operazioni di Lettura/Scrittura causano lentezza al sistema per cui si consiglia di lanciare questo test in periodi di riposo.

Nota: Il test Extended o Conveyance (se supportato) possono essere effettuati solo se il prodotto è registrato.

Dischi SCSI

Vengono visualizzate le informazioni dei dischi SCSI.


Livello acustico

E' possibile modificare il livello acustico di un disco IDE/ATA Seriale se la funzione è supportata. Basso livello acustico riduce il rumore ma anche le prestazioni (il sistema delle testine essendo più lento è più silenzioso). Il livello acustico non influisce sulla velocità di rotazione.

Si raccomanda di usare il livello acustico raccomandato dal produttore che è visualizzato. Il livello acustico non impatta sullo stato di salute del disco.

Se si compara le prestazioni di due o più dischi, questi devono avere il medesimo livello acustico.


Avvisi

Hard Disk Sentinel, per ogni disco installato, nel momento in cui c'è un degrado del campo data relativo agl'attributi S.M.A.R.T. importanti, memorizza in questa finestra un avviso.

Gli attributi importanti sono:

•

5: Reallocated Sectors Count. (Contatore dei settori spostati nell'area di riserva)

•

10: Spin Retry Count. (Tentativi di avvio dello spidel)

•

196: Reallocation Event Count. (Contatore di settori riallocati)

•

197: Current Pending Sector Count. (Numero di settori instabili)

•

198: Off-Line Uncorrectable Sector Count. (Numero di errori di lettura /scrittura incorreggibili )

•

199: Ultra ATA CRC Error Count (errori durante il trasferimento dati).

Se un disco non risponde dopo il tempo impostato, viene registrata un'anomalia (la frequenza di controllo si può impostare elle opzioni avanzate ).

Tutte le segnalazioni riportano data e ora,l'identificativo dell'attributo e il nuovo valore di data. Se Hard Disk Sentinel viene avviato occasionalmente, è possibile che due attributi siano variati dall'ultimo avvio in questo caso la data e l'ora delle segnalazioni sono uguali.

In caso di segnalazioni, è possibile impostare Hard Disk Sentinel affinché provveda a 'inviare email o di avvisi a altri utenti in rete. Queste opzioni sono presenti solo se il software è registrato.

E' possibile disabilitare il controllo di qualche attributo nella pagina S.M.A.R.T. usando l'opzione "Applica". Se viene diselezionato un attributo, non saranno più registrati eventi e inviati avvisi relativi all'attributo e eventuali variazioni non avranno conseguenze sullo stato di salute del disco.

Nota: La versione corrente mostra solo gli ultimi 50 avvisi. Quelli più vecchi vengono ignorati


Prestazioni

In questa finestra è visualizzato l’ammontare dei dati ( letti e scritti ) sia nella corrente sessione sia dall’installazione. Vengono anche visualizzate le medie giornaliere dei bytes letti e scritti.

Hard Disk Sentinel monitorizza continuamente la corrente velocità di lettura e scrittura e controlla l’utilizzo dell’ hard disk: il valore è espresso in percentuale. Questo valore va esaminato insieme all’utilizzo della CPU tramite il task manager.

Se l’Hard Disk Sentinel intercetta un’operazione di scrittura, viene acceso un "led" rosso e visualizzata la velocità di scrittura. In caso di operazione di lettura il “led” è verde ed è visualizzata la velocità di lettura. Questi colori sono indipendenti dallo stato di salute dl disco.

In base alla velocità corrente di trasferimento dati e dell’utilizzo corrente del disco, l’applicazione stima una possibile ma teorica velocità massima di trasferimento dati. Questo valore calcolato da questa formula: velocità massima stimata = (velocità corrente di trasferimento) / (utilizzo corrente del disco in %). Per esempio, se il trasferimento dati corrente è pari a 20 MB/sec e il l’utilizzo corrente del disco è del 50%, la velocità massima stimata è pari 40 MB/sec. Per aumentare la precisione, in presenza di un basso valore di utilizzo del disco, il valore stimato è automaticamente ignorato. Questo valore massimo stimato è teorico poichè influenzato dal tipo di disco, dalla sua caches o dal tipo di applicazione.

I diagrammi dell'attuale utilizzo del disco e delle attuali prestazioni del disco possono essere utili. Per esempio:

•

Se si usano due o più dischi, si può vedere quale disco è attivo la relativa velocità. Se il sistema operativo è installato sul primo disco e gli altri dischi hanno applicazioni che generano traffico si può controllare le prestazioni globali

•

Durante la copia tra due dischi. Si possono controllare e comparare le prestazioni dei due dischi.

•

Durante la masterizzazione su unità ottiche: per verificare la reale velocità di trasferimento (velocità di masterizzazione). Basso utilizzo del disco significa che può esser alzatala velocità di masterizzazione.

•

Su un Server (file o database server ad alto carico) è possibile esaminare la velocità di trasferimento dei dischi. Questo aiuto per l'amministratore di sistema può aiutarlo a decidere se sono necessari dischi più veloci nel caso vengano aggiunti nuovi utenti.

•

Se durante operazioni che dovrebbero essere a velocità costante (per esempio una masterizzazione di un DVD) , il diagramma relativo all'utilizzo del disco ha notevoli picchi potrebbe significare che i dati sono frammentati (necessaria una deframmentazione) oppure che viene usata molta memoria virtuale.

Nota: Il monitoraggio delle prestazioni dipende dal sistema operativo per esempio ciò non è possibile con Windows 95/98/ME. Su particolari dischi esterni ( per es. pendrive o memory card) questa funzione non è supportata.


 Allarmi

Allarmi

Gli allarmi generati dal disco sono riportati in questa pagina.

La lista contiene tutti i tipi di eventi (temperatura eccessiva, condizione del disco critica, previsione di un guasto, ecc) e la data dell'evento

Vengono registrati in questa lista solo gli allarmi selezionati (allarmi sonori, e-mail, ecc).


Unità logiche ((partizioni))

In questo pannello sono riportati tutti i dettagli della partizione selezionata compreso l'indicazione dell'unità fisica (si ricordi che un'unità logica può essere associata a più unità fisiche), il tipo, il nome e il numero di serie, lo spazio totale e quello libero.


Configurazione

Tramite questa finestra possibile modificare le opzioni di Hard Disk Sentinel. Le opzioni sono suddivise in categorie selezionabili tramite un menù posto sulla parte sinistra. Il menù offre queste possibilità:

•

Lista dischi

•

Preferenze

•

Finestra di stato

•

Soglie / Icone in systray

•

Allarmi

•

Messaggi

•

E-mail

•

Registrazione

•

Aggiornamenti

•

Opzioni avanzate

•

Controllo disco

•

Tasti caldi

•

Integrazione

•

Operazioni (disponibile solo nella versione PROFESSIONAL)

•

Invia Report raw


Lista dischi

In questa finestra vengono visualizzati tutti i dischi rilevati. Selezionando il box a sinistra del n. del disco, è possibile decidere se si vuole visualizzarlo nella finestra di stato. Mentre con il doppio click, lo si può rimuovere dalle icone in systray.

E' possibile visualizzare in systray la temperatura massima solo per un disco (ovvero se abbiamo due dischi: uno a 30° l'altro a 35° verrà segnalata una temperatura di 35°) . Se poi, nella finestra soglie/Icone in systray si desidera visualizzare anche lo stato nel caso sia maggiore della soglia, in questo caso lampeggerà per un secondo l'icona in systray con la temperatura a 35° un secondo se lo stato è minore della soglia.

Note: Se si trascina il mouse sull'icona in systray, vengono visualizzati i dettagli dei dischi in una piccola finestra.

Se si clicca su un disco, con il tasto destro su un disco, viene visualizzato il menù relativo (vedi l'immagine sopra)


Preferenze

Tramite questa finestra è possibile configurare le opzioni globali di Hard Disk Sentinel.

All'avvio del programma, apri la finestra di stato: la finestra di stato viene attivata o no, all'avvio del'applicazione. Eventuali modifiche a questa opzione vengono attuate al riavvio dell'applicazione).

Carica HD Sentinel all'avvio di Windows: Hard Disk Sentinel può essere avviato automaticamente all'avvio di Windows. Si raccomanda d usare questa opzione per poter controllare continuamente i dischi.

All'avvio, mostra la finestra principale: All'avvio del'applicazione, viene mostrata la finestra principale. Nota: questa opzione può essere disabilitata solo se l'applicazione è registratata.

Visualizza l'applicazione nella barra applicazioni attive: Se una qualsiasi finestra di Hard Disk Sentinel è aperta (eccetto la finestra di stato), l'applicazione è posta anche nella barra delle applicazioni attive.

E' possibile scegliere la lingua usata nell'interfaccia utente, nei reports, nelle e-mails e nei messaggi, come pure l'unità di misura della temperatura (Celsius o Fahrenheit) e l'unità di misura per il trasferimento dati,la capacità del disco e delle partizioni (MB, GB or TB) ( rif. pagina prestazioni dei dischi ).


Finestra di stato

In questa finestra è possibile configurare le opzioni della finestra di stato. L'utente può selezionare, per essa, un colore o un'immagine di sfondo. La scelta può essere fatta tramite il pulsante "Seleziona".

Nota: quando si usa un'immagine come sfondo, questa viene adatta alle misure della finestra di stato

Se l'opzione Blocca la fuoriuscita dallo schermo è abilitata la finestra di stato non può essere posizionata fuori dallo schermo ma viene allineata la bordo dello stesso.

E' possibile configurare la trasparenza trasparenza della finestra di stato (se supportata dal sistema operativo) e il tipo di font, la dimensione e il colore. Si raccomanda di usare appropriate impostazioni al fine di disturbare il meno possibile l'esercizio.

Nella parte bassa, ci sono una serie di parametri che si possono o meno visualizzare in systray. Nota: i parametri selezionati sono visualizzati se si passa con il mouse sull'icone in systray.

Tramite l'opzione Sfondo completamente trasparente, la finestra di stato è invisibile.Se questa opzione è selezionata, la finestra di stato può essere visualizzata tramite i tasti caldi e chiusa cliccando sulla X rossa.

Se si usa Windows Vista, è possibile usare Vista gadget per visualizzare le informazioni del disco (per esempio: temperatura e stato). La tipologia di visualizzazione del gadget (colore, font, l'hard disks da visualizzare) può essere fatta tramite le opzioni della finestra di stato.


Soglie / Icone

In questa finestra è possibile impostare le soglie e e colori delle icone in systray.

I colori possono essere impostati per tutti e tre i casi: sfondo (verde) per bassa temperatura, sfondo (rosso) per alta temperatura e sfondo per temperatura intermedia (giallo). Anche le tre soglie possono essere personalizzate. Il colore dello sfondo o del carattere può essere trasparente. Per far questo è necessario definire un colore personalizzato con Rosso=254, Verde=254, Blu=255.

Si può decidere se visualizzare l'icona per rappresentare lo stato del disco. Essa può essere [image] ( stato perfetto),oppure [image] (stato critico) oppure [image] (accettabile ma di guardia).

Se si decide di visualizzare in systray sia la temperatura si lo stato: le due immagini si alternano con una frequenza di un secondo. Se questo alternarsi di icone da fastidio , si può usare le impostazioni di default ovvero: flash delle icone solo in caso di problemi


Allarmi

Le pù importanti funzioni di Hard Disk Sentinel sono associate a allarmi. Laddove le soglie sono superate, si possono pianificare varie azioni quali avvisi acustici, invio di messaggi in rete,salvataggi di dati per prevenire la perdita di dati o addirittura lo spegnimento del PC. Si possono prevedere reazioni specifiche a seconda dell'evento ovvero quando:

E' previsto un guasto: ossia c'è un paramero S.M.A.R.T. critico, in altre parole se un'attributo critico ha superato la soglia definita dal produttore. In questo caso il disco dovrebbe essere sostituito immediatamente.

Nota: in questo caso lo stato di salute del disco è al 0%. Nota: questa funzione è presente solo se il software è stato registrato.

La condizione del è critica ( bassa) : viene innescato questo evento quando l'icona che rappresenta lo stato di salute del disco è gialla o rossa ovvero sono state superate le soglie impostate. Nota: questa funzione è presente solo se il software è registrato. Se non è registrato, solo lo stato giallo può attivare un allarme.

La temperatura è alta: questo evento su un hard disk si riferisce alla temperatura oltre le soglie rosse o gialle configurate. Nota: questa funzione è presente solo se il software è registrato. Se non è registrato, solo lo stato giallo può attivare un allarme.

E' stato registrato un nuovo avviso: questo evento significa che un hard disk, ha un attributo S.M.A.R.T. critico che si è degradato e, per questo viene registrato nella finestra relativa.

Nota: questa funzione è presente solo se il software è registrato

Lo spazio libero su disco è basso: questo evento segnala che il valore dello spazio libero ha superato il valore impostato. Nota: questa funzione è presente solo se il software è registrato. I valore di soglia può essere impostato globalmente o per singolo disco (usando una % o megabytes )::

E' possibile impostare un avviso acustico: in questo caso si può selezionare un file audio supportato dal sistema (es. wav, mid, mp3, wma) che Hard Disk Sentinel userà all'uopo.

Se Ripeti avviso acustico è abilitato, l'applicazione ripete in continuazione l'avviso acustico fino a quando l'Utente desidera interromperlo (tramite il menù veloce o la finestra principale) dopo averne preso coscienza. Questa funzione è consigliata sui Server.

L'opzione Usa gli altoparlanti del PC abilita l'uso degl'altoparlanti interni ("buzzer") al PC al posto della scheda audio. Questa opzione non serve se si usano altoparlanti esterni al computer. L'uso di questa opzione può essere utile sui server (in combinazione con le opzioni precedenti).

Nota se l'opzione è abilitata, il suono emesso è un doppio "beep-beep" a 1000 Hz al posto del suono emesso emesso dagl'altoparlanti.

Nota: qualche computers, specialmente notebooks, possono non essere muniti di questi altoparlanti. Si prega i verificare che gli allarmi siano udibili dal Vostro sistema

Tramite il pulsante Prova il suono, è possibile provare il suono di allarme configurato (file o altoparlanti PC). Se il suono non è udibile, controllare cavi,altoparlanti o la configurazione.

E' possibile inviare un'email giornaliera contenente lo stato di tutti i dischi. Hard Disk Sentinel ritenta automaticamente a inviare le-mail se ci sono stati problemi di problemi di rete.

Nota: questa funzione è presente solo se il software è registrato

Se l'opzione Invia messaggio è impostato, in caso di nuovo evento viene visualizzato o inviato a secondo delle impostazioni del messaggi.

Se l'opzione Backup di emergenza impostato, le operazioni pianificate vengono avviate automaticamente nel momento in cui si verifica l'allarme. E' possibile pianificare varie operazioni a secondo dell'evento dell'hard disk. Nota: Questa funzione è presente solo nella versione PROFESSIONAL.

Se l'opzione Spegni è abilitata, il computer viene spento automaticamente in presenza de relativo evento. Hard Disk Sentinel, prima dello spegnimento, provvede a chiudere tutte le applicazioni. E predisposto un timer di un minuto per dar tempo all'Utente di chiudere tutte le applicazioni o per interrompere lo spegnimento stesso. Se è impostato anche backup di emergenza, lo spegnimento viene eseguito dopo i salvataggi

Importante: in ogni sessione, ogni problema su ogni disco può avviare un solo avviso. In altre parole, se la temperatura di un disco raggiunge il livello giallo l'allarme è innescato (es. avviso acustico e/o invio di e-mail), ma se, successivamente, il medesimo disco si raffredda e di nuovo raggiunge lo stato giallo non genera più un nuovo allarme. Quanto sopra per evitare molti allarmi (per esempio invio di e-mails) se il disco lavora vicino ala soglia. Ovviamente se altri hard disk generano allarmi questi vengono attivati.

La lista degli allarmi viene azzerata ogni giorno a mezzanotte. Ciò significa che un computer (server) che funziona in continuazione può generare un solo allarme per disco al giorno.

La lista di ogni avviso è mostrata nella finestra principale.


Messaggi

Quando succede un problema, Hard Disk Sentinel può inviare un allarme. In questa pagina è possibile configurare il tipo di messaggio. E' possibile la combinazione di più allarmi.

Nota:Sarebbe saggio prevedere almeno un allarme per tipo di inconveniente.

Invia e-mail: in caso di problemi, Hard Disk Sentinel invia un'e-mail con la descrizione del problema. L' e-mail deve essere pre configurata nella sezione E-mail. E possibile attivare la linea a internet ( se non è già attiva) prima di inviare l'email e disattivarla dopo l'invio.

Nota: Se si usa l'opzione 'chiudi la connessone dopo l'invio' e se la linea era già attiva prima del problema la connessione NON viene chiusa!

L'Utente può decidere il formato dell'e-mail. Il report può essere in formato HTML report (al massimo 50 kbytes per disco), Testo completo o ridotto. Quest'ultimo può essere utile in caso di invio dell'email a un SMS gateway. Nota: il tipo di report desiderato viene usato anche per l'invio del report giornaliero. o su richiesta dell'Utente, pigiando l'apposito pulsante, nella finestra principale. E' possibile e' configurare gli elementi che si vogliono visualizzare/includere nei report tipo Txto o HTML report (se si usa la versione registrata).

Nota: indipendemente dagli elementi configurati, il report XML contiene tutti le sezioni.

Invia messaggio a un computer remoto: Con questa opzione è possibile, in caso di problemi, inviare un messaggio a un computer in rete ( comando NET SEND).Il destinatario può essere cercato nella rete tramite il pulsante seleziona. In una rete complessa, questa ricerca può essere lunga, per cui si consiglia di specificare direttamente il nome del computer (senza \\ prefix). Tramite il pulsante Invia testo è possibile verificare la connessione.

Importante: se il computer remoto non è accessibile, a causa per esempio di problemi di rete, Hard Disk Sentinel ritenta l'invio ogni 5 minuti (della sessione corrente) fino al recapito. Se l'Utente riavvia l'applicazione, non si effettuano più tentativi.

Nota: Il servizio messaggi supporta solo piccoli messaggi (massimo 254 caratteri). E' da notare, tuttavia, che è sufficiente che il destinatario del messaggio (normalmente l'amministratore) abbia una piccola descrizione del problema e il mittente. In certi casi può essere utile all'amministratore leggere sul computer che ha generato il problema, il file HDS_problem_log.txt nella cartella di installazione. E' possibile che alcuni caratteri ( fuori standard ASCII) non possono essere visualizzati dal destinatario.

Visualizza il messaggio sullo schermo: usando questa opzione, il messaggio di allarme viene visualizzato sullo schermo. In modo opzionale, può essere preparato un messaggio che precede quello di errore.Per esempio può essere preparato questo messaggio: "Si prega di contattare l'amministratore al n. XX-XXXXX-XXX e riportagli la seguente segnalazione:" . Si consiglia di usare la visualizzazione del messaggio sullo schermo per computers che non sono in rete ne' dispongono collegamento a internet.

Note: L'invio di un'email con il report giornaliera è indipendente dalle opzioni di questa finestra.


E-mail

In questa finestra è possibile configurare il sistema di e-mail tramite questi parametri:

•

Nome mittente: questo nome verrà visualizzato come mittente (può essere, per esempio, nome dell'Utente del computer).

•

E-mail mittente: e-mail del mittente (può essere, per esempio, l'email dell'Utente del computer)

•

SMTP server: nome o indirizzo IP del server SMTP da usare.

•

E-mail de destinatario: indirizzo e-mail del destinatario a cui verrà inviato l'allarme (per esempio: l'amministratore, oppure un'account legato d un cellulare ). E' possibile introdurre due o più indirizzi separati da una virgola (,)

•

Porta: da specificare nel caso che il server SMTP non usi la porta 25 standard.

•

Nome utente, password: Devono essere introdotti questi valori se l'SMTP server, per inviare l'email, richiede l'autenticazione (usata da molti ISP - Internet Service Providers). Se non è necessaria l'autenticazione non è richiesta, si prega di lasciare invariati questi due parametri.

Tramite la tendina Mail account si può scegliere qualche account presente in Outlook or Outlook Express per configurare velocemente questa finestra (esclusa l'autenticazione).

Nota: Può essere che non tutti gli accounts vengano visualizzati.

Nota: Dopo le varie impostazioni, si raccomanda di inviare un' Email di test per verificare l'esattezza dei parametri.


Registrazione

Dopo l'acquisto del prodotto, viene inviato automaticamente all'Utente una chiave di sblocco. Su questa pagina si introduce, appunto, la chiave per attivare Hard Disk Sentinel affinché possa eseguire tutte le funzioni. Nota: una licenza base è valida solo per la versione base, ovvero non è valida per la versione PRO. Al contrario una licenza PRO da a possibilità di sfruttare le funzionalità basic e PRO.

L'Utente può introdurre un nome a piacere di registrazione che sarà visualizzato nella finestra Info.

Hard Disk Sentinel verifica la correttezza della chiave automaticamente se si usa il pulsante Registra e attiva on-line..

Se il computer è connesso a internet, si raccomanda appunto la funzione Registra e attiva on-line che è veloce e automatica.

Se la linea a internet non è momentaneamente, è possibile usare la procedura Registra e attiva via e-mail dopo aver introdotto una chiave valida e n nome utente. In questo modo, Hard Disk Sentinel crea un file da inviare (magari da un'altro computer) via e-mail a info@hdsentinel.hu allegando anche la chiave introdotta. Come riposta si riceve un file di attivazione che devono essere copiati nella cartella i installazione di Hard Disk Sentinel. Dopo il riavvio del l'applicazione, tutte le funzioni sono abilitate.

Nota: Se la Vostra chiave non è legale e se l'attivazione on-line line da errore, s prega di non ritentare via e-mail.

Nota: Se si deve reinstallare il sistema operativo, la successiva reinstallazione di Hard Disk Sentinel può essere registrato e reattivato come la prima volta. Se invece si sostituisce l'hard disk, e si procede alla nuova registrazione viene decrementato il contatore di re-attivazioni legali. Dopo 5 reattivazioni su cinque diversi hard disk, per ulteriori riattivazioni si prega di contattare il Supporto Tecnico. Se invece si sostituiscono il secondo terzo disco ecc, questa operazione non ha effetto sulla fase di registrazione.

Se sono installati due o più sistemi operativi sullo stesso computer, Hard Disk Sentinel può essere installato, registrato e attivato su tutti i sistemi operativi.

Nota: Se si usa la versione CORPORATE, questa pagina è inutile. Non è possibile cambiare il nome utente o usare i pulsanti Registra e attiva, poiché l'applicazione è già registrata e attivata


Aggiornamenti

Hard Disk Sentinel si può auto aggiornare se esiste una versione disponibile da scaricare. L'Utente può scegliere se controllare se sono disponibili nuovi aggiornare un vola alla settimana oppure, manualmente, tramite il tasto Controlla se ci sono aggiornamenti. E' visualizzata la data dell'ultimo controllo effettuato.

Durante il controllo e l'aggiornamento,viene chiusa l'applicazione e quindi le icone in systray per il tempo di controllo e di (eventuale) download delle nuove versioni:

Nota: Durante la fase di registrazione e attivazione della versione PROFESSIONAL, vengono scaricati alcuni moduli di backup. Più tardi, anche questi moduli saranno soggetti all'aggiornamento.

Nota: Dopo il download, la nuova versione viene startata immediatamente. La lista degl'allarmi elaborati viene cancellata ma nuovi allarmi saranno gestiti normalmente.

Nota: Durante il controllo, viene mostrata solo l'ultima versione ufficiale (non beta). Versioni di prova (beta) possono essere installate solo manualmente.

Nota: La fase di controllo/aggiornamento non cambia nulla sulla registrazione del prodotto.

Nota: Gli utenti registrati possono aggiornare gratuitamente il prodotto e dopo l'aggiornamento l'applicazione rimane registrato se a suo tempo era stato usato un codice d registrazione valido.

E' possibile salvare e ripristinare la configurazione. Con il salvataggio viene salvato la corrente configurazione incluse tutte le opzioni e la configurazione operazioni, le statistiche precedenti, i logs e i dettagli della registrazione del prodotto (i dai di registrazione e il file i attivazione). In questo modo se si reinstalla il prodotto e sufficiente Ripristiare la configuzione e in questo modo vengono riattivati i precedenti settaggi, statistiche e il prodotto viene automaticamente registrato. Si consiglia di copiare il file di configurazione (HDSentinel.cfg) su un supporto rimovibile (es. pen-drive ) in modo di averlo a disposizione in caso di crash.

Nota: se la configurazione hardware è cambiata è necessario ripetere la registrazione del software.

Nota: La funzione di salvataggio configurazione è disponibile solo nelle versioni registrate.


Opzione avanzate

Si suggerisce di modificare queste opzioni solo da parte di Utenti esperti !.

Frequenza di controllo: rappresenta la frequenza di interrogazione dei parametri S.M.A.R.T.. Se non si varia, la frequenza pre impostata è pari a 5 minuti. Molti dischi o unità lente possono causare rallentamenti all'applicazione, in questo casi si consiglia di aumentare il valore. Nota: In ogni caso un'altra frequenza (es. valori tra 1 e 5 secondi, riducono le prestazioni.

Metodo di calcolo delle condizioni: l'Utente può scegliere il metodo per calcolare le prestazioni dei dischi. Si raccomanda di usare il metodo "Analisi data (standard)".

Abilita l'allarme s il disco non risponde: se il disco, a seguito dell'interrogazione non risponde viene generata una segnalazione ( e un'avviso se previsto). Nella pagina informazion del disco è visualizzato una icona gialla poi rossa con il problema. Si sconsiglia di usare questa opzione ma solo se è veramente necessario per esempio se si usa Windows 98/ME.

Disabilita lo scandisk automatico: Con questa opzione si evita lo scandisk al riavvio di Windows per evitare ulteriori danni al disco.

Attendi prima di avviare scandisk: se è abilitato lo scandisk, con questa opzione è possibile introdurre un ritardo prima di avviare lo scandisk. Quanto sopra per permettere all'Utente ,durante questo ritardo, di non avviare lo scandisk ( premendo un tasto).

Sincronizza l'orologio del PC con l'atomic clock: si può decidere, a una certa ora, di sincronizzare l'orologio del PC con un server apposito via NTP (Network time protocol). Questo può essere utile per poter determinare l'esatta ora dell'allame oppure, nella versione PROFESSIONAL, per avviare in modo preciso certe operazioni. Nota:se la versione non è registrato, questa funzione viene disabilitata dopo la sincronizzazione.

Genera e aggiorna un file XML: Se selezionato, i dettagli dell' hard disk sono esportati automaticamente in un file speciale XML file che può essere elaborato da altri software. In modo standard, viene usato il nome HDSentinel.xml file ma esso può essere cambiato pigiando il pulsante Seleziona. Il precedente file XML salvato nel precedente giorno viene salvato come copia di backup con l'estesione .BAK.

Nota: questa funzione è disponibile solo per versioni registrate.


Controllo disco

Hard Disk Sentinel esamina in continuazione lo spazio libero delle unità logiche (partizioni) e lo può mostrare tramite Icone disco (oltre allo stato di salute del disco))).

Modifica il simbolo standard dell'icona del disco: Con questa opzione è possibile cambiare le icone standard di Windows dei dischi con altre che riportano in modo grafico lo spazio libero e lo stato di salute: questo in tutte le applicazioni incluso Windows Explorer.

Controlla lo spazio sui dischi di rete: è possibile esaminare lo spazio libero sui dischi di rete e visualizzarlo nella finestra principale.

Cambia il simbolo standard delle icone dei dischi di rete: dopo il controllo dei dischi di rete remoti, viene visualizzato lo spazio libero su icone specifiche .

Controlla lo spazio di dischi removibili: è possibile controllare lo spazio dei dischi removibili (per esempio:pendrives, dischi esterni, card readers).

Cambia il simbolo standard delle icone dei dischi rimovibili: dopo l'acquisizione dei valori, possono essere variate le icone dei dischi rimovibili per visualizzare lo spazio.

Nota: sulla maggioranza delle memorie esterne non gestisco la tecnologia S.M.A.R.T. per questo su queste unità vengono visualizzate (anche tramite ico) solo informazioni riguardo lo spazio.

Nota: controllare lo spazio su unità remote o rimovibili può causare rallentamenti specialmente se le unità non risultano accessibili o se il card reader non ha memorie inserite. Per questo si raccomanda di usare questa opzione a ragion veduta per non ridurre troppo le prestazioni del sistema.

E' possibile escludere alcune unità dal controllo dello spazio e dalla modifica delle icone ( senza : / senza spazi. Esempio: CDE ).

Nota: Hard Disk Sentinel può modificare le icone solo se è attivo; nel caso contrario vengono visualizzate solo le icone standard di Windows ( o di altre applicazioni di terze parti).

Nota: qualche sistema operativo (per esempio Windows XP SP1) può visualizzare le icone disco in modo scorretto. Per risolvere il problema, si prega di aggiornare il sistema all'ultimo service pack.

L'opzione Set Icona disco è usata per determinare il tipo di icona dell' hard disk (XP or Vista) usata da Windows Explorer. L'icona mostra lo stato e lo spazio usato del disco.


Tasti caldi

E' possibile avviare qualche funzione di Hard Disk Sentinel tramite tasti caldi anche si sta lavorando in alte applicazioni

I tasti caldi sono disponibile solo nella versione registrata.


Operazioni

Hard Disk Sentinel PROFESSIONAL può creare operazioni automatiche (backup), pianificare la loro esecuzione in caso di anomalie. Queste caratteristiche sono descritte nei seguenti capitoli:

•

Progetti

•

Pianficare

•

Backup di emergenza


Progetti

Operazioni: Progetti

Queste funzioni sono disponibili solo nella versione PROFESSIONAL.

Usando Hard Disk Sentinel PRO, è possibile definire varie operazioni (progetti) e pianificare il loro avvio regolarmente. I progetti definiti possono essere avviati in caso di qualche evento, per esempio in caso di uno stato del disco scadente. E' possibile eseguire due o più progetti nel medesimo momento o in modo sequenziale ( avvia uno progetto solo quando è terminato un'altro). I I progetti, normalmente operazioni di salvataggio, possono realizzare qualsiasi operazione.

Cliccando su Nuovo, si assegna un nome ( non più modificabile) al progetto e una piccola descrizione.

Usando Rimuovi, si cancella definitivamente il progetto visualizzato. Nota: se è associato una o più date o eventi, l'Utente deve confermare la rimozione.

Nel campo Commento è possibile digitare una breve descrizione del progetto.

Tipi di azioni di progetto:

· Esegui un programma o una file batch: tramite questo opzione può essere avviato un programma o un comando interno (per esempio COPY) o un file batch (.BAT). I files possono essere compressi o masterizzati su un CD/DVD. Il programma/procedura batch è selezionato tramite il tasto Soglia. Il nome e il percorso dell'applicazione devono essere delimitati da " nel caso che il programma il percorso contengono uno o più spazi. Possono essere specificati ulteriori parametri dopo l'ultimo " Per esempio: "C:\Programmi\Mioprogramma\MioProg.exe" parameter1 parameter2. Se l'Utente seleziona Avvia in modo invisibile senza visualizzare finestre, l'applicazione è avviata in modo invisibile.

Se si usa l'opzione Suono in caso di errore, viene generato un suono (in accordo con le opzioni Messaggi) se il programma o il file BAT chiude con un codice di errore diverso da 0.

Nota: quando si usa un file BAT, può essere usato EXIT xx per impostare il codice di ritorno. Se il file BAT contiene il comando if .. then... , questo può essere usato il codice di uscita. Se il codice di uscita è 0 significa che il tutto è terminato correttamente, in caso contrario viene generato questo allarme sonoro e non vengono avviati altri progetti in cascata a questo.

· Copia files o cartelle: in questo caso possono essere copiati files o cartelle. Tramite il pulsante configura si può configurare opportunamente le operazioni di copia files e cartelle files. Nota:questa funzione è disponibile solo nella versione registrata.

· Masterizza CD/DVD usando NERO: Hard Disk Sentinel può usare l'applicazione NERO (TM) della società Ahead Software AG per masterizzare il contenuto di una cartella su un'unità ottica.

E' necessario specificare il percorso del programma NEROCMD.EXE (la versione command-line di Nero) usando Seleziona l'applicazione. Se non viene specificato ma un progetto richiama Nero, Hard Disk Sentinel chiederà di definire il percorso dell'applicazione non trovata.

La sequenza dei comandi che verrà usata viene mostrata. Usando CTRL+C, è possibile copiarla negl'appunti.

E' da definire la cartella da salvare Essa può contenere variabili (per esempio, %USER%, %LAST%, ecc) i cui dettagli sono descritti nella pagina impostazioni cartelle. Se viene usato %LAST%, la cartella più recente (creata con l'uso di data e ora ) contenuta nella cartella specificata (che nel nostro caso è C:\Documenti ) viene usata come cartella d salvare. Questa definizione se un progetto precedente ha salvato i dati in C:\Documenti è ed stata usata l'opzione : Usa la data come nome della cartella e conserva gli ultimi XX salvataggi completi .

E' necessario specificare l'unità di uscita (in caso ci siano più di un driver ottico installato) è la velocità di scrittura. Deve essere impostata anche il tipo di supporto (CD or DVD) inserito. La velocità che viene visualizzata dipende dalle proprietà sia dell'unità sia dal supporto ottico. Sono impostabili anche la protezione del buffer underrun (BURN) e la verifica scrittura.

E' possibile usare altri comandi nella riga i comandi che verranno inviati a NEROCMD.EXE. Come parametro può essere usato --disable_eject per disabilitare l'espulsione del disco. La lista completa può essere visualizzata tramite il comando NEROCMD /?

E' possibile avviare una masterizzazione 'silenziosa' (ovvero senza l'apertura di nessuna finestra ) è gestirne gli errori tramite l'azione di progetto Esegui un programma o una file batch. Si prega di consultare il manuale di NEROCMD per scoprire tutte le sue funzionalità.

Nota: questa funzione è disponibile solo se la versione è registrata.

· Comprimi files usando RAR/7-Zip: Hard Disk Sentinel può usare, come compressori, l'applicazione WINRAR (TM) della società RarSoft oppure l'applicazione gratuita 7-Zip. La lista delle opzioni sono comuni ai due compressori. Nota: Le vecchie versioni di 7-Zip non supportano la modalità multi volume.

E' necessario selezionare, tramite il pulsante Seleziona l'applicazione, il percorso dei programmi RAR.EXE o 7Z.EXE. e non viene specificato ma un progetto richiama Nero, Hard Disk Sentinel chiederà di definire il percorso dell'applicazione non trovata.

La sequenza dei comandi che verrà usata viene mostrata. Usando CTRL+C, è possibile copiarla negl'appunti.

La cartella da comprimere è specificata tramite la finestra cartella da salvare. Essa può contenere variabili (per esempio, %USER%, %LAST%, ecc) i cui dettagli sono descritti nella pagina impostazioni cartelle.

E' richiesto anche la definizione del file di uscita ovvero il file compresso. Tramite l'opzione multi volume si abilita l'archiviazione del file di uscita su più volume la cui dimensione singola è pari a xxxxx kbytes (1024 bytes).

E' possibile usare altri comandi nella riga i comandi che verranno inviati a RAR o 7Z. Come parametro può essere usato -mXXX per specificare il tipo di compressione, '-pXXX per specificare una password oppure -sfx pr creare un file compresso auto estraente La lista completa può essere visualizzata tramite il comando WINRAR /? or 7Z

E' possibile avviare una compressione 'silenziosa' (ovvero senza l'apertura di nessuna finestra ) è gestirne gli errori tramite l'azione di progetto Esegui un programma o una file batch. Si prega di consultare il manuale di WINRAR o 7-Zip per scoprire tutte le sue funzionalità.

· Esporta sezioni del registro: la chiave del registro specificata viene esportata nel file d uscita (il nome del file può contenere anche variabili).

Nota: questa funzione è disponibile solo se la versione è registrata.

Tramite il pulsante Salva si memorizza i progetti creati o modificati. Si consiglia di usare questo pulsante con una certa frequenza. Usando il pulsante Ripristina l'ultimo salvataggio è possibile ricaricare l'ultimo salvataggio della configurazione dei progetti.

Tramite il pulsante Avvia ora il progetto è avviato immediatamente. Prima di pigiare questo pulsante d consiglia di Salvare il progetto.

Hard Disk Sentinel, tramite il pulsante [image] , può creare un collegamento del breve per il progetto corrente che può essere usato per lanciare velocemente il progetto relativo anche se Hard Disk Sentinel non è attivo.

Nota: se il progetto in questione contiene delle variabili, queste assumono il valore che avevano nel momento in cui è stato creato il collegamento. Si raccomanda di non usare variabili per progetti che verranno eseguiti tramite collegamento sul desktop oppure usare solo variabili costanti (per esempio %COMPUTER%).

Nota: questa funzione è disponibile solo se la versione è registrata.

Dopo che il progetto è stato creato ( e testato con l' Avvia ora ) è possibile richiamarlo opportunamente nella pagina operazioni/pianifica o operazioni/backup di emergenza . In quest'ultimo caso, i progetti saranno avviati come nella finestra degl'allarmi

Test hard disk(s): E' possibile esaminare e testare il disco usando la funzione Test hard disk (supportato da dischi IDE e S-ATA). E' possibile selezionare un singolo disco o tutti quelli installati simultaneamente

Se si muove il mouse sopra il disco, vengono visualizzati i tests supportati: selezionare il tipo di test desiderato.

E' possibile inviare il report allo sviluppatore del software,quando il test è terminato (sempre o in caso di errore). Il report contiene i dettagli del test, inclusi eventuali problemi ( per esempio: settori rovinati ).

Nota: questa funzione è disponibile solo nella versione registrata.

Nota: Le versioni future potrebbero avere altri tipi di progetti.

Tramite il pulsante Salva si memorizza i progetti creati o modificati. Si consiglia di usare questo pulsante con una certa frequenza. Usando il pulsante Ripristina l'ultimo salvataggio è possibile ricaricare l'ultimo salvataggio della configurazione dei progetti.

Tramite il pulsante Avvia ora il progetto è avviato immediatamente. Prima di pigiare questo pulsante d consiglia di Salvare il progetto.

Hard Disk Sentinel, tramite il pulsante [image] , può creare un collegamento veloce per il progetto corrente che può essere usato per lanciare velocemente il progetto relativo anche se Hard Disk Sentinel non è attivo.

Nota: Se il progetto in questione contiene delle variabili, queste assumono il valore che avevano nel momento in cui è stato creato il collegamento. Si raccomanda di non usare variabili per progetti che verranno eseguiti tramite collegamento sul desktop oppure usare solo variabili costanti (per esempio %COMPUTER%).

Nota: questa funzione è disponibile solo se la versione è registrata.

Dopo che il progetto è stato creato ( e testato con l' Avvia ora ) è possibile richiamarlo opportunamente nella pagina operazioni/pianifica o backup di emergenza . In quest'ultimo caso, i progetti saranno avviati come nella finestra degl'allarmi


Pianificazioni

Operazioni, Pianificare

Queste funzioni sono disponibili solo nella versione PROFESSIONAL.

Può essere definita una lista di progetti da eseguire per ogni giorno della settimana. Nella tendina Esegui il, l'Utente può scegliere il giorno nel quale deve essere avviato il Progetto/i .

Tramite l'opzione sospendi il prossimo giorno trovato, si decide bloccare i progetti il prossimo giorno selezionato. Per esempio, se il giorno selezionato è il lunedì e l'opzione sospendi è attivata, il prossimo lunedì non verranno avviati i progetti. Ciò può essere utile all'amministratore per disabilitare momentaneamente la sequenza di progetti. Dopo che il giorno è passato (es. dopo il prossimo lunedì ), l'applicazione riattiva di nuovo questi progetti.

La croce X rossa sotto la dicitura Cancella può essere usata per rimuovere il corrispondete progetto dalla lista ( tuttavia rimane presente nella scheda progetti). A destra della croce rossa c'è il numero c'è il numero del progetto utile nel caso si voglia creare una catena di progetti: uno dopo l'altro.

Nella colonna Progetto, viene visualizzato il nome del progetto creato nella scheda Progetti.

Nella colonna Avvio viene impostato il modo con qui verrà avviato il progetto. Queste sono le possibili modalità:

•

Ora precisa: il progetto viene avvitato all' Ora impostata (ora:minuti). Se il progetto non può partire all'ora impostata (per esempio, se il sistema non è attivo), il progetto viene avviato appena possibile se l'opzione Anche più tardi è impostata. Si coglie l'occasione per ricordare che progetti lunghi vanno pianificati solo di notte.

•

Dopo l'avvio: avvia il progetto dopo un certo ritardo dalla partenza di Hard Disk Sentinel . Il ritardo è impostabile nella colonna Ora (ora:minuti). In altre parole il progetto è avviato ogni qualvolta viene riavviato Hard Disk Sentinel. Si raccomanda di usare questa opzione per backup veloci.

•

Dopo l'avvio 1/giorno: come l'opzione precedente ma con la differenza che questo progetto è avviato solo la prima volta (nell'ambito di un giorno ) in cui viene avviato Hard Disk Sentinel. Raccomandato, per esempio, per aggiornare l'antivirus.

•

Ripetitivo: ripetere questo progetto dopo un periodo prestabilito. Il periodo è impostabile nella colonna Ora (ora:minuti).. Raccomandato per salvataggi differenziali.

•

Dopo X : viene avviato questo progetto quando il progetto x si è concluso.Nota: Se il progetto X non esiste, questo progetto non partirebbe. Raccomandato per progetti di archiviazione files, masterizzazione su unità ottiche

Con l'opzione Chiedi prima di avviare il progetto non parte automaticamente ma viene visualizzata una finestra con il nome e il commento del progetto con la quale si chiede autorizzazione a procedere. Se si risponde no, questo progetto e queeli concatenati non verranno avviati. Nota: questa opzione può essere disabilitata solo se la versione è registrata ovvero la versione non registrata chiede sempre la conferma a procedere.

Se l'opzione Abilita non è impostata, il progetto relativo è bloccato senza che ci sia la necessità di rimuoverlo completamente. Nota: se si disabilita un progetto dal quale dipendono altr progetti, anche questi non verranno avviati: Hard Disk Sentinel avvisa l'Utente che c'è questa situazione particolare.

Un nuovo progetto viene aggiunto con Aggiungi un nuovo progetto alla lista.


Backup di emergenza

Operazioni,Backup di emrgenza

Queste funzioni sono disponibili solo nella versione PROFESSIONAL.

I progetti vanno inseriti con lo stesso modo usato nella finestra Pianifica .Questi progetti verranno eseguiti allorché è previsto il backup di emergenza nella finestra Avvisi.

Nella tendina Disco è possibile selezionare il disco a cui si riferirà il progetto/i che saranno definiti.

La croce X rossa sotto la dicitura Cancella può essere usata per rimuovere il corrispondete progetto dalla lista ( tuttavia rimane presente nella scheda progetti). A destra della croce rossa c'è il numero c'è il numero del progetto utile nel caso si voglia creare una catena di progetti: uno dopo l'altro.

Nella colonna Progetto, viene visualizzato il nome del progetto creato nella scheda Progetti.

Nella colonna Avvia è possibile definire quando deve essere avviato il processo ovvero::

•

Automatico: avvia automaticamente nel momento in cui viene rilevato il problema.

•

Dopo X : viene avviato questo progetto quando il progetto x si è concluso. Nota: Se il progetto X non esiste, questo progetto non partirebbe

Con l'opzione Chiedi prima di avviare il progetto non parte automaticamente ma viene visualizzata una finestra con il nome e il commento del progetto con la quale si chiede autorizzazione a procedere. Se si risponde no, questo progetto e quelli concatenati non verranno avviati. Nota: questa opzione può essere disabilitata solo se la versione è registrata ovvero la versione non registrata chiede sempre la conferma a procedere.

Se l'opzione Abilita non è impostata, il progetto relativo è bloccato senza che ci sia la necessità di rimuoverlo completamente. Nota: se si disabilita un progetto dal quale dipendono altr progetti, anche questi non verranno avviati: Hard Disk Sentinel avvisa l'Utente che c'è questa situazione particolare.

Un nuovo progetto viene aggiunto con Aggiungi un nuovo progetto alla lista.


Trasferimento files

La versione registrata di Hard Disk Sentinel PROFESSIONAL possiede un modulo interno adibito ai salvataggi. Tramite di esso è possibile configurare diverse tipologie di salvataggi. La configurazione e le funzioni sono descritte in questi capitoli:

•

Opzioni generali

•

Operazioni

•

Opzioni

•

Opzioni cartelle

•

Avanzamento progetto


Opzioni generali

Operazioni, copia files e cartelle: opzioni generali

Queste funzioni sono disponibili solo nella versione PROFESSIONAL registrata.

Si possono definire quali sono i suffissi dei file da escludere in fase di salvataggio.

Nota: Questa opzione è valida per tutti i progetti di backup.


Operazioni

Operazioni, trasferimento files e cartelle: operazioni

Queste funzioni sono disponibili solo nella versione PROFESSIONAL registrata.

Tramite il pulsante Nuovo si definiscono le cartelle da salvare e le cartelle di destinazione tramite la finestra apposita. Tramite[****]Modifica si possono effettuare modifiche a una riga e con Cancella si elimina una riga dalla lista.

Nelle finestra Generali si possono impostare le opzioni comuni a tutti i progetti "trasferisci files e cartelle". Nella finestra Opzioni si possono impostare opzioni particolari per il progetto selezionato .


Opzioni

Operazioni, Copia files e cartelle: opzioni

Queste funzioni sono disponibili solo nella versione PROFESSIONAL registrata.

Con queste opzioni è possibile personalizzare il progetto di backup.

Calcola l'ammontare dei dati da copiare: Hard Disk Sentinel può calcolare l'ammontare dei dati da salvare per poter stimanarne la durata. In caso di una mole elevata questo calcolo può durare un certo tempo: in questo caso si può disabilitare questa opzione . Se il progetto è relativo a un backup di emergenza, questa opzione dovrebbe non essere non selezionata.

Non avviare il backup se la mole è inferiore a XX kbytes: non eseguire il salvataggio se la cartella da salvare ha una dimensione minore di xx KB. Con questa opzione, è possibile mantenere come validi i backup esistenti e evitare di creare backup di cartelle vuote o con contenuti parziali.

Avviso acustico se la mole è inferiore a a XX kbytes: genera un avviso se la mole di dati è inferiore di xx kbytes tramite e e-mail, messaggi in rete o messaggio sul video ( rif. finestra messaggi). E' anche possibile un avviso acustico (vedi sotto).

Verifica i dati copiati: durante il salvataggio, Hard Disk Sentinel crea automaticamente il carattere di controllo CRC per tutti i files (e memorizza questo valore nella cartella di destinazione) per controllare l'integrità del salvataggio e, in seguito, per controllare la fase di ripristino ( funzione disponibile in futuro). Se questa opzione è selezionata viene controllata,dopo il salvataggio, la sua integrità. Se il salvataggio ha grosse dimensioni questa operazioni può durare un certo tempo.

Copia solo i nuovi files o quelli modificati: salva solo i nuovi files o quelli modificati rispetto all'ultimo salvataggio ( rif. salvataggio differenziale).

Togli il bit archive sui files copiati: Hard Disk Sentinel cancella, dopo il salvataggio, il bit di archive. Questa opzione è da usare in combinazione con la precedente.

Cancella i files dopo averli copiati con successo: cancella tutti i files contenuti nella cartella da salvare dopo il completamento del salvataggio stesso. Usare questa funzione solo in casi speciali (per esempio, in caso di salvataggi da un'unità di piccola capacità al fine di liberare spazio). Nota: le (vuote) cartelle non sono cancellate.

Salva le sottocartelle: vengono salvate anche le eventuali sottocartelle.

Salva il nome della cartella (da salvare) e il suo contenuto: se si seleziona questa opzione, il nome della cartella da salvare (l'ultima cartella del percorso) viene creata anche nella cartella di destinazione ed in essa verranno copiati i relativi files. Se questa opzione è disabitata, il contenuto della cartella da salvare viene copiata direttamente nella cartella di destinazione. Esempio:Cartella da salvare:C:\MAIL - Cartella destinazione: C:\BACKUP. In questo caso se l'opzione è disabilitata il risultato è che viene effettuata la seguente copia normale mentre se è abilitata il risultato nella cartella di destinazione è il seguente :C:\BACKUP\MAIL\files..

Non visualizzare la finestra di stato di avanzamento salvataggio: normalmente è visualizzata la finestra di stato d'avanzamento progetto. Se questa opzione è impostata, la finestra non viene visualizzata ma lampeggia solo una icona (floppy) in systry per indicare che il salvataggio è in corso.

Usa la data come nome della cartella e conserva gli ultimi XX salvataggi completi: se si usa questa opzione viene generata, nella cartella di destinazione del backup, una cartella avente il nome aaaa-mm-gg_hh_mm. Per esempio, se un backup è previsto giornalmente, dopo una settimana troveremo sette cartelle dl backup: una per giorno. Inoltre verrà conservate solo un numero di cartelle ( con la data) previsto nell'opzione: gli archivi più vecchi saranno cancellati. Usando questa opzione è possibile ripristinare una situazione retroattiva al massimo di xx salvataggi. Il lato, forse, negativo è che questo sistema necessita di un pò di spazio.

E' possibile generare un report dopo l'esecuzione del backup in ogni caso oppure, solo in presenza di problemi oppure mai. Il report può essere inviato via e e-mail, via messaggi di rete, oppure può essere visualizzato un messaggio sullo schermo ( rif. finestra messaggi) E' anche possibile un avviso acustico (vedi sotto).

Se si abilita l'opzione Avviso acustico in caso di problemi, viene generato il suono impostato nella finestra allarmi.

E' possibile impostare la priorità del progetto: se è "massima" il progetto è eseguito il più presto possibile scapito delle altre applicazioni. La massima è da usare solo in caso i backup di emergenza, altrimenti usare idle o normale).


Opzioni cartella

Operazioni, trasferimento files e cartelle: opzioni cartella

Queste funzioni sono disponibili solo nella versione PROFESSIONAL registrata.

Tramite questa finestra si definisce la cartella da salvare e la cartella(e) destinazione. Nel senso che che una cartella può essere copiata su più cartelle.

Quando si definisce la cartella di destinazione è possibile usare (una o più) varabili. Per esempio è possibile creare delle cartelle differenti legate al nome utente o al nome computer ecc.. Hard Disk Sentinel può creare automaticamente la cartella di destinazione se quella specificata non esiste.

Con la variabile %LAST=cartella% , il nome della cartella è uguale al nome dell'ultima all'ultima usata ( questa opzione ha senso solo se si usa l'opzione "usa la data come nome della cartella...." nella pagina opzioni del progetto. Questa opzione può essere utile per masterizzare/comprimere ( tramite un progetto di tipo ' segui un programma o un file batch'.

E' possibile usare questa variabile anche in forma ridotto ovvero solo %LAST%. In questo caso, la cartella prima di %LAST% corrisponderà all'ultimo salvataggio. Per esempio C:\BACKUP\%LAST=C:\BACKUP% e C:\BACKUP\%LAST% generano lo stesso risultato (ovvero il backup di C:\BACKUP). Si raccomanda di masterizzare un CD/DVD usando uno di questi esempi come cartella da salvare, in questo caso verrà masterizzata la cartella più recente.

Nota: I formalismi %LAST=folder% e %LAST% possono essere usati solo se si usa l'opzione Usa la data come nome della cartella e conserva gli ultimi XX salvataggi completi.

Nota: la cartella può essere sul computer locale o su uno in rete. E' possibile specificare solo percorsi standard UNC ( (Universal Naming Convention) es. \\server\cartella . Si prega di verificare che il percorso di rete sia disponibile.


Trasferimento files

Operazioni, trasferimento files e cartelle: trasferimento files

 Top Previous Next

I processi di tipo copia files e cartelle definiti nella finestra operazioni, nel momento che vengono avviati viene visualizzata un finestra contenete l'operazione in corso (copia,verifica ecc), la percentuale di avanzamento, il tempo rimasto ecc - se l'opzione calcola l'ammontare dei dati è selezionata.

L'esecuzione del progetto di salvataggio può essere interrotta tramite Cancella. In questo caso, Hard Disk Sentinel crea un report (se l'opzione report è abilitata) per informare l'Utente che il corrente progetto è stato interrotto: se ci sono progetti legati a quello interrotto non vengono avviati. Nota: in qualche caso l'interruzione necessita di qualche secondo.

Se si pigia sulla X (chiudi) in alto a destra, questa finestra viene nascosta e il salvataggio prosegue: il suo avanzamento, ora, viene visualizzato in systray tramite un'cona (floppy) lampeggiante:

Hard Disk Sentinel visualizza l'operazione corrente se si passa con il mouse sopra l'icona del floppy. Se, invece si clicca con il tasto sinistro sul floppy , viene visualizzata di novo la finestra di stato d'avanzamento.

Nota: Al termine di un progetto, il resoconto viene salvato nel file project_log.txt nella cartella di installazione di Hard Disk Sentinel. Si raccomanda di esaminarlo in caso di problemi.


Integrazione

In questa finestra è possibile configurare l'integrazione di Hard Disk Sentinel con il sistema operativo.

Protezione

L'applicazione può essere protetta da una password: senza conoscerla non è possibile visualizzare le opzioni della configurazione. In più, è possibile definire una password per poter modificare le opzioni della configurazione.

Se la protezione è attivata, l'amministratore, digitando la password, può accedere alla corrispondente finestra. Il software ricorda la password dopo la chiusura della finestra per cui l'utente non deve ridigitarla a meno che l'opzione Sconnetti sia stata abilitata. In questo caso, una volta scaduto il tempo impostato, Hard Disk Sentinel chiederà di nuovo la password..

L'amministratore di sistema può impostare l'opzione Attiva la password ora dopo aver visto e/o modificato qualcosa: in questo modo l'interfaccia del programma è di nuovo protetta.

Nota: Questa funzione è disponibile solo se il prodotto è stato registrato.

Service

Hard Disk Sentinel può lavorare in due differenti modi . Esso può funzionare come Applicazione o come Servizio. Di default, esso viene avviato come Applicazione ovvero il software viene startato all'accesso dell'utente ( con i diritti di amministrazione corretti ). Prima della versione 2.02 era possibile solo questo modo.

Quando Hard Disk Sentinel funziona come NT Service, il software viene caricato insieme al sistema operativo al di là della connessione dell'utente al sistema operativo e dei suoi diritti.

In questo modo Hard Disk Sentinel lavora indipendentemente dall'utente e l'applicazione controlla e verifica lo stato dei dischi ed effettua le operazioni di backup start backup come nell'altro modo.

Solo l'amministratore di sistema può installare, disinstallare o modificare i servizi. Infatti l'amministratore può configurare le opzioni (per esempio: impostare le soglie, gli allarmi) e passare in Service mode. Si raccomanda di usare la suddetta opzione (protezione) per evitare modifiche alla configurazione non autorizzati !!

Note riguardo il 'service mode':

· Questa modalità è disponibile solo su sistemi operativi NT (Windows 2000, XP, 2003, Vista).
· Il software ha le stesse funzionalità sia in service mode sia in modo applicazione.
· Il nome del servizio è: HardDiskSentinelService, e viene avviato con una connessione al "Sistema locale". L' amministratore può effettuare modifiche tramite il Pannello d controllo, Strumenti di amministrazione, Servizi (per esempio per abilitare l'accesso a dischi /risorse remote). I progetti di backup e le applicazioni esterne ereditano i diritti necessari.
· Il Service mode può essere avviato o terminato anche tramite il menù di avvio grazie al collegamento veloce del gruppo Hard Disk Sentinel.. Dopo l'interruzione del servizio è possibile passare al modo applicazione. Chi fa queste operazioni deve avere i diritti e la password (se prevista) necessari.
· E' possibile usare il software in modo "invisibile" ,ovvero senza la visualizzazione delle icone in systray, finestre messaggi vari ecc, se disabilita la funzione "Consenti al sevizio di interagire con il desktop" presente nelle proprietà del servizio. In questo caso l'utente non riesce ad accedere alle finestra principale o a quella di configurazione fino a quando il servizio non viene stoppato tramite il collegamento veloce. Windows Vista non permette all'utente di interagire con i servizi, infatti se si usa il sistema operativo Vista Hard Disk Sentinel service funziona in modo "invisibile" . La funzione invisibile è adatta solo a utenti esperti
· Quando è attivo il service mode,la funzione aggiornamenti non è possibile e per cui, se i vuole effettuare gli aggiornamenti il servizio va chiuso tramite l'apposito pulsante o il menù di avvio.
· Per l'avvio o la chiusura del servizio non e' necessario ricaricare il sistema.
· L'amministratore del sistema dovrebbe disabilitare l'accesso alla cartella di Hard Disk Sentinel da parte degli utenti con diritti limitati. In questo si evitano manomissioni a certi file che contengono le impostazioni dell'applicazione.
· Qualche sistema, applicazione o temi del desktop possono causare un visualizzazione scorretta di qualche parte dell'interfaccia utente (finestra di stato, informazioni sul desktop).

Controllo remoto.

Se l'opzione Abilita controllo via web è abilitata è possibile controllare lo stato dei dischi da un computer in rete o da un computer remoto / mobile phone/PDA usando un normale browser. E' possibile specificare una password per evitare accessi non autorizzati. Tramite il pannello Protezione è possibile, infatti, specificare un nome utente e una password da utilizzare per l'accesso remoto.

E' possibile specificare la porta HTTP, in accordo con la configurazione di rete.

Nota: questa funzione è disponibile solo nelle versioni registrate.

Quando l'opzione è abilitata sono possibili queste tipi di ricerche da utilizzare nel web browser:

· http://server:port/status : viene visualizzata l'intera finestra di stato con tutti i suoi contenuti (esattamente come configurata, con una frequenza di aggiornamento come specificato qui. La finestra non ha bordi o margini e può essere inserita in un IFRAME.
· http://server:port/statuswin.bmp : finestra di stato ma solo con immagine
· http://server:port/report : viene visualizzato il report HTML cosi' come configurato nella sezione messaggi
· http://server:port/xml : report XML completo

Nota: Si può usare l'opzione status anche se la finestra di stato è disabilitata sul computer (server).

Nota: Se il Vostro computer server usa un IP dinamico è necessario usare un provider che trasformi l'IP dinamico in un nome host predeterminato. Questo servizio è offerto gratis per esempio da www.no-ip.com , www.dyndns.com ecc.

Nota: Tutte le richieste remote vengono memorizzate con il loro IP e data nel file "NetLog.txt". Richieste non ammesse verranno interrotte con la segnalazione l'errore: 403 Forbidden nel browser. NON è possibile accedere ai files di sistema o ad altre informazioni di sistema.

Le finestre di stato di due o più computer possono essere facilmente combinate in una singola pagina web (con l'automatico aggiornamento). Con questo sistema è possibile esaminare lo stato di differenti configurazioni aprendo una banale pagina con il browser tramite file server in rete o tramite un PC/phone/PDA remoto. Esempi:

<html>

<head>

<title>Hard Disk Sentinel Status</title>

</head>

<body>

<center>

<iframe src="http://192.168.2.101:61220/status" width=220

height=61 frameborder=0></iframe><br>PC #1<br><br>

<iframe src="http://192.168.2.102:61220/status" width=220

height=61 frameborder=0></iframe><br>PC #2<br><br>

<iframe src="http://192.168.2.103:61220/status" width=220

height=61 frameborder=0></iframe><br>PC #3<br><br>

</body>

</html>

Visualizzazione di 3 finestre di stato in IFRAMEs (aggiornato automaticamente, separatamente).

<html>

<head>

<title>Hard Disk Sentinel Status</title>

<META HTTP-EQUIV="Refresh" CONTENT="300">

<META HTTP-EQUIV="Pragma" CONTENT="no-cache">

<META HTTP-EQUIV="Expires" CONTENT="-1">

<META HTTP-EQUIV="CACHE-CONTROL" CONTENT="NO-CACHE">

</head>

<body>

<center>

<a href="http://192.168.2.101:61220/report"><img

src="http://192.168.2.101:61220/statuswin.bmp" border=0></a><br>PC #1<br><br>

<img src="http://192.168.2.102:61220/statuswin.bmp"><br>PC #2<br><br>

<img src="http://192.168.2.103:61220/statuswin.bmp"><br>PC #3<br><br>

</body>

</html>

Visualizza 3 finestre di stato, e aggiorna tutto ogni 300 secondi. Quando la 1° finestra è cliccata, viene visualizzato il report completo di questo computer.

Accetta connessioni remote dal server: Hard Disk Sentinel Enterprise può essere usato per analizzare dischi aziendali ovvero controllare i dischi su cui funziona un Hard Disk Sentinel client. Se questa opzione è abilitata, il Server può inviare comandi per prelevare informazioni di questo Client.

Abilita DynDNS, No-IP o un Servizio personalizzato: Usando questi servizi, è possibile trasformare un indirizzo IP dinamico in un nome host fisso/statico. In questo modo è possibile gestire in remoto un computer anche se utilizza un IP dinamico.

Per configurare questi Servizi è necessario iscriversi gratuitamente a uno di questi due servizi. I parametri richiesti, tramite il pulsante "Configura" sono : nome utente, password e il nome dell'host scelti in fase di registrazione. Quando l'applicazione rileva un variazione dell'indirizzo IP la comunica, ogni minuto, al servizio DNS Dinamico.

Al termine dell'introduzione dei tre parametri, è possibile effettuare un test per verificare che tutti i parametri introdotti siano corretti

Se la configurazione è stata impostata correttamente, la risposta è positiva e la si vede passando con il mouse sul servizio.


Invia report raw

Invia raw report

Invia raw report

Da questa pagina è possibile creare un report "raw" , ovvero le informazioni prelevate dai dischi, e invialo al team di Hard Disk Sentinel. Queste informazioni ci aiutano a capire eventuali problemi o a implementare l'applicazione.

Il report può essere salvato e inviato in un secondo tempo manualmente via email a: reports@hdsentinel.hu o immediatamente tramite l'apposito pulsante.


Appendice

Appendice

Le informazioni generali relative alla tecnologia S.M.A.R.T. e le funzioni di Hard Disk Sentinel sono descritte nei seguenti capitoli che, tenuto conto del loro contenuto tecnico, non sono stati tradotti:

•

Vendor specific vs raw values

•

Health calculation

•

Performance calculation

•

Power on time

•

Temperature calibration

•

•

•

S.M.A.R.T. attributes

Text Description

Test Hard Disk


Vendor specific vs raw values

As described on the S.M.A.R.T. page of the hard disks, you may see that the evaluation of attributes are possible by using the vendor specific method (checking the value and the worst fields) or by using a different method which is independent from the manufacturer (checking the data field). How these two different methods work and what is the difference?

Vendor specific values

The current status of the hard disk are constantly examined by many sensors. The raw values measured are stored (in the "data" field of the corresponding S.M.A.R.T. attribute) and evaluated by an algorythm (coded internally in the firmware of the hard disk).

After this evaluation, the vendor specific result for the attribute is stored in the value field. It indicates how "good" the attribute is (compared to the number in the threshold field. When the hard disk is new (never used before) this value has a theoretical maximum value and then it decreases - until it reaches the threshold level.

This way one attribute is perfect if the following inequality is TRUE:

A - f(r) >= C

Where:

•

A - theoretical maximum value, the "best" possible value for the attribute.

•

f - a function to calculate the decrement based on the raw (r) values. Usually it is a linear function, so r is multiplied by a B constant.

•

C - the vendor specific threshold level, under this level, the attribute is considered problemmatic.

Using this method has some disadvantages. The A, B, C, values (or the f function) is not defined exactly (these may vary from model to model even on two hard disks from the same manufacturer). Other disadvantage is that the attributes are evaluated independently, the relationship between them is ignored.

In the real life it is possible to find non realistic values which may indicate improper status of the hard disk. Some hard disk manufacturers may define 60-70 years or even more for a hard disk total lifetime when the corresponding attribute is examined. Also it is possible that many thousands of bad sectors are needed until the hard disk will show itself problemmatic if the above method is used. Of course, many problems may occur long time before reaching this threshold. For example, examining and reallocating data from sectors on a bad (damaged) data area may take lots of time (even hours) - and it may not be completed without problems. During this process, the system is usually not responding, so a problemmatic hard disk which generates problems again and again may significantly reduce the overall system stability.

Most hard disk analyser applications use the above method to determine the hard disk health status. In many cases, displayed hard disk status is much better than the actual because of the moderate threshold values. Some manufacturers may change the values to show the health status of their driver better than others. This may mislead some softwares or the users.

It is important that after one S.M.A.R.T. attribute reaches the threshold level, the hard disk should run for 24 hours (to run a possible backup). In most cases it is not enough and only partial data can be saved during this time. Saving data from a problemmatic, almost dead hard disk can be very painful, long and expensive process. It is better to identify and prepare for the problem long time before a catastrophic situation.

Analysing raw values

Hard Disk Sentinel was designed to overcome this situation. The default evaluation methods check the raw values of the S.M.A.R.T. attributes. This way it is possible to determine the hard disk health independently from the manufacturers and models. Note: it is possible to select vendor specific evaluation method in the condition calculation. But the constant use of this method is not recommended (because of the problems described above), as it may give improper results.

When raw values are evaluated, there is no pre-defined (vendor specific) threshold for the attributes. But increasing problems reduce the disk health (constantly and drastically) and this predicts the possible failure and data loss.

The detailed explanation of the calculation methods are described here.


Health calculation

It is possible to select many different health (condition) calculation methods at the advanced options. The differences between these evaluation methods:

Analyse data field

If this option is selected, the raw, measured numbers (displayed in the Data column for the corresponding S.M.A.R.T. attributes) are used to determine hard disk health. When developing the calculation method, the following aspects were important:

•

It should reflect the actual status. Should not depend on time or past values. Determine the result without using long time analysing or testing methods.

•

It should not increase with time - do not show the health status better after some time (except if some pending sectors were successfully tested and they can be used because they have no problems).

•

It should reflect small changes and degradations. Constantly increasing number of problems should constantly decrease the result.

•

It should count the relationship between attributes. More different problems should decrease the result much drastically than only one single problemmatic attribute.

•

The result should be same for two (or more) hard disks with the same problems, even if the hard disks are from different models, manufacturers.

•

The result should be controlled in some situations. For example after replacing a problemmatic power supply, the problems encountered previously should be ignored. Also an improper sensor should be ignored or its value should be modified (please see temperature calibration about this).

The hard disk has 100% condition initially. All critical health-rated S.M.A.R.T. parameters (if they are available, it depends on the manufacturer) decrease this value. These attributes have a pre defined weight and a maximum limit value (the latter defines the maximum degradation in health value for the attribute). The overall health percent value is calculated by multiplying the remaining percent values (100 - degradation %).

Currently, Hard Disk Sentinel has two different such methods. By using the default method, the weights and limits (see below) are lighter. If the more strict, recommended for servers option is used the values are much more strict, the problems may reduce the health much drastically.

The following tables contain the health related (critical) S.M.A.R.T. attributes affecting the health value with their weights and maximum limits:

Weights and limits for the default calcuation method:

S.M.A.R.T. attribute | Weight | Limit %
Reallocated sectors count | 1 | 70
Seek error rate | 0.5 | 20
Spin retry count | 3 | 60
Reallocation event count | 0.6 | 30
Current pending sectors count | 0.6 | 48
Off line uncorrectable sectors count | 1 | 70

Weights and limits for the more strict calculation method:

S.M.A.R.T. attribute | Weight | Limit %
Reallocated sectors count | 6 | 60
Seek error rate | 2 | 20
Spin retry count | 6 | 40
Reallocation event count | 4 | 30
Current pending sectors count | 4 | 30
Off line uncorrectable sectors count | 6 | 60

The numbers are determined by examining the arrived reports and the S.M.A.R.T. status of (unusable) hard disks received for data recovery.

Note: the Data column contains hexadecimal values. These should be converted to decimal before calculation. The lower 16 bits (righmost 4 digits) are used in the calculation method.

For example: using the default calculation method. If the "Reallocated sectors count" attribute has 0002 in the "Data" column, the health value = 100 x ( 100 - 2x1 ) % = 98 %

If the "Current pending sectors count" attribute has 0005 in the "Data" column also on the same hard disk, the health is = 98 x ( 100 - 5x0.6) % = 95 %. The more strict calculation method gives 100 x (100 - 2x6) % x (100 - 5x4) % = 70 % as the resulting health value.

The limit % defines how much % can the attribute decrease the overall health value. For example, if the "Off line uncorrectable sectors" attribute contains 0200 in the "Data" column (which is 512 if converted to decimal value), the heatlh should fall by 512 x 1 = 512 %, but the limit for this attribute is only 70 %. With other words, if the value of the "Off line uncorrectable sectors" is high, the health value of the disk cannot be larger than 30 %. Other problems may decrease the health value more.

Analyse vendor specific values

If this option is selected, the health-related S.M.A.R.T. attributes are evaluated. All such attributes will have a small condition value calculated between 0 and 100% based on the actual value, the threshold and the theoretical maximum value (the latter is determined by Hard Disk Sentinel based on the manufacturer and model). Multiplying these values will give the overall health of the hard disk condition.

For example: the threshold for the "Reallocated sectors count" is 36, the value is 84 and the initial value for this attribute was 100. The condition value for this attribute is: (1 - (100-84)/(100-36)) x 100 = 75 %. If (on the same hard disk) the threshold for the "Seek error rate" is 30, the value is 60, and the initial value is 90, the condition of this attribute is 50 % and the overall health of the hard disk is 37.5 %.

Note: 1.40 and previous versions of Hard Disk Sentinel had only more strict, recommended for servers calculation method. Upgrading from 1.40 or older version may result in a different health value display. On the advanced options page it is possible to modify the calculation method any time.

Note: the selected calculation method is saved into the reports to prevent confusion.

Note: usually the different health values follow the formula:

Vendor specific >= Default >= More strict

By using the "more strict" method, the health value decreases drastically in case of any small problem, so the use of this method is recommended only when no (even small) problem is allowed.


Performance calculation

The performance value of the hard disk can be calculated differently (like the health value). The calculation method option on the advanced options panel defines the method used to calculate performance value also.

Analyse data field

Hard Disk Sentinel combines different values to determine this value. The raw values of performance related S.M.A.R.T. attributes (for example, seek time) affect the overall performance by maximum 25%. The number of data transfer errors (ultra ATA CRC errors) found in the last month may also reduce the performance value by 25%. These transfer errors are not really indicate the problem of the hard disk, but they can decrease the stability and performance of the system.

The rest 50% of the performance value is calculated by examining the currently used DMA transfer mode and the maximum available transfer mode. If the hard disk works only in PIO (programmed I/O) mode, this part of the condition value is 0 instead of 50.

For example: if the transfer rate is only Ultra DMA mode 2 (33 MB/s) instead of its maximum available transfer rate Ultra DMA mode 5 (100 MB/s) but the performance related S.M.A.R.T. attributes are correct and no data transfer errors found in the past month, the overall performance value will be 25 + 25 + (2/5) x 50 = 70 %. In this example, the problem is probably caused by using an old IDE cable with only 40 wires.

Analyse vendor specific values

If this option is selected, the performance-related S.M.A.R.T. attributes are evaluated. All such attributes will have a value calculated between 0 and 100% based on the actual value, the threshold and the theoretical maximum value (the latter is determined by Hard Disk Sentinel based on the manufacturer and model). Multiplying these values will give the overall performance value of the hard disk condition.


Power on time, remaining lifetime

Hard disk power on time can be determined by examining the #9 "Power on time count" S.M.A.R.T. attribute of the hard disk. This value is supported by most modern IDE and S-ATA hard disks.

The raw value of this attribute is constantly increasing when the hard disk is under power (running, but not neccessarily performing a read or write operation). The unit of the time depends on the manufacturer. It can be hours (the value is increased once per every hour), minutes or half-minutes. Different units are also possible and two hard disks from the same manufacturer may not have same time units.

After installation, Hard Disk Sentinel starts examining this attribute. It checks the elapsed time between two consecutive increases of the raw value of this attribute. During this test, "Measuring" is displayed instead of the power on time. This test can run up to 20 minutes (worst case). If the user closes the application during the test, it will be automatically restarted on the next launch of Hard Disk Sentinel until it can determine the unit of time used on all hard disks. After successful measure, the unit is saved and it will be used automatically later.

The value displayed next to the Power on time indicates the total time the drive was running (powered). Idle time (when there was no read or write operation) also increases this value but standby time does not increase this time. One displayed day means 24 hours. For example, a two years old hard disk which is used 12 hours every day will show the same "power on time" as a one year old hard disk which is used in 24/7 mode (like a 3 years old hard disk working 8 hours every day).

Note: the power on time display may not be correct on some models.

Estimated remaining lifetime

Analyse data field

if the "Analyse data field" option is selected as condition calculation method on the advanced options page, the remaining lifetime is calculated by the following method:

•

By default, the total expected lifetime of a hard disk in perfect condition is defined as 5 years (running every day and night on all days). This is equal to 1825 days in 24/7 mode or 43800 hours.

•

The elapsed power on time decreases this value.

•

The result is decreased according the number of days when the temperature was too high. If the maximum (peak) temperature was high, it is not so critical but if the average temperature was too high (it means the temperature was high for longer time) the result is reduced drastically.

•

The result is multiplied by the square of the health value of the disk.

Note: Hard Disk Sentinel displays 1000 days as maximum value for estimated remaining lifetime. Of course in an ideal situation this value will not decrease even after hundreds of days.

For example: the hard disk is working for 600 days (600 x 24 hours) and its temperature was not too hot (there were no days with too high average temperature) and the health is 70%. The total remaining lifetime is 1225 x 0.7 x 0.7 = 600 days and 6 hours.

As you can see, the health value drastically determines the estimated remaining lifetime of the hard disk. If the health value is low, the remaining lifetime display will remain unchanged for many days, even if the power on time value increases. For example, if the health value is 25% for a hard disk, 16 days needed (assuming the hard disk is working 24 hours daily) to decrease the remaining lifetime with one single day (because 16 x 0.25 x 0.25 = 1).

Note: the estimated remaining lifetime depends on many factors (temperature, health) so it is recommended to perform the steps of the temperature calibration and select the correct condition calculation method based on the actual situation and use the correct offset values for the S.M.A.R.T. attributes if neccessary. Only advanced users should use and modify these options because a wrong combination of settings may result in improper display of some values.

Analyse vendor specific values

If the "Analyse vendor specific values" setting is used, the estimated lifetime is determined by the threshold exceed date for the critical S.M.A.R.T. attribute which will reach its threshold before any other critical S.M.A.R.T. attributes of the hard disk. Such threshold exceed dates are displayed on the S.M.A.R.T. attribute graphs of a hard disk (if the "display vendor specific values" option is selected next to the graph).

Note: this method is reliable only if Hard Disk Sentinel constantly analyses the hard disks for a very long time (this may be weeks or even months). In other cases it is possible to predict incorrect results by a small degradation of the attributes (for example, threshold exceed date would be in January 2100. Of course this is not real but such values may appear in other hard disk monitoring applications). To avoid this situation, Hard Disk Sentinel displays 1000 days as maximum value for estimated remaining lifetime. Of course in an ideal situation this value will not decrease even after hundreds of days.


Temperature calibration

The temperature sensor built in most modern hard disks may give improper results. The difference between the measured and the actual temperature can be 7-9 Celsius degress or even more.

To fix this problem, it is possible (and recommended) to measure the actual temperature of the hard disk by using an external infrared thermometer or a front panel with temperature sensor and set the difference between the measured temperature and the temperature displayed by Hard Disk Sentinel (reported by the drive itself) as temperature offset. This is called calibration.

After the real temperature has measured (by the thermometer or other external temperature sensor), the offset can be calculated by subtracting the value reported by the software from the measured value. This offset can be positive (the software reports smaller temperature than the real) or negative (the software reports higher temperature than the real).

This offset can be specified on the S.M.A.R.T. page of the hard disk, after selecting attribute #194 (hard disk temperature) and using the + / - buttons (by clicking on the number between the icons, the offset value can be entered directly in Celsius units).

Hard Disk Sentinel will automatically increase (or decrease) all hard disk reported temperatures by the configured offset value. This way the correct (real) temperature will be displayed and used in all cases (for example, when checking hard disk temperature against a threshold and when saving reports etc.)

It is recommended to perform the temperature calibration on all installed hard disks if possible. Same type of hard disks may require different temperature offsets.

Note: if the calibration is not possible (the computer chassis cannot be opened), an estimated offset value can be determined by checking the first displayed temperature immediately after starting the computer and comparing the value with the environment (room, office) temperature. At this time, the CPU, video card or other components are not too warm and they do not affect the temperature of the hard disk. Of course this is true only if the computer had enough time to cool down to the environment temperature (it was not powered off for at least 8 hours).

For example, if the hard disk temperature is displayed as 17 Celsius degrees (immediately after starting the computer) and the room temperature is 22 Celsius degrees, +5 can be configured as offset value (because the hard disk cannot be cooler than its temperature). This offset is better than nothing but of course an external thermometer is needed to determine the proper temperature offset value.

Note: the temperature offset should be specified in Celsius units, regardless of the selected temperature unit (Celsius or Fahrenheit).

Note: the unregistered version automatically resets all offset values to 0 when the user restarts Hard Disk Sentinel.


S.M.A.R.T. attributes

S.M.A.R.T. attributes (ATA)

 Top Previous Next

This is the list of all known attributes supported by IDE and Serial ATA hard disks. Note: some manufacturers may use the attributes for different purposes also. Attributes not listed here are "vendor specific" attributes (their purpose is not known).

1 | Errors occured while reading raw data from a disk | Indicate problem with the disk surface or the read/write heads.
2 | General throughput performance of the hard disk | Indicate problem with motor, servo or bearings.
3 | Time needed by spindle to spin-up to full RPM | Indicate problem with motor or bearings.
4 | Count of start/stop cycles of spindle | This value does not directly affect the condition of the drive.
5 | Count of sectors moved to the spare area | Indicate problem with the disk surface or the read/write heads.
6 | Margin of a channel while reading data | The exact function of this attribute is not specified.
7 | Rate of positioning errors of the read/write heads | Indicate problem with servo, head. High temperature can also cause this problem.
8 | Average time of seek operations of the heads | Indicate problem with servo.
9 | Total time the drive is powered on | The unit of the measure depends on the manufacturer.
10 | Retry count of spin start attempts | Indicate problem with motor, bearings or power supply.
11 | Number of attempts to calibrate a drive | Indicate problem with motor, bearings or power supply.
12 | Number of complete power on/off cycles | This value does not directly affect the condition of the drive.
13 | Number of software read errors | The number of uncorreactable read errors.
190 | Airflow temperature | The temperature of the air inside the hard disk housing.
191 | Count of problems caused by mechanical shock | Acceleration (for example falling) can cause mechanical shock.
192 | Count of power off cycles | This value does not directly affect the condition of the drive.
193 | Count of load/unload cycles | Number of cycles the head moved into landing zone position.
194 | Disk temperature | The temperature inside the hard disk housing.
195 | Count of correctable errors | Number of errors corrected by the internal error correcting mechanism.
196 | Count of sector remap operations | Number of all (successful and failed) remap operations.
197 | Count of unstable sectors | These pending sectors may be remapped to the spare area.
198 | Count of uncorrectable errors when reading/writing | Indicate problem with the disk surface or the read/write heads.
199 | Count of errors during data transfer between disk and host | Indicate problem with the power supply or data cable.
200 | Errors occured while writing raw data from a disk | Indicate problem with the disk surface or the read/write heads.
201 | Number of software read errors | The number of uncorreactable read errors.
202 | Number of data address mark errors | Number of incorrect or invalid address marks.
203 | Number of data correction errors | Invalid error correction checksum found during error correction.
204 | Number of corrected data errors | Errors corrected by the internal error correction mechanism.
205 | Number of thermal problems | Total number of problems caused by high temperature.
206 | Head flying height | The height of the disk heads above the disk surface.
207 | Current value during spin up | The current needed to spin up the drive.
208 | Number of cycles needed to spin up | The number of retries during spin up because of low current available.
209 | Drive performance during offline operations | The seek performance of the drive during internal self tests.
220 | Distance of the disk has shifted relative to the spindle | Incorrect disk spin can be cause by mechanical shock or high temperature.
221 | Number of mechanical errors | Number of errors resulting from shock or vibration.
222 | Number of powered on hours | This value is constantly increasing (once per every hour).
223 | Number of load/unload operations | The number of drive head enters/leaves the data zone.
224 | Mechanical friction rate | The rate of friction between mechanical parts. Indicate problem with the mechanical subsystem of the drive.
226 | Total time the heads are loaded | The time while the read/write heads are in the data zone.
227 | Rate of torque increase | Torque increase during the spin up operation of the hard disk.
228 | Number of power off cycles | The number of times the head was retracted as a result of power loss.
230 | Head positioning amplitude | Head moving distances between operations.
231 | Disk temperature | The temperature inside the hard disk housing.
240 | Number of head positioning hours | Time spent during the positioning of the drive heads.
250 | Number of retries during read operations | Number of errors found during reading a sector from disk surface.

S.M.A.R.T. attribute list (SCSI)

This is the list of all known attributes supported by SCSI hard disks. Note: some manufacturers may use the attributes for different purposes also. Attributes not listed here are "vendor specific" attributes (their purpose is not known).

01 | Buffer over/under run counters
02_0000 | Write errors corrected without substantial delay
02_0001 | Write errors corrected with possible delays
02_0002 | Total write errors
02_0003 | Total write errors corrected
02_0004 | Total write errors corrected by algorythm
02_0005 | Total bytes written
02_0006 | Total uncorrected write errors
03_0000 | Read errors corrected by ECC hardware method
03_0001 | Read errors corrected with possible delays
03_0002 | Total read errors
03_0003 | Total read errors corrected
03_0004 | Total read errors corrected by algorythm
03_0005 | Total bytes read
03_0006 | Total uncorrected read errors
04_0000 | Read reverse errors corrected by ECC hardware method
04_0001 | Read reverse errors corrected with possible delays
04_0002 | Total read reverse errors
04_0003 | Total read reverse errors corrected
04_0004 | Total read reverse errors corrected by algorythm
04_0005 | Total bytes read reverse
04_0006 | Total uncorrected read reverse errors
05_0000 | Verify errors corrected without substantial delay
05_0001 | Verify errors corrected with possible delays
05_0002 | Total verify errors
05_0003 | Total verify errors corrected
05_0004 | Total verify errors corrected by algorythm
05_0005 | Total bytes verified
05_0006 | Total uncorrected verify errors
06_0000 | Non medium errors
07 | Last error event
0B | Last deferred error or asynchronous event
0D_0000 | Temperature
0D_0001 | Reference temperature
0E_0001 | Manufacture date (year/week)
0E_0002 | Accounting date
0E_0003 | Specified cycle count over device lifetime
0E_0004 | Accumulated start-stop cycles
0F | Application client parameter data
10 | Self test results log
18 | Protocol specific port log
37_0000 | Blocks sent to initiator
37_0001 | Blocks received from initiator
37_0002 | Blocks read from cache and sent to initiator
37_0003 | I/O commands with size smaller than segment size
37_0004 | I/O commands with size larger than segment size
3E_0000 | Power on time
3E_0008 | Remaining minutes until next internal test


Text Description

Text Description

Hard Disk Sentinel analyses the S.M.A.R.T. attributes provided by the disk and by evaluating these values, creates and displays a textual rating. It may contain the number of problems encountered during the lifetime of the hard disk, the spin up problems, the data transfer errors, etc. The background color of this area (green, yellow, red) indicates the health of the disk. The text area may contain tips to correct the problems so it is recommended to read the details.

Bad sectors?

What is a "bad sector"? How they born and how they can be fixed? Users are confused because verifying the disk surface with software (for example by using Windows Scandisk) does not report any problems or bad sectors.

S.M.A.R.T. is constantly analysing the disk surface during normal operations. If it finds a problemmatic area (one or more sectors where the data is hard is hard to read or write), it tries to read the data and copy it (reallocate) to the spare area. The original location is then (internally) marked as bad and all further read/write operations pointing to the original location is then redirected to the spare area.

When the operation is completed, the original (bad) area is not accessible by software any more. Even re-install or complete re-format will not show problems because the original bad area is not used any more. That's why software (for example Windows' Scandisk) will not find problemmatic sectors. Only the hardware security erase function will access this area (clearing these sectors also).

That's why for example DOS "format" command will never show bad sectors on most modern hard disks because of S.M.A.R.T. (except if the spare area is full but it is really hard to find a such hard disk).

Reallocation of the sectors may be completed with or without some errors (hard disks are working much better now compared to older models). But the reallocation procedure may cause system instability if it takes too much time.

The user should not notice anything about the steps described above - just when the number of bad sectors is high enough (the threshold is reached) and then S.M.A.R.T. predicts a possible failure.

A very small scratch or mote on the disk surface can cause some bad sectors. Usually, if the number of bad sectors is low, they do not cause big problems. But if their number is constantly increasing (and the displayed health value is decreasing), these can lead to failure. It is recommended to monitor your hard disk constantly if your hard disk is not 100% perfect.

Test Hard Disk

Si consiglia periodicamente di analizzare e verificare lo stato del disco (specialmente se il suo stato di salute è inferiore al 100%). Il metodo migliore è di eseguire un Extended self-test, che analizza tutti i componenti hardware e la superfice del disco. Altri test (di tipo software) non son in grado di analizzare il disco con questo livello di dettagli. Questo test ( e gli altri supportati ) può essere avviato manualmente nella pagina Informationi o automaticamente (tramite una pianificazione) nella maschera Operazioni (Solo con la versione Professionale).


Test Hard Disk

 Top Previous

Il test, implementato per i dischi IDE e Serial ATA, è un ottima soluzione per testare, in modo semplice, lo stato del disco. Normalmente sono supportati il modo short ed extended anche se qualche modello supporta anche il modo conveyance. La lista dei modi supportati e il tempo stimato è visualizzato nella schermata Informazioni della finestra principale del disco.

Questi tests non sono di tipo distruttivo ovvero non alterano i dati memorizzati nel disco. Durante il test, si può usare il disco anche se le le prestazioni sono un pò ridotte (e viceversa, se si usa il disco, il test dura di più specialmente nel caso si tratti del disco su quale è installato il sistema operativo.)

Il test Short verifica i più importanti componenti del disco (testine di lettura/scrittura, servo, elettronica, memoria interna ecc). Esso dura solo qualche minuto.

Quello Extended effettua un test completo della superficie del disco per verificare la presenza di eventuali aree rovinate e tenta la riallocazione di settori rovinati. Si raccomanda di eseguire periodicamente questo test specialmente se la salute del disco è minore del 100%.

Infine, il test Conveyance (se suportato) effettua dei test specifici al disco. Normalmente verifica le parti meccaniche del disco.

Il risultato del test (sia in caso positivo che negativo) viene mostrato all'utente nella sezione Informazioni. In questa sezione, possono essere avviati manualmente tutti i test disponibili oppure è possibile pianificare l'avvio tramite il menù Operazioni (Solo per la versione Professional).