Bevezetés

Köszönjük, hogy a Hard Disk Sentinel programot választotta. A Hard Disk Sentinel egy merevlemez ellenőrző és felügyelő alkalmazás, melynek célja, hogy a felderítse az esetleges merevlemez problémákat, teljesítmény csökkenéseket és a várható meghibásodásokat. Segítségével előre jelezhető a merevlemezzel kapcsolatos problémák jelentős része, így elkerülhetővé válnak a kritikus adatvesztések.

Kérjük tekintse át a jelenlegi kézikönyvet, melyben az általános működésről valamint a program által nyújtott szolgáltatásokról lesz szó.


Merevlemezek

A merevlemezek

A számítógépekben található merevlemezek belsejében egy vagy több lemez található, melyre az adatokat a lemez felett légpárnán repülő író/olvasó fej rögzíti. Ugyanez a fej végzi a visszaolvasás, törlés műveleteket is.

Mivel az egyes lemezeken az adatsűrűség növekedése miatt a tárolt adat nagyon parányi helyen található, bármilyen apró (akár mikroszkópikus) felületi sérülés, karc vagy kosz (akár csak egy porszem) is az adatok sérüléséhez vezethet. Éppen ezért a merevlemezeket gyártás során hermetikusan lezárják, hogy a környezeti levegőben található porszemek, páracseppek a házon kívül maradjanak.

Amennyiben mégis valamilyen sérülés, szennyeződés, anyaghiba folytán a lemez egy része nem olvasható vagy írható, az ilyen terület hibásnak minősül. Ilyen esetben a merevlemez a hibás területet automatikusan megjelöli (ha ott korábban volt adat, azt menti egy előre kijelölt tartalék területre) és a későbbiekben ezt már nem használja. Az ilyen területre való minden további hivatkozás a tartalék területre kerül átirányításra, az eredeti terület még teljes újraformázás után sem érhető el. Ez egyrészt jó, mivel a probléma automatikusan javításra kerül, míg másrészt a felhasználó így nem vesz tudomást az esetlegesen folyamatosan romló állapotról (pl. egy parányi porszem, anyagdarab, mely a lemez felületét karcolja).

A felületi sérüléseken, szennyeződéseken kívül több más probléma is veszélyezteti a merevlemezek épségét. Ilyen lehet pl. a magas működési hőmérséklet, a nem megfelelő tápellátás vagy mechanikai behatás. Ez utóbbi lehet egyszeri (ütődés, esés) vagy periódikus (vibráció). Ezen problémák jelentős része a Hard Disk Sentinel program segítségével kiszűrhető, az általuk okozott kár megelőzhető.

S.M.A.R.T.

A S.M.A.R.T. (Self-Monitoring Analysis and Reporting Technology, azaz Ön-ellenőrző Analizáló és Nyilvántartó Technológia) az IBM fejlesztése. Létrehozásának célja a merevlemez állapotának folyamatos figyelése, különböző módszerekkel, eszközökkel. Egy merevlemezben maximálisan 30 különféle mért érték (attribútum) tárolására és aktualizásálásra van lehetőség, melyek egy része közvetve vagy közvetlenül meghatározza a lemez egészségi állapotát, míg más részük statisztikai információt hordoz.

Mára gyakorlatilag az összes IDE/Serial ATA/SCSI merevlemezbe beépítésre került, de nem vált teljesen szabványossá, így az egyes attribútumok jelentése gyártónként eltérő. Bizonyos esetekben ez nem túl szerencsés, ezért érdemes gyártó független elemzési módszert választani. A Hard Disk Sentinel alkalmazás képes erre, erről részletesebben a kondíció számítási módszerek leírásánál olvashat.

Szerencsére bizonyos paraméterek többé-kevésbé szabványossá váltak, így a mai modern merevlemezek jelentős részén lehetséges a működési hőmérséklet és a bekapcsolva töltött idő kiolvasása. Többek között ezeket az attribútumokat is felügyeli a Hard Disk Sentinel.

A S.M.A.R.T. specifikációja szerint a probléma észlelésétől és jelentésétől még 24 órát kell a lemeznek működnie, amíg az adatok mentése folyik a problémás lemezről. A legtöbb esetben ez nagyon kevés - éppen ezért fontos a korábbi felismerés, megelőzés.

Megjegyzés: bizonyos merevlemez vezérlők ill. meghajtóprogramok meggátolhatják a S.M.A.R.T. értékek kinyerését. Ilyen esetben a merevlemez állapotáról sajnos nem kérhető információ. Nem lehetséges lekérdezni a működési paramétereit USB/Firewire csatolóval ellátott külső házba helyezett merevlemezeknek, valamint hardveres RAID tömböknek sem.


Telepítés

Windows 8,7,Vista,2012,2008,XP,2003,2000,NT4 esetén semmilyen előzetes előkészület nem szükséges a telepítés előtt. A program nem igényel külön telepítendő komponenseket, így az operációs rendszer első indulása után azonnal telepíthető.

Windows 98/98SE/ME felhasználók: Az operációs rendszer alaphelyzetben nincs felszerelve S.M.A.R.T. támogatással. Emiatt telepítés előtt szükséges a Smartvsd.vxd fájl átmásolása a Windows\System mappából a Windows\System\IoSubsys mappába, majd a rendszert újra kell indítani. A Hard Disk Sentinel telepítése csak ez után lehetséges. (a problémáról részletesen olvashat a Microsoft honlapján (angol nyelven).

A program letöltés után tetszőleges merevlemez meghajtóra telepíthető, alaphelyzetben a többi, korábban telepített program közé kerül. Telepítése eltávolítható meghajtóra (pl. pendrive) nem támogatott és nem ajánlott mivel a program folyamatosan menti a mért értékeket, talált problémákat a telepítési mappájában található adatbázisokba. Ezek segítségével a korábban mért értékek visszakereshetők, grafikusan kirajzolhatók.

A telepítés során a program parancsikonja az asztalon valamint a gyorsindító pulton létrehozásra kerül (ez kikapcsolható a telepítés során). A telepítés végén a program (amennyiben a felhasználó másképp nem rendelkezik) elindításra kerül.

Alapbeállítások

A program automatikusan megjeleníti a státusz ablakot a jobb felső sarokban, benne a telepített merevlemezek hőmérsékletével, típusával és kondíciójával. Megjelenik továbbá a program főablaka is, mely részletes információkat tartalmaz és ahonnan minden funkció elérhető.

Alaphelyzetben a program nem küld riasztást, de az újonnan talált problémákat a merevlemezek hibanaplójába bejegyzi.

A program automatikusan bejegyzi magát, mint a Windows-szal együtt indítandó programot, így a későbbi indítások során már a rendszerrel együtt automatikusan betöltésre kerül és felügyeli a merevlemezt. Ez kikapcsolható.


A program összetevői

A Hard Disk Sentinel főbb komponenseiről az alábbi címekre kattintva kaphat bővebb információt:

  • A státusz ablak

  • Tálca ikon

  • Meghajtó ikon

  • Gyorsmenü

  • Főablak

  • Beállítások

  • Mentési műveletek beállítása és végrehajtása (csak a PROFESSZIONÁLIS változat használata esetén)


Státusz ablak

A státusz ablak

A Hard Disk Sentinel főablakában a "Státusz ablak mutatása" (3. gomb a gombsorban) segítségével kapcsolható ki/be az a státusz ablak, amelyben folyamatosan ellenőrizhető a telepített merevlemezek hőmérséklete, típusa és kondíciója. Ez a státusz ablak minden más ablak felett kerül megjelenítésre, segítségével folyamatosan nyomon követhető a lemezek állapota.

  • Amennyiben az egér mutatója a státusz ablak fölé kerül, a jobb felső sarokban megjelenik egy kis ikon (ld. a felső ábrán), melyre kattintva a státusz ablak eltűntethető.

  • Bal egérgombbal a státusz ablakra kattintva alul, egy kiegészítő panelen megjelenik a logikai meghajtók listája, mely gyors áttekintést ad a szabad hely nagyságáról az egyes logikai meghajtókon. Itt bármely meghajtóra kattintva a meghajtón található állományok jelennek meg a Windows intézőben, illetve újabb kattintásra a státusz ablakon ez a kiegészítő panel eltűnik.

    Státusz ablak logikai meghajtók (partíciók) információival

  • Ha a bal egérgombot a státusz ablakon lenyomva tartva az egér elmozdul, a státusz ablak áthelyezhető a képernyőn, tetszőleges pozícióba. Alaphelyzetben a státusz ablak a kép széléhez igazodik, de beállítható, hogy akár részben vagy teljesen ki lehessen tolni a képernyőről.

  • Dupla bal kattintásra az egér alatti merevlemez részletes adatlapja jön elő a program főablakában.

  • Jobb kattintásra a program gyorsmenüje érhető el (mely a tálca ikonon történő jobb kattintással is elérhető, ha a státusz ablak nem látható).

Megjegyzés: A státusz ablakban megjelenített információ és annak megjelenése részletesen testreszabható. A program automatikusan menti a módosításokat és a státusz ablak pozícióját, a következő induláskor annak megfelelően jeleníti meg (vagy nem jeleníti meg, ha a státusz ablak korábban elrejtésre került).


Tálca ikon

    Tálca ikon az állapot kijelzéssel

Jobb oldalt alul az óra mellett a program tálca ikon(ok) segítségével is képes jelezni a merevlemezek állapotát. Telepítés után alaphelyzetben valamennyi merevlemezhez megjelenik egy ikon a lemez hőmérsékletével (ha a hőmérséklet információ lekérdezhető az adott merevlemezen). A program színek segítségével érzékelteti a hőmérsékletet, így 40 Celsius fok alatt zöld, 40 és 50 között sárga, 50 felett pedig piros színnel kerül a hőmérséklet kijelzésre. Természetesen ezen értékek változtathatóak, testre szabhatóak.

Több lemez esetén nem mindig egyértelmű, melyik lemezről van szó. A merevlemezek ikonjai balról jobbra növekvő sorrendben találhatóak, de bizonyos esetekben az ikonok átrendeződhetnek, mivel a sorrendet befolyásolhatja más tálca-ikon kezelő program, külső eszköz illesztése, leválasztása stb... Az egeret az ikon fölé húzva gyorstippként megjelenik az ikonhoz tartozó merevlemez sorszáma, típusa, logikai meghajtóinak betűjelei (amennyiben a státusz ablakban is megjelenítésre kerül a kérdéses lemezhez) valamint a kondíciója és hőmérséklete.

Bármely tálca ikonon dupla kattintással a program főablaka jelenik meg, melyben a merevlemezekről részletes információ kerül kijelzésre.

A tálca ikonon jobb kattintásra a program gyorsmenüje kerül megjelenítésre, innen a gyakran használt funkciók érhetőek el.


Meghajtó ikon

A meghajtó ikonok

A logikai merevlemezek ikonjain keresztül a program folyamatosan megjeleníti a lemezek állapotát (jó, elfogadható illetve rossz) és a szabad hely mértékét. Így bármilyen program (pl. Windows intéző) esetén a lemezek állapota azonnal láthatóvá válik.

Merevlemez állapot és felhasznált hely kijelzés a merevlemez ikonokon

Ez az opció különösen hasznos lehet több merevlemez esetén ill. ha a státusz ablak megjelenítése nem lehetséges. A felhasznált hely kijelzés 16 lépcsőben kerül megjelenítésre. Ahogy a felhasznált terület nagysága nő, az ikon felső részén található csík zöldből először sárga, majd piros színbe vált át.

Megjegyzés: A szabad hely kijelzés a szabad hely küszöb beállításával akár meghajtónként külön-külön is módosítható. Magasabb küszöb esetén "hamarabb" ér a csík a piros mezőbe.

Az ikon jobb alsó sarkában található szimbólum a merevlemez kondíciójának függvényében változhat. Alaphelyzetben ha a lemez kondíciója 50%-nál nagyobb, ZÖLD pipa kerül kijelzésre (rendben). 25 és 50 % közötti értéknél sárga felkiáltójel (figyelmeztetés), ez alatt pedig piros X kerül a lemez ikonja mellé. Természetesen ezen küszöbértékek változtathatóak, testre szabhatóak.

Megjegyzés: A kondíciót jelző szimbólum csak azokon a meghajtókon kerül kijelzésre, ahol a lemez egészségi állapota lekérdezhető. Külső (USB) meghajtókon, hálózati meghajtókon csak a szabad terület nagyságának kijelzésére van lehetőség. (Alaphelyzetben ez a lehetőség nincs engedélyezve, az opció aktiválható a lemez figyelés beállításoknál). A kondíciót jelző szimbólum kijelzése Windows 98/98SE/ME alatt nem támogatott.

Az ikon állapot jelzéséhez szükséges az egyes meghajtók folyamatos felügyelete. Lassú eszköz (pl. bizonyos típusú kártyaolvasók) használata esetén érdemes ezt a funkciót teljesen, vagy részben (adott meghajtókra) tiltani. Ez részletesen a lemez figyelés oldalon konfigurálható.

Természetesen ahhoz, hogy az ikonokon megjelenjen a felhasznált terület és kondíció szimbólum, a programnak folyamatosan futnia kell.


Gyorsmenü

A gyorsmenü a státusz ablakon ill. a tálca ikonon jobb egérkattintásra érhető el. Innen lehetőség van:

  • A státusz ablak elrejtésére/előhívására (a megfelelő opció látható).

  • A program beállításainak megtekintésére, módosítására.

  • A hőmérséklet statisztika megjelenítésére. A program főablakában a kiválasztott meghajtón a hőmérséklet panel kerül kiválasztásra.

  • A merevlemez jellemzőinek megjelenítésére. A kiválasztott merevlemez meghajtó lesz az aktív a főablakban. (Az utoljára használt információs panel marad használatban).

  • A jelenlegi súgó megnyitására.

  • A program névjegyének megtekintésére, mely tartalmazza az aktuális verzió információt, a regisztrált felhasználó nevét, egy gyorslinket a program weblapjára és a felhasználói felület fordítását végző személy nevét.

  • A hangjelzések tiltására a jelenlegi munkamenetben. Amennyiben a figyelmeztetéseknél a hangjelzések beállításra kerültek, probléma (pl. túlmelegedés, alacsony szabad hely, stb...) esetén a program (opcionálisan ismétlődő) hangjelzéssel figyelmeztet. Amennyiben ez zavaró, de a jelenlegi munkamenet nem megszakítható, úgy a hangjelzések a munkamenet idejére elnémíthatóak. Megjegyzés: mivel ez az opció újraindítás, kikapcsolás után automatisan visszaáll (a hangjelzések újra engedélyezve lesznek), ajánlatosabb a használata, mint a figyelmeztetéseknél törölni a hangjelzést.

  • A program bezárására. Ez a program futását megszakítja, azaz a továbbiakban nem felügyeli a merevlemezek állapotát. Megjegyzés: következő indulásnál a korábbi állapothoz képest történt változások feljegyzésre kerülnek a naplóba, ezért ha nincs lehetőség a program folyamatos futtatására, akkor is észlelhető az esetleges romlás, ha a programmal a merevlemezek állapota időszakosan ellenőrizhető.


Főablak

A Hard Disk Sentinel főablakából elérhető valamennyi funkció a felső menü valamint a gyorsgombok segítségével.

Főablak a merevlemez információkkal

A főmenü elemei:

  • Fájl menü: ezen belül a program bezárására van lehetőség.

  • Nézet menü: a merevlemezhez tartozó különböző információs panelek megjelenítését szolgálja.

  • Riport menü: segítségével a merevlemezekről teljes leírás készíthető szöveges (TXT) illetve formázott HTML formátumban. A kívánt riport a menüből tetszés szerint menthető vagy azonnal küldhető e-mail-en keresztül bármely címre (alapértelmezettként a beállított címzett címét ajánlja fel a program és a beállított levelezési opciókat használja küldésnél).

  • Beállítások menü: a program különböző működési paraméterei állíthatóak, melyek külön kategóriákban helyezkednek el.

  • Súgó menü: Megtekinthető a jelenlegi súgó illetve a program névjegye.

A főmenü alatt látható gyorsgombok fölé húzva az egeret gyorstippben megjelenik a gombokhoz tartozó funkció. A gyorsgombok használatával az alábbi feladatok végezhetőek:

  • Újraellenőrzés a lemezek állapota azonnal újraolvasásra kerül, függetlenül a beállított frissítési gyakoriságtól.

  • A korábbi figyelmeztetések újraküldésének engedélyezése a már lekezelt figyelmeztetések listájának törlése, ezáltal a figyelmeztetések újra küldésre kerülnek, a hangjelzések újra megszólalnak, stb.

  • Státusz ablak megjelenítése / elrejtése a státusz ablak elrejtése/előhívása.

  • Riport készítése és mentése teljes riport mentése. (A riport típusa a beállítások ablakban konfigurálható).

  • Riport készítése és küldése e-mail-ben teljes riport küldése e-mailben. (A riport típusa a beállítások ablakban konfigurálható).

  • Beállítások a beállítások ablak megjelenítése.

  • Hangjelzések engedélyezése / tiltása a hangjelzések időlegesen tilthatók/engedélyezhetők a jelenlegi munkameneten. Folyamatos hangjelzés esetén a hangjelzések tudomásul vétele, ezáltal a folyamatos hangjelzés leállítása.

  • Súgó megjelenítése a jelenlegi súgó megtekintése.

  • Névjegy a névjegy ablak előhívása.

A főablak bal oldalán találhatóak a számítógépbe telepített merevlemezek (felül) valamint a merevlemezekhez tartozó logikai meghajtók (alul). A két rész közötti vonal segítségével a panelek mérete változtatható. Az egyes elemekre kattintva a jobb oldalon az információs területen a kiválasztott merevlemez vagy meghajtó részletes információi kerülnek megjelenítésre.

A kiválasztó panelen található listában a lemezek állapota folyamatosan frissül, a legaktuálisabb információk kerülnek ott kijelzésre. Így valamennyi meghajtó legfontosabb adatai (hőmérséklet, kondíció illetve szabad hely nagysága és a teljes mérethez való aránya) láthatóak.

A kiválasztó és az információs panelek közötti függőleges vonalra kattitva és az egeret húzva a panelek mérete állítható. Megjegyzés: A program automatikusan menti az ablak pozícióját, méretét és a paneleket határoló csúszkák pozícióját, így későbbi indításkor az utolsó beállításoknak megfelelő helyzetben kerül az ablak megjelenítésre.

Az információs panelen attól függően, hogy fizikai meghajtó vagy logikai meghajtó lett kiválasztva, megjelenik azok részletes adatlapja.


Fizikai meghajtó információ

A fizikai meghajtókról több információs oldal található. Az egyes oldalok közötti lapozás a fülek segítségével lehetséges.

  • Áttekintés

  • Hőmérséklet

  • S.M.A.R.T.

  • Információk

  • Napló

  • Teljesítmény

  • Figyelmeztetések


Áttekintés

A merevlemez teljesítmény és kondíció értéke olvasható le. (Az egyes százalékos értékek számítási módja elérhető a megfelelő szóra kattintással).

Ez alatt a merevlemez szöveges értéklése olvasható. A program elemzi a merevlemez által elérhetővé tett S.M.A.R.T. paramétereket és azokat kiértékelve készít egy szöveges értékelést. Ez tartalmazza a lemez felületén található hibás szektorok mennyiségét, indulási problémákat, adatátviteli hibákat, stb. Az értékelés háttérszíne (zöld, sárga ill. piros) a merevlemez állapotára utal (tökéletes, problémás, rossz). Az értékelés esetlegesen tartalmazhat probléma megnevezést vagy ötleteket, melyekkel a merevlemez jelenlegi állapota javítható, emiatt ajánlott elolvasni.

Középen a merevlemez működési ideje és becsült hátralévő élettartama olvasható le. Ezek méréséről, kijelzéséről és a becslés módszeréről a mellékletekben bővebben olvashat.

A panel alsó részén a merevlemez kondíciójának grafikonja található. A program minden nap menti a nap során mért legalacsonyabb kondíciót és ezeket az értékeket visszamenőleg is tárolja. Így a grafikonon leolvasható az elmúlt időszak alatt mért kondíció és annak változása. Amennyiben a program már elég régóta használatban áll, a grafikon alatti területen látható gördítősáv segítségével korábbi időszak állapota is megtekinthető. A kis lemez ikon segítségével a grafikon képként (BMP vagy JPG formátumban) menthető.


Hőmérséklet statisztika

A hőmérséklet oldalon a kiválasztott merevlemez jelenlegi, és az aktuális napon mért átlagos és legmagasabb hőmérséklete olvasható le.

A hőmérsékletről (a lemez állapotához hasonlóan) a program szöveges értékelést is készít. Ebben túl magas hőmérséklet esetén ötletek kerülnek kijelzésre a probléma megoldásához.

Adott esetben előfordulhat, hogy a merevlemezben található hőmérséklet szenzor mérési eredménye nem teljesen pontos. Ilyenkor ajánlatos a hőmérséklet kalibráció elvégzése (erre a program a szöveges értékelés végén figyelmeztet is, amíg nem történik meg a hőmérséklet eltolás (még ha az 0 is) beállítása).

Az információs panel alsó részében a jelenlegi utoljára mért hőmérséklet értékek, valamint az elmúlt napokon mért átlagos és maximális hőmérséklet értékek olvashatóak le. Az átlagos, maximális hőmérsékletet kiválasztva a grafikon az elmúlt napok mért értékeit tartalmazza. A grafikon alatti csúszka segítségével a korábbi időszak adatai is előhívhatók (amennyiben a program kellően hosszú ideje figyeli és menti a merevlemezek állapotát). A kis lemez ikon segítségével a grafikon képként (BMP vagy JPG formátumban) menthető.


S.M.A.R.T.

A S.M.A.R.T. (Ön-ellenőrző Analizáló és Nyilvántartó Technológia) oldalon az IDE és Serial ATA merevlemezek által támogatott működési paraméterek listája kerül kijelzésre. Minden merevlemezhez maximálisan 30 db különböző attribútum rendelhető hozzá, melyeket a gyártó határoz meg. Emiatt nem minden merevlemez tartalmaz minden attribútumot. Az attribútumok listája fix, nem bővíthető. A gyártó különböző típusú merevlemezein is eltérő lehet, azonos típusú merevlemezek általában azonos attribútumlistával rendelkeznek.

S.M.A.R.T. attribútumok részletes listája, állapotjelzők és grafikonok

Balról jobbra haladva a lista az attribútum azonosítójával (számával) kezdődik, ez 0 és 255 között lehet. Amennyiben az attribútum a merevlemez állapotát közvetlenül befolyásolja és értéke kritikus szintet érhet el, a program zöld pipával (attribútum rendben) vagy piros X szimbólummal (attribútum nem megfelelő) jelez az azonosító előtt.

Ezután következik az attribútum neve, amennyiben az ismert. Az attribútumok túlnyomó többsége széles körben elterjedt és több gyártó is használja, de bizonyos attribútumok értékét, jelentőségét a merevlemez gyártója nem publikálja.

A Küszöb mező az attribútumhoz tartozó küszöb értékét tartalmazza. Ha az attribútumhoz tartozó Érték mezőben ennél a küszöbnél alacsonyabb szám található, a kérdéses attribútum értéke nem megfelelő. (Ha kritikus értékről van szó, ebben az esetben jelenik meg a piros X az azonosító mellett a sor elején). A Legrosszabb mezőben a valaha mért legrosszabb (legalacsonyabb) érték kerül kijelzésre.

A Státusz mezőben az attribútum állapota látható. Ez lehet:

  • OK: az érték a küszöb feletti vagy azzal egyenlő, nincs gond.

  • OK (Mindig rendben): a küszöb nulla, tehát nem lehetséges ennél alacsonyabb mért érték. Főként a csak statisztikai információt hordozó attribútumoknál fordul elő.

  • Kudarc: kritikus attribútum esetén az érték mező a küszöböt átlépte (alacsonyabb annál).

  • Élettartam lejárt: nem kritikus attribútum esetén az érték mező a küszöböt átlépte (alacsonyabb annál).

Az Adat mezőben a nyers mért számadatok olvashatóak le. Ezek azok adatok, melyek még nem kerültek értelmezésre, feldolgozásra a merevlemez által (az Érték mező már egy feldolgozott, gyártó és merevlemez-specifikus számot tartalmaz). Ezek a számok hexadecimális formátumban kerülnek megjelenítésre, de a táblázaton jobb egérgomb lenyomása után választható a decimális kijelzés is.

Ajánlatos a nyers adatok használata kiértékelésnél és kondíció számításnál, mivel így lehetőség van a gyártótól, típustól függetlenül objektíven értékelni a merevlemez állapotát.

Az Eltolás mezőben megadható, hogy a program kiértékeléskor a nyers számadatokat milyen eltolási értékekkel vegye figyelembe. Ennek használatát mutatja be a hőmérséklet kalibráció fejezet. Az eltolási értékek beállítására több lehetőség is kínálkozik:

  • A - és + ikonokra kattintva az eltolási érték egyel csökkenthető illetve növelhető.

  • Az ikonok közötti számra kattintva az eltolási érték közvetlenül megadható.

  • Az attribútum kijelölése után a billentyűzet - és + valamint ENTER gombjainak lenyomásával az eltolás értéke változtatható, megadható.

Megjegyzés: ajánlott az eltolási érték közvetlen megadása a számra kattintással vagy ENTER használatával.

A Használat mezőben található ikonnal megadható, hogy a merevlemez állapotának értékelésekor mely attribútumokat vegye figyelembe a program. Amely attribútumok tiltásra kerülnek (nincs "pipa"), azok nem számítanak bele a kondíció és teljesítmény számításba. A tiltott attribútumok változása nem kerül bele a merevlemez naplójába sem. Ezek miatt az attribútumok tiltása NEM ajánlott.

Figyelmeztetés: az eltolási értékek és a Használat opciók megváltoztatásával a merevlemez állapotának kijelzése esetleg pontatlanná válhat. Kizárólag tapasztalt felhasználók módosítsák ezeket az opciókat!

Megjegyzés: az eltolási értékek és a Használat opció beállítása csak a regisztrált változat használata esetén kerülnek tárolásra, ellenkező esetben a következő indításnál az alapértelmezett beállítások lesznek érvényesek.

Az egyes attribútumok jelentése, jelentősége gyorstippben jelenik meg, ahogy az egérmutató a kérdéses attribútum fölé kerül. A táblázaton jobb egérgomb lenyomása után beállítható hogy ez az információ folyamatosan látható legyen az egyes attribútumok alatt. Az ismert S.M.A.R.T. attribútumok listája megtalálható a függelékben.

A táblázaton jobb egérgomb lenyomása után lehetséges a táblázatban foglalt információk másolása a vágólapra, melyek így szöveges fájlba, levélbe, dokumentumba beilleszthetők.

Attribútum grafikon

A táblázat alatt az éppen aktuálisan kijelölt attribútum korábban mért értékei kerülnek grafikusan ábrázolásra. A grafikonon látható, időben hogyan változott az attribútum. A grafikon két végpontja az első (telepítés napja) és utolsó (jelenlegi) állapotot tükrözi, a köztes napok automatikusan kerülnek kiválasztásra.

A grafikon mellett az attribútum állapotjelzői találhatóak. Minden attribútumhoz tartozik egy vagy több állapotjelző, mely megmutatja, hogy az adott attribútum milyen célt szolgált. Ezek az állapotjelzők lehetnek:

  • Kritikus: a merevlemez állapotát döntően befolyásoló érték (pl. tartalék területre áthelyezett szektorok száma).

  • Statisztikai: az állapotot nem befolyásoló statisztikai érték (pl. újraindítások száma).

  • Teljesítmény: teljesítményért, gyorsaságért felelős attribútum (pl. felpörgési, sávraállási idő).

  • Hiba-arány: általában javítható, a merevlemez működését kritikusan nem befolyásoló problémák jelölésére használatos (pl. sávraállás sikertelensége).

  • Esemény Számláló: számláló érték, mely egyes események, problémák esetén növekedhet (pl. újabb hibás szektor esetén).

  • Ön-ellenőrző: Az attribútum értéke folyamatos vizsgálat alatt áll.

Grafikon nézetek

A grafikonon két különböző típusú számsor jeleníthető meg. Alapértelmezett esetben az Adat mező kijelzése van kiválasztva, azaz a nyers, gyártó-független mért értékek kerülnek kijelzésre. Az alapértelmezett kijelzés megváltoztatása a fejlett opciók beállításainál lehetséges. Az egyes módszerek közötti különbségről itt olvashat.

Adat mező kijelzése

Ezek az értékek probléma esetén növekednek, mivel a konkrétan előfordult problémák számát (pl. hibás szektorok száma) jelzik. A grafikon ebben az esetben ideális, ha stagnáló tendenciát mutat.

Természetesen bizonyos attribútumok (pl. bekapcsolva töltött idő, bekapcsolások száma, stb.) értéke folyamatosan növekszik, ezért ezeknél a grafikon is növekvő tendenciát mutat, ami teljesen normális. Továbbá bizonyos (főleg statisztikai) attribútumoknál az érték nagyon magas számot is elérhet, majd hirtelen lezuhanhat, ez is teljesen normális. A grafikon jelentősége a kritikus attribútumok (pl. áthelyezett, hibás szektorok száma) fontos, ahol a korábbi időszak elemzése során fény derülhet problémás időszakokra.

Érték mező kijelzése

Az érték mező analízise által megvizsgálható a merevlemez gyártó által értelmezett értékeinek alakulása. Ezek az értékek probléma esetén csökkennek, amíg az attribútumhoz tartozó küszöbértéket el nem érik (ha kritikus attribútumról van szó, gyártói szempontból ekkor minősül hibásnak a merevlemez, ekkor már mindenképpen azonnali cserére van szükség).

S.M.A.R.T. attribútum küszöb elérésének várható időpontja

A grafikonon sötétkék vonal köti össze a valós, mért értékeket, a grafikon alsó részén pedig az attribútumhoz tartozó küszöbszint jelenik meg sárgával.

Amennyiben a grafikon csökkenő tendenciát mutat, a kék vonal meghosszabbításában egy lila vonal húzódik, mely a lehetséges további romlási folyamatot jelzi. Azaz, amennyiben a helyzet az elmúlt időszakhoz képest hasonló mértékben változik, a grafikonról pontosan leolvasható, mikor fogja az érték a küszöbszintet elérni.

A fenti példán jól látszik, hogy a merevlemez 2006. június 29-én került először ellenőrzésre, akkor az áthelyezett (hibás) szektorokhoz tartozó értéke 100 volt. 2006. október 17-én ez az érték már csak 80 volt és ha ilyen iramban romlik a merevlemez állapota, legkésőbb 2007. június 16-án (a grafikon mellett, jobb oldalon is kiemelten látható) a merevlemez azonnali cserére szorul.

A két különböző kijelzési módszer közötti különbségről és a javasolt megoldásról itt olvashat bővebben.

Megjegyzés: SCSI merevlemezek esetén a S.M.A.R.T. panel a SCSI merevlemez által támogatott statisztikai információkat tartalmazza (pl. írt/olvasott bájtok száma, előforduló írás/olvasási problémák száma, stb). Ezen paraméterekben bekövetkezett változások a táblázat alatti grafikonon is leolvashatók.

A táblázat és a grafikon közé kattintva és az egeret fel/le húzva beállítható az egyes panelek egymáshoz viszonyított mérete.


Információk

Az információs panelen a merevlemez számos tulajdonsága megtekinthető. Segítségével leolvasható és ellenőrizhető a gyártó, a modell típusa, revíziója (belső változat azonosítója) valamint sorozatszáma is. Ez segítheti bizonyos esetekben a lemez beazonosítását.

Kijelzésre kerülnek többek között a merevlemezen található logikai meghajtó(k), így több merevlemez, több meghajtó esetén egyszerűen beazonosítható, mely meghajtóhoz mely merevlemez tartozik.

A táblázaton jobb egérgomb lenyomása után lehetséges a táblázatban foglalt információk másolása a vágólapra, melyek így szöveges fájlba, levélbe, dokumentumba beilleszthetők.

IDE, Serial ATA merevlemez

IDE és Serial ATA merevlemezek kezelése az ATA felületen keresztül történik, ezen keresztül a program lekéri és megjeleníti a merevlemezek fizikai tulajdonságait (pl. összes szektorok száma, hibajavító bájtok száma, stb.) Lényeges információ lehet a Puffer mérete, mely megadja, hogy milyen nagyságú belső átmeneti gyorsítótárat használ a lemez. Teljesítmény szempontból érdemes minél nagyobb átmeneti gyorsítótárral rendelkező meghajtó vásárlása.

A merevlemez által támogatott maximális Ultra DMA mód és jelenleg kiválasztott Ultra DMA mód is megjelenítésre kerül. Ez utóbbi határozza meg, hogy jelenleg milyen (elméleti maximum) sebességgel képes a merevlemez és a vezérlő adatokat cserélni. Értelemszerűen minél nagyobb a kijelzett sebesség, annál előnyösebb.

Amennyiben Ultra DMA átviteli mód mellett (0) látható, akkor a rendszer nem használja ki az ultra DMA mód adta lehetőségeket és csak PIO (programozott input/output) módban kezeli a merevlemezt. Ez nem csak a lemez, de a teljes rendszer teljesítményét is jelentősen csökkenti, mivel a processzornak meg kell várni minden egyes írás/olvasás művelet végrehajtását, addig nem képes más feladatot ellátni. Ezért ilyenkor érdemes a konfigurációt ellenőrizni és a problémát elhárítani.

Megjegyzés: bizonyos vezérlők és rendszerek esetében előfordulhat, hogy a merevlemez PIO módban üzemel, de a merevlemeznél a legmagasabb Ultra DMA fokozat került korábban kiválasztásra, így az jelenik meg a programban.

Megjegyzés: a Hard Disk Sentinel ellenőrzi, hogy az ATA információs táblázat teljes és annak ellenőrző összege megfelelő-e. Ez utóbbi biztosítja, hogy az információk nem sérültek és hitelesek - ellenkező esetben bizonyos információk (pl. teljesítmény érték, adatátviteli üzemmód, Serial ATA tulajdonságok) kijelzése pontatlan lehet. Erre figyelmeztet is:

ATA adatok érvényességét ellenörző bájtok

Érvénytelen kontroll bájt és/vagy ellenőrző összeg nem befolyásolja a kondíció és hőmérséklet értékek detektálását és kijelzését.

Akusztika Menedzsment

A merevlemeznél lehetőség van az akusztikai jellemzők megtekintésére és beállítására is, amennyiben az támogatott a merevlemez által. Magasabb akusztikai szint esetén a merevlemez gyorsabban (de hangosabban) dolgozik, míg alacsonyabb szint esetén a merevlemez lassabban (de csöndesebben) állítja az író/olvasó fejet a megfelelő pozícióba. A beállítás a merevlemez forgási sebességét nem befolyásolja. Amennyiben a merevlemez támogatja, megjelenik a Beállítás lehetősége is.

Megjelenítésre kerülnek a legfontosabb ATA jellemzők, melyeken leolvasható milyen extra szolgáltatásokat képes nyújtani a merevlemez (pl. biztonsági üzemmód, energiagazdálkodás, stb).

S.M.A.R.T. Tesztek

S.M.A.R.T. öntesztek állapota, teszt indítása

A merevlemez beépített hardveres tesztjeinek eredménye a listában megtekinthető. A merevlemez által támogatott tesztek innen indíthatóak az "Indítás"-ra kattintással. Az egyes ön-tesztek (gyártó által meghatározott) becsült időtartama leolvasható, de tapasztalatok szerint a teszt a jelzettnél akár két-háromszor is több időt vehet igénybe. A Rövid ön-teszt általánosságban teszteli a merevlemez komponenseit (író/olvasó fejek, szervó, elektronika, stb.), míg a Részletes és a Szállítás ön-tesztek (amennyiben támogatottak) a gyártó által meghatározott tesztlépéseket hajtják végre. A Részletes ön-teszt teljes felületellenőrzést tartalmaz, melynek során az esetleges problémás területek is vizsgálatra kerülnek, így időszakosan ajánlott ezt a tesztet elvégeztetni.

A teszt futása alatt egy állapotjelző ablak látható. Az ön-teszt befejezése után hibátlan lefutás esetén megjelenik az ezt jelző üzenet, míg hiba esetén megjelenik a hibás részegység (pl. elektronika, olvasófej, szervó, stb.). Az ön-teszt alatt a merevlemez továbbra is használható. Ilyenkor általában a HDD LED nem világít de hallható, hogy a merevlemez dolgozik. A teszt alatt végzett minden lemezművelet lassíthatja a tesztet és fordítva: a teszt miatt a lemez elérése, írás/olvasás parancsok lassabban hajtódnak végre, ezért nem célszerű komolyabb fájlműveleteket végezni a teszt alatt.

Megjegyzés: a Részletes és Szállítás tesztek (amennyiben támogatottak) csak a regisztrált változatban indíthatóak.

SCSI merevlemez

SCSI merevlemez esetén a megjelenített információk tartalmazzák a lemez azonosításához elengedhetetlenül szükséges információkat, valamint a SCSI eszköz gyártója által megadott (vendor) információkat, a probléma előrejelző funkció meglétét és annak bekapcsolt állapotát valamint a merevlemez állapotát jelző ASC és ASCQ értékeket.


Akusztika szint

Akusztikai szint beállítása

A merevlemeznél lehetőség van az akusztikai jellemzők megtekintésére és beállítására is, amennyiben az támogatott a merevlemez által. Magasabb akusztikai szint esetén a merevlemez gyorsabban (de hangosabban) dolgozik, míg alacsonyabb szint esetén a merevlemez lassabban (de csöndesebben) állítja az író/olvasó fejet a megfelelő pozícióba.

Amennyiben a merevlemez támogatja, lehetőség van az akusztikai szint változtatására. Ekkor a csúszka segítségével állítható a sebesség és csendesség közötti kompromisszum. A gyártó által ajánlott szint is megjelenítésre kerül. Természetesen a lemez többi működési paramétereit, egészségi állapotát NEM befolyásolja bármely akusztikai szint kerül is kiválasztásra.

Merevlemezek teljesítmény és zaj összehasonlító tesztjében ajánlott, hogy az egyes tesztalanyok azonos (pl. leghangosabb ill. leghalkabb) állásban legyenek, az eredmények objektivitása miatt.

Megjegyzés: az akusztika szint beállításának lehetősége erősen függ a vezérlő (alaplap ill. merevlemez vezérlő kártya) képességeitől, annak meghajtó (driver) programjától. Amennyiben a vezérlő ill. a meghajtóprogram nem támogatja ezt a funkciót, úgy egy hibaüzenet jelenik meg és az akusztikai szint nem változik. Szerencsére mind több és több alaplap és vezérlő meghajtóprogramja támogatja ezt a lehetőséget (Serial ATA esetében valamivel rosszabb a jelenlegi helyzet).


Napló

A merevlemez naplójába kerülnek be a fontosabb attribútumok adat mezőjében bekövetkezett változások. Ezek az attribútumok az alábbiak:

  • 5: Tartalék területre áthelyezett szektorok száma.

  • 10: Felpörgési újrapróbálkozások száma.

  • 196: Áthelyezési kísérletek száma.

  • 197: Függőben lévő szektorok száma.

  • 198: Javíthatatlan szektorok száma.

  • 199: Adatátviteli hibák száma.

Bejegyzésre kerül továbbá, ha a merevlemez hosszú ideig nem válaszol az operációs rendszer felé (amennyiben ez a funkció engedélyezésre kerül a fejlett opciók oldalon.

Az egyes bejegyzéseknél tárolásra kerül az időpont, a kérdéses attribútum és annak korábbi illetve jelenlegi értéke. Elképzelhető, hogy egy időben több naplóbejegyzés is készül, ha több attribútum egyszerre módosul a korábban tárolt értékekhez képest, főképp ha az alkalmazás csak ritkábban kerül indításra.

Az új naplóbejegyzésekhez figyelmeztetés is köthető. Így amennyiben a program újabb problémát észlel (a merevlemez állapota romlik), képes riasztani. Ennek a funckiónak a használata csak a regisztrált változatban lehetséges.

Lehetőség van az egyes paraméterek tiltására a S.M.A.R.T. oldalon, a Használat mező alatti opció segítségével. Az íly módon tiltott attribútumokban bekövetkező változások nem kerülnek bejegyzésre és a program a kondíció számítása során sem veszi figyelembe a tiltott attribútumokat.

Megjegyzés: A napló jelen változata a legfrissebb 50 hibát képes tárolni, ez után a korábban tárolt problémák törlésre kerülnek.


Teljesítmény

A teljesítmény oldalon leolvasható, hogy a merevlemez mennyi adatot írt és olvasott a jelenlegi munkamenetben, valamint a telepítés óta összesen. Ez utóbbi alapján a napi átlagos írás és olvasás értéke is kijelzésre kerül.

A jelzett telepítési dátumon dupla kattintással megadható az aktuális merevlemez telepítési dátuma - így a napi írás/olvasás mennyiségek ennek megfelelően kerülnek kiszámításra.

A program folyamatosan figyeli és megjeleníti az éppen aktuális írási és olvasási sebességet, valamint, hogy mennyire "megterhelő" a merevlemez számára az aktuális használat. Ez százalékban kerül kijelzésre, hasonlóképpen a Feladatkezelőben megjelenített processzor kihasználtságához.

Amint a program írási folyamatot észlel, piros "led" és a jelenlegi írási sebesség kerül kijelzésre. Olvasás esetén az olvasási sebesség és egy zöld "led" jelenik meg. Természetesen ezek a színek nincsenek kapcsolatban a merevlemez egészségi állapotával.

Az éppen aktuális átviteli sebesség és az aktuális merevlemez kihasználtság alapján a program készít egy becslést, hogy milyen elméleti csúcs sebességet lenne képes elérni a merevlemez ideális körülmények között, rövid időre. Ez az alábbi formula alapján kerül kiszámításra: (elméleti maximum sebesség) = (jelenlegi sebesség) / (lemezkihasználtsági % érték). Tehát pl. ha éppen aktuálisan 20 MB/másodperc sebességgel dolgozik a merevlemez és a kihasználtsági fok 50%, akkor az elméleti maximum 40 MB/másodperc. A mérés pontossága érdekében a túl alacsony kihasználtsági fokú eredmények nem vesznek részt a becslésben, de természetesen ez csak egy elméleti érték, különböző eszközök, gyorsítótár, egyéb programok és az operációs rendszer is torzíthatja az értéket.

A jelenlegi átviteli sebesség és kihasználtság grafikonja számos esetben hasznos lehet:

  • Több merevlemez használata esetén látható, mely lemez(ek) aktívak és milyen sebességgel dolgoznak. Például ha a rendszer az első meghajtón található és a többi meghajtón nagy forgalmú alkalmazás folyik, külön ellenőrizhető azok forgalma. Állandó terhelés mellett ellenőrizhető a rendszert tartalmazó meghajtó forgalma, mely pl. segíthet kideríteni a túl nagy virtuális memória felhasználást.

  • Merevlemezről másik lemezre való másolás esetén. A két lemez átviteli sebessége és kihasználtsága összehasonlítható, így gyorsan kideríthető, hogy mely lemez a gyengébb láncszem teljesítmény szempontból.

  • Merevlemezről optikai egységre való írás esetén felderíthető, hogy a kérdéses sebességű írás valóban milyen sebességgel zajlik és ez mennyire megterhelő (azaz lehetséges-e gyorsítani a folyamatot).

  • Szerver esetében (fájl vagy nagyobb forgalmú adatbázis szerver esetén) megfigyelhető, hogyan alakul a merevlemez teljesítményének kihasználtsága és sebessége, azaz esetleges bővítés (több felhasználó, nagyobb adatforgalom) esetén a lemez cseréje indokolt-e.

  • Amennyiben viszonylag állandó sebességűnek mondható művelet (másolás, CD/DVD írás) közben a lemezkihasználtság nagyon ugrál (a grafikonban sok a tüske), úgy a merevlemezen található adatok valószínűleg eléggé töredezettek, érdemes lehet töredezettségmentesíteni. (ezt a jelenséget okozhatja a virtuális memória nagy mértékű használata is).

    Megjegyzés: A teljesítmény mérés és kijelzés operációs rendszer függő, Windows 95/98/ME alatt nem támogatott. Bizonyos külső meghajtókon (pl. pendrive, memóriakártya) ez a funkció nem működik.


Figyelmeztetések

Ezen az oldalon a merevlemez által generált figyelmeztetések naplója kerül megjelenítésre.

Leolvasható, hogy pontosan mikor és milyen esemény történt (magas hőmérséklet, alacsony kondíció, meghibásodás várható, stb.), mely kiváltotta a figyelmeztetést.

A listában csak azok az események láthatóak, melyekhez valamilyen figyelmeztetés társítva lett (például hangjelzés vagy üzenet küldése).


Logikai meghajtó

Logikai meghajtó információ

Az információs panelen megjelenik a logikai meghajtóval kapcsolatos valamennyi információ, beleértve azt, hogy mely fizikai meghajtó(ko)n található az adott logikai meghajtó (tükrözött vagy átnyúló kötet esetén több fizikai merevlemezhez is kapcsolódik az adott meghajtó), mi a kötet típusa, sorozatszáma, címkéje, valamint mekkora a teljes és a szabad terület nagysága.


Beállítások

A Hard Disk Sentinel működési paramétereinek megváltoztatására nyílik lehetőség a Beállítások ablak használatával. Az egyes kategóriák a bal oldali menüből érhetőek el, melyekhez tartozó opciók a jobb oldali nagyobb panelen találhatóak. Az egyes kategóriák:

  • Merevlemezek

  • Beállítások

  • Státusz ablak

  • Küszöbérték / Tálca ikon

  • Figyelmeztetések

  • Üzenet beállítások

  • E-mail beállítások

  • Regisztráció

  • Frissítés

  • Fejlett opciók

  • Lemez figyelés

  • Gyorsbillentyűk

  • Műveletek (csak a PROFESSZIONÁLIS változat használata esetén)

  • Integráció

  • Teszt riport küldése


Beállítások: Merevlemezek

A merevlemezek ablakban felsorolásra kerülnek a program által felismert merevlemezek. A merevlemez sorszáma előtti négyzet bejelölésével kiválasztható, mely lemezek állapota kerüljön kijelzésre a státusz ablakban. Dupla kattintás esetén pedig kijelölhető, mely merevlemezek állapota látszódjon a tálca ikonon.

Kiválasztható, hogy csak a legmagasabb hőmérsékletű merevlemez látszódjon ikonként, ebben az esetben a meghajtó esetleg kicserélődhet, ahogy a működési hőmérséklet változik. Ebben az esetben ha a kondíció szimbólum kijelzése a tálca ikonon is engedélyezve van, a legrosszabb (legalacsonyabb) kondíciójú merevlemezhez tartozó szimbólum kerül kijelzésre, még ha az nem is feltétlen azonos a legmagasabb hőmérsékletű merevlemezzel.

Megjegyzés: a tálca ikon fölé húzva az egér mutatóját az éppen aktuális merevlemez sorszáma és adatai gyorstipp-szerűen megjelennek.

Bármely merevlemezen jobb egérgombot lenyomva a merevlemez gyorsmenüje kerül kijelzésre. Ebben a menüben is lehetőség van a lemez tálca ikon engedélyezésére/tiltására az adott merevlemeznél, valamint megjeleníthető a merevlemez bármely információs adatlapja. Lehetőség van továbbá a lemez akusztikai paramétereinek változtatására (ha az támogatott a merevlemez által).


Beállítások: Beállítások

A program általános működési paraméterei állíthatók ezen az oldalon.

Státusz ablak mutatása indításnál: a program induláskor automatikusan megjelenítse-e a státusz ablakot. A státusz ablak elrejtése, előhívása ezt az opciót is automatikusan változtatja (tehát elrejtett státusz ablak melletti újraindítás során az ablak nem kerül automatikusan megjelenítésre).

Indítás a Windows-szal együtt: a program automatikusan induljon a Windows indítása során, a felhasználó bejelentkezése után. Ajánlott a funkció használata, mivel így a merevlemezek folyamatos felügyelet alá kerülnek. A késleltetés opcióval megadható, hogy induláskor a Hard Disk Sentinel program mennyit várjon, mielőtt a merevlemezek állapotát először meghatározza. Hasznos lehet a használata amennyiben az operációs rendszerrel számos program indul és azok így betöltődnek és elindulnak, mire a Hard Disk Sentinel program az állapotot kiolvassa.

Kezdőképernyő mutatása: a program főablakának automatikus megjelenítése a program indulásakor. Megjegyzés: ez az opció csak a regisztrált változat használata esetén módosítható, különben a főablak minden induláskor automatikusan megjelenítésre kerül.

A program látható legyen a futó alkalmazások között: amennyiben a program egy (vagy több) ablaka meg van nyitva, a tálcán a futó alkalmazások között megjelenik a Hard Disk Sentinel is. Az opció tiltása esetén csak az óra melletti ikonként látszik a program.

Beállítható a program által használt nyelv és a kijelzésnél, riportoknál használatos hőmérsékleti egység (Celsius vagy Fahrenheit). Továbbá kiválasztható a merevlemezek teljesítmény kijelzés oldalán használatos összes olvasott és írt adat valamint a napi átlagos olvasás és írás adatmennyiség egysége is (MB, GB vagy TB egységben). Megadható továbbá a merevlemezek és partíciók méretének kijelzésekor használt egység is.


Beállítások: Státusz ablak

Státusz ablak beállításai

A státusz ablak megjelenítési paraméterei állíthatók be ezen az oldalon. Megadható, hogy kiválasztott szín vagy háttérkép kerüljön megjelenítésre a státusz ablak háttereként (Az egyes "Kiválasztás" gombok segítségével adható meg a kívánt szín ill. kép). Előnézetben megjelenik az ablakban a kiválasztott háttér. Megjegyzés: háttérkép kiválasztása esetén a kép automatikusan átméretezésre kerül, felveszi a státusz ablak méretét.

A Képernyő széléhez igazítva opció segítségével beállítható, hogy a státusz ablak kihúzható legyen-e a képernyőről vagy sem. Ha az opció engedélyezve van, az ablak automatikusan a képernyő széléhez igazodik ha ahhoz túl közel kerül illetve ha az ablak egy része a látható tartományok kívülre esik.

Megadható az ablak átlátszóságának mértéke (amennyiben ezt az operációs rendszer támogatja), valamint beállítható az ablakban használt betűk típusa, nagysága, színe is. Ajánlott a betűtípus gondos beállítása, hogy a háttérnek, a szín- és fényviszonyoknak valamint a felhasználónak megfelelő legyen valamint az ablak mérete ne legyen zavaró a mindennapi munka során.

Lehetőség van arra, hogy a státusz ablak ne reagáljon az egérre hanem továbbítsa az egérkattintást az ablak alatt található ablak számára. Ez különösen hasznos lehet, ha az átlátszóság opcióval kombináljuk. Megjegyzés: az opció használata esetén a státusz ablakot nem lehet elmozdítani és nem reagál az egérkattintásokra. Így a tálca ikon segítségével lehet a program különböző funkcióit előhívni.

A státusz ablakban található információk közvetlenül az asztalra is kitehetők. Így az adatok a többi ablak "alatt" kerülnek kijelzésre; az Asztal megjelenítése ikon segítségével hívhatóak elő. Az X és Y koordináták segítségével megadható, hogy az adatok a képernyő mely részén kerüljenek kijelzésre. Megjegyzés: az adatok az asztalon látható parancsikonok előtt kerülnek kijelzésre, így célszerű egy üres területet kijelölni. A funckió használatához az "Aktív desktop" és a "Saját weblap megjelenítése" opciót ki kell kapcsolni a megjelenítés tulajdonságainál. Megjegyzés: a funkció intenzíven használhatja a processzort ezért csak indokolt esetben aktiváljuk!

A Teljesen átlátszó háttér opció segítségével a státusz ablak átlátszóvá tehető, így a feliratok és ikonok között a státusz alatti ablak érhető el. Ebben az állapotban általában nem lehet a státusz ablakot a jobb felső sarokban lévő vörös X segítségével bezárni de természetesen a gyorsbillentyűk segítségével eltűntethető és újra megjeleníthető.

A Mindig legfelül opcióval beállítható, hogy a státusz ablak mindig a többi ablak felett jelenjen meg, akkor is ha más ablak kerül kiválasztásra. Ennek az opciónak megváltoztatása után teljes újraindítás szükséges.

Beállítható, hogy az egyes merevlemezekhez milyen információk kerüljenek kijelzésre a státusz ablakban. Megjegyzés: a tálca ikon felett megjelenő gyorstippen is ezek az adatok kerülnek kijelzésre ha az egérmutató az ikon fölé kerül.

Windows Vista/7 alatt engedélyezhető a Vista oldalsáv minialkalmazás (gadget) használata is. Ennek segítségével a merevlemezekről információ jeleníthető meg a Vista oldalsávon. A minialkalmazás megjelenését (szín, betűtípus, megjelenítendő merevlemezek) a státusz ablak beállításai határozzák meg.


Beállítások: Küszöbérték / Tálca Ikon

Küszöbszintek és megfelelő tálca ikonok

Ezen az oldalon beállítható a tálca ikonok vizuális megjelenítése. Alapértelmezett esetben a tálca ikonon a hőmérséklet kerül kijelzésre (valamint ezzel felváltva a kondíciónak megfelelő szimbólum: Vörös , ha a kondíció értéke az oldalon megadott küszöbszint alá esik).

A hőmérséklet színe három lépcsőben állítható: megadható a számok előtér és háttérszíne alacsony hőmérséklet esetén (zöld szint), magas hőmérséklet (vörös szint) illetve a kettő között (sárga szint). Az alacsony és magas hőmérséklet küszöb az ablakban beállítható. Bármely előtér és háttérszín lehet átlátszó: ehhez a szín kiválasztására szolgáló ablakban az "egyéni színek definiálása" lenyomása után a vörös = 254, zöld = 254, kék = 255 színt kell megadni. Az így beállított ikon a tálcán és a státusz ablakban is átlátszó színnel kerül megjelenítésre.

Lehetőség van a tálca ikonon a merevlemez állapotának megfelelő szimbólum megjelenítésére is. Ez lehet Zöld (kíváló, magas kondíció esetén), Vörös (rossz, alacsony kondíció esetén) illetve Sárga a két megadott küszöbérték között. Beállítható, hogy mely esetekben kerüljön a kondíció kijelzésre, pl. csak ha túl alacsony értéket vesz fel.

Amennyiben mind a hőmérséklet, mind a kondíció kijelzés engedélyezve van, az ikonon a két szimbólum másodpercenként váltakozva kerül megjelenítésre. Ez a módszer adott esetben figyelemfelkeltő (de esetlegesen zavaró) lehet, ezért ajánlott az alapértelmezett beállítás használata: csak a probléma (alacsony kondíció) esetén villogjon az ikon.


Beállítások: Figyelmeztetések

A Hard Disk Sentinel egyik logfontosabb funkciója, hogy adott körülmények között képes bizonyos feladatok végrehajtására, figyelmeztetésre. Így az esetleges problémák még időben felderíthetőek. Az egyes problémákhoz több végrehajtandó feladat is hozzárendelhető.

Várható meghibásodás esetén: ez az esemény akkor következik be egy adott merevlemezen, ha az már a gyártó által meghatározott küszöbértékeket elérte. Ebben az esetben a merevlemez azonnali cseréje szükséges. Megjegyzés: ilyenkor a merevlemez kondíciója már 0%-ra csökkent. Megjegyzés: Ez a funkció csak a regisztrált változatban használható.

Alacsony kondíció esetén: ez az esemény akkor következik be egy adott merevlemezen, ha a lemez kondíciója a megadott sárga ill. vörös szint alá csökken. Megjegyzés: Ez a funkció teljes körűen csak a regisztrált változatban használható, ellenkező esetben csak a sárga szinthez kapcsolható figyelmeztetés.

Túl magas hőmérséklet esetén: ez az esemény akkor következik be egy adott merevlemezen, ha a lemez hőmérséklete a megadott sárga ill. vörös szint fölé emelkedik. Megjegyzés: Ez a funkció teljes körűen csak a regisztrált változatban használható, ellenkező esetben csak a sárga szinthez kapcsolható figyelmeztetés.

Új naplóbejegyzés esetén: ez az esemény akkor következik be egy adott merevlemezen, ha a lemez állapota romlani kezd és a merevlemez naplójába újabb probléma kerül bejegyzésre. Megjegyzés: Ez a funkció csak a regisztrált változatban használható.

Alacsony szabad terület esetén: ez az esemény akkor következik be egy adott logikai meghajtón, ha a szabad terület mértéke megadott küszöbszint alá csökken. Megjegyzés: Ez a funkció csak a regisztrált változatban használható. A szabad terület küszöb megadható globálisan minden meghajtón de lehetőség van a meghajtónkénti külön beállításra is (százalékos vagy megabájtos egységben):

Szabad terület küszöb beállítása

Lehetőség van a hangjelzés kiválasztására is. Bármilyen rendszer által támogatott hangfájl (pl. wav, mid, mp3, wma) megadható, melyet a program figyelmeztetésként fog használni.

A Hangjelzés ismétlése opció használatával a program folyamatosan ismétli a hangjelzést probléma esetén, amíg a felhasználó nem jelzi a hangjelzések tiltásával (a gyorsmenüből vagy a főablakból), hogy tudomásul vette a hangjelzéseket és az azokat kiváltó okot. Az opció használata ajánlott olyan számítógép (pl. szerver) esetén, melynél alaphelyzetben nincs felhasználó vagy a távoli figyelmeztetésre nincs lehetőség.

A PC speaker használata opció segítségével a belső hangkeltő eszköz kerül használatra. Így nem szükséges a számítógépre külső hangszórót csatlakoztatni. Használata ajánlott szerver esetén, esetlegesen az előző opcióval kombinálva. Megjegyzés: PC speaker kiválasztása esetén a figyelmeztetést dupla 1000 Hz-es "bip-bip" jelenti. Bizonyos számítógépek (pl. laptopok) nem biztos, hogy tartalmaznak PC speaker-t.

A Hangjelzés tesztelése gomb segítségével a beállításoknak megfelelő hangjelzés (hangfájl lejátszása ill. PC speaker használata) tesztelhető. Amennyiben a hangjelzés nem hallható, érdemes a kábelek, hangszórók ellenőrzésének elvégzése, esetleg a beállítások módosítása.

Lehetőség van adott időpontban státusz e-mail küldésére. Amennyiben a megadott időpontban a küldés nem lehetséges (pl. hálózati probléma miatt vagy mert a számítógép nincs bekapcsolva) az e-mail automatikusan küldésre kerül egy későbbi (legkorábban lehetséges) időpontban. Megjegyzés: Ez a funkció csak a regisztrált változatban használható.

Az Üzenet küldés/jelzés opció használatakor a beállított üzenetek kerülnek kézbesítésre, megjelenítésre.

A Pánik mentés opció használatakor az egyes problémák esetén a beállított művelet(ek) kerül(nek) végrehajtásra. Megjegyzés: Ez a funkció csak a PROFESSZIONÁLIS változatban használható.

A Lekapcsolás opció segítségével probléma esetén a számítógép leállítható a további problémás működést megakadályozandó. Természetesen a lekapcsolás csak a többi feladat végrehajtása után következik be. Lekapcsolás előtt egy perces visszaszámolás indul, ez alatt az idő alatt a lekapcsolási folyamat megszakítható.

Fontos: adott munkamenet alatt merevlemezenként minden probléma egyszer indít be figyelmeztetést. Más szavakkal ha pl. egy merevlemez hőmérséklete felmegy a sárga szintig és az adott szintnél valamely figyelmeztetés engedélyezve van, a figyelmeztetések végrehajtásra kerülnek. Ha a későbbiekben a merevlemez visszahűl a küszöbérték alá, majd újra felmelegszik, nem készül újabb figyelmeztetés. Íly módon elkerülhető, hogy a határérték közeli merevlemez túl sok figyelmeztetést generáljon (pl. túl sok e-mail kerüljön kézbesítésre). Természetesen ha egy másik merevlemez melegszik fel, figyelmeztetés készül.

A program által korábban lekezelt figyelmeztetések listája automatikusan törlésre kerül minden nap éjfélkor. Ez egy hosszú időn keresztül működő számítógép (szerver) esetén azt jelenti, hogy minden merevlemez naponta maximum egy figyelmeztetést készíthet minden problémához.

A korábban már lekezelt figyelmeztetések listája manuálisan bármikor törölhető a főablakból.


Beállítások: Üzenet beállítások

Probléma esetén a Hard Disk Sentinel alkalmazás képes üzenetet küldeni, megjeleníteni. Ezen az oldalon lehetséges az egyes üzenettípusok beállításása, azok tetszőleges kombinációja beállítható. Megjegyzés: legalább az egyik üzenettípus mindenképp legyen kiválasztva.

E-mail küldése: az opció segítségével e-mail küldhető probléma esetén. Az e-mail beállítások oldalon beállítható, hogy a levélküldés milyen paraméterek mellett valósuljon meg. Lehetőség van az alapértelmezett internetkapcsolat tárcsázására (ha szükséges, pl. modem vagy ADSL használata esetén szükséges lehet), illetve a lehetséges a kapcsolat bontása a küldés után. Megjegyzés: utóbbi opció használata esetén ha a kapcsolat aktív volt a figyelmeztetés elküldése előtt (a számítógép csatlakoztatva volt az internetre), a kapcsolat NEM kerül bontásra.

Megadható, milyen típusú e-mail kerüljön kiküldésre. Ez lehet részletes HTML riport (képekkel), részletes szöveges riport (csak sima szöveg) vagy tömör szöveges riport. Utóbbi használata ajánlott ha cél a minél tömörebb információ küldése (pl. email-SMS átjáró használata esetén). Megjegyzés: az itt kiválasztott típusú riport kerül küldésre napi státusz e-mail-ként is. Továbbá az itt kiválasztott típusú riport (szöveges vagy HTML) kerül automatikusan mentésre és küldésre a főablakban található gyorsgombok használatakor.

Testreszabható, hogy a Részletes szöveges illetve HTML riport mely elemeket tartalmazza (regisztrált változat használata esetén). Megjegyzés: az itt található opcióktól függetlenül az XML riport valamennyi adatot tartalmazza.

Üzenet küldése erre a számítógépre: Figyelmeztetés küldhető helyi hálózaton átküldött üzenet (hasonlóan a NET SEND parancs által küldött üzenetekhez). Ehhez szükséges, hogy mind a helyi mind pedig a távoli (fogadó) számítógépen fusson az üzenetkezelő szolgáltatás. A Kiválasztás gomb segítségével tallózható a helyi hálózat és a távoli számítógép megadható, de annak neve (ha ismert) is beírható, a \\ előtag nélkül. Teszt üzenet is küldhető a kapcsolat kipróbálására.

Fontos: az üzenetkezelő által küldött üzenetek ha a távoli számítógép nem válaszol (nincs bekapcsolva vagy nem elérhető), akkor a program folyamatosan újraküldi az üzenetet (5 percenként újrapróbálkozik), amíg nem sikerül a küldés (a program újraindításakor ez az újraküldési folyamat megszakításra kerül).

Megjegyzés: A hálózati üzenetkezelő szolgáltatás kialakítása végett a maximálisan átküldhető üzenet hossza 254 karakter, melyből esetlegesen csak a probléma rövid leírása és a küldő számítógépe olvasható ki. A fogadónak ilyenkor célszerű a küldő számítógépet átvizsgálnia. Érdemes a program mappájában található HDS_problem_log.txt fájl átvizsgálása, mely tartalmazza a korábban küldésre került üzeneteket is. Bizonyos esetekben az ékezetes karakterek hibásan jelenhetnek meg az átküldött üzenetben.

Üzenet megjelenítése a képernyőn: ennek az opciónak használatakor a kijelzőn jelenik meg a probléma. Opcionálisan megadható, hogy az üzenet előtt jelenjen meg egy egyéni felirat, melyet külső fájlból olvas be a program minden egyes üzenet megjelenítésekor. Használata ajánlott hálózatra közvetlenül nem csatlakozó de felhasználó által működtetett számítógép esetén, ahol az egyéni üzenet lehetséges értéke pl. "Kérem hívja a rendszergazdát az XX-XXXX-XXX telefonszámon és olvassa be az alábbi üzenetet:".

Megjegyzés: természetesen a napi státusz e-mail kizárólag e-mail lehet, függetlenül az itt beállított üzenet-típusoktól.


Beállítások: E-mail beállítások

Ezen az oldalon az e-mail küldéséhez szükséges beállítások adhatóak meg. A küldéshez szükséges megadni az alábbi információkat:

  • Feladó név: ez fog látszani, mint küldő név, mikor az e-mail továbbításra kerül (például a számítógép állandó felhasználójának teljes neve).

  • Feladó e-mail: a feladó e-mail címet kell megadni, melyről az e-mailt a program küldi (például a felhasználó e-mail címe).

  • SMTP szerver: a használni kívánt levelezőszerver neve vagy IP címe.

  • Címzett e-mail: a levél címzettje, aki a problémát/státusz levelet meg fogja kapni (például a rendszergazda e-mail címe). Vesszővel elválasztva több címzett is megadható, így többen is értesülhetnek az adott problémáról, státuszról.

  • Port: amennyiben a szerver nem szabványos (25-ös) porton keresztül kommunikál, úgy megadható.

  • Felhasználó, Jelszó: amennyiben a levelezőszervernél hitelesítés szükséges, megadható a használi kívánt felhasználónév és jelszó. Ha nincs szükség hitelesítésre, ezek a mezők maradjanak üresen.

A Levélfiók mezőben kiválasztható egy létező Outlook vagy Outlook Express programban definiált levélfiók. Kiválasztás esetén a feladó neve és címe, az SMTP szerver és a felhasználónév (ha van) automatikusan beírásra kerül. Ebben az esetben elegendő csak a címzett (és az esetleges jelszó) megadása. Biztonsági okokból a jelszót a program nem tölti ki automatikusan, hitelesítés esetén a felhasználónak meg kell adnia ezt az információt.

Megjegyzés: a levélfiók mezőben nem minden esetben jelenik meg valamennyi definiált levélfiók.

Megjegyzés: a mezők kitöltése után ajánlott az E-mail teszt gomb segítségével egy teszt üzenetet küldeni, hogy az esetleges hibás konfigurációra még időben fény derüljön.


Beállítások: Regisztráció

Ezen az oldalon adható meg a vásárlás után kapott regisztrációs kulcs, melynek segítségével a program regisztrálható és így valamennyi funkciója korlátozás nélkül használható. Megjegyzés: Értelemszerűen az alapváltozat regisztrálásával a PRO változat funkciói (műveletek, pánik mentés, stb.) továbbra sem elérhetőek. A PRO változat regisztrálásával viszont valamennyi (alap és PRO) funkció használhatóvá válik.

Egy tetszőlegesen választott felhasználónév megadása szükséges. Ez lehet bármi, például a vásárló neve, beceneve, a cég neve, stb. A névjegy ablakban ez a név jelenik meg, mint regisztrált felhasználó. Az itt megadott felhasználónév a későbbiekben bármikor megváltoztatható a regisztrációs kulcs újbóli megadásával és bármely "regisztráció" gomb megnyomásával. Ebben az esetben mivel a program már aktiválásra került, nincs szükség újbóli aktiválásra, tehát nincs szükség hálózati adatkommunikációra sem.

A program a regisztrációs kulcsot két lépcsőben ellenőrzi: a felhasználó számítógépén (ez a folyamat a regisztráció) valamint a Hard Disk Sentinel alkalmazás szerverén (ez a folyamat az aktiválás). A program teljes körűen használható, ha az ellenőrzés mindkét lépcsője sikeresen lezajlott. Erre a kalóz-felhasználás visszaszorítása érdekében van szükség.

Amennyiben a számítógép internetre kapcsolódik, ajánlott az on-line aktiválás használata. Ilyenkor nincs más teendő, csak lenyomni a Regisztráció és aktiválás on-line gombot (tetszőleges felhasználónév és a kapott regisztrációs kulcs megadása után természetesen). Az aktiválás normál esetben néhány másodpercnél nem tart tovább, még viszonylag alacsony hálózati sebességnél sem.

Ha az on-line aktiválás nem lehetséges, a Regisztráció és aktiválás e-mail-en keresztül opció használata szükséges. Ekkor a program létrehoz egy fájlt, melyet (másik számítógépről) e-mail-en keresztül el kell küldeni az info@hdsentinel.hu címre a kapott regisztrációs kulccsal együtt. Válaszlevélben küldjük az aktivált kulcsfájlt mely a program telepítési mappájába kell, hogy kerüljön. A program újraindítása után valamennyi funkció már korlátozás nélkül használható.

Megjegyzés: Amennyiben az Ön által megadott kód nem a gyártótól származik és az on-line aktiválás hibával tér vissza, kérem NE próbálja meg az e-mail-en keresztüli aktiválást. A nem valós regisztrációs kulcsot tartalmazó (vagy regisztrációs kulcs nélkül érkező) regisztrációs kérelmek automatikusan törlésre kerülnek.

Megjegyzés: Amennyiben az operációs rendszert újra kell telepíteni, a program is gond nélkül újratelepíthető és újra aktiválható. Ez megtehető akárhány alkalommal ha a felhasználó számítógépében az első merevlemez nem változik. Ha ez a merevlemez cserére került (vagy teljes gépcsere történt) a legális aktiválások száma egyel csökken. Ezután erre a merevlemezre is érvényes, hogy cseréig tetszőleges számú újraaaktiválás végezhető (rendszer újratelepítés esetén). A program összesen 5 különböző merevlemezhez köthető hozzá (amennyiben az Ön által használt számítógépben az első merevlemez ennél többször cserélődik és további felhasználásra van szüksége, lépjen kapcsolatba a gyártóval). A további (akármennyi) merevlemezek illetve más komponensek cseréje, eltávolítása nincs befolyással a program regisztrált állapotára.

Ha azonos számítógépen egynél több operációs rendszer található, a program mindegyik operációs rendszer alatt regisztrálható és aktiválható.

Megjegyzés: a vállalati (CORPORATE) változat használata esetén az oldalon található opciók használatára nincs szükség. Nem lehetséges a regisztrált felhasználó módosítása, sem a "Regisztráció" gombok használata mivel a Hard Disk Sentinel automatikusan regisztrálva és aktiválva kerül telepítésre.

Amennyiben a licensz érvényessége időben korlátos, a licensz lejáratának dátuma is kijelzésre kerül. Lejárat esetén kérem vegye fel a kapcsolatot a szoftver gyártójával a licensz meghosszabbításának ügyében.


Beállítások: Frissítés

A program képes figyelni interneten keresztül, hogy van-e újabb (frissített) változat és ha igen, az automatikusan letöltésre kerül. Engedélyezhető az automatikus (heti) frissítés, valamint az Új verzió keresése és frissítés most gomb segítségével az ellenőrzés (és frissítés) bármikor kérhető. Az ablakban megjelenik az új verzió ellenőrzésének utolsó dátuma.

Ellenőrzés és frissítés esetén a program bezáródik (eltűnik a tálca ikon, státusz ablak és valamennyi esetleg nyitva lévő ablak) és a frissítő modul elvégzi az ellenőrzést és a frissítést:

A frissítő modul

Megjegyzés: PROFESSZIONÁLIS változat regisztrálása esetén is ez az ablak jelenik meg, az archiváló modul letöltése érdekében. Frissítéskor ez a modul is automatikusan frissítésre kerül.

Megjegyzés: frissítés után a korábban elküldött figyelmeztetések újra küldésre kerülnek.

Megjegyzés: a program csak az utoljára kiadott végleges változatra frissít. A nem végleges, kipróbálásra szánt (béta) változatok nem kerülnek letöltésre, azokat manuálisan kell letölteni és telepíteni.

Megjegyzés: frissítés után a korábban valós regisztrációs kulccsal regisztrált Hard Disk Sentinel továbbra is regisztrált marad.

Lehetőség van az aktuális konfiguráció elmentésére és visszatöltésére is. Mentés esetén a jelenlegi beállítások (beleértve a beállított műveleteket is), a korábbi statisztikák, napló és a regisztrációs adatok (regisztrált felhasználó és aktivációs állomány) is mentésre kerül. Így egy esetleges újratelepítéskor csak vissza kell tölteni a korábban elmentett konfigurációt és a szoftver automatikusan regisztrált lesz: valamennyi beállítás, korábbi statisztika, grafikon a korábbi állapotnak megfelelően fog üzemelni.

Megjegyzés: amennyiben a számítógép konfigurációja megváltozik, visszatöltés után szükség lehet az újraaktiválásra.

Megjegyzés: a konfiguráció elmentése csak regisztrált változat használata esetén lehetséges.


Beállítások: Fejlett opciók

A program működésének finomhangolására használatos opciók találhatóak ezen az oldalon. Módosításuk csak gyakorlott felhasználók számára ajánlott!

Ellenőrzés gyakorisága: az egyes merevlemezek állapotának ellenőrzései között eltelt idő. Alaphelyzetben a program 5 percenként kérdezi le a merevlemezek állapotát (részletes S.M.A.R.T. információ, hőmérséklet, kondíció, stb). Túl sok merevlemez vagy lassan válaszoló eszköz használata esetén a csúszkát érdemes a jobb oldal irányába tolni, de lehetőség van ennél gyakoribb ellenőrzésre is. Megjegyzés: a nagyon gyakori (1, 5 másodperc) ellenőrzés esetleg teljesítménycsökkenést okozhat.

Kondíció számítási módszer: kiválasztható, hogy a kondíció és a teljesítmény milyen módszer szerint kerülön kiszámításra. Ajánlott az adat mező analízise opció használata vagy esetleg a szigorúbb analízis nagyobb adatbiztonság esetén. A szigorúbb módszer használata különösen ajánlott szerver, hordozható számítógép illetve olyan gép esetén, melynél komoly adatforgalom vagy különösen fontos adatok tárolása történik.

Figyelmeztetés engedélyezése ha a merevlemez nem válaszol: amennyiben a merevlemez hosszú időn keresztül nem válaszol a program lekérdezésére, figyelmeztetés kérhető. Ilyenkor a merevlemez információs ablakában sárga, majd piros felirat is jelzi a problémát, továbbá a lemez naplójába is bejegyzésre kerül ez az információ. Az opció használata csak kifejezetten indokolt esetben javasolt, bizonyos helyzetekben (pl. Windows 98 alatt)

Lemezellenőrzés futásának tiltása: a Windows indulásakor automatikus lemezellenőrzés (checkdisk) indítása tiltható ennek az opciónak segítségével. Adott esetben ezzel megakadályozható, hogy egy leállítás után egy problémás fej a lemez esetleg még ép területét tönkretegye.

Várakozás a lemezellenőrzés indítása előtt: megadható, hogy a Windows indulásakor ha szükséges az automatikus lemezellenőrzés indítása, az ellenőrzés hány másodpercet várjon az indulás előtt. Ez alatt az idő alatt a folyamat gombnyomással megszakítható.

A számítógép órájának szinkronizációja atomórához: NTP (network time protocol) segítségével a számítógép órája szinkronizálható, íly módon mindig a pontos időt fogja mutatni. Ajánlott a funkció használata, mivel így az esetleges riasztások pontos ideje leolvasható. Különösen ajánlott, ha a PROFESSZIONÁLIS változat időzített mentési feladatokat is végrehajt. Megjegyzés: a nem regisztrált változat használata esetén az első óraállítás után a funkció tiltásra kerül.

XML fájl készítése és frissítése: az opció használata esetén a merevlemez(ek) adatainak lekérdezése után az adatok mentésre kerülnek egy speciális XML fájlba, mely feldolgozható más szoftverekkel. Alaphelyzetben a HDSentinel.xml fájl kerül használatra, de a Kiválasztás gomb segítségével ez módosítható. Az elmúlt napon legutoljára mentett XML fájl biztonsági másolatként .BAK kiterjesztéssel tárolásra kerül. Megjegyzés: ez a funkció csak a regisztrált változat használata esetén működik.


Beállítások: Lemez figyelés

A Hard Disk Sentinel a logikai meghajtók (partíciók) szabad helyét is folyamatosan figyeli. Ennek az információnak segítségével képes a meghajtó ikonok módosítására, azaz az ikonon kifejezni a felhasznált hely mértékét, valamint alacsony szabad hely esetén figyelmeztetni.

Alapértelmezett meghajtó ikonok módosítása: az opcióval globálisan kikapcsolható az ikonok módosítása. Kikapcsolt állapotban sem a szabad hely, sem pedig a kondíció nem kerül kijelzésre a meghajtó ikonon, a Windows által alapértelmezett ikonok kerülnek kijelzésre. Bekapcsolt állapotban a módosított, plusz információkat hordozó ikonok látszanak valamennyi alkalmazásban (így a Sajátgépben is).

Hálózati meghajtók szabad területének figyelése: az opcióval engedélyezhető, hogy a program automatikusan figyelje és időszakosan frissítse a hálózati meghajtók szabad területére vonatkozó információkat a főablak logikai meghajtó részében.

Alapértelmezett meghajtó ikonok módosítása a hálózati meghajtókon: a lekérdezés során kapott információ segítségével a hálózati meghajtókhoz tartozó ikon is képes a szabad terület információ kijelzésére.

Eltávolítható meghajtók szabad területének figyelése: az opcióval engedélyezhető, hogy a program automatikusan figyelje és frissítse az eltávolítható meghajtók (pl. pendrive, külső merevlemez, kártyaolvasóban található kártyák) szabad területére vonatkozó információkat a főablak logikai meghajtó részében.

Alapértelmezett meghajtó ikonok módosítása az eltávolítható meghajtókon: a lekérdezés során kapott információ segítségével az eltávolítható meghajtókhoz tartozó ikon is képes a szabad terület információ kijelzésére.

Megjegyzés: a hálózati és eltávolítható meghajtókon a S.M.A.R.T. információk lekérdezése nem lehetséges. Így az ikon kondíciónak megfelelő szimbólumot nem tartalmaz, csak szabad helyet jelző csíkot.

Megjegyzés: a hálózati és eltávolítható meghajtók ellenőrzése adott esetben időigényes lehet. Emiatt az opciók engedélyezése csak abban az esetben ajánlott, ha a meghajtók lekérdezése nem okoz teljesítménycsökkenést, lassulást (pl. ha a hálózati meghajtó nem érhető el illetve ha nincs memórikártya behelyezve a kártyaolvasóba).

Lehetőség van meghajtónként is megadni, mely meghajtókon a szabad hely nagyságát ne figyelje a program illetve mely meghajtók alapértelmezett rendszerikonját ne módosítsa. Ehhez a megfelelő mezőben a meghajtók betűjelét kell felsorolni.

Megjegyzés: a program az ikonokat csak akkor képes felügyelni és módosítani, ha éppen fut. Bezárás során az eredeti rendszerikonok kerülnek kijelzésre (vagy amennyiben más alkalmazás is módosítja az ikonokat, akkor az általa beállított ikonok).

Megjegyzés: bizonyos rendszerek (pl. Windows XP SP1) esetén az ikonok kijelzése nem biztos, hogy az éppen aktuális állapotot tükrözi. Ilyen esetben ajánlatos a legfrissebb szervízcsomag telepítése.

A Lemez ikonkészlet menüpont alatt kiválasztható, hogy XP vagy Vista ikonok kerüljenek megjelenítésre (a felhasznált hely nagyságával és a merevlemez kondíciójával) a Sajátgépet megnyitva.


Beállítások: Gyorsbillentyűk

Lehetőség van a program bizonyos funkcióit gyorsgombok segítségével is elérni. Ezek a gyorsbillentyűk működnek tekintet nélkül arra, mely alkalmazás fut az előtérben (kivéve bizonyos alkalmazásokat, pl. játékokat, melyek alatt a gyorsbillentyűk esetleg nem működnek).

A gyorsbillentyűk közül az egyik legáltalánosabban használt a státusz ablak eltűntetése/újbóli megjelenítése, a főablak illetve a Beállítások ablak előhozása.

A gyorsbillentyűk csak a regisztrált változatban használhatóak.

Megjegyzés: előfordulhat, hogy bizonyos billentyűkombinációk hatástalanok némely operációs rendszer alatt. Vista alatt ilyen pl. a CTRL+ALT+Fx billentyűk által alkotott kombináció.


Műveletek

A Hard Disk Sentinel PROFESSZIONÁLIS változata képes automatikus (mentési) műveletek létrehozására, azok ütemezésére és probléma esetén automatikus végrehajtásukra. A rendszer beállításának folyamata az alábbi fejezetekből sajátítható el:

  • Projektek

  • Időpontok

  • Pánik mentés


Beállítások: Műveletek

Ezek a funkciók kizárólag a PROFESSZIONÁLIS változat használata esetén érhetőek el.

Lehetőség van különböző feladatok (továbbiakban: projekt) megadására, melyeket a Hard Disk Sentinel alkalmazás időzítve illetve bizonyos feltételek teljesülése esetén automatikusan lefuttat. Egy-egy időponthoz (eseményhez) több ilyen feladat is köthető, ilyenkor ezek sorban futnak le, a sorrendet a felhasználó állíthatja be. Ezek a feladatok általában adatmentési műveletek de lehetnek teljesen más jellegű műveletek is.

Kezdéskor egy rövid, tömör nevet kell adni a mentési projektnek (ez a későbbiekben nem változtatható meg). Az Új gomb lenyomásával a program felkér a név megadására, majd a projekt adatlapja jelenik meg, mely egyelőre üres.

Az Eltávolítás gomb használatával az éppen aktuális projekt törölhető a projektek listájából, ha már nincs rá szükség. Megjegyzés: törlés esetén ha a projekt bizonyos időpontokhoz, eseményekhez hozzá volt rendelve, a program megerősítést vár a törlés előtt. Törlésnél ajánlatos körültekintően eljárni, főleg ha az adott projekt lefutásához más projekt(ek) is voltak hozzárendelve.

Megadható egy Megjegyzés mező is a projekthez. Ez egy hosszabb leírást tartalmazhat a projekt által végzett feladat(ok)ról. Ha a projekt csak kérdésre futhat, a projekt neve és megjegyzése jelenik meg, mely segítségével a felhasználó eldöntheti, hogy valóban kívánja-e a feladat futtatását.

A projekt típusa lehet:

  • Külső program vagy kötegfájl indítása: ebben az esetben a projekt egy külső program, belső parancs (pl. copy) vagy köteg (BAT) fájl indítását végzi. Alkalmazható pl. egyes mappák külső archiválóprogrammal történő összecsomagolására és/vagy az archivált állományok optikai lemezre való írására, de elképzelhető pl. vírusadatbázis frissítését elvégző parancs is.

    Ebben az esetben meg kell adni a végrehajtandó parancsot teljes elérési úttal és parancssori paraméterekkel együtt. A Tallózás gomb segítségével a futtatandó alkalmazás is kiválasztható. Az alkalmazás nevét és elérési útját idézőjelek (") közé kell tenni ha a névben vagy az elérési útban szóköz szerepel! Az esetleges paraméterek a nevet lezáró idézőjel után megadhatóak. Például: "C:\Program Files\Program Mappa\Program.exe" paraméter1 paraméter2

    Lehetőség van a projekt "csendben" futtatására is, ekkor nem jelenik meg ablakban a futó feladat.

    Amennyiben a Hiba esetén figyelmeztetés opció engedélyezve van, az üzenet beállítások-nak megfelelően e-mail, hálózati üzenet vagy megjelenő ablak figyelmeztet, ha a külső alkalmazás vagy BAT fájl nem 0-ás hibakóddal tér vissza. Megjegyzés: BAT fájl használata esetén az EXIT xx segítségével adható meg bármilyen hibakód (ahol xx a kód száma). Egy elágazásokat tartalmazó BAT fájlnál ennek segítségével beállítható, mely ponton milyen hibakóddal fejezze be a futást. 0-ás kód esetén a Hard Disk Sentinel a lefutást tökéletesnek veszi, ellenkező esetben figyelmeztetést generál ha az opció engedélyezve van. Ilyenkor a projekttől függő más projektek indítása nem következik be.

  • Állományok átvitele: ebben az esetben a program a belső másoló modult használja. Ennek segítségével átfogóbb mentési feladatok definiálhatók. A Beállítás gombra kattintva megjelennek a mentési projekt beállításai. Megjegyzés: ez a funkció csak a regisztrált változatban érhető el.

  • CD/DVD készítése NERO segítségével: a program az Ahead Software AG NERO (TM) programjának segítségével optikai lemezre archiválja a megadott mappa tartalmát.

    CD/DVD írása Nero segítségével

    Szükséges a NEROCMD.EXE fájl (parancssori CD/DVD író alkalmazás) pontos helyének megadása az Alkalmazás kiválasztása gomb segítségével. Amennyiben ez nem történik meg, de projekt beállításra kerül, a Hard Disk Sentinel mentéskor rákérdez a hiányzó alkalmazás pontos helyére.

    A teljes végrehajtásra váró parancssor megtekinthető az összes paraméterrel. CTRL+C lenyomásával ennek az ablaknak a tartalma a vágólapra menthető.

    Íráshoz szükséges megadni a forrásmappát. Ez tartalmazhat változóneveket (pl. %USER%, %LAST%, stb) ezek leírása megtalálható a mappák kiválasztásánál. %LAST% esetén az adott mappából (esetünkben L:\MENTES) az utoljára létrehozott dátumos mappa kerül írásra, amennyiben egy másik projekt az L:\MENTES mappába mentést végzett Az aktuális dátum használata mappanévként és az utolsó XX mentés megtartása opció használatával.

    Szükséges kiválasztani az író meghajtóját (több optikai egység esetén) valamint az írási sebességet. Az írási sebesség automatikusan módosul a behelyezett lemez és az író tulajdonságainak megfelelően. Meg kell adni, hogy az írás CD ill. DVD médiára történjen. Opcionálisan engedélyezhető a puffer kiürülés elleni védelem valamint az, hogy az írás után a lemez ellenőrzése is megtörténjen-e.

    Tetszőleges paraméterek megadhatók, melyek továbbításra kerülnek a NEROCMD.EXE felé. Ilyen lehet pl. a --disable_eject, így a lemez nem kerül automatikusan kiadásra. A teljes paraméterlista lekérdezhető a NEROCMD /? parancs megadásával.

    Lehetőség van az írás csendben (ablak megjelenítése nélküli) futtatására valamint hibakezelés engedélyezésére, hasonlóan a Külső program vagy kötegfájl indítása típusú projekthez. A NEROCMD által visszaadott hibakódok listája megtalálható a program felhasználói kézikönyvében.

    Megjegyzés: ez a funkció csak a regisztrált változatban érhető el.

  • Fájlok csomagolása RAR/7-Zip segítségével: a program a RarSoft WINRAR (TM) alkalmazását illetve az ingyenes 7-Zip alkalmazást képes használni külső tömörítőként. A megadható paraméterek mindkét esetben azonosak. Megjegyzés: a régebbi verziójú 7-Zip még nem támogatta a több kötetes archívumok létrehozását.

    Fájlok összecsomagolása

    Szükséges a RAR.EXE fájl ill. 7Z.EXE fájl (parancssori csomagoló alkalmazás) pontos helyének megadása az Alkalmazás kiválasztása gomb segítségével. Amennyiben ez nem történik meg, de projekt beállításra kerül, a Hard Disk Sentinel mentéskor rákérdez a hiányzó alkalmazás pontos helyére.

    A teljes végrehajtásra váró parancssor megtekinthető az összes paraméterrel. CTRL+C lenyomásával ennek az ablaknak a tartalma a vágólapra menthető.

    Csomagoláshoz szükséges megadni a forrásmappát. Ez tartalmazhat változóneveket (pl. %USER%, %LAST%, ezek leírása megtalálható a mappák kiválasztásánál).

    Szükséges megadni egy célfájlt, melybe a csomagolást a külső alkalmazás elvégzi. Opcionálisan kérhető, hogy több kötetes archívum készüljön, megadható a kötetméret is kbájt (1024 bájt) egységben.

    Tetszőleges paraméterek megadhatók, melyek továbbításra kerülnek a WINRAR.EXE / 7Z.EXE felé. Ilyen lehet pl. a -mXXX, a tömörítési módszer megadására, a -pXXX a jelszóval védett archívum létrehozására vagy a -sfx az önkibontó archívum létrehozására. A teljes paraméterlista lekérdezhető a WINRAR /? ill. a 7Z (paraméterek nélkül) parancs megadásával.

    Lehetőség van a csomagolás csendben (ablak megjelenítése nélküli) futtatására valamint hibakezelés engedélyezésére, hasonlóan a Külső program vagy kötegfájl indítása típusú projekthez. A WINRAR ill. 7-Zip által visszaadott hibakódok listája megtalálható a megfelelő program felhasználói kézikönyvében.

    Megjegyzés: ez a funkció csak a regisztrált változatban érhető el.

  • Registry kulcsok exportálása: kiválasztott registry kulcsok exportálhatóak előre megadott fájlba (ahol a fájl neve tartalmazhat változókat is).

    Registry kulcsok exportálása

    Megjegyzés: ez a funkció csak a regisztrált változatban érhető el.

  • Számítógép BEkapcsolása: Helyi hálózaton keresztül távoli számítógép "felébresztése" Wake-on-lan adatcsomag segítségével. A számítógép hálózati kártyájának MAC címének megadása szükséges (mely például megtudható az adott számítógépen készített Hard Disk Sentinel teljes riportból). Opcionálisan beállítható, hogy a szoftver várjon, amíg a számítógép nincs készen (nem válaszol PING kérésre) de ne várjon tovább, mint egy beállított maximális időtartam. Ajánlott ellenőrizni a megfelelő tűzfal, számítógép (wake-on-lan engedélyezve van-e) és hálózati beállításokat.

    Távoli számítógép bekapcsolása hálózaton keresztül

    Megjegyzés: ez a funkció csak a regisztrált változatban érhető el.

  • Számítógép KIkapcsolása: Helyi számítógép vagy hálózaton keresztül távoli számítógép leállítása, újraindítása. A helyi számítógép ezen kívül készenléti üzemmódba küldhető vagy hibernálás indítható.

    Távoli számítógép kikapcsolása hálózaton keresztül

    Megjegyzés: ez a funkció csak a regisztrált változatban érhető el.

  • Fájlok küldése e-mail-en keresztül: Fájlok vagy mappák továbbíthatóak e-mail-ben. A megfelelő típus (fájlok/mappák) kiválasztása után a fájlok / mappák megadása pontosvesszővel elválasztva történik. A levél (levelek) küldéséhez az e-mail beállítások oldalon meghatározott feladó, szerver és hitelesítési opciók kerülnek felhasználásra.

    Fájlok küldése e-mail-ben

    Lehetőség van minden egyes fájlt külön-külön e-mailben küldeni (mely opció ideális viszonylag nagyobb, de még e-mailben küldhető méretű állományok átviteléhez). Kérhető kisebb fájlok együttes küldése, mely esetben egy minimális limit megadható. Így az elküldött e-mail-ek legalább a megadott mennyiségű adatot (pl. 2000 Kbájt) fognak tartalmazni, kivéve az utolsó e-mail-t, mely a fennmaradó fájlokat tartalmazza. Az opció használata előtt érdemes körültekintően ellenőrizni a mentendő adatok mennyiségét és a rendelkezésre álló e-mail tárhelyet.

    Megjegyzés: ez a funkció csak a regisztrált változatban érhető el.

  • Fájlok átvitele FTP-n keresztül: Fájlok vagy mappák tartalma tölthető fel FTP szerverre. A megfelelő típus (fájlok/mappák) kiválasztása után a fájlok / mappák megadása pontosvesszővel elválasztva történik.

    Fájlok automatikus feltöltése FTP szerverre

    Az átvitelhez meg kell adni a (távoli) FTP szerver nevét ill. IP címét, a kapcsolódáshoz használandó felhasználónevet és jelszót. Opcionálisan megadható port (alapértelmezett a 21-es, szabványos FTP port), passzív mód használata és távoli mappa is. A Beállítás gombra kattintva további, átvitelt befolyásoló opciók is megadhatók (az itt is elérhető mentési opciókon felül), például az FTP időtúllépés mértéke és a hibák esetén újrapróbálkozások száma.

    Megjegyzés: FTP átvitel esetén is használható az "utolsó XX mentési állapot megtartása" opció. A folytatás (REST) nem támogatott.

    Megjegyzés: ez a funkció csak a regisztrált változatban érhető el.

  • Merevlemez(ek) tesztelése: A számítógépben használt merevlemezek állapota vizsgálható a beépített hardver önteszt segítségével (IDE vagy S-ATA merevlemezek esetén). A tesztelni kívánt lemez(ek) a listából kiválaszthatóak, de kérhető valamennyi lemez egyidejű tesztelése is.

    Az egyes merevlemezek által támogatott tesztek gyorstippben megjelennek, mikor az egér a kérdéses lemez fölé kerül. A tesz típusát a támogatott tesztek listája alapján kell kiválasztani.

    Lehetőség van arra, hogy a teszt lefutása után értesítést kérjünk az eredményekről minden esetben illetve csak ha valemilyen hiba történt a teszt során. Az eredményekben tételesen leolvasható, hogy a teszt során milyen új problémákat talált a program (pl. újabb hibás terület, javított vagy gyenge szektorok).

    Megjegyzés: ez a funkció csak a regisztrált változatban érhető el.

Megjegyzés: a későbbi változatokban több projekt típus is beépítésre fog kerülni.

Az Indítás most gomb segítségével a beállított projekt azonnal indítható. Indítás előtt minden esetben szükséges a beállítások mentése a Mentés gomb használatával.

A Parancsikon létrehozása az asztalon gomb lenyomásával az aktuális projekthez parancsikon készíthető az asztalra. Így a projekt manuálisan is indítható (még akkor is, ha a Hard Disk Sentinel alkalmazás éppen nem fut). Megjegyzés: a változókat tartalmazó projekt esetén a változók kiértékelése a parancsikon létrehozásakor megtörténik. Ezért ajánlott csak változók nélküli projektek vagy gyakorlatilag állandó változók (pl. %COMPUTER%) használata a manuálisan indítandó projektek megadásánál. Megjegyzés: ez a funkció csak a regisztrált változatban érhető el.

A Mentés gomb segítségével a projekt, az időpontok listái és az események listája mentésre kerül. Ajánlott a funkció sűrű használata, mivel bizonyos funkciók csak akkor érhetőek el, ha az aktuális beállítások mentésre kerültek. Az Alapértelmezett projektek visszaállítása gomb segítségével a legutóbbi mentett állapot kerül visszatöltésre, használatával egy véletlen törlés, módosítás visszaállítható.

A feladatok meghatározása után azok időpontokhoz vagy eseményekhez rendelhetőek. Ilyen esemény pl. a pánik mentés, mely végrehajtásra kerül, ha valamely merevlemezzel kapcsolatban probléma lép fel és az adott problémához a pánik mentés mint figyelmeztetés engedélyezve van.


Beállítások: Műveletek, Időpontok

Ezek a funkciók kizárólag a PROFESSZIONÁLIS változat használata esetén érhetőek el.

A projektekhez tartozó időpontok beállítása

Minden egyes naphoz külön feladatlista állítható össze. Legfelül a legördülő menüből kiválasztható a kérdéses napja a hétnek, melyre a projektek végrehajtását el kívánjuk végezni.

A Felfüggesztve a következő ilyen napon opció engedélyezésével a soron következő kiválasztott napon (pl. ha kedd van kiválasztva, akkor a következő kedden) a megadott feladatok egyike sem fog lefutni. Így előre beállítható ha a feladatok végrehajtását szüneteltetni szeretnénk pl. tervezett karbantartás idejére. A kérdéses napot elhagyva a program automatikusan visszaáll normál üzemmódba azaz utána valamennyi projekt le fog futni. Így nem fenyeget a veszély, hogy esetlegesen letiltásra került projektek nem lesznek újra engedélyezve.

A Törlés mező alatti piros X segítségével az adott projekt törölhető az aznapi feladatlistából. Természetesen ettől a projekt még nem kerül törlésre, az bármikor újra kiválasztható és hozzáadható a feladatlistákhoz. Ezután következik a projekt sorszáma, melynek akkor van jelentősége, ha több projekt végrehajtását is tervezzük, melyek egymás utáni sorredben (szekvenciálisan) kerülnek végrehajtásra.

A Projekt mező alatt adható meg a projekt neve, ami végrehajtásra kerüljön. Itt a korábban létrehozásra került projektek választhatók ki.

Az Indítás mező alatt kiválasztható, hogy a kérdéses feladat milyen időpontban illetve helyzetben induljon el. Ennek a mezőnek az értékei lehetnek:

  • Fix időben: a projekt az Időpont mezőben meghatározott időpontban fog indulni (óra:perc). Ha a projekt indítása az adott időpontban nem lehetséges (pl. a rendszer még nem töltődött be), a Később indulhat opció kiválasztásával megadható, hogy a projekt lefusson-e a megadott időpontnál későbbi (de lehetséges legkorábbi) időpontban. Ajánlott: fix időzített, időigényesebb projektekhez (pl. teljes éjszakai mentések).

  • Betöltés után: a Hard Disk Sentinel program elindítása után megadott késleltetéssel, mely az Időpont mezőben szerepel (óra:perc). Többszöri újraindítás után minden egyes betöltés után lefut a beállított projekt. Ajánlott: gyors adatmentéshez (pl. új vagy módosított dokumentumok, képek).

  • Betöltés után naponta 1X: a program indítása után megadott késleltetéssel mely az Időpont mezőben szerepel (óra:perc). Minden nap csak az első indításkor hajtódik végre, utána már nem. Ajánlott: napi egyszeri adatmentéshez vagy napi feladatok végrehajtásához (pl. víruskereső adatbázisának frissítése).

  • Ismétlődően: beállított periódusidő elteltével (mely az Időpont mezőben szerepel óra:perc formában) a projekt folyamatos ismétlése. Ajánlott: gyorsan változó adatok, sűrűn érkező állományok archiválására.

  • Ha lefutott X: indítás, amennyiben az adott napon a jelölt sorszámú projekt lefutott. Kiválasztása csak akkor lehetséges, ha az X sorszámú projekttel a feladatlista már mentésre került. Megjegyzés: ha a láncban valamelyik projekt futását a felhasználó leállítja vagy a projekt tiltásra kerül, a tőle függő projekt(ek) nem kerülnek végrehajtásra. Egy projekt lefutásához több más projekt futása is köthető, így azok már egyszerre fognak futni, amint az előző projekt futása befejeződött. Ajánlott: mentett adatmennyiség csomagolása, esetleg automatikus archiválása optikai adattárolóra.

A Kérdésre indul opció használatával a projekt lefutása nem történik meg automatikusan, a felhasználónak meg kell erősítenie a futtatási szándékot. Íly módon a felhasználó késleltetheti vagy megállíthatja a projekt (és a tőle függő többi projekt) végrehajtását. Használata csak indokolt esetben javasolt, mivel a projektek végrehajtása addig nem történik meg, míg a felhasználó nem válaszol a megjelent ablakra. Megjegyzés: ez a funkció csak a regisztrált változatban tiltható le, a nem regisztrált változatnál a projektek csak kérdés után indulhatnak.

Az Engedélyezve opció használatával az adott projekt futása tiltható. Így ha hosszabb időn keresztül szeretné a felhasználó a projekt futását megakadályozni a projekt törlése nélkül, ezzel az opcióval megteheti. Megjegyzés: amennyiben egy (vagy több) projekt függ a tiltott projekttől, a program mentéskor figyelmeztet arra, hogy a függő projekt(ek) sem fog(nak) lefutni a tiltás miatt. Ekkor lehetőség van a beállítások felülvizsgálatára.

A projekt lista végén található Projekt hozzáadása feliratra kattintva adható újabb projekt a feladatlistához.


Beállítások: Műveletek, Pánik mentés

Ezek a funkciók kizárólag a PROFESSZIONÁLIS változat használata esetén érhetőek el.

Pánik mentés: indítás probléma esetén

Az időpontok beállításához hasonlóan az egyes mentési projektek hozzárendelhetők bizonyos eseményekhez is. Ilyenek lehetnek pl. ha a merevlemez kondíciója túl alacsony szintre csökken, a hőmérséklete túl magas szintre emelkedik, stb. Az egyes eseményekhez, melyekhez "pánik mentés" (projekt(ek) végrehajtása) kapcsolható, a Figyelmeztetések oldalon található.

Megadható egy általános feladatlista, amin szereplő projektek végrehajtásra kerülnek ha bármely merevlemezen problémát észlel a program (és a problémának megfelelő pánik mentés opció engedélyezve van a Figyelmeztetések oldalon. Ezen túlmenően lehetőség van külön-külön feladatlistát összeállítani az egyes merevlemezekhez. Így például beállítható, hogy ha az első merevlemezes meghajtón meghibásodás várható, akkor azonnal induljon a mentés a második merevlemezre. Ha pedig a második merevlemezzel van gond, induljon archiválás külső merevlemezre vagy hálózati adatmentő-szerverre.

A felső legördülő menüből választható, hogy a feladatlista mely merevlemezhez tartozzon.

A Törlés mező alatti piros X segítségével az adott projekt törölhető a feladatlistából. Természetesen ettől a projekt még nem kerül törlésre, az bármikor újra kiválasztható és hozzáadható a feladatlistákhoz. Ezután következik a projekt sorszáma, melynek akkor van jelentősége, ha több projekt végrehajtását is tervezzük, melyek egymás utáni sorredben (szekvenciálisan) kerülnek végrehajtásra.

A Projekt mező alatt adható meg a projekt neve, ami végrehajtásra kerüljön. Itt a korábban létrehozásra került projektek választhatók ki.

Az Indítás mező alatt kiválasztható, hogy a kérdéses feladat milyen helyzetben induljon el. Ennek a mezőnek az értékei lehetnek:

  • Automatikusan: a projekt végrehajtása a probléma észlelésekor automatikusan megtörténik.

  • Ha lefutott X: indítás, amennyiben a jelölt sorszámú projekt lefutott. Kiválasztása csak akkor lehetséges, ha az X sorszámú projekttel a feladatlista már mentésre került. Megjegyzés: ha a láncban valamelyik projekt futását a felhasználó leállítja vagy a projekt tiltásra kerül, a tőle függő projekt(ek) nem kerülnek végrehajtásra. Egy projekt lefutásához több más projekt futása is köthető, így azok már egyszerre fognak futni, amint az előző projekt futása befejeződött.

A Kérdésre indul opció használatával a projekt lefutása nem történik meg automatikusan, a felhasználónak meg kell erősítenie a futtatási szándékot. Íly módon a felhasználó késleltetheti vagy megállíthatja a projekt (és a tőle függő többi projekt) végrehajtását. Használata csak indokolt esetben javasolt, mivel a projektek végrehajtása addig nem történik meg, míg a felhasználó nem válaszol a megjelent ablakra. Megjegyzés: ez a funkció csak a regisztrált változatban tiltható le, a nem regisztrált változatnál a projektek csak kérdés után indulhatnak.

Az Engedélyezve opció használatával az adott projekt futása tiltható. Így ha hosszabb időn keresztül szeretné a felhasználó a projekt futását megakadályozni a projekt törlése nélkül, ezzel az opcióval megteheti. Megjegyzés: amennyiben egy (vagy több) projekt függ a tiltott projekttől, a program mentéskor figyelmeztet arra, hogy a függő projekt(ek) sem fog(nak) lefutni a tiltás miatt. Ekkor lehetőség van a beállítások felülvizsgálatára.

A projekt lista végén található Projekt hozzáadása feliratra kattintva adható újabb projekt a feladatlistához.


Állományok átvitele

A Hard Disk Sentinel PROFESSZIONÁLIS regisztrált változatában található mentési modul sokrétű beállítái lehetőséggel képes számtalan kombinációjú mentési feladat megvalósítására. Ennek a résznek a beállításairól és működéséről az alábbi fejezetekben olvashat:

  • Projekt műveletek

  • Mappák kijelölése

  • Globális beállítások

  • Projekt opciók

  • Futó projekt működés közben


Beállítások: Műveletek, Állományok átvitele

Ezek a funkciók kizárólag a regisztrált PROFESSZIONÁLIS változat használata esetén érhetőek el.

Fájlok mentésének beállítása

A fájlok átvitelének beállításakor a legfontosabb, hogy kijelölésre kerüljenek a forrás és a célmappa párok, ahonnan és ahova az adatok átvitele történik.

Az Új gombra kattintással megjelenik az ablak, ahol megadhatóak ezen mappák. A Szerkesztés segítségével egy korábban beállított bejegyzés szerkeszthető (a bejegyzésen dupla kattintással is hasonló eredmény érhető el. A Törlés gomb használatával pedig a mappalistából eltávolítható az éppen kijelölt bejegyzés.

A Globális beállítások oldalon az összes "állományok átvitele" típusú projektre érvényes beállítások találhatóak. A Projekt opciók oldalon pedig az éppen szerkesztés alatt lévő projekt lefutása finomhangolható.


Beállítások: Műveletek, Állományok átvitele, Mappák kiválasztása

Ezek a funkciók kizárólag a regisztrált PROFESSZIONÁLIS változat használata esetén érhetőek el.

Fájlok mentésének beállítása

A fájlok átvitelének beállításakor a legfontosabb, hogy kijelölésre kerüljenek a forrás és a célmappa párok, ahonnan és ahova az adatok átvitele történik.

Kiválasztható, de manuálisan is bevihető a menteni kívánt forrásmappa és a mentés céljaként jelölt mappa. Célként több, különböző mappa (akár több, különböző meghajtón, sőt számítógépen) is megadható, ekkor a forrásmappa minden egyes megadott célmappába mentésre kerül. A célmappák megadásánál alkalmazhatóak az ablakban felsorolt változók bármelyike (akár több is). Így például hálózati mentés esetén minden számítógépről kérhető a felhasználók neve, a számítógép neve vagy IP címe szerinti válogatás is.

A %LAST=mappa% helyére a megadott mappából az utoljára frissített al-mappa neve kerül. Ennek jelentősége akkor van, ha több teljes mentési állapotot kívánunk megtartani, de az utolsó mentett mappával további műveleteket szeretnénk végezni. Ennek működéséről és beállításáról a projekt opciók oldalon található információ.

Ez az opció rövidebb formában is megadható, lehetőség van %LAST% használatára. Ebben az esetben a %LAST% előtt megadott mappából keresi ki a Hard Disk Sentinel az éppen aktuális legfrissebb mentési állapotot tartalmazó mappát. Így tehát a C:\MENTES\%LAST=C:\MENTES% valamint a C:\MENTES\%LAST% ugyanazt az eredményt fogja hozni. Például CD/DVD-re történő archiválás esetén ha forrásmappának az előbbi példák egyike kerül megadásra, akkor a C:\MENTES mappából a legfrissebb archívum kerül írásra.

Megjegyzés: a %LAST=mappa% ill. %LAST% csak akkor használható, ha az aktuális dátum használata mappanévként és az utolsó XX mentés megtartása opció engedélyezve van.

Megjegyzés: a mappanevek tartalmazhatnak helyi vagy távoli (hálózati) meghajtókat és UNC neveket is (pl. \\szerver\megosztás\mappanév). A beállításoknál körültekintően kell eljárni, hogy a hálózati erőforrások a későbbiekben is elérhetőek legyenek a program számára.


Beállítások: Műveletek, Állományok átvitele, Globális beállítások

Ezek a funkciók kizárólag a regisztrált PROFESSZIONÁLIS változat használata esetén érhetőek el.

Fájlok mentésének beállítása

Megadható, hogy mely fájlmaszknak megfelelő állományokat a program hagyjon figyelmen kívül. Ezek archiválása nem történik meg.

Megjegyzés: Ez a beállítás érvényes valamennyi állomány átviteli projekt végrehajtására.


Beállítások: Műveletek, Állományok átvitele, Projekt opciók

Ezek a funkciók kizárólag a regisztrált PROFESSZIONÁLIS változat használata esetén érhetőek el.

Fájlok mentésének beállítása

Ezen opciók segítségével az archiválási folyamat futása finomhangolható, a helyzet alapján testreszabható.

A másolandó adatmennyiség kiszámítása másolás előtt: engedélyezés esetén a program archiválás előtt megszámolja, mennyi adatot kell menteni a projekt végrehajtása során. Sok fájl, mappa esetén ez hosszadalmas lehet, pánik mentéses projekt esetén esetleg kikapcsolható. Használatával archiválás közben is látható, hogy hol tart a művelet és mennyi idő van még hátra az archiválásból (becsült érték a korábbi sebesség alapján).

Ne induljon a mentés ha az adatmennyiség kevesebb, mint XX kbájt: amennyiben a forrásmappában nem áll rendelkezésre a megadott mennyiségű adat, a projekt nem fut le. Használatával bizonyos esetekben kikerülhető, hogy a korábbi mentések megtartása mellett üres (vagy hiányos) mappa kerüljön mentésre.

Figyelmeztetés ha túl kevés az adat: ha nem áll rendelkezésre a megadott mennyiségű adat, a program hibaüzenetet generál. Ez az Üzenet beállítások-nak megfelelően lehet e-mail, hálózati üzenet vagy képernyőn megjelenő ablak. Opcionálisan kérhető, hogy probléma esetén hangjelzéssel (ld. lejjebb) is figyelmeztessen a program.

A másolt adat ellenőrzése: a mentés során a program automatikusan CRC ellenőzőösszeget készít minden fájlhoz és ezt az átmásolt fájlok mellett tárolja (ennek segítségével a későbbiekben megjelenő visszatöltő modul bármikor ellenőrizni tudja a mentés épségét valamint a tárolt lista alapján automatikusan el tudja végezni a visszatöltést). Az opció használatával a mentés lefutása után a program azonnal visszaellenőrzi a mentett adatok épségét. Sok fájlnál ez hosszadalmas lehet, elképzelhető, hogy tovább tart, mint maga a mentés.

Csak az újabb és módosított fájlok másolása: csak azon fájlok archiválása, melyek a legutolsó archiválás óta megváltoztak vagy akkor még nem léteztek.

Arhív bit törlése az átmásolt fájlokon: segítségével későbbiekben kiszűrhető, mely fájlok kerültek mentésre és mely fájlokat szükséges a későbbiekben archiválni. Használata az előző opcióval együtt ajánlott.

Forrás fájlok törlése mentés után: a sikeresen lezajlott mentés után a forrásfájlok törlése. Segítségével a forrásmappa kiürítésre kerül. Használata csak különösen indokolt esetben ajánlott (pl. kis kapacitású tárolóegységről archiválás, majd annak kiürítése). Megjegyzés: az (üres) almappák nem kerülnek törlésre.

Almappák mentése: beállítható, hogy a forrásmappában található almappák tartalma is mentésre kerüljön-e vagy sem.

Forrásmappa nevének mentése a célmappába a fájlokkal együtt: ha az opció engedélyezve van, a forrásmappa neve (a forrás elérési út utolsó mappája) is létrehozásra kerül a célmappán belül és a forrásmappa tartalma ebbe a mappába kerül mentésre. Ellenkező esetben a célmappába csak a forrásmappán belül található fájlok és mappák kerülnek mentésre.

Ne mutassa a mentési állapot ablakot: beállítható, hogy a mentés során az éppen aktuális helyzetet mutató mentési ablak látszódjon-e vagy sem. Tiltás esetén a tálca ikonon villogó lemezek jelzik, hogy éppen mentési folyamat történik.

Az aktuális dátum használata mappanévként és az utolsó XX mentés megtartása: segítségével beállítható, hogy az egyes forrásmappák a célmappán belül többször is mentésre kerüljenek, több különböző állapot megtartásával. Íly módon biztosítható, hogy pl. napi mentés esetén 7 mentés megtartásával egy teljes hétre visszamenőleg valamennyi mentési állapot tárolva legyen. Mentéskor a célmappában automatikusan létrehozásra kerül egy új mappa az éppen aktuális dátumnak és időnek megfelelően, melybe az aktuális adatok kerülnek mentésre. Amennyiben már a megadott számú mentési állapot létezik, a mentés előtt a legrégebbi mappa tartalma törlésre kerül. Használatával egy napokkal korábbi véletlen törlés, módosítás, adatvesztés esetén is helyreállítható egy régebbi, stabil állapot; hátránya, hogy lényegesen több hely szükséges hozzá, mint egy egyszerű adatmentéshez.

A művelet befejezésekor kérhető jelentés minden esetben, csak ha valami probléma történt, illetve beállítható, hogy ne legyen jelentés. A jelentés az Üzenet beállítások-nak megfelelően lehet e-mail, hálózati üzenet vagy képernyőn megjelenő ablak. Opcionálisan kérhető, hogy probléma esetén hangjelzéssel is figyelmeztessen a program.

A Probléma esetén hangjelzés a Figyelmeztetések oldalon beállítható hangjelzés opcióknak (megadott hangfájl lejátszása illetve PC speaker használata, esetleg a jelzés folyamatos ismétlésével) megfelelően kerül végrehajtásra.

Megadható A művelet prioritása. Ennek segítségével kiválasztható, hogy az adott projekt végrehajtása mennyire terhelje a számítógépet (esetlegesen a többi alkalmazás kárára). Pánik mentés esetén ajánlott a "maximális" beállítás használata.


Állományok és mappák átvitele

Amennyiben projektek beállításainál a projekt típusánál Állományok átvitele lett kiválasztva, a mentést a Hard Disk Sentinel belső modulja végzi. Működés közben egy ablakban folyamatosan nyomon követhető az éppen végzett munkafolyamat (pl. állományok másolása, ellenőrzés, stb.) valamint megtekinthető a munkafolyamat jelenlegi állapota, feldolgozott adatmennyiség és a folyamatból hátralévő idő - ha a mentés előtt az adatmennyiség kiszámítása opció engedélyezve volt.

A Mégse gomb segítségével a projekt végrehajtása megszakítható. Ilyen esetben a program (amennyiben a jelentés küldése opció engedélyezve volt) jelenti, hogy a projekt végrehajtása a felhasználó által meg lett szakítva. Ilyenkor a projekttől függő további projekt(ek) nem kerülnek végrehajtásra. Megjegyzés: bizonyos esetekben előfordulhat, hogy a gombot lenyomva a művelet még kis ideig fut, nem áll le azonnal.

Az ablak jobb felső sarkában található X (bezáró gomb) segítségével az ablak becsukható. Ilyenkor a mentés továbbra is fut, erről az óra mellett megjelenő mentésért felelős villogó lemez ikon tudósít:

Mentés állapotának megjelenítése a tálca ikonon

Az ikon fölé húzva az egeret megtekinthető, hogy éppen milyen műveletet végez a program és hol tart annak végrehajtásában. Az ikonra bal egérgombbal kattintva a mentés ablak jelenik meg (ezzel párhuzamosan az ikon eltűnik).

Megjegyzés: a program mappájában található project_log.txt fájlba a program minden alkalommal bejegyzi, hogy az adott projekt lefutott-e illetve milyen probléma történt a végrehajtás során. Ajánlott ennek a fájlnak az ellenőrzése probléma esetén.


Beállítások: Integráció

Ez az oldal a szoftver rendszerbe illesztésével, integrációjával kapcsolatos beállításokat tartalmazza. Ezen funkciók használata kizárólag tapasztalt felhasználók számára ajánlott!

Védelem

Lehetőség van arra, hogy a programot jelszóval védjük: jelszó ismerete nélkül a felhasználó nem tudja az aktuális beállításokat megtekinteni és módosítani. Opcionálisan a program információs főablakát is letilthatjuk, így jelszó hiányában a számítógép felhasználója nem férhet hozzá a merevlemez(ek) részletes adataihoz.

Ilyenkor a rendszergazda csak az általa korábban megadott jelszóval képes a megfelelő ablakot megnyitni. A főablak illetve a beállítások ablak bezárása után a szoftver még emlékszik a megadott jelszóra, így ismételt megnyitáskor azt nem kell újból megadni - kivéve, ha az automatikus kijelentkezés opció engedélyezésre került. Ez esetben a megadott idő után a Hard Disk Sentinel a jelszó ismételt begépelésére szólít fel.

A rendszergazdának a szükséges ellenőrzések, módosítások elvégzése után lehetősége van azonnal kijelentkezni a Kijelentkezés Most gomb használatával. Ezután a felhasználói felület ismét jelszóval védetté válik.

Megjegyzés: Ez a funkció csak a regisztrált változatban használható.

Szolgáltatás

A Hard Disk Sentinel kétféle üzemmódban képes működni: Alkalmazás és Szolgáltatás módban. Az Alkalmazás üzemmód az alapértelmezett módszer: a program a (rendszergazda jogosultsággal rendelkező) felhasználó bejelentkezése után elindul és a merevlemezek állapotát felügyeli. A 2.02 változat előtt ez volt az egyetlen működési üzemmód.

Szolgáltatásként (NT Service) futtatva a program az operációs rendszer betöltődésekor a memóriába kerül és aktív - akkor is ha a felhasználó még nem jelentkezett be illetve ha a számítógépet korlátozott jogosultságú felhasználó kezeli. A szoftver ez esetben a felhasználótól függetlenül ellenőrzi a merevlemezek állapotát, riaszt, mentést indít - a másik esethez hasonlóan.

Szolgáltatás telepítés, karbantartás csak rendszergazda jogosultsággal lehetséges. Így a rendszergazdának kell a megfelelő beállításokat, riasztási opciókat megadni, majd a programot szolgáltatás üzemmódba átváltani. Célszerű az előző (védelem) menüpont használatával kombinálni, az illetéktelen felhasználást megakadályozandó.

Tudnivalók a szolgáltatás üzemmódról:

  • Ez az üzemmód kizárólag NT alapú operációs rendszereken működik (Windows 2000, XP, 2003, Vista).

  • Szolgáltatás üzemmódban a program ugyanazokat a funkciókat és feladatokat látja el, mint alkalmazás módban.

  • A szolgáltatás neve: HardDiskSentinelService, alaphelyzetben "Helyi rendszerfiók" jogosultsággal fut. A rendszergazda ezt megváltoztathatja a Vezérlőpult, Felügyeleti eszközök, Szolgáltatások menüpont alatt, ha szükséges pl. távoli meghajtók elérése mentési feladatoknál. A beállított mentési projektek és külső alkalmazások is öröklik a megadott jogosultságot.

  • A szolgáltatás indítható és leállítható a Start menüben található Hard Disk Sentinel programcsoport megfelelő parancsikonjaival is. A leállítás után lehetőség van a szolgáltatás megszűntetésére és az alkalmazás üzemmód visszaállítására. Ez természetesen csak jelszó (ha beállításra került) és rendszergazda jogosultság birtokában lehetséges.

  • Lehetőség van a program "láthatatlan" futtatására is (ablakok, tálca ikon megjelenítése nélkül) ha a "Szolgáltatás együttműködhet az asztallal" opció tiltásra kerül (az operációs rendszer "szolgáltatás tulajdonságok" ablakában). Ez esetben az információk és beállítások elérése nem lehetséges, csak ha a szolgáltatás leállításra kerül a megfelelő parancsikonnal. Windows Vista operációs rendszer az interaktív (felhasználói felülettel rendelkező) szolgáltatások esetén a felületet nem jeleníti meg, így ez esetben a Hard Disk Sentinel ilyen "láthatatlan" üzemmódban fut ha a szolgáltatás mód engedélyezve van.

  • A szolgáltatás üzemmódban nem működik az "automatikus frissítés" funkció és a program nem zárható be a hagyományos módon. Ilyenkor a szolgáltatás a megfelelő parancsikonnal állítható le (vagy az Integráció ablakban visszaváltható Alkalmazás módra).

  • A rendszer leállításakor, újraindításakor a szolgáltatás automatikusan leáll illetve indul, nincs szükség kézi leállításra.

  • A rendszergazdának javasolt a program telepítési mappáját a korlátozott jogosultságú felhasználók elől tiltani, hogy a programot megkerülve se legyen lehetőség a beállítások, adatok megváltoztatására.

  • Bizonyos rendszerek, szoftverek, asztal-témák használata esetén a felhasználói felület egyes elemei (státusz ablak, asztalra kerülő kijelzés) nem vagy hiányosan jelenhetnek meg.

  • Az automata frissítő használata esetén a Hard Disk Sentinel programcsoportban nem kerülnek létrehozásra a szolgáltatást vezérlő parancsikonok. Emiatt javasolt a 2.05-ös változat manuális telepítése.

  • Lehetőség van a szolgáltatás indítására, leállítására a Vezérlőpult, Felügyeleti eszközök, Szolgáltatások ablakban: a HardDiskSentinelService szolgáltatáson jobb egérgombbal kattintva megjelenő menüből az Indítás és Leállítás parancsok kiválasztásával. A megfelelő jogosultság birtokában ez távoli (hálózati) számítógépről is megtehető.

  • Mikor a szolgáltatás nem fut, lehetőség van a szolgáltatás telepítésére vagy eltávolítására a HDSentinel.exe /INSTALL illetve HDSentinel.exe /UNINSTALL parancsok kiadására a Hard Disk Sentinel telepítési mappáján belül.

Távfelügyelet

WebStatus engedélyezése: bekapcsolt állapot esetén helyi vagy távoli számítógépről/mobiltelefonról/PDA-ról egy böngésző segítségével információ kérhető az adott gép állapotáról. A hozzáférés opcionálisan jelszóval védhető, ez esetben a böngészőben tetszőleges felhasználónév és a Védelem panelen megadott jelszó megadása szükséges a hozzáféréshez.

Lehetőség van a hozzáférés portjának megváltoztatására is az adott hálózati konfigurációnak megfelelően.

Megjegyzés: ez az opció csak regisztrált változat használata esetén aktiválható.

Az opció engedélyezése után a böngészőben az alábbi lekérdezések használhatók:

  • http://szervernév:port/status : a státusz ablak teljes tartalma (ahogy beállításra került), mely automatikusan frissül a megadott időintervallum szerint. Keret és margó nélküli ablak, ideális IFRAME-be illesztéshez.

  • http://szervernév:port/statuswin.bmp : státusz ablak (csak kép)

  • http://szervernév:port/report : teljes HTML riport mely a beállításoknak megfelelő szekciókat tartalmazza

  • http://szervernév:port/xml : teljes XML riport

Megjegzés: a számítógépen (szerveren) a státusz ablaknak nem kell, hogy látszódjon a funkció használatához.

Például: ha a helyi gépen ez az opció engedélyezve van az alapértelmezett beállításokkal, akkor http://localhost:61220/status használható.

Megjegzések: NetLog.txt fájlba kerül naplózásra minden hozzáférés (IP címmel és dátummal együtt), a fentiektől eltérő lekérés esetén 403 Forbidden hibaüzenet jelenik meg a böngészőben. A funkció használatával a fájlrendszer és egyéb adatok távolról NEM érhetőek el. Dinamikus IP cím esetén szükség lehet egy olyan szolgáltatás használatára, mely a dinamikus címet fix névvé alakítja, így a számítógép (szerver) a hálózaton elérhetővé válik. Ilyen szolgáltatást (díjmentesen) biztosít például: http://www.no-ip.com és http://www.dyndns.com .

    Merevlemez állapot megjelenítése egy böngészővel (PDA-ról)
    Merevlemez állapot megjelenítése távolról egy böngésző segítségével (PDA-ról)

Két vagy több számítógéphez tartozó Hard Disk Sentinel státusz ablak egyszerűen felhelyezhető egyetlen HTML lapra, melynek tartalma automatikusan frissül, így mindig az aktuális állapotot tükrözi. Íly módon a különböző gépek állapota ennek a lapnak (mely HTML fájl elhelyezhető a hálózatban található webszerveren vagy akár magán a PC-n/mobiltelefonon/PDA-n is) lekérésével ellenőrizhető, akár távolról is. Például:

    <html>
<head>
<title>Merevlemez Állapot</title>
</head>
<body>
<center>
<iframe src="http://192.168.2.101:61220/status" width=220
height=61 frameborder=0></iframe><br>PC #1<br><br>
<iframe src="http://192.168.2.102:61220/status" width=220
height=61 frameborder=0></iframe><br>PC #2<br><br>
<iframe src="http://192.168.2.103:61220/status" width=220
height=61 frameborder=0></iframe><br>PC #3<br><br>
</body>
</html>
    Megjelenít 3 státusz ablakot beágyazott keretben (IFRAME). Az adatok külön-külön automatikusan frissülnek.
    <html>
<head>
<title>Merevlemez Állapot</title>
<META HTTP-EQUIV="Refresh" CONTENT="300">
<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">
<META HTTP-EQUIV="CACHE-CONTROL" CONTENT="NO-CACHE">
</head>
<body>
<center>
<a href="http://192.168.2.101:61220/report"><img
src="http://192.168.2.101:61220/statuswin.bmp" border=0></a><br>PC #1<br><br>
<img src="http://192.168.2.102:61220/statuswin.bmp"><br>PC #2<br><br>
<img src="http://192.168.2.103:61220/statuswin.bmp"><br>PC #3<br><br>
</body>
</html>
    Megjelenít 3 státusz ablakot és egyszerre frissíti őket 300 másodpercenként. A legfelső ablakra kattintás során annak a gépnek a teljes riportja tekinthető meg.
    Merevlemez állapot megjelenítése távolról egy böngésző segítségével (PDA-ról)
    A fenti kód elmentve a PDA-n egy HTML fájlba és megnyitva a böngészőben.

Szerver kapcsolat engedélyezése: A Hard Disk Sentinel Enterprise változata képes a távoli számítógépek állapotát felügyelni. A központi számítógépen az egyes merevlemezek állapota leolvasható, tesztelhető. Ha ez az opció engedélyezésre kerül, a program válaszol a szerver felől érkező parancsokra, információ-lekérdezésre.

DynDNS, No-IP, egyéb dinamikus DNS szolgáltatás használata: lehetőség van arra, hogy csatlakozásonként változó (dinamikus) IP címmel rendelkező számítógép is állandó, fix néven csatlakozzon az internethez. Így távoli lekérdezés (webstatus, szerver kapcsolat) is lehetséges, mivel a szerver a fix néven keresztül el tudja érni a számítógépet.

Ehhez szükséges, hogy egy fix nevet (ún. hoszt név) hozzunk létre valamely szolgáltatónál, majd beállítsuk a megfelelő adatokat (felhasználó, jelszó, hoszt név). Ezután a program ha érzékeli, hogy IP cím változás történt, 1 percen belül automatikusan frissíti a névhez tartozó IP címet, így a távoli elérés továbbra is lehetséges marad.

A "beállítás" gomb használatával megadhatóak az egyes szolgáltató(k)hoz tartozó adatok. A frissítés után az egeret a megfelelő sorra húzva gyorstippben megjelenik az utolsó szerver válasz, mely (hiba esetén) segít felderíteni a probléma okát (pl. nem megfelelő felhasználónév).


Beállítások: Teszt riport küldése

Ezen az oldalon lehetőség van nyers adatokat tartalmazó teszt riport készítésére. Ez a program működése szempontjából részletesebb információkat szolgáltat, mint a kész, formázott szöveges vagy HTML riport. Ezek az információk segíthetnek az esetleges problémák feltárásában, ezért várjuk az ilyen riportokat a reports@hdsentinel.hu címre.

A riport elkészítése után azonnal küldhető. A küldés ebben az esetben automatikusan feltöltésre kerül a www.hdsentinel.com szerverre. Ha a számítógép nem rendelkezik aktív internet kapcsolattal, úgy a Mentés gomb segítségével a riport fájlba menthető és később manuálisan küldhető (esetlegesen másik számítógépről).


Merevlemez Tesztek

Az alábbi oldalakon a szoftver által támogatott lemez-tesztekről található bővebb információ. Javasolt a tesztek használata előtt az alábbi oldalak (különösen az általános információk) tanulmányozása, melyek számos kérdésre választ adhatnak.

  • Általános információk, tesztekkel kapcsolatos válaszok

  • Hardver önteszt: rövid, részletes, szállítási önteszt

  • Véletlen elérési idő teszt

  • Felület teszt


Teszt - Általános Információk

Miért van az, hogy a merevlemez kondíciója alacsony, a Sentinel a szöveges értékelésben jelzi, hogy hibás szektorokat talált, a tesztek mégsem találnak hibát?

Ha a merevlemez hibás szektort talál, az adatokat megkísérli az előre kijelölt tartalék adatterületre átmenteni, majd ha az sikerült, az eredeti szektort hibásnak megjelöli és oda többet nem ír, onnan nem próbál meg olvasni, minden további művelet a tartalék területre kerül átirányításra (ez az átallokálás). Így a tesztek (melyek nem kizárólagosan a jelen szoftver által végzett teszteket jelentik) is az így módosított felületet érik el. Optimális esetben ilyenkor a felület már tökéletes, a hibás részek a további használatból ki vannak zárva. A problémát az okozza, ha a hibás terület relatíve nagy (ezzel a párhuzamosan a kondíció alacsony) és folyamatosan újabb hibák születnek, melyek áthelyezése (javítása) nem mindig zajlik tökéletesen, érdemes azt ellenőrzött körülmények között a tesztek segítségével megkísérelni. Bővebb információ a szöveges értékelés pont alatt olvasható.

Valamennyi teszt célja a merevlemez problémák felderítése. Mivel a kondíció a problémák alapján kerül meghatározásra, teszt során a kondíció csökkenhet. A kondíció problémák "eltűnése" (nem javítása!) során növekedne, mely általában nem lehetséges, kivéve ha gyenge szektorok felülvizsgálata alapján azok mennyisége csökken, esetleg nullázódik, ilyenkor a kondíció emelkedhet. Más hibák, melyeket a merevlemez felismert (és javított) számának csökkentése nem lehetséges és nem is cél, de az "eltolás" mező használatával ezek a problémák figyelmen kívül hagyhatóak a merevlemez további élettartama során, ha az állapot stabil. Erről bővebben a szöveges értékelés és a hőmérséklet kalibráció fejezetben található információ.

Miért talál a merevlemez teszt több/kevesebb hibás szektort, mint amennyi a szöveges értékelésben olvasható?

A szöveges értékelésben látható hibás szektorok azok, melyeket a merevlemez már átallokált, azaz már nincsenek használatban. A teszt által feltárt rossz szektorok viszont még aktív területen vannak, így ezek veszélyt jelentenek a tárolt adatokra. A cél, hogy a merevlemezt rákényszerítsük arra, hogy az ilyen szektorokat is allokálja át, hogy azok se jelentsenek további veszélyt. Ideális esetben (bár a merevlemez kondíciója csökken az átallokálás miatt) a lemez a továbbiakban jobban működik.

Javítható (növelhető-e) a merevlemez kondíciója? Visszaállítható-e 100 %-ra?

Ha a merevlemezen gyenge szektorok voltak, a teszt során ezek állapota javulhat, így a kondíció növekedhet és ha más jellegű probléma nem volt, akár 100 %-ra is visszaállhat. Ellenkező esetben a kondíció csökkenhet ha a merevlemez állapota nem stabil és újabb problémák kerülnek feltárásra.

Ha az alaposabb írástesztek többszöri lefutása után sem változik a kondíció, akkor a lemez állapota stabil, ilyen esetben a talált hibák a S.M.A.R.T. oldalon az eltolás oszlop segítségével figyelmen kívül hagyhatóak - ilyen értelemben visszaállítható a 100 %-os állapot.

Garanciális csere csak 0 % kondíció esetén lehetséges. Ennél magasabb (de viszonylag alacsony) kondíció esetén külünösen érdemes a tesztek akár egymás utáni többszöri futtatása, mivel így még további lappangó problémák is felszínre kerülhetnek.

Miért jó a merevlemez tesztek használata? Miért nem elég csak fájlok másolásával írást végezni (és így átallokálást kérni)?

A tesztek során a merevlemez nagyobb fokú ellenőrzés és felügyelet alatt áll, mint sima fájlműveletek közben. A fájlrendszer leválasztásra kerül, így más szoftver és főként az operációs rendszer nem "szól bele" a folyamatba, fájlrendszer állapota sem befolyásolja a tesztet. Az egyes blokkok átviteli idejét, ismétlések számát felügyeli a szoftver, csakúgy, mint a merevlemez hőmérsékletét, állapotát. Lehetséges továbbá a szektorok tartalmát a teszt alatt megvizsgálni. Hasonlóan, ahogy műtétet is ellenőrzött körülmények között hajtanak végre az orvosok, a merevlemez teszt (és javítás, átallokálás) is javasolt, hogy ellenőrzött körülmények között fusson.

Teszt-típusok

Alapvetően két típusú tesztről beszélhetünk: hardver önteszt, és szoftveres tesztelés. Utóbbi kategóriába esik a lemez felületét nem ellenőrző, csak a fej sávraállási képességét vizsgáló véletlen elérési idő teszt is.

A hardver tesztek jellemzője, hogy a szoftveres módszereknél alaposabban fér hozzá a merevlemezhez és alaposan megvizsgálja azok komponenseit (fej, mechanika, belső elektronika, stb.) a felületvizsgálat mellett. A tárolt adatokat nem veszélyezteti, így különösebb előkészület vagy adatmentés nélkül is bármikor indíthatóak az alkalmas IDE, S-ATA merevlemezeken. Időszakos használatuk javasolt, különösen tökéletes vagy közel tökéletes állapotú merevlemezeken az esetleges problémák feltárására.

Bizonyos esetekben azonban ezek a tesztek nem érhetőek el, nem támogatottak vagy viszonylag alacsony számú hiba esetén is hamar leállnak hibát jelezve. További probléma, hogy részletes információt nem kapunk az eredményről, azaz mely terület(ek) épsége került veszélybe. Ilyenkor megfelelő szoftveres teszt használata javasolt.

A szoftveres tesztelés során fontos tudni, hogy a felületet érintő ÍRÁS művelet az, mely a merevlemezt alaposan teszteli mivel rákényszeríti a lemezt az írás alatt álló szektor(ok) épségének ellenőrzésére, gyenge szektor esetén annak felülvizsgálatára, hibás, nehezen elérhető szektorok esetén az áthelyezésre, ún. átallokálásra. Emiatt olvasást végző tesztek (pl. scandisk, de akár a formázás is) nem alkalmasak a hibák javítására, némely esetben azok felismerésére sem. A Scandisk logikai hibákat (a fájlrendszer hibáit) ellenőrzi és javítja, melyek teljes újrapartícionálás és újraformázás után eltűnnek - az esetek nagy többségében az itt jelzett (vagy nem jelzett) hibák nincsenek kapcsolatban az eszköz fizikai állapotával, hibáival.

Jellegükből adódóan az ÍRÁStesztek általában destruktívak, azaz a tárolt adatok törlésre kerülnek. Minden esetben nagyon körültekintően járjunk el az ilyen tesztek alkalmazása előtt, fontos az adatok mentése!

A szoftveres teszteket javasolt ritkábban használni a hardveres tesztekhez képest, használatuk akkor fontos, ha

  • új merevlemez kerül a rendszerbe, mely még nem tárol adatokat
  • a hardver öntesztek nem futnak le, hibával zárulnak
  • a merevlemez gyanúsan viselkedik és/vagy kondíciója változik
  • a merevlemez vagy SSD/flash memóriás eszközön tárolt adatok felfrissítése a cél (törlés nélkül), melyet javasolt időszakosan elvégezni az adatok megőrzése céljából (ennek gyakorisága használat függvénye)

Ilyen esetben először javasolt az olvasási önteszt végrehajtása, mely nem veszélyezteti az adatokat és hibákat nem javít, de ellenőrizhető, hogy mely adatterület(ek) sérültek, nehezen és/vagy lassan kezelhetőek, valamint milyen hőmérsékleti és átviteli karakterisztikával rendelkezik a kérdéses merevlemez. A hibák feltárása, javítása ez után javasolt az alkalmas írásteszt segítségével. Komolyabb problémák esetén (adatmentés után) a felület újrainicializálása javasolt (akár 3-asnál magasabb szinttel is), mely művelet egyszerűbb változatát egyéb alkalmazások tévesen alacsony szintű formázásnak (low level format) is hívnak.

FONTOS: A tesztek alkalmazása során bekövetkezendő esetleges adatvesztésért a fejlesztő semmilyen felelősséget nem vállal! Minden esetben javasolt az adatmentés és a tesztek működésének tanulmányozása azok használata előtt.


Hardver Önteszt

Az IDE / Serial ATA / SCSI / SAS merevlemezek hardveres öntesztjei kitűnő módszerek arra, hogy a lemez állapota gyorsan vagy alaposan átvizsgálásra kerüljön. Általában rövid és részletes öntesztek támogatottak a merevlemezek által, de lehetőség van más típusú (szállítási) öntesztre is bizonyos típusok esetén. A lemezek által támogatott önteszteket listája és azok becsült futási ideje a lemezhez tartozó Információk oldalon leolvasható.

Az említett tesztek használata az adatok épségét, biztonságát nem veszélyezteti. A teszt közben a merevlemez továbbra is használható de lassabb lesz (és viszont: a lemez használat jelentősen kitolhatja a teszt futását, akár a becsült időtartam többszörösére is. Ez különösen rendszermeghajtónál jelentős, ahol az op. rendszer ill. egyéb szoftverek által sűrű írás/olvasás zajlik).

A Rövid ön-teszt általánosságban teszteli a merevlemez komponenseit (író/olvasó fejek, szervó, elektronika, stb.). Ez néhány percet vehet igénybe.

A Részletes ön-teszt a fentieken túl teljes felületellenőrzést tartalmaz, melynek során az esetleges problémás területek mélyreható vizsgálata megtörténik, és a talált hibás szektorok a használatból kikerülnek. Időszakosan ajánlott ezt a tesztet elvégezni (különösen ha nem tökéletes kondíciójú merevlemezről van szó).

A Szállítás ön-teszt (amennyiben támogatott) a gyártó által meghatározott tesztlépéseket hajtja végre. Ez általában a mozgó alkatrészek alaposabb vizsgálatát jelenti, segítségével kideríthető, ha szállítás közben valamely részegység sérült.

Az Információk oldalon leolvasható, hogy a legutolsó tesztek mikor kerültek indításra, milyen eredménnyel zárultak (sikeres lefutás illetve valamely részegység miatti hiba) és mennyi ideig futottak. Innen a tesztek azonnal indíthatóak manuálisan de beállítható, hogy időzítve, automatikusan kerüljenek lefutásra akár valamennyi telepített merevlemezen (Professzionális változat, Műveletek oldal).


Véletlen Elérési Idő Teszt

Ezzel a teszttel megvizsgálható a merevlemez zajszintje, elérési ideje és hőmérsékletének változása, különösen hosszantartó és komoly megterhelés mellett.

A teszt különösen alkalmas az akuszikai szint módosítása után a megváltozott zajszint és sávraállási idő (melyeket befolyásol a merevlemez akusztikai beállítása) ellenőrzésére. Ilyen esetben egy rövidebb időtartamú teszt is elegendő.

A teszt segítségével megvizsgálható, hogy a merevlemez hogyan reagál hosszabb ideig tartó nagyobb terhelésre, változik-e annak teljesítménye illetve milyen mértékben emelkedik meg az üzemi hőmérséklet. Ez a nyugalmi állapothoz képest akár 10-15 Celsius fokot is jelenthet, így ha a merevlemez a teszt indítása előtt is már magas hőmérsékleten üzemel, érdemes a tesztet felügyelet mellett indítani és kritikus hőmérséklet elérésekor azt leállítani.

A teszt javasolt végrehajtása: új merevlemez beüzemelésekor, extrém terhelés és hőmérséklet szint tűrésének tesztjére. Ilyenkor 8 órás vagy még hosszabb időtartamú tesztelés is elképzelhető.

A teszt akkor is használható, ha a hardver önteszt hibával leáll illetve nem támogatott a merevlemez által. A teszt nem veszélyes a tárolt adatokra, csak az író-olvasó fej véletlen helyre pozícionálása történik meg a kiválasztott időtartamú teszt alatt.

Megjegyzés: a nem regisztrált változatban csak a legrövidebb (2 perces) teszt használható és az is csak egyetlen alkalommal, egy meghajtón.


Felület Teszt

Ezzel a teszttel a merevlemez felülete vizsgálható meg több különböző módszerrel, melyek egy része nincs hatással a tárolt adatokra, míg más tesztek destruktív jellegűek, azaz a tárolt adatok törlésre kerülnek.

Első lépésben a lemez és a végrehajtani kívánt teszt kiválasztása történik meg. Az egyes tesztek részletes leírása, adatokra gyakorolt hatása áttekinthető, ezek tanulmányozása erősen ajánlott a teszt indítása előtt.

Az alábbi tesztek lehetségesek:

  • Olvasás teszt - A lemez felületét végigolvasva megvizsgálja, hogy az egyes szektorok elérhetőek és olvashatóak-e. A teszt biztonságos, nincs hatással a tárolt adatokra. A lemezzel kapcsolatos problémák rejtve maradhatnak és az esetleges problémák NEM feltétlen kerülnek javításra (hasonlóan a ScanDisk-hez).

  • ÍRÁS teszt - A lemez felületét választható mintázattal tölti fel, felülírva a tárolt adatokat. Az esetleges gyenge szektorokat és rejtett problémákat felülvizsgálja és a hibás szektorokat áthelyezi a tartalék területre (ez a művelet a regeneráció).

    A teszt után a tároló eszköz jobban használható, mivel a továbbiakban hibás területek szerepét a tartalék szektorok veszik át.

  • ÍRÁS + olvasás teszt - A lemez felületét választható mintázattal tölti fel, felülírva a tárolt adatokat, majd a szektorokat visszaolvasva ellenőrzi azok olvashatóságát és épségét. Az esetleges gyenge szektorokat és rejtett problémákat felülvizsgálja és a hibás szektorokat áthelyezi a tartalék területre (ez a művelet a regeneráció).

    A teszt után a tároló eszköz jobban használható, mivel a továbbiakban hibás területek szerepét a tartalék szektorok veszik át.

  • Olvasás + ÍRÁS + olvasás teszt (adatterület felfrissítése) - Az adatok beolvasását követően az egyes blokkok visszaírásra kerülnek, majd az így tárolt szektorokat ismételten beolvassa és összehasonlítja az eredeti tartalommal. Az alapos olvasás-írás-olvasás teszt egy plusz írási ciklust iktat be az adatok visszaírása előtt, így fokozva a felület ellenőrzését és a hibajavítás hatékonyságát (regenerálást).

    A művelet általában biztonságos a tárolt adatokra nézve de adatvesztés léphet fel, ha a rendszer instabil, áramszünet, túlhajtás, memória-, tápellátás- vagy kábelhiba esetén illetve egyéb esetekben.

    A teszt az adatterület felfrissítésére és regenerálásra alkalmazható, teljes törlés nélkül, de az adatok mentése javasolt a teszt indítása előtt.

  • Lemez felületének újrainicializálása - A lemez felületét meghatározott inicializáló mintázattal tölti fel, majd törlést hajt végre. A teszt így felülírja a tárolt adatokat, majd a szektorokat visszaolvasva ellenőrzi azok olvashatóságát és épségét. Az esetleges gyenge szektorokat és rejtett problémákat felülvizsgálja és a hibás szektorokat áthelyezi a tartalék területre (ez a művelet a regeneráció).

    A teszt után a tároló eszköz jobban használható, mivel a továbbiakban hibás területek szerepét a tartalék szektorok veszik át.
    Hosszadalmas és időigényes művelet, főként ha az újrainicializálás szintje (a felülírások száma) magas.
    A teszt egyszerűbb változata más alkalmazásokban (tévesen) alacsony szintű formázás (low level format) néven is szerepelhet. Jellegéből adódóan kíválóan alkalmas adatmegsemmisítésre is: a legalább 3-as szintű inicializálás meggátol mindennemű adatvisszanyerést (Navso P-5239-26 standard adatmegsemmisítés).

    Az egyes tesztekhez kapcsolódóan számos beállítási lehetőség használható:

    Általánosságban beállítható, hogy milyen sorrendben történjen a blokkok bejárása, illetve ismételje-e a tesztet a szoftver egymás után több alkalommal, valamint, hogy a merevlemezhez tartozó kötetek (logikai meghajtók) leválasztásra kerüljenek-e a teszt időtartama alatt. Utóbbi erősen ajánlott, mivel így biztosítható, hogy a szoftver kizárólagosan használja a merevlemezt, így pontosabb és alaposabb tesztelést végezve. Rendszermeghajtó (mely tartalmazza magát az operációs rendszert, a felhasználó gyökér (root) mappáját, virtuális memória fájlt) nem zárolható ilyen módon. Rendszermeghajtón csak az adatokat nem befolyásoló olvasás teszt hajtható végre, a rendszert tartalmazó merevlemezen írásteszt végrehajtására nincs lehetőség.

    Megjegyzés: bizonyos tesztek és beállítások csak a PROFESSZIONÁLIS változat használata esetén érhetőek el.

    Megjegyzés: ha jelszó beállításra került, a program a tesztek használata előtt azt minden esetben kéri, az illetéktelen tesztindítást (különösen a destruktív tesztek kapcsán) megakadályozandó.

    Teszt Információk

    A szoftver az adatterületet 10000 blokkra osztva mutatja, ez a felületi térkép. Az egyes blokkokra kattintva a blokkokat alkotó szektorok tartalma megjeleníthető, így ellenőrizhető a tárolt adat illetve felülírás után a szektor tartalma. Lehetséges teszt indítása nélkül is megvizsgálni a tárolt adatokat illetve egy korábbi teszt eredményét ismételten előhívni (ha mentésre került) a Nézet gomb lenyomása után. Ez a művelet biztonságos a tárolt adatokra nézve.

    Az egyes tesztek során a szoftver ellenőrzi a blokkokat alkotó szektorok épségét. Ha a blokkok hiba nélkül elérhetőek, zöld színnel jelöli meg azokat, melyek egyre sötétedő árnyalata jelzi, hogy a szektorok egyre lassabban kezelhetőek (természetesen a szoftver kiszűri a merevlemezek végén tapasztalható teljesítménycsökkenésből adódó lassulást). Sárga színnel jelzi a sérült de javított blokkokat, melyeket csak többszöri próbálkozás során sikerült elérni és kezelni. Vörös színnel jelzi a hibás blokkokat, melyek többszöri próbálkozásra sem olvashatóak vagy írhatóak (a kiválasztott teszttől függően). Ezeken a hibás blokkokon további ÍRÁS teszt szükséges, mely rákényszeríti a merevlemezt a szektor(ok) átallokálására.

    Sérült vagy hibás blokkok esetében mindenképpen szükséges a felület teljes felülvizsgálata valamely ÍRÁSteszt segítségével. Ilyenkor a szoftver rákényszeríti a merevlemezt, hogy a szektorokat ellenőrizze, azok tartalmát a tartalék területre helyezze át és a későbbiekben a tartalék szektorokat írja/olvassa az eredeti hibás terület helyett. Ezt a folyamatot regenerálásnak is hívják. Az eredményül kapott merevlemez jobban használható, akár későbbi teszteken teljesen "zöld" állapotú is lehet (mivel a hibás terület már nincs használatban), viszont a lemez kondíciója ilyen esetben csökken, mivel újabb hibák kerültek feltárásra. Tehát a regenerálási folyamat általában nem javítja a kondíciót, kivéve, ha gyenge szektorok kerülnek felülvizsgálatra és azok állapota stabilizálódik.

    A teszt során hibás blokkok elérésekor elképzelhető, hogy a szoftver és/vagy a rendszer nem válaszol, míg az áthelyezési folyamat tart. Ez a hibás terület nagyságától függően percekig de akár órákig is eltarthat. Ilyen esetben nem javasolt a megszakítás, reset és lekapcsolás különösen kerülendő. Ilyenkor az is lehetséges, hogy a lemez vezérlője illetve annak meghajtóprogramja leválasztja a nem válaszoló merevlemezt, így az eltűnik a rendszerből. Ez különösen USB-s átalakító/keretek használata esetén lehetséges, ilyenkor javasolt a merevlemezt közvetlenül alaplapi csatlakozóra kötve tesztelni újra.

    A tesztek javasolt végrehajtása: új merevlemez beüzemelésekor alapos írásteszttel (újrainicializálással) meggyőződni a felület épségéről. A véletlen elérési teszt-hez hasonlóan a program méri a teszt alatt a hőmérsékletet, így extrém terhelés előidézésére és a válasz (hőmérséklet és átviteli sebesség) ellenőrzésére is alkalmas. A tesztek végrehajtása javasolt nem csak merevlemezeken, de SSD-k, flash memóriakártyák, pendrive-ok állapotának tesztelésére, adatterületük felfrissítésére időszakosan, megelőzendő az adatok "elszivárgását" a flash memóriacellákból.

    A tesztek akkor is használhatóak, ha a hardver önteszt hibával leáll illetve nem támogatott a merevlemez által.

    Megjegyzés: a nem regisztrált változat esetén a szektorok tartalma kiolvasható és megtekinthető, de tesztek indítására nincs mód.

    Megjegyzés: a teszt folyamán az egyes blokkok átviteli sebességét (és így a sebesség függvényében látható árnyalatot) a háttérben futó alkalmazások és/vagy az operációs rendszer által végzett lemez- és CPU műveletek befolyásolhatják. Emiatt a szoftver a teszt időtartamára megakadályozza a képernyővédő és az esetleges energiatakarékossági üzemmód használatát, valamint emelt szintű prioritással dolgozik. Javasolt a teszt alatt más szoftver(ek) használatát mellőzni, ha a sebességcsökkenés nagyobb mértékű (sötétzöld) illetve nagyobb területet érint (azaz nem csak 1-1 blokkon jelentkezik), akkor érdemes a tesztet megismételni. A teszt ismétlése kérhető a programban, így a blokkok sebességének átlaga alapján jelenik meg a szín, kiküszöbölve a pillanatnyi sebességcsökkenést.

    Példák

    A merevlemez hasznos adatterületének vége hibás. A hibás területek összefüggő területet alkotnak, komolyabb felületi sérülést feltételezve. Jól látható, hogy a hibás blokkok melletti blokkok is elromomolhatnak, különösen a bal alsó sarokban látható sérült (sárga) blokk utal erre, mely valószínűleg hamarosan rosszabb állapotba kerül. Látható továbbá, hogy amely szektorok nem jeleznek hibát, azok is meglehetősen lassan kezelhetőek. Ilyen esetben célszerű az egérmutatóval az első hibás terület pontos helyét megnézni és egy olyan módon partícionálni a meghajtót, hogy az ez utáni terület már ne legyen használva.

    A merevlemez számos hibát produkált, írás- és olvasás műveletek közben megakadt, kondíciója alacsony szintű (30 %). Látható, hogy mely területek érintettek: olvashatatlan (hibás), sérült és lassan kezelhető szektorok váltakoznak.

    Ugyanaz a merevlemez többszöri felület-újrainicializálás során. A gyenge szektorok felülvizsgálatra kerültek, a hibás területeket a merevlemez átallokálta, így azok már nincsenek használatban (ezzel párhuzamosan a kondíció csökkent 20%-ra), viszont a lemez felülete meglehetősen sokat javult, az állapot stabilizálódott, a merevlemez még egy ideig használható (de az alacsony kondíció miatt azért kritikus adatok tárolása nem javasolt).

    Szintén egy tipikus alacsony kondíciójú (22 %) merevlemez felületi térképe. Többszöri teljes felülírás (újrainicializálás) segíthet a lemez állapotán, de a merevlemez első felének használata nem javasolt (megfelelő partícionálással érdemes kihagyni ezt a részt).


Mellékletek

A S.M.A.R.T. technológiával valamint a Hard Disk Sentinel alkalmazással kapcsolatos általános információk.

  • Gyártó specifikus vs. nyers értékek

  • Kondíció számítás

  • Teljesítmény számítás

  • Működési idő

  • Hőmérséklet kalibráció

  • Ismert S.M.A.R.T. attribútumok


Gyártó specifikus vs. nyers értékek

Mint a merevlemez S.M.A.R.T. adatlapján látható, a merevlemezek egyes paramétereinek értékelése történhet a gyártó által javasolt módszer (az érték és a küszöb mező analízise) vagy gyártó függetlenül az egyes problémák mennyiségének vizsgálata (az adat mező analízise) alapján. Hogyan is történik ez, mi a különbség az egyes értékelési módszerek között?

Gyártó specifikus értékek

A merevlemezen belül a pillanatnyi állapotot több szenzor, értékelő algoritmus folyamatosan méri. A mérések nyers eredménye ill. a problémák összes mennyisége a megfelelő S.M.A.R.T. attribútum "adat" mezőjében kerül rögzítésre. Az egyes gyártók által meghatározott, típusonként eltérő módszer alapján ez az adat valamilyen formában feldolgozásra kerül.

A feldolgozás után létrejön a gyártó specifikus érték mezőben található eredmény, ami elméletileg a merevlemeznél a kérdéses attribútum relatív "jóságát" határozza meg a küszöb mezőhöz képest. A merevlemez első használatakor az érték mező egy elméleti maximum értéken áll, melyről a használat során folyamatosan alacsonyabb szintre kerül - míg a küszöb által meghatározott alacsony szintet el nem éri.

Tehát az egyes attribútumok hibátlansága akkor teljesül, ha az alábbi egyenlőtlenség IGAZ:

A - f(ny) >= C

Ahol:

  • A - elméleti maximális érték, az attribútum "legjobb" értéke.

  • f - egy leképező függvény, mely a nyers értékek alapján kiszámított eredménnyel csökkenti a kezdeti értéket. Általában lineáris függvény, azaz ny értéke egyszerűen szorzásra kerül egy B értékkel.

  • C - a meghatározott küszöb értéke, mely alatt az attribútum értéke hibásnak minősül

A módszer problémáit az jelenti, hogy nincsenek az A, B, C értékek, (ill. f függvény) egyértelműen meghatározva, valamint az, hogy az egyes paraméterek egymástól függetlenül kerülnek kiértékelésre.

A gyakorlati életben több ízben találkozhatunk irreális értékekkel, melyek a merevlemez állapotáról nem adnak valós képet. Például bizonyos gyártók a merevlemez teljes élettartamára mintegy 60-70 évet jelölnek meg, ha a megfelelő attribútum értékét kiolvassuk, de példának említhető az is, hogy bizonyos esetekben akár több ezer hibás szektor is kellhet ahhoz, hogy a merevlemez magát (a fenti módszerrel) problémásnak mutassa. Természetesen a való életben a problémák már jóval korábban jelentkeznek. Nem beszélve arról, hogy egy-egy újabb problémás terület analizálása és onnan az adatok mentése a meghajtó számára akár órákig is tarthat (ha egyáltalán tökéletesen sikerül). Ilyen esetben a rendszer általában megáll, tehát egy folyamatosan romló, újabb és újabb hibákat produkáló merevlemez a teljes rendszer stabilitását is veszélyeztetheti.

A merevlemez ellenőrző programok túlnyomó többsége a fenti gyártó specifikus módszert használja a merevlemez állapotának kijelzésére. Ilyen esetekben a legtöbb meghajtó jelentősen előnyösebbnek tűnik a valós állapotnál. Bizonyos gyártók az értékek állításával jobbnak próbálják beállítani a meghajtót mint amilyen valójában - és ez sajnos több programot, felhasználót megtéveszt.

Fontos tudni, hogy amikor a fenti módszerrel valamely kritikus S.M.A.R.T. paraméter értéke hibásra válik, a merevlemeznek még 24 óráig kell működnie (az adatmentés idejére). Ez azonban az esetek nagy többségében kevés és esetleg nem sikerül az adatokat (vagy egy részüket) tökéletesen menteni. Egy alig működő, gyakorlatilag halott merevlemezről nagyon hosszadalmas, nehézkes és drága lehet az adatok mentése. Éppen ezért fontosabb a problémát időben felismerni és felkészülni rá.

Nyers értékek analízise

Pontosan ezért került kifejlesztésre a Hard Disk Sentinel alkalmazás. A programban található értékelő módszerek a nyers értékekre építenek. Így a gyártó által megadott értékektől függetlenül, objektívan értékeli az egyes merevlemezek állapotát. Megjegyzés: lehetőség van a gyártó specifikus értékek használatára is a kondíció számításnál. Ennek tartós használata azonban nem ajánlott, mivel (a fenti problémák miatt) a gyártó specifikus értékek analízise az esetek nagy többségében sajnos pontatlan.

Az eljárás hátránya, hogy nincs előre meghatározott (gyártó-specifikus) küszöbérték, amit elérve a merevlemez magát hibásnak mutatná. Viszont szaporodó problémák esetén a kondíció értéke folyamatosan és rohamosan csökken, ami még időben jelezheti a közelgő katasztrófát.

A számítási módszerek részletes leírása itt található.


Kondíció számítás

Ahogy a Beállítások ablakban a fejlett opcióknál látható, a merevlemezek kondíciója több különböző módszerrel kerülhet kiszámításra. Lássuk ezeket részletesen!

Adat mező analízise

Ebben az esetben a kritikus merevlemez attribútumuk nyers Adat mezője kerül kiértékelésre. A jelenleg használt kiértékelési és számítási módszer kidolgozásánál fontos szempontok voltak:

  • Ne legyen szükséges hosszú analizálás és tesztelés a meghatározáshoz, ne függjön időben az elmúlt időszaktól, a pillanatnyi állapotot tükrözze.

  • Időben ne emelkedjen, a merevlemez állapota idővel ne mutassa magát jobbnak (kivétel ha a függőben lévő szektorokról kiderül, hogy nincs probléma azok használatával).

  • Lehetőség szerint kis változások is érzékelhetőek legyenek, problémák esetén csökkenés folyamatos legyen.

  • Vegye figyelembe az attribútumok közötti kapcsolatot, több együttes probléma jelentősebben csökkentse, mint ha "csak" egy probléma lenne.

  • Két, azonos problémával rendelkező, de különböző gyártójú, típusú merevlemez esetén a kondíció azonos értéket vegyen fel.

  • Értéke bizonyos körülmények között befolyásolható legyen (pl. hibás táp cseréje után megoldható legyen a korábbi problémák figyelmen kívül hagyása az értékelésnél, ill. nem megfelelően működő szenzor tiltható legyen vagy értéke módosítható legyen. Erről a hőmérséklet kalibráció részben olvashat).

Alaphelyzetben a merevlemez állapota 100%-os kondícióról indul. Ezt az alábbi kondíciót befolyásoló S.M.A.R.T. attribútumok (amennyiben ezek léteznek az adott merevlemezen) csökkentik, különböző mértékben. Minden attribútumhoz tartozik egy súly és egy maximális limit, amennyivel a kondíciót befolyásolhatja. Az egyes maradék százalékokat (100-a csökkenés százalékban) összeszorozva megkapható a lemez kondíció értéke.

Jelenleg a programban ennek a módszernek két különböző típusa létezik. Az alapértelmezett módszer esetén az értékelési súlyok, limitek (ld. alant) valamivel enyhébbek. A szigorúbb analízis (szerver esetén ajánlott) használatával ezek az értékek szigorúbban kerültek meghatározásra, azaz ugyanolyan mértékű probléma szigorúbban kerül elbírálásra (nagyobb mértékben csökkenti a merevlemez kondícióját).

Az alábbi táblázatban láthatóak az egyes élettartamot befolyásoló S.M.A.R.T. attribútumok, melyek a számításban részt vesznek, valamint azok súlya és a maximális csökkentés mértéke:

Az alapértelmezett számítási módszer esetén használatos súlyok és limitek:

S.M.A.R.T. attribútum | Súly | Limit %
Áthelyezett szektorok száma | 1 | 70
Fejpozícionálási hibák száma | 0.5 | 20
Felpörgési újrapróbálkozások száma | 3 | 60
Áthelyezési kísérletek száma | 0.6 | 30
Függőben lévő szektorok száma | 0.6 | 48
Javíthatatlan szektorok száma | 1 | 70

Az szigorúbb számítási módszer esetén használatos súlyok és limitek:

S.M.A.R.T. attribútum | Súly | Limit %
Áthelyezett szektorok száma | 6 | 60
Fejpozícionálási hibák száma | 2 | 20
Felpörgési újrapróbálkozások száma | 6 | 40
Áthelyezési kísérletek száma | 4 | 30
Függőben lévő szektorok száma | 4 | 30
Javíthatatlan szektorok száma | 6 | 60

A táblázatban szereplő értékek a beérkező riportok valamint az adatmentésre jelentkező (gyakorlatilag működésképtelen) merevlemezek S.M.A.R.T. paramétertáblája alapján került meghatározásra.

Megjegyzés: mivel az Adat oszlopban található szám 16-os számrendszerben kerülnek kijelzésre, először decimálissá kell alakítani. A számításnál az alsó 16 bit, azaz a jobb oldali 4 számjegy kerül felhasználásra.

Például: alapértelmezett számítási módszer esetén ha a "Reallocated sectors count" sorában az Adat oszlopban 0002 található, a lemez kondíciója = 100 x ( 100 - 2x1 ) % = 98 %

Ha a "Current pending sectors count" sorában az Adat oszlopban 0005 ugyanezen a meghajtón, akkor a kondíció = 98 x ( 100 - 5x0.6) % = 95 %. Szigorú számítási módszer esetén ugyanez 100 x (100 - 2x6) % x (100 - 5x4) % = 70 % lenne.

A Limit % megadja, hogy az adott attribútum maximálisan hány százalékot tud a kondíción csökkenteni. Például ha a lemezen az "Off line uncorrectable sectors" sorában az Adat 0200 (ami decimálisan 512), akkor a kondíciónak le kellene esnie 512 x 1 = 512 %-kal, de a maximális csökkenés ehhez az attribútumhoz csak 70 %. Más szóval ha az "Off line uncorrectable sectors" attribútum értéke magas, a merevlemez kondíciója nem lehet 30 %-osnál nagyobb, de más probléma még tovább csökkentheti a kondíció értékét.

Gyártó specifikus értékek analízise

Ebben az esetben a kondícióért felelős S.M.A.R.T. attribútumok kerülnek kiértékelésre. Minden egyes ilyen attribútum külön-külön értékelésre kerül 0 és 100% között az érték, a küszöb és az elméleti kezdőérték (melyet a program a gyártó és típus alapján határoz meg) alapján.

Az így kapott értékek összeszorzásával kapjuk meg a merevlemez kondíciójának értékét.

Például: a "Reallocated sectors count" attribútumnál a küszöb 36, az érték 84, a kezdőérték 100 volt. Ebben az esetben az attribútum értékelése: (1 - (100-84)/(100-36)) x 100 = 75 %. Amennyiben ugyanezen meghajtón a "Seek error rate" attribútumnál a küszöb 30, az érték 60, a kezdőérték 90, akkor ennek az attribútumnak az értékelése 50 %, a merevlemez kondíciója pedig összességében 37.5 %.

Megjegyzés: az 1.40 és korábbi változatokban csak az "Adat mező szigorú analízise" volt implementálva. Emiatt régebbi változatról áttérés esetén a kondíció érték kijelzése változhat, mivel alaphelyzetben az enyhébb módszer kerül kiválasztásra. A fejlett opcióknál bármikor módosítható a kívánt számítási módszer.

Megjegyzés: a kondíció számítási módszer a riportokba bekerül, az esetleges félreértéseket elkerülendő.

Megjegyzés: általában a kondíció értékek a következő formulát követik:

Gyártó-specifikus >= Alapértelmezett >= Szigorú módszer

azaz a szigorú módszer esetén a legkisebb a kondíció érték, ez reagál legnagyobb mértékben az egyes problémákra. Éppen ezért használata igazán kritikus helyzetekben indokolt, ahol gyakorlatilag nem engedhető meg semmilyen apró probléma sem.


Teljesítmény számítás

Az egyes merevlemezekhez tartozó teljesítmény érték kiszámítása (hasonlóan a kondíció számításhoz is többféleképpen történhet. A teljesítmény számítási módszert is meghatározza a fejlett opcióknál található kondíció számítás módszerének kiválasztása.

Adat mező analízise

Ebben az esetben a program figyelembe veszi a teljesítményért felelős S.M.A.R.T. attribútumok nyers értékét (pl. sávraállás ideje), mely maximálisan 25%-ban meghatározója a végső értéknek. További 25%-ban meghatározza a teljesítmény értékét az, hogy az elmúlt egy hónap során hány db adatátviteli hiba (ultra-ATA CRC error) került regisztrálásra a merevlemez naplójába. Mivel az a probléma nem kifejezetten a merevlemez hibájára utal, de a rendszer stabilitását és teljesítményét károsan befolyásolhatja, ezért van a teljesítmény értékre hatással.

50%-os mértékben pedig a merevlemez aktív adatátviteli módja határozza meg a teljesítményt, a maximális adatátviteli módhoz képest. Ha a merevlemez programozott input/output módban működik, akkor ebből az 50%-ból 0% lesz.

Például: ha egy merevlemezes meghajtó 33 MB/s-os átvitellel (Ultra DMA mód 2) működik a 100 MB/s-os (Ultra DMA mód 5) elméleti maximuma helyett, de a teljesítményért felelős értékek rendben vannak és nem volt adatátviteli hiba az elmúlt hónapban, akkor a teljesítmény érték 25 + 25 + (2/5) x 50 = 70 % lesz. Ez esetben a problémát valószínűleg egy régi 40 eres IDE kábel használata okozza.

Gyártó specifikus értékek analízise

Ebben az esetben kizárólag a teljesítményért felelős S.M.A.R.T. attribútumok kerülnek kiértékelésre. Minden egyes ilyen attribútum külön-külön értékelésre kerül 0 és 100% között az érték, a küszöb és az elméleti kezdőérték (melyet a program a gyártó és típus alapján határoz meg) alapján.

Az így kapott értékek összeszorzásával kapjuk meg a merevlemez teljesítményének értékét.


Működési idő

A merevlemez működési idejének mérését az IDE és S-ATA merevlemezek túlnyomó többsége támogatja, értékét a #9-es számú Bekapcsolva töltött idő (power on time count) S.M.A.R.T. attribútum tárolja. Ennél az attribútumnál az "Adat" mező tartalma folyamatosan, meghatározott időközönként (típusonként változóan) növekszik.

Amely gyártók, típusok esetén az időegység kérdéses lehet, ennek meghatározásához a Hard Disk Sentinel figyeli az egyes merevlemezeket és méri, hogy mennyi idő telik el az érték két egymást követő növekedése között. Ez alapján képes meghatározni a pontos működési időt. Ilyenkor egy becsült érték (szürke színnel) jelenik meg, míg a mérés tart ez (ez általában maximum 20 perc alatt lezajlik). Ha a program bezárásra kerül a mérés befejezése előtt, a következő indításnál automatikusan újrakezdi a mérést mindaddig, míg nem sikerül meghatároznia a telepített merevlemezekhez tartozó mérési időegységet. Sikeres mérést követően az egység mentésre kerül, a későbbiekben indítás után már automatikusan a megfelelő egység kerül kiválasztásra. A mérés nincs hatással sem a merevlemez, sem a számítógép teljesítményére.

A mérést követően (vagy ha az szükségtelen) a pontos működési idő feketével kerül kijelzésre és eltűnik a "becsült érték" felirat. Ha a jelzett érték pontosságával kapcsolatban aggályok merülnek fel, az "Újratesztelés" gomb segítségével a mérés megismételhető.

A mérés befejezése után javasolt teszt riport küldése. A beérkezett időegységek a programba beépítésre kerülnek, így egy későbbi változatban már jóval kevesebb típusnál lehet szükséges a fenti mérési folyamat, azaz a pontos működési idő az első indítástól kezdve leolvasható.

A működési idő mellett megjelenő érték megmutatja, hogy a merevlemez összesen mennyi időt töltött bekapcsolva, működés közben. Ebbe beleszámít az üresjárati idő is, mikor a lemez nem végez semmilyen műveletet, de nem számít bele a készenléti módban eltöltött idő. A kijelzett "nap" 24 órás működési időt feltételezve jelenik meg. Tehát egy 2 éves merevlemez ami napi 12 órát ment (minden nap) és egy egyéves merevlemez, ami minden nap éjjel-nappal dolgozott, ugyanannyi működési időt fog mutatni (hasonlóan egy 3 éves merevlemezhez, ami napi 8 órában üzemelt csak).

Megjegyzés: bizonyos típusok esetén a működési idő kijelzés pontatlan lehet.

Becsült hátralévő élettartam

Adat mező analízise

Amennyiben a fejlett opcióknál található kondíció számítás módszerénél az "Adat mező analízise" került kiválasztásra, úgy a program az alábbi módon határozza meg a hátralévő időtartamot:

  • Alaphelyzetben a merevlemez várható élettartamának 5 évet feltételez (5 éven keresztüli teljes terheléssel való működést, más szóval 1825 napot, mely alatt a merevlemez folyamatosan dolgozik éjjel-nappal).

  • Ebből kivonja a már lefutott működési időt.

  • A kapott értéket csökkenti a túl magas hőmérsékleti napok arányában. Mikor csak rövid időre volt magas a hőmérséklet, az nem számít kritikusnak, de ha adott napokon keresztül az átlaghőmérséklet folyamatosan magas volt, akkor nagyobb mértékben csökken a hátralévő napok száma.

  • A kapott értéket pedig megszorozza a merevlemez kondíciójának négyzetével.

Megjegyzés: A program maximálisan 1000 napot ír hátralévő élettartamnak. Természetesen ideális esetben (ha nem történik probléma) akkor ez a kijelzés nem változik még több száz nap elteltével sem.

Példa: ha a merevlemez összesen 600 napot (600x24 órát) töltött működés közben, megfelelő hűtéssel (azaz nem voltak túl forró napok), de közben a kondíciója lecsökkent 70%-osra, úgy a becsült hátralévő élettartam már csak 1225 x 0.7 x 0.7 = 600 nap és 6 óra.

Alacsony kondíció esetén a kondíció érték döntően befolyásolja a merevlemez hátralévő élettartamát. Emiatt elképzelhető, hogy egy alacsonyabb hátralévő élettartam kijelzés több napig is állandó marad, még ha a működési idő közben növekszik is. Például egy 25%-os kondíciójú merevlemez esetén 16 teljes napi működési időre van szükség, hogy a becsült hátralévő élettartam egy nappal csökkenjen (mivel 16 x 0.25 x 0.25 = 1).

Megjegyzés: mivel a hátralévő élettartam kijelzés több más paramétertől (hőmérséklet, kondíció) is függ, érdemes elvégezni a hőmérséklet kalibrációt és a helyzetnek leginkább megfelelően kiválasztani a kondíció számítási módszert, esetleg eltolási értékeket alkalmazni, amennyiben a merevlemez pontos előélete ismert és a helyzet indokolja. Ezen lehetőségek kizárólag haladó felhasználók számára ajánlottak, mivel nem megfelelő beállítás esetén a merevlemez állapota nem a valóságnak megfelelően kerül kijelzésre!

Gyártó specifikus értékek analízise

Ha "Gyártó specifikus értékek analízise" került kiválasztásra, az itt kijelzésre kerülő élettartamot az a kritikus S.M.A.R.T. attribútum határozza meg, mely a legkorábban éri el a gyártó által meghatározott küszöbszintet. Ezek a küszöb elérési időpontok a merevlemez S.M.A.R.T. paramétereinél a grafikonon leolvashatóak (ha a grafikon mellett az "Érték mező kijelzése" opció kerül kiválasztásra).

Megjegyzés: ez a módszer csak akkor lehet igazán hatásos, ha a merevlemezeket folyamatosan és nagyon hosszú időn keresztül (akár hónapok) megfigyeli és ellenőrzi a program. Ellenkező esetben nagyon kis érték változásból nagyon hibás becslés készül (pl. küszöb várható elérése 2100. januárjában, melyek más merevlemez figyelő alkalmazásban gond nélkül kijelzésre kerülnek). Éppen ezért a program maximálisan 1000 napot ír hátralévő élettartamnak. Természetesen ideális esetben (ha nem történik probléma) akkor ez a kijelzés nem változik még több 100 nap elteltével sem.


Hőmérséklet kalibráció

A merevlemezben található hőmérséklet érzékelő tévedhet és nem feltétlen a valós hőmérséklet kerül kijelzésre. Ez különösen érvényes bizonyos típusokra, nem ritka, hogy 7-9 Celsius fokkal is kevesebbet mutat a lemez a tényleges hőmérsékletnél. Más típusú meghajtók között pedig van egy széria ami jóval magasabb hőmérsékletet jelez a valósnál (akár 15-20 Celsius fok is lehet az eltérés).

Éppen ezért lehetséges és ajánlott egy külső eszköz (pl. infrás hőmérő vagy speciális, hőmérővel ellátott előlapi panel) használatával megmérni a lemez valós hőmérsékletét, majd a mérési eredmény és a program által jelzett hőmérséklet különbségét beállítani (ez a folyamat a kalibráció).

A mérés után kiszámítható a külső hőmérőn látható érték és a programban jelzett hőmérsékleti érték különbsége. Ez a különbség a hőmérséklet eltolás értéke. Lehet pozitív (ha a Hard Disk Sentinel a valós hőmérsékletnél kevesebbet mutat) vagy negatív (ha a szoftver által kijelzett hőmérséklet magasabb a valóságosnál).

Az eltolás (offszet) érték beállítható a merevelemez S.M.A.R.T. oldalán ha a 194-es hőmérséklet attribútumot választjuk és az eltolást a + / - gombok segítségével megadjuk (vagy a számra kattintva egyből beírható a kívánt érték, Celsius fok egységben).

S.M.A.R.T. attribútumok részletes listája, állapotjelzők és grafikonok

A program a továbbiakban minden hőmérséklet értékhez, amit a merevlemeztől kap, hozzáadja (vagy kivonja) a beállított eltolási értéket, ezért a korrekt (valós) hőmérsékletet fogja mutatni.

Ajánlott minden lemezen külön elvégezni a hőmérséklet kalibrációt - ha lehetséges. Még ugyanolyan típusú lemezek használata esetén is elképzelhető különböző hőmérséklet eltolási érték.

Megjegyzés: Ha a kalibráció nem lehetséges (a számítógép háza nem bontható meg) akkor megoldás lehet az, hogy bekapcsolás után közvetlenül megnézzük a program által kijelzett hőmérséklet értékeket és azokat a környezet (szoba, iroda) hőmérsékletével hasonlítjuk össze. Ilyenkor mivel a processzor, videókártya és a többi egység még nem melegedett be nagyon, számottevően nem befolyásolják a merevlemez hőmérsékletét. Természetesen ez csak abban az esetben igaz, ha a számítógép előzőleg lehűlt a környezet hőmérsékletére, tehát nem volt bekapcsolva legalább 8 órán keresztül.

Például ha bekapcsoláskor a merevlemez hőmérsékletét a program 17 Celsius foknak jelzi, de a szobában 22 Celsius fok van, akkor +5 beállítható eltolási értéknek (mivel fizikailag a merevlemez nem lehet a környezeténél hűvösebb). Az így kijelzett hőmérséklet máris közelebb áll a valóságoshoz, de az igazán pontos eltolási érték meghatározásához ajánlott külső hőmérő használata.

Megjegyzés: az eltolási értéket minden esetben Celsius fokban kell érteni, függetlenül attól, hogy a hőmérséklet a programban milyen egységben (Celsius vagy Fahrenheit) kerül kijelzésre.

Megjegyzés: A nem regisztrált változat használata esetén az eltolási értékek a program legközelebbi indításakor automatikusan a kezdőértékekre (0-ra) állnak vissza.


S.M.A.R.T. attribútumok

S.M.A.R.T. attribútumok listája (ATA)

Az alábbi táblázatban megtalálható az ismert S.M.A.R.T. attribútumok listája, melyeket az IDE és S-ATA merevlemezek támogatnak. Megjegyzés: bizonyos esetekben a gyártó az itt közölttől eltérő célra is használhatja az attribútumokat. A fel nem sorolt attribútumok "gyártó specifikusak", a pontos céljuk és működésük nem ismert.

1 | Raw Read Error Rate | Olvasás közben előforduló nem javított hibák száma Lemezfelület vagy fejek hibájára utalhat. Kritikus attribútum
2 | Throughput Performance | Átviteli hatékonyság Motor, szervó ill. csapágy problémára utalhat.
3 | Spin Up Time | Működési fordulatszám eléréséhez szükséges felpörgési idő Motor ill. csapágy problémára utalhat. Kritikus attribútum
4 | Start/Stop Count | Felpörgések/leállások száma Értéke közvetlenül nem befolyásolja a lemez állapotát.
5 | Reallocated Sector Count (Reallocated Sectors Count) | Tartalék területre áthelyezett szektorok száma Lemezfelület vagy fejek hibájára utalhat. Kritikus attribútum
6 | Read Channel Margin | Olvasáskor fenntartott sáv Nincs meghatározott szerepe.
7 | Seek Error Rate | Fejpozícionálás közben előforduló hibák száma Szervó ill. fej probléma vagy magas hőmérséklet okozhatja. Kritikus attribútum
8 | Seek Time Performance | Átlagos fejpozícionálási idő Szervó problémára utalhat. Kritikus attribútum
9 | Power-On Time Count | Bekapcsolva töltött idő Folyamatosan növekvő számláló, mérése gyártótól függő egységben történik.
10 | Spin Retry Count | Felpörgési újrapróbálkozások száma Motor, csapágy vagy tápegység problémára utalhat. Kritikus attribútum
11 | Drive Calibration Retry Count | Kalibrálási újrapróbálkozások száma Motor, csapágy vagy tápegység problémára utalhat.
12 | Drive Power Cycle Count | Ki/Bekapcsolások száma Értéke közvetlenül nem befolyásolja a lemez állapotát.
13 | Soft Read Error Rate | Szoftveres olvasási hibák száma Nem javítható olvasási hibák száma.
184 | End-to-End error | Paritáshibák száma a belső gyorsítótár (cache) és a vezérlő közötti átvitetelben.
187 | Reported Uncorrectable Errors | Hardveres hibajavítással nem javítható hibák száma.
188 | Command Timeout | Időtúllépés miatti hibák száma. Nullánál nagyobb érték esetén tápegység illetve adatkábel csatlakoztatási probléma valószínűsíthető.
189 | High Fly Writes | Bizonytalan írási műveletek száma, melyeket a fej nem megfelelő repülési magassága okoz.
190 | Airflow Temperature | Léghőmérséklet A lemezen belüli levegő hőmérséklete.
191 | Mechanical Shock | Mechanikai behatások száma Hirtelen gyorsulás (pl. esés) miatt fellépő problémára utalhat.
192 | Power off Retract Cycle | Kikapcsolások száma Értéke közvetlenül nem befolyásolja a lemez állapotát.
193 | Load/Unload Cycle Count | Megadja, hogy a fej hányszor állt be illetve lépett ki a parkolózónából.
194 | HDD Temperature | Működési hőmérséklet Meghajtón belül mért hőmérséklet érték (Celsius).
195 | Hardware ECC Recovered | Javítható hibák száma A belső hibajavító algoritmussal javított hibák mennyiségére utal.
196 | Reallocation Event Count | Áthelyezési kísérletek száma A tartalék területre indított áthelyezések (sikeres és sikertelen) száma. Kritikus attribútum
197 | Current Pending Sector Count | Függőben lévő szektorok száma A gyenge szektorok mennyisége, melyek áthelyezésre kerülhetnek. Kritikus attribútum
198 | Off-Line Uncorrectable Sector Count | Javíthatatlan szektorok száma Lemezfelület vagy fejek hibájára utalhat. Kritikus attribútum
199 | Ultra ATA CRC Error Count | Adatátviteli hibák száma Gyenge tápegység, sérült vagy túl hosszú adatkábel okozhatja.
200 | Write Error Rate | Írás közben előforduló hibák száma Lemezfelület vagy fejek hibájára utalhat.
201 | Soft Read Error Rate | Szoftveres olvasási hibák száma Nem javítható olvasási hibák száma.
202 | Data Address Mark Errors | Adatcímzési hibák száma Nem megfelelő címjelző használata esetén növekedhet.
203 | Run Out Cancel | Adatjavítási hibák száma Hibás ellenőrzőösszeg az adatok javítása során.
204 | Soft ECC Correction | Szoftveresen javított hibák száma A belső hibajavító algoritmussal javított hibák mennyiségére utal.
205 | Thermal Asperity Rate | Hőmérsékleti problémák száma A magas hőmérséklet miatt bekövetkezett hibák számára utal.
206 | Flying Height | Fej repülési magasság A fej lemez feletti repülési magasságát adja meg.
207 | Spin High Current | Felpörgés közben túl magas feszültség Túl magas tápfeszültség miatti felpörgési problémák mennyisége.
208 | Spin Buzz | Felpörgéshez szükséges ciklusok száma Nagyobb áramfelvétel miatti újrafelpörgések száma.
209 | Offline Seek Performance | Önteszt alatti teljesítmény A lemez öntesztje alatti pozícionálási teljesítményt határozza meg.
211 | Vibration During Write | Írás közben tapasztalt vibráció.
212 | Shock During Write | Írás közben tapasztalt mechanikai behatás, sokk.
220 | Disk Shift | Lemez középponttól elmozdulása A lemez nem megfelelő pörgése elmozdulás (pl. mechanikai sokk) miatt.
221 | G-Sense Error Rate | Mechanikai behatások száma Hirtelen gyorsulás (pl. esés) vagy vibráció miatt fellépő problémára utalhat.
222 | Loaded Hours | Bekapcsolva töltött idő Folyamatosan növekvő számláló, órás egységben számol.
223 | Load/Unload Retry Count | Betöltések száma Megadja, hogy a fej hányszor állt be illetve lépett ki az adatzónából.
224 | Load Friction | Súrlódási érték A mechanikai eszközök problémája miatt bekövetkezett súrlódás mennyisége.
226 | Load-in Time | Betöltve töltött idő Megadja, hogy a fej mennyi időt töltött az adatzónában.
227 | Torque Amplification Count | Felpörgési nyomaték értéke A nyomaték növekedésének mértéke a felpörgés során.
228 | Power-off Retract Count | Tápfeszültség megvonás mennyisége A tápfeszültség kiesése miatti leállások száma.
230 | GMR Head Amplitude | Fejpozícionálási amplitudó Művelet végzése közben a fej kilengésének mértéke.
231 | Hard Disk Temperature | Működési hőmérséklet Meghajtón belül mért hőmérséklet érték.
240 | Head Flying Hours | Fejpozícionálási idő A fej pozícionálásával eltöltött összes idő (órában kifejezve).
250 | Read Error Retry Rate | Olvasási újrapróbálkozások száma Lemezfelület vagy fejek hibájára utalhat.
254 | Free Fall Event Count | Zuhanásérzékelő szenzor által mért zuhanás és gyorsulás események száma.

S.M.A.R.T. attribútumok listája (SCSI)

Az alábbi táblázatban megtalálható az ismert S.M.A.R.T. attribútumok listája, melyeket a SCSI merevlemezek támogatnak. Megjegyzés: bizonyos esetekben a gyártó az itt közölttől eltérő célra is használhatja az attribútumokat. A fel nem sorolt attribútumok "gyártó specifikusak", a pontos céljuk és működésük nem ismert.

01 | Buffer túl/alulcsordulás számláló
02_0000 | Késleltetés nélkül javított íráshibák
02_0001 | Késleltetéssel javított íráshibák
02_0002 | Összes íráshiba
02_0003 | Összes javított íráshiba
02_0004 | Összes algoritmussal javított íráshiba
02_0005 | Összes írt bájt
02_0006 | Összes nem javított íráshiba
03_0000 | Hardveres hibajavítással javított olvasáshibák
03_0001 | Késleltetéssel javított olvasáshibák
03_0002 | Összes olvasáshiba
03_0003 | Összes javított olvasáshiba
03_0004 | Összes algoritmussal javított olvasáshiba
03_0005 | Összes olvasott bájt
03_0006 | Összes nem javított olvasáshiba
04_0000 | Hardveres hibajavítással javított fordított olvasáshibák
04_0001 | Késleltetéssel javított fordított olvasáshibák
04_0002 | Összes fordított olvasáshiba
04_0003 | Összes javított fordított olvasáshiba
04_0004 | Összes algoritmussal javított fordított olvasáshiba
04_0005 | Összes fordított olvasott bájt
04_0006 | Összes nem javított fordított olvasáshiba
05_0000 | Késleltetés nélkül javított ellenőrzéshibák
05_0001 | Késleltetéssel javított ellenőrzéshibák
05_0002 | Összes ellenőrzéshiba
05_0003 | Összes javított ellenőrzéshiba
05_0004 | Összes algoritmussal javított ellenőrzéshiba
05_0005 | Összes ellenőrzött bájt
05_0006 | Összes nem javított ellenőrzéshiba
06_0000 | Nem média hiba
07 | Utolsó hiba esemény
0B | Utolsó késleltett hiba vagy aszinkron esemény
0D_0000 | Hőmérséklet
0D_0001 | Referencia hőmérséklet
0E_0001 | Gyártás dátuma (év/hét)
0E_0002 | Üzembehelyezés dátuma
0E_0003 | Indítások engedélyezett száma az élettartam alatt
0E_0004 | Lemez indítások száma
0F | Szoftver kliens paraméter
10 | Önteszt eredmény napló
18 | Protokol specifikus napló
37_0000 | Vezérlőnek küldött csomagok száma
37_0001 | Vezérlőtől érkező csomagok száma
37_0002 | Gyorsítótárból kiolvasott csomagok száma
37_0003 | Szegmensméretnél kisebb csomagok száma
37_0004 | Szegmensméretnél nagyobb csomagok száma
3E_0000 | Működési idő
3E_0008 | Következő öntesztig hátralévő idő


Szöveges Értékelés

A program elemzi a merevlemez által elérhetővé tett S.M.A.R.T. paramétereket és azokat kiértékelve készít egy szöveges értékelést. Ez tartalmazza a lemez felületén található hibás szektorok mennyiségét, indulási problémákat, adatátviteli hibákat, stb. Az értékelés háttérszíne (zöld, sárga ill. piros) a merevlemez állapotára utal (tökéletes, problémás, rossz). Az értékelés esetlegesen tartalmazhat probléma megnevezést vagy ötleteket, melyekkel a merevlemez jelenlegi állapota javítható, emiatt ajánlott elolvasni.

Hogyan Tovább?

Ha a merevlemez állapota nem 100%-os, az még nem feltétlen jelenti, hogy komoly baj van. A megjelenített kondíció egy jelzés, melyet a program az alapján állapít meg, hogy a a lemez eddigi használata során milyen hibák és problémák történtek, melyek az állapotot befolyásolták. Ezeket a hibákat a merevlemez a belső naplójába rögzíti, a Hard Disk Sentinel program pedig onnan kiolvassa és megjeleníti.

Ilyen esetben célszerű meggyőződni, hogy a korábbi problémák még aktuálisak lehetnek-e vagy azok már megoldásra találtak. Például ha hibás szektorokról van szó, azokat a merevlemez már nem használja, így problémát nem okoznak, mivel helyettük a merevlemez a tartalék adatterületet írja és olvassa. Emiatt felületvizsgáló programok (pl. scandisk) sem jeleznek hibát, mivel a valódi hibás területet már nem érik el. (ld. lent)

Hasonlóan, ha felpörgéssel kapcsolatos problémát említ a program (melyet okozhat tápegység vagy tápellátás probléma) és ez megszűnt (tápegység csere történt), akkor ezek a korábbi hibák már nem jelentősek.

Azt fontos ellenőrizni, hogy a merevlemez állapota mennyire stabil, azaz a kondíció milyen mértékben változik (ha egyáltalán) hosszabb távon és esetleg nagyobb terhelés következtében. Ha a jelzett kondíció nem kimondottan magas, de stabil, akkor a merevlemez már kizárta a kérdéses területet a további használatból, annak nagysága nem változik, ezért elméletileg nincs miért aggódni (ha ilyen jellegű problémákat tárt fel a program).

A stabilitás ellenőrzésére a legalkalmasabb eszközök a merevlemez hardveres öntesztjei, melyek a tárolt adatokra nem jelentenek veszélyt. Ezek a programban a merevlemezt kiválasztva a Lemez menüből indíthatóak és alaposan megvizsgálják a lemez komponenseit (fejek, szervó, firmware, belső memória) és a részletes teszt a teljes felületet is. Ha ezek a tesztek hiba nélkül lefutnak (akár egy nem 100%-os lemezen is), akkor az állapot viszonylag stabilnak tekinthető.

Ellenkező esetben (hibás teszt-eredmények) érdemes más módszerrel alapos tesztelésnek vetni alá a merevlemezt. Egy jó megoldás a felület teljes végigírása (nem csak olvasás), mely végezhető a programban található felületi tesztek segítségével is. A legjobb megoldás a Lemez felületének újrainicializálása, de számos egyéb módszer is rendelkezésre áll a merevlemez állapotának vizsgálatához. Az Írás tesztek alkalmasak arra, hogy valóban felderítsék és javítsák a merevlemez állapotát.

Ha a lemez állapota alapos tesztek után sem változik, akkor a jelenlegi problémák törölhetőek. Így a program a későbbiek során csak az ez után előforduló újabb problémákat veszi figyelembe, de addig ismételten 100%-os állapotúnak jelzi a merevlemezt. Ezt a lemez "S.M.A.R.T." adatlapján lehet megtenni, ahol az egyes problémá(ka)t jelző (felkiáltójellel ! megjelelölt sorokban) az "Eltolás" mezőben kell megadni negatív előjellel a talált problémák számát, mely ugyanezen sor "Adat" oszlopában olvasható le (illetve a szöveges értékelésben is megjelenik). Például ha a program 5 hibás szektort említ, akkor a megfelelő sorban "-5"-öt kell megadni. Erről bővebb információ a hőmérséklet kalibráció fejezetben található.

Mindenesetre az ilyen merevlemezeket ajánlott fokozott figyelemmel kezelni, különösen ha több, különböző problémát és/vagy gyenge szektorokat is jelez a program. Javasolt a folyamatos felügyelet és bármilyen apró probléma, kondíció csökkenés esetén azonnal teljes adatmentés indítása. Erre a program PRO változata automatikusan, beavatkozás nélkül is képes.

Ha a kondíció alacsony, de 0 % feletti, garanciális csere még nem kérhető, mivel az öntesztek eredménye és a jelzett állapottól függetlenül a merevlemez "túl kevés" problémával rendelkezik, hogy a gyártó engedélyezze a cserét. Garanciális csere csak akkor kérhető, ha a problémák száma kellően magas szintet ér el és átlépi a gyártó által meghatározott küszöbszintet. Ez esetben a kondíció 0%, ennél nagyobb érték esetén a cserét általában visszautasítja a gyártó vagy a forgalmazó.

Mindazonáltal az alapos írás tesztek további problémákat hozhatnak felszínre, melyek a kondícót tovább csökkentik.

Érdemes lehet a gyár által adott teszt-programmal is ellenőrizni a merevlemezt, de fontos tudni, hogy ez néha nem javítja, csak elfedi a hibákat, azaz a későbbiek során azok újból megjelenhetnek. Ezért javasolt a gyári tesztprogram után is a folyamatos felügyelet - különösen akkor ha az állapot - akár pozitív, akár negazív irányba - módosul.

Hibás szektorok?

Furcsának hathat ez, hiszen a lemez felületét ellenőrző szoftverek (pl. Windows lemezellenőrző) nem jeleznek hibás területet, akkor hogy is van ez?

A merevlemezben található önellenőrző algoritmus a következőképpen működik: mikor a lemez felületén problémát (hibás szektort) észlel, elkezdi onnan az adatokat átmenteni a tartalék adatterületre. Ilyenkor az eredeti helyet megjelöli hibásnak és minden további (ide irányuló) írás és olvasás átirányításra kerül a tartalék területre.

A folyamat végén az eredeti (hibás) terület szoftveres úton nem érhető el többé. Ezért (többszöri) formázás és újratelepítés után sem mutat a lemez hibát, mivel valójában a hibásnak minősített adatterület ilyenkor nem esik formázás (ellenőrzés) és használat alá. Emiatt például az említett alkalmazás (Scandisk) sem talált hibát a felületen, még alapos teszteléssel sem. Egyedül a hardveres biztonsági törlés funkció éri el ezt a területet is, mely törli az esetlegesen ott maradt információt is.

Emiatt pl. a DOS-os formázás a mai modern merevlemezeknél (a S.M.A.R.T. tevékenysége miatt) gyakorlatilag sosem talál hibás szektort (illetve csak akkor, ha a tartalék terület már megtelt, de ez valóban ritka).

Az adatok átmentése nem minden esetben problémamentes (bár tény, hogy a lemezek sokat fejlődtek ilyen téren az elmúlt évek alatt). Legjobb esetben az átmentés gond nélkül lezajlik, de a rendszert ez rövidebb-hosszabb ideig megakaszthatja, veszélyeztetheti annak stabilitását.

A merevlemez felületén lévő mikroszkópikus karc vagy porszemcse is okozhat néhány hibás szektort. Amíg ezek száma relatíve alacsony (állandó), addig nem okoznak különösebb problémát, de ha a mennyiségük folyamatosan emelkedik (ezzel párhuzamosan a kondíció érték csökken), úgy a meghibásodás várhatóan be fog következni. Emiatt érdemes a nem tökéletes merevlemezeket fokozott figyelemmel kísérni.

SSD kondíció - Tökéletes SSD alacsony kondícióval?

A szöveges értékelésben adott esetben olvasható, hogy az SSD állapota tökéletes, de a kondíció érték mégis alacsony. Ebben az esetben az SSD nem mutat komoly hibákat, nincsenek hibás szektorok (hibás memória-cellák), sem egyéb jelentős problémák.

Viszont az SSD-re történő írás miatt az SSD memóriacellái folyamatos terhelésnek vannak kitéve. Mivel az egyes cellák csak korlátozott számban (nem végtelen mennyiségben) írhatóak felül, ezért a használat miatt a cellák élettartama, kondíciója folyamatosan csökken. Az SSD-k "wear-leveling" funkciója ezt próbálja minimalizálni azzal, hogy az írást folyamatosan más-más pozícióba kényszeríti, de teljesen nem lehet kiküszöbölni.

Az SSD-k ilyen általános állapotát bizonyos SSD-specifikus S.M.A.R.T. attribútum(ok) határozzák meg, mint például a "#209 Remaining Drive Life" (vagy más, hasonló jelentőségű általános kondíciót meghatározó érték(ek) a S.M.A.R.T. oldalon). Ezekre a Hard Disk Sentinel felhívja a figyelmet a szöveges értékelésben, és a kérdéses attribútom kiválasztásával (a S.M.A.R.T. oldalon) a lista alatti grafikonon ellenőrizhető, hogyan változott idővel az állapot.

Ha az SSD kondíciója alacsony, egyre nagyobb az esély, hogy a memória-cellákban tárolt adatok sérülhetnek vagy elveszhetnek.

A merevlemezeket nem érinti ez a hatás, így előfordulhat, hogy több éves használat után is a merevlemezek 100%-os állapotúak. Ezzel ellentétben általában az SSD-k kondíciója időben folyamatosan csökkenő tendenciát mutat.

Merevlemez Teszt

A lemezek állapotát (különösen ha nem tökéletes kondíciójú merevlemezről van szó) érdemes időszakosan alapos vizsgálatnak alávetni. Erre a Hard Disk Sentinel program számos megoldást kínál, kezdve a hardver ön-teszt funkciókkal, mely átfogóan ellenőrzi a merevlemezek komponenseit és a teljes felületet. Ez a Lemez menüpont alatt, vagy az Információk oldalról indíthatóak manuálisan vagy beállítható, hogy időzítve, automatikusan kerüljenek lefutásra akár valamennyi telepített merevlemezen (Professzionális változat, Műveletek oldal).

A Lemez menü Felület teszt pont alatt található tesztek segítségével a teljes felület átvizsgálható olvasás- és írástesztek segítségével, így az esetleges problémák felszínre hozhatóak és javíthatóak.