Johdanto

Kiitos paljon että käytät ohjelmaa Hard Disk Sentinel. Se on kiintolevyn analysointisovellus, joka on luotu tarkkailemaan kiintolevyn tilaa, lämpöä ja kuntoa. Lisäksi se voi paljastaa mahdollisia ongelmia ja suoritustehon alenemista sekä ennustaa kiintolevyn vikoja. Käyttämällä tätä ohjelmaa on mahdollista välttää vakava tietojen katoaminen.

Ole hyvä ja lue huolella tämä dokumentointi. Seuraavissa luvuissa kuvataan Hard Disk Sentinelin kaikki toiminnot ja ominaisuudet.


Kiintolevyt

Tietokoneiden sisäisillä kiintolevyillä on yksi tai useampia fyysisiä levyjä. Levyn yllä liitävä luku-kirjoituspää suorittaa kaiken lukemisen, kirjoituksen ja poistotoiminnot.

Kun kiintolevyn kapasiteetti kasvaa, dataa tallennetaan yhä pienemmille alueille levyn pinnalla. Mikä tahansa pieni (jopa mikroskooppinen) vaurio tai lika pinnassa heikentäisi mahdollisuuksia tärkeän datan saantiin. Levyt on hermeettisesti suljettu pitämään kosteus ja lika levyn rungon ulkopuolella.

Tämä prosessi ei aina suju loppuun ilman ongelmia. On mahdollista etteivät levyn pinnan jotkin alueet ole luku- tai kirjoituskelpoisia johtuen pienestä vauriosta tai liasta. Tässä tapauksessa kiintolevy merkkaa tämän alueen huonoksi eikä koskaan enää käytä näitä sektoreita mihinkään (luku- tai kirjoitus)operaatioon. Jos tällä alueella aiemmin oli dataa, kiintolevy yrittää ensin lukea ja kopioida datan erityisvaratulle alueelle. Kun prosessi on valmis, kaikki pyyntö vanhalle alueelle ohjautuu uudelleen varatulle alueelle. Levyn alkuperäiselle (ongelmalliselle) alueelle ei voi päästä edes täydellisen uudelleenalustuksen jälkeen.

Tämä kuulostaa hyvältä - koska ongelma ratkeaa automaattisesti, mutta käyttäjä ei huomaa lainkaan yhä heikkenevää kiintolevyn tilaa, ennen kuin hänen on väistämättä kohdattava käyttökelvoton kiintolevy ja tietojen menetys.

On muitakin mahdollisia ongelmia, jotka voivat heikentää kiintolevyn kuntoa. Korkea lämpötila, huonolaatuinen virta tai mekaaninen tärähdys ja värinä voivat vakavasti vahingoittaa kiintolevyä. Monet sellaiset ongelmat voi paljastaa käyttämällä ohjelmaa Hard Disk Sentinel, jolloin ongelmien aiheuttama tietojen menetys voidaan välttää.

S.M.A.R.T.

S.M.A.R.T. (Self-Monitoring Analysis and Reporting Technology) tuottanut IBM. Se on luotu tarkkailemaan levyn tilaa käyttäen monenlaisia metodeja ja laitteita. Yhdellä ATA-kiintolevyllä voi olla jopa 30 sellaista mitattavaa arvoa (attribuuttia). Jotkin niistä vaikuttavat suoraan tai epäsuorasti kiintolevyn kuntotilaan ja toisilla on antaa tilastollisia tietoja.

Nykyään kaikissa uudenaikaisissa IDE/Serial ATA/SCSI-kiintolevyissä on S.M.A.R.T. -toiminto. Se ei oikeastaan ole standardi - joten attribuuttien merkitys voi vaihdella valmistajasta valmistajaan. Tästä syystä valmistajasta riippumaton levyn kunnon analysointimetodi on tarpeen, kun määritetään minkä tahansa kiintolevyn todellinen tila. Hard Disk Sentinel voi tehdä tämän, ole hyvä ja tutustu jaksoon kunnon arviointimenetelmät.

Monia attribuutteja käyttävät kaikki valmistajat ja niitä käytetään samaan (tai lähes samaan) tapaan. Siksi esimerkiksi on mahdollista selvittää monien kiintolevyjen lämpötila ja päälläoloaika. Tämä sovellus tarkkailee näitä arvoja (ja monia muita).

Kun ongelma havaitaan, S.M.A.R.T. -spesifikaatioiden mukaan kiintolevyn tulisi toimia ainakin 24 tuntia suorittaakseen datan varmistuksen. Mutta monissa tapauksissa tämä aika ei riitä - siksi on tärkeää tunnistaa ongelmat ja korjata, ennen kuin on liian myöhäistä.

Huomaa: Jotkin kiintolevyohjaimet tai -ajurit voivat estää S.M.A.R.T. -arvojen lukemisen ja tutkimisen. Näissä tapauksissa nykyistä kuntoa, lämpötilaa tai muuta tilaa ei voi määrittää kys. kiintolevy(i)llä. Ole hyvä ja ota yhteyttä ohjaimen valmistajaan saadaksesi päivitetyn ajurin tai laiteohjelmiston. Ei ole mahdollista määrittää ulkoisten USB/Firewire-kiintolevyjen ja RAID-levypakkalaitteiden S.M.A.R.T. -tilaa.


Asennus

Windows 98/98SE/ME-käyttäjät: Käyttöjärjestelmässä ei ole oletuksena ladattuna S.M.A.R.T. -ajuria. Ennen asennusta sinun täytyy kopioida tiedosto Smartvsd.vxd kansiosta Windows\System kansioon Windows\System\IoSubsys ja käynnistää tietokoneesi uudelleen. Ole hyvä ja asenna Hard Disk Sentinel vasta tämän toimenpiteen jälkeen. (Ongelma on kuvattuna Microsoftin websivulla).

Latauksen jälkeen sovellus voidaan asentaa kaikille fyysisille, ei-siirrettäville kiintolevyille. Oletuksena se ehdottaa asennusta kansioon Program files. Se ei ole suositettavaa eikä asennus ole tuettu siirrettävälle tallennusvälineelle (esim. muistitikulle), koska sovellus tallentaa jatkuvasti nykyisiä mitattuja arvoja tietokantaansa (asennuskansioonsa). Tästä tietokannasta johtuen on mahdollista noutaa ja esittää graafisesti aiemmin mitattuja arvoja.

Asennuksen aikana voidaan luoda sovelluksen kuvake työpöydälle ja pikakäynnistykseen. Hard Disk Sentinel käynnistyy automaattisesti asennuksen jälkeen - ellei käyttäjä estä sitä.

Oletukset

Tilaikkuna näytetään automaattisesti oikeassa yläkulmassa. Se näyttää asennettujen kiintolevyjen mallit sekä lämpötila- ja kuntoarvot. Myös pääikkuna avautuu näyttäen yksityiskohtaisia tietoja. Hard Disk Sentinelin kaikkia ominaisuuksia pääsee tutkimaan tästä ikkunasta.

Oletuksena sovellus ei anna mitään hälytyksiä/varoituksia, mutta äskettäin löydetyt ongelmat kirjataan kiintolevyn lokiin.

Hard Disk Sentinel tallentuu automaattisesti rekisteriin käynnistymään seuraavalla kertaa Windowsin mukana. Näin se alkaa tarkkailla kiintolevyn tilaa heti, kun Windows käynnistyy. Tietysti tämä toiminto voidaan passivoida.


Sovelluksen komponentit

Hard Disk Sentinelin pääkomponentit kuvataan seuraavissa jaksoissa:

  • Tilaikkuna

  • Ilmaisinaluekuvake

  • Levykuvake

  • Pikavalikko

  • Pääikkuna

  • Asetukset

  • Varmistustehtävien asetukset ja suoritus (käytettävissä vaina PROFESSIONAL-versiossa)


Tilaikkuna

Asennuksen ja käynnistyksen jälkeen tilaikkuna ilmestyy automaattisesti oikeaan yläkulmaan. Se näyttää asennettujen kiintolevyjen mallit sekä lämpötila- ja kuntoarvot. Tämä ikkuna on aina päällimmäisenä. Näin on mahdollista tarkkailla levyjen nykyistä tilaa.

  • Kun hiiriosoitin viedään tämän ikkunan päälle, pieni kuvake (katso yllä) ilmestyy tilaikkunan oikeaan yläkulmaan. Ikkuna piilotetaan jos käyttäjä napsauttaa (hiiren vasenta painiketta) tämän kuvakkeen päällä.

  • Kun ikkunan päällä napsautetaan hiiren vasenta painiketta, näytetään loogisten asemien lista pikakatsauksena kunkin levyn vapaasta tilasta. Jos napsautetaan minkä tahansa loogisen levyn päällä, se avautuu automaattisesti Resurssienhallinnassa. Uusi vasen napsautus tilaikkunan päällä piilottaa tämän loogisen levyn tietopaneelin.

    Status window with logical disk information

  • On mahdollista siirtää tilaikkuna minne vain näytöllä napsauttamalla ja pitämällä hiiren vasenta painettuna ja siirtämällä hiirtä. Oletuksena ikkunaa ei voi siirtää näytön ulkopuolelle (se on linjattu näytön reunoihin), mutta eston voi poistaa. Näin ikkunan voi siirtää (osin tai täysin) näytön ulkopuolelle.

  • Kun on kaksoisnapsautettu (vasenta), hiiriosoittimen alla olevan kiintolevyn tarkat tiedot näkyvät sovelluksen pääikkunassa.

  • Käyttämällä hiiren oikeaa painiketta näytetään pikavalikko. (Sen voi näyttää myös napsauttamalla oikeaa ilmaisinaluekuvakkeenpäällä. Tämä on käytännöllistä, jos tilaikkuna on piilotettu.)

Huomaa: Tilaikkunassa näkyviä tietoja ja tämän ikkunan ulkoasua voi muokata. Sovellus tallentaa automaattisesti ikkunan modifikaatiot sekä sijainnin ja seuraavalla kertaa ikkuna näytetään aiemmin muokattuna (tai ei näytetä lainkaan - jos tilaikkuna piilotettiin aiemmin).


Ilmoitusaluekuvake

    Tray icon showing information

Oikeassa alakulmassa kellon vieressä Hard Disk Sentinel voi näyttää kiintolevyjen tilan käyttäen ilmoitusaluekuvakkeita. Tuoreen asennuksen jälkeen näkyy kunkin kiintolevyn lämpötilaa osoittava kuvake (jos kiintolevyn lämpötilan voi selvittää). Sovellus näyttää yhä korkeampia lämpötiloja käyttäen eri värejä: alle 40 celsius-asteessa kuvakkeen tausta on vihreä, 40 - 50:n välillä lämpötilakuvake on keltainen ja yli 50:ssä se on punainen. Tietenkin näitä kynnysarvoja ja värejä voi muokata käyttäjän mieltymysten mukaan.

Kun kahdella tai useammalla levyllä on ilmoitusaluekuvakkeet, ei ehkä ole selvää mikä kuvake kuuluu millekin levylle. Kuvakkeet näytetään kiintolevyjen järjestyksessä (vasemmalta oikealle), mutta joissain tapauksissa näiden kuvakkeiden järjestys voi vaihtua johtuen käyttöjärjestelmän tai muiden sovellusten käyttämistä ilmoitusalluekuvakkeista. Jos hiiriosoitin viedään minkä tahansa Hard Disk Sentinel -ilmoitusaluekuvakkeen päälle, niin numero, malli, lämpötila ja kunto sekä muut tiedot (kaikki näkyvät levyn tilaikkunassa) näytetään vihjeenä.

Jos käyttäjä kaksoisnapsauttaa (vasemmalla painikkeella) mitä vain HDS-ilmoitusaluekuvaketta, näkyy pääikkuna esittäen yksityiskohtaisia tietoja kaikista asennetuista kiintolevyistä.

Napsauttaen oikealla ilmoitusaluekuvaketta näkyy pikavalikko useimmin käytetyin toiminnoin.


Levykuvake

Levykuvakkeet

Loogisten levyjen kuvakkeilla Hard Disk Sentinel näyttää jatkuvasti näiden levyjen tilan (kuntotilan, mikä voi olla hyvä, hyväksyttävä ja huono) sekä käytetyn tilan määrän. Tällä tavoin missä tahansa sovelluksessa (esim. Resurssienhallinnassa) voidaan helposti nähdä nykyinen tila.

Hard disk health and used space displayed on hard disk icons

Tämä valinta on erityisen hyödyllinen, jos kaksi tai useampia kiintolevyjä on asennettuina tai tilaikkunaa ei voi näyttää. Käytetty tila näkyy 16 eri vaiheessa. Kun loogisen aseman käytetty tila kasvaa, juova muuttuu keltaiseksi ja sitten punaiseksi.

Huomaa: Käytetyn tilan näyttö riippuu asetuksesta vapaan levytilan kynnys. On mahdollista säätää vapaan levytilan kynnys erikseen kullekin loogiselle levylle. Jos säädetään korkeampi vapaan tilan kynnys, juova saavuttaa keltaisen tai punaisen alueen aiemmin.

Kiintolevyn kuntoa heijastava symboli näkyy kuvakkeiden oikeassa alakulmassa. Oletuksena tämä symboli voi olla vihreä rasti, jos kunto on parempi kuin 50%. Välillä 25% - 50% näkyy keltainen huutomerkki ja alle 25%:ssa näkyy punainen X loogisten levyjen kuvakkeissa. Tietysti näitä kynnysarvoja voi säätää.

Huomaa: Kuntosymboli näkyy vain S.M.A.R.T. -tuen omaavilla levyillä, jolloin on mahdollista selvittää nykyinen kuntotila. Ulkoiseen (USB/Firewire-) kiintolevyyn assosioituneiden loogisten levyjen ja etäasemien yhteydessä on mahdollista näyttää tietoja vain käytetystä levytilasta. (Tämä valinta on oletuksena passivoitu, sen voi aktivoida asetuspaneelissa levyn hallinta). Kuntotiedot eivät näy Windows 98/98SE/ME:n yhteydessä.

Levyjen nykyisen kuntotilan näyttämiseksi on tarpeen säännöllisesti tutkia levyjen tilaa (kuntoa, käytettyä tilaa). Hitaampien laitteiden tai asemien (esim. tietynlaisten kortinlukijoiden tai verkkoasemien) tutkimiseen vaadittaneen enemmän aikaa ja tämä voi pidentää sovelluksen vasteaikaa tai hidastaa järjestelmää. Näissä tapauksissa tämä valinta pitäisi osittain tai kokonaan poistaa kyseisiltä asemilta. Tätä voi säädellä asetuspaneelissa levyn hallinta.

Hard Disk Sentinelin tulisi olla aktiivinen (käynnissä) näyttääkseen kuntosymbolin ja käytetyn tilan loogisten levyjen kuvakkeilla. Ellei se ole käynnissä näitä lisätietoja ei voi näyttää.


Pikavalikko

Pikakäynnistys

Tämä valikko ilmestyy, jos käyttäjä napsauttaa hiiren oikeaa painiketta tilaikkunan tai ilmaisinaluekuvakkeen päällä. Tästä valikosta on mahdollista:

  • Näyttää tai piilottaa tilaikkuna (kyseinen valinta on saatavilla).

  • Avata asetussivu ja säätää asetuksia.

  • Näyttää kiintolevyn lämpötilatilasto.

  • Näyttää kiintolevyn yksityiskohtaiset tiedot pääikkunassa (näytetään ennalta valittu tietopaneeli).

  • Näyttää tämä ohje.

  • Näyttää sovelluksen Tietoja -ikkuna, josta selviää asennettu nykyinen versio, rekisteröidyn käyttäjän nimi, pikalinkki sovelluksen web-sivulle ja sen henkilön nimi ja sähköpostiosoite, joka on tehnyt liittymän käännöksen.

  • Aktivoida tai passivoida nykyisen session äänihälytykset. Jos äänihälytykset on aktivoitu sivulla Hälytykset niin, kun havaitaan ongelma (esim. ylikuumeneminen, vähäinen levytila jne.) sovellus tekee kuuluvan hälytyksen. (Valinnaisesti tämä hälytys voi toistua niin kauan, kuin käyttäjä ei vahvista, että hän tunnistaa ongelman napsauttamalla tätä valintaa tai käyttämällä samaa valintaa pääikkunassa.) Käyttämällä tätä valintaa äänihälytykset voi poistaa käytöstä nykyisen session ajaksi. Sovelluksen uudelleenkäynnistyksen jälkeen äänihälytykset aktivoituvat taas - on parempi käyttää tätä valintaa, kuin poistaa äänihälytykset sivulla Hälytykset.

  • Sulkea Hard Disk Sentinel. Tämä pysäyttää sovelluksen ja se ei enää tarkkaile kiintolevyjen tilaa. Huomaa: Seuraavassa käynnistyksessä viime ajon jälkeiset muutokset kunnossa tutkitaan ja kirjataan levyn lokiin. Näin siis ellei Hard Disk Sentinel voi toimia jatkuvasti, mutta voidaan ajaa jaksoittain, sitä voi käyttää todentamaan levyjen tila ja muutokset (kunnon heikkeneminen).


Pääikkuna

Hard Disk Sentinelin pääikkunasta on mahdollista päästä säätämään kaikkia ominaisuuksia ja toimintoja käyttäen päävalikkoa tai pikapainikkeita.

Main window with hard disk information

Päävalikossa on seuraavat valinnat:

  • Tiedosto: täällä on eräänä valintana sulkea (lopettaa) Hard Disk Sentinel.

  • Näytä: on mahdollisuus valita , minkä tietopaneelin näyttää liittyen valittuun kiintolevyyn.

  • Raportti: voi luoda täydellisen teksti- tai HTML -raportin käyttäen näitä valintoja. On mahdollista vain tallentaa (ja avata välittomästi) raportti tai lähettää se välittömästi s-postina mihin tahansa osoitteeseen. Oletuksena näytetään muokattu vastaanottajan osoite ja muokattuja postitusvalintoja käytetään lähetettäessä raporttisähköposti.

  • Asetukset: sovelluksen ominaisuuksia ja toimintoja voi säädellä tässä ikkunassa. Valinnat on järjestetty eri kategorioihin.

  • Ohje: voi näyttää ajankohtaisen ohjeen tai Tietoja-ikkunan.

Kun hiiriosoitin viedään päävalikon alla olevien pikapainikkeiden päälle, painikkeiden toiminto näytetään vinkkiruudussa. Painikkeita käyttäen on mahdollista suorittaa seuraavat tehtävät:

  • Refresh tutkia uudelleen kaikkien kiintolevyjen tila riippumatta säädetystä havainnointitaajuudesta.

  • Re-enable alerts tyhjätä käsiteltyjen hälytysten lista, jolloin hälytykset lähetetään taas, äänihälytykset annetaan taas, jne.

  • Show / hide status window piilottaa tai näyttää tilaikkuna.

  • Modify acoustic level säätää kiintolevyn äänitasoa (jos tuettu). Korkeampi äänitaso merkitsee enemmän melua ja nopeampaa hakutehoa, alempi äänitaso merkitsee vähemmän melua, mutta hitaampaa hakutehoa.

  • Seek test testata aseman hakutehoa, melua ja lämpötilaa. Testiä voi käyttää tehokkaasti "stressaamaan" kiintolevyä nostamalla sen lämpötilaa.

  • Drive tests suorittaa kiintolevyn sisäisiä itsetestejä todentamaan kriittisiä komponentteja ja paljastamaan mitä vain piilo-ongelmia.

  • Create and save report tallentaa täydellinen raportti. Voi valita raportin tyypin (teksti tai HTML).

  • Send report in e-mail lähettää täydellinen raporttisähköposti. Voi valita raportin tyypin (teksti tai HTML).

  • Send test report to developer lähettää testiraportti suunnittelijalle auttamaan jatkokehittelyssä. Hyödyllinen todennettaessa ongelmia tai paljastettaessa erinäisiä asioita.

  • Configuration avata ikkuna Asetukset.

  • Enable / disable sound alerts passivoida tai aktivoida äänihälytykset nykyisessä sessiossa. Jos on aktivoitu valinta "Toista äänihälytys", tätä painiketta voi käyttää varmentamaan äänihälytykset ja passivoimaan jatkossa äänihälytykset.

  • Help avata ajankohtainen ohje.

  • About näyttää Tietoja-ikkuna.

Pikapainikkeiden alapuolella vasemmalla näkyvät asennetut fyysiset kiintolevyt (yläpaneeli) ja saatavissa olevat loogiset asemat (alapaneeli). Vaakaerotinta ylä- ja alalistojen välissä voi käyttää säätämään eri paneelien kokoa. Jos mikä tahansa fyysinen tai looginen levy valitaan hiiren vasemmalla painikkeella, levyn tai aseman tarkat tiedot näkyvät oikealla suuremmassa tietopaneelissa.

Valitsinpaneeleissa päivitetään asemien lista säännöllisesti. Näin levyjen pikatiedot (lämpötila, kunto tai vapaa tila) heijastavat aktuaalista, viimeisintä tilaa.

Erotinta valitsimen ja tietopaneelien välissä voi käyttää muuttamaan näiden kahden kokoa. Huomaa: sovellus tallentaa automaattisesti tämän ikkunan sijainnin ja koon sekä erottimien sijainnin. Näin ikkuna ilmestyy seuraavalla kertaa aiemmin säädöin.

Tietopaneelissa näkyvät juuri valittuna olevan fyysisen levyn tai loogisen aseman tarkat tiedot.


Fyysisen levyn tiedot

Fyysisestä levystä on saatavissa monia eri tietosivuja. On mahdollista vaihtaa näkymää sivujen välillä käyttäen välilehtiä tai valiten sivun Näytä-valikosta.

  • Yleiskatsaus

  • Lämpötila

  • S.M.A.R.T.

  • Tiedot

  • Loki

  • Levyn suoritusteho

  • Hälytykset


Yleiskatsaus

Valitun kiintolevyn nykyisen suoritustehon ja kunnon arvot ovat nähtävissä (napsauta linkkejä tutustuaksesi kyseisten arvojen laskentametodeihin).

Sitten näkyy nykyisen tilan sanallinen kuvaus. Hard Disk Sentinel analysoi levyn tarjoamat S.M.A.R.T. -attribuutit ja arvioimalla näitä arvoja luoden ja näyttäen sanallisen arvion. Se voi käsittää lukuisasti levyn elinaikana tavattuja ongelmia, kiihdytysongelmia, datan siirtovirheitä jne. Tämän alueen taustaväri (vihreä, keltainen, punainen) osoittaa levyn kuntoa. Tekstialue voi sisältää ongelmien korjausvinkkejä, joten on suositettavaa tutustua yksityiskohtiin.

Keskellä näkyvät virran päälläoloajan ja arvioidun jäljellä olevan elinajan arvot. Näiden arvojen mittaus- ja laskentaprosessia kuvataan liitteessä.

Paneelin alaosassa näkyy aiemmin mitattujen levyn kuntoarvojen graafinen historia. Hard Disk Sentinel tallentaa kunakin päivänä mitatun huonoimman kuntoarvon ja nämä arvot näkyvät tässä graafissa. Jos sovellusta käytetään pidemmän ajanjakson, graafin alla olevaa vierityspalkkia voi käyttää vierittämään aiempaan päivään. Käyttämällä pientä levykuvaketta graafin voi tallentaa kuvana (BMP tai JPG).


Lämpötilatilasto

Tällä sivulla on mahdollista tarkastella tänään mitattuja tämän hetkistä ja keskimääräistä sekä maksimilämpötilaa.

Lämpötila-arvoihin perustuva sanallinen arviointi on nähtävissä (kuten levyn kuntoon perustuva arviointi). Korkean lämpötilan kyseen ollen sovellus antaa vinkkejä välttää ongelmat.

Monissa tapauksissa on mahdollista, ettei kiintolevyn sisällä oleva lämpötila-anturi ole tarkka. On suositettavaa suorittaa lämpötilan kalibrointi (tämä sanoma näkyy niin kauan, kuin lämpötilan poikkeamaa ei ole säädetty (tasan 0:aan) kiintolevyllä).

Tämän sivun alaosassa näkyvät nykyisen session aikana mitatut edelliset arvot. On myös mahdollista tarkastella edellisinä päivinä mitattuja keskimääräisiä ja maksimilämpötiloja. Jos Hard Disk Sentinelia käytetään pitemmän jaksoisesti, graafin alla olevaa vierityspalkkia voi käyttää vierittämään johonkin edeltävään päivään. Käyttäen pientä levykuvaketta graafin voi tallentaa kuvana (BMP tai JPG).


S.M.A.R.T.

Sivulla S.M.A.R.T. (Self-Monitoring Analysis and Reporting Technology) näkyy valitun IDE- tai Serial ATA -kiintolevyn S.M.A.R.T. -attribuuttien lista. Kaikki kiintolevyt voivat tallentaa jopa 30 eri attribuuttia, jotka heijastavat kyseisen kiintolevyn tilaa. Attribuuttilista on valmistajan määrittämä - joten kaikki kiintolevyt eivät sisällä kaikkia attribuutteja. Lista on kiinteä, ei ole mahdollista lisätä tai poistaa attribuutteja sen jälkeen, kun kiintolevy on lähtenyt tehtaalta. Lista saattaa vaihdella saman valmistajan eri kiintolevyillä, mutta saman tyyppisillä kiintolevyillä on yleensä samat attribuuttilistat.

S.M.A.R.T. attribute details, flags and trends for selected attribute

Vasemmalta käsin lista alkaa tunnisteella (numerolla). Se voi olla väliltä 0 - 255. Jos attribuutti suoranaisesti vaikuttaa kiintolevyn kuntotilaan ja se voi saavuttaa kriittisen tason, Hard Disk Sentinel näyttää numeron edessä vihreän rastin (Attribuutti OK) tai punaisen X:n (attribuutti ei ole kunnossa).

Sitten näkyy attribuutin nimi - ellei se ole tuntematon. Useimpia attribuutteja käyttävät laajalti kaikki (tai lähes kaikki) valmistajat. Joidenkin attribuuttien arvo tai merkitys on tuntematon, koska valmistaja ei julkaise niitä tietoja.

Sarake Kynnys sisältää attribuutin kynnysarvon. Jos sarake Arvo sisältää kynnystä pienemmän luvun, attribuutti ei ole kunnossa. Jos attribuutti on kriittinen, näkyy tässä tapauksessa rivin alussa punainen X. Sarakkeessa Huonoin näkyy huonoin ikinä mitattu arvo.

Sarakkeessa Tila näkyy attribuutin nykyinen kuntotila. Se voi olla:

  • OK: arvo on sama tai suurempi kuin kynnys. Ei ole mitään ongelmaa.

  • OK (Läpäisee aina): kynnys on nolla, joten arvon ei ole mahdollista olla pinempi. Näkyy yleensä vain attribuuteilla, jotka ilmaisevat tilastollisia tietoja.

  • Epäonnistunut: kriittisen attribuutin arvo on ylittänyt kynnyksen (arvo on kynnystä pienempi).

  • Käyttöraja ylitetty: ei-kriitisen attribuutin arvo on ylittänyt kynnyksen (arvo on kynnystä pienempi).

Sarakkeessa Data näkyvät mitatut arvot. Näitä arvoja ei ole arvioinut kiintolevy. Päinvastoin sarakkeessa Arvo on arvioitu lukema, joka riippuu valmistajasta ja kiintolevystä. Nämä arvot näytetään heksadesimaalimuodossa. On mahdollista valita desimaaliarvot valikosta, joka ilmestyy kun napsauttaa hiiren oikealla taulukkoa S.M.A.R.T.

Kun tutkii levyn kuntoa ja laskee kuntoarvoa, on suositettavaa tarkistaa raw-arvot , koska näin on mahdollista saada objektiivinen, valmistajasta riippumaton kuva kiintolevyjen tilasta.

Sarakkeesta Siirtymä on mahdollista määrittää siirtymäarvo (positiivinen tai negatiivinen). Hard Disk Sentinel lisää (vähentää) tämän lukeman attribuuttiin arvioidessaan sitä. Tätä voi käyttää esim. proseduurissa lämpötilan kalibrointi. Siirtymäarvoa voi säätää on monin valinnoin:

  • Käyttäen kuvakkeita - ja +: lukema pienenee tai suurenee yhdellä.

  • Napsauttaen numeroa kuvakkeiden välissä: numeron voi säätää suoraan pikkuikkunassa.

  • Jos valitaan sopiva attribuutti, nappeja + ja - sekä näppäintä ENTER voi käyttää siirtymäarvon säätöön.

Huomaa: on suositettavaa säätää siirtymä suoraan napsauttaen numeroa tai painaen ENTER.

Valintaruutua sarakkeessa Aktivoi voi käyttää aktivoimaan/passivoimaan attribuutti. Jos attribuutti passivoidaan, se ei anna lukemia kunto- ja suoritustehoarvoihin. Passivoitujen attribuuttien muutokset (heikkenemiset) eivät tallennu kiintolevyn lokiin. Tästä syystä minkään attribuutin passivointi EI ole suositettavaa.

Huomioi: jos käyttää siirtymiä ja Aktivoi-valintoja, kiintolevyn tila ehkä näytetään virheellisesti tai epätarkasti. Vain kokeneiden käyttäjien tulisi modifioida mitään näistä valinnoista.

Huomaa: siirtymien ja Aktivoi-valintojen muutokset tallenetaan vain rekisteröidyssä versiossa. Jos käyttää rekisteröimätöntä versiota, sellaisten valintojen muutokset hylätään automaattisesti, kun sovellus käynnistetään uudelleen.

Sanallinen kuvaus (ilmentäen attribuutin merkitystä ja tärkeyttä) esitetään vihjeenä, kun viedään hiiri attribuutin päälle. Oikea napsautus taulukon päällä tuo esiin ponnahdusvalikon, jossa on valinta säilyttää tämä kuvaus nähtävissä kunkin attribuutin osalta. Täydellinen lista tunnetuista S.M.A.R.T. -attribuuteista on kuvattuna liitteessä.

Käyttäen hiiren oikeaa painiketta on mahdollista kopioida taulukon tiedot leikepöydälle. Myöhemmin on mahdollista liittää nämä tiedot tekstitiedostoon, s-postiin tai dokumettiin.

Attribuuttigraafi

Taulukon alapuolella näkyy juuri valitun S.M.A.R.T. -attribuutin graafinen historia. Tästä graafista on mahdollista tutkia attribuutin muutoksia. Graafin päätepisteet kuvaavat attribuutin ensin mitattua arvoa (asennuspäivänä) ja viimeisintä (nykyistä) arvoa. Kaikki muut näiden kahden päiväyksen väliset päivät on valittu automaattisesti.

Graafin vieressä näkyvät attribuutin tilaliput. Kaikilla attribuuteilla voi olla yksi tai useampia tilalippuja. Ne ilmaisevat attribuutin päämerkitystä. Niitä voivat olla:

  • Kriittinen: arvo voi ratkaisevasti vaikuttaa kiintolevyn kuntotilaan (esim. erityisvaratulle alueelle siirrettyjen sektorien määrä).

  • Tilastollinen: arvo ei vaikuta suoraan tai epäsuorasti tilaan (esim. virtasyklien määrä).

  • Suoritusteho: arvo voi vaikuttaa suoritustehoon tai nopeuteen (esim. virran päälläoloaika, hakuaika).

  • Virhetaajuus: yleensä korjauskelpoisia attribuutteja, jolloin arvo ei suoraan vaikuta kiintolevyn kuntoon (esim. hakuvirheaste).

  • Tapahtumalukema: lukema-arvo, kasvaa kun ilmaantuu joitain tapahtumia tai ongelmia (esim. löytyy uusi huono sektori).

  • Itsesuojaus: attribuutin arvoa tarkkaillaan jatkuvasti.

Attribuuttien graafiset esitykset

On mahdollista näyttää kahta eri lajia numeroita. Oletuksena on valittuna Näytä tietokenttä, jolloin näytetään valmistajasta riippumattomat raw-numerot. Oletusmoodin voi valita asetussivulta Lisävalinnat. Metodien välisiä eroja kuvataan täällä.

Näytä tietokenttä

Nämä arvot kasvavat ongelman sattuessa, koska niihin itse asiassa sisältyy ongelmien (esim. huonojen sektorien) tai tapahtumien määrä. Graafi on ideaalinen, jos suuntaus on paikallaan oleva.

Monet attribuutit (esim. virran päälläoloaika, aseman virtasyklien määrä jne.) ovat alati kasvavia. Tämä tekee myös näiden attribuuttien graafisuuntauksesta kasvavan, mutta se on täysin normaalia. Joillain (etenkin tilastollisilla) attribuuteilla määrä voi olla hyvin korkea ja sitten se voi pudota, mikä myös on normaalia. Graafi on tärkeä kriittisillä attribuuteilla (esim. uudelleenvarattujen, huonojen sektorien määrä), jolloin edellisten arvojen analysointi voi paljastaa levyn elinkaaren ongelmapäiviä tai -kauden.

Näytä valmistajan määrittämät arvot

Tutkimalla lukemien määrää sarakkeessa "Arvo", on mahdollista tarkistaa valmistajasta riippuvien arvojen suuntaus. Nämä arvot pienenevät ongelman sattuessa, kunnes ne saavuttavat attribuutin kynnysarvon. Jos attribuutti on kriittinen ja kynnys on saavutettu, levyllä on S.M.A.R.T. -ongelma. Tässä vaiheessa kiintolevy tulisi välittömästi korvata. Tällaisessa tilanteessa valmistajan pitäisi korvata levy takuuehtojen mukaisesti.

Attribute trend: estimated reach of threshold

Tumman sininen viiva yhdistää todelliset mitatut arvot. Graafin alaosassa näkyy kynnys keltaisena viivana.

Jos suuntaus on pienenevä, purppuraviiva yhdistää viimeksi mitatun arvon kynnykseen. Tämä viiva on piirretty perustuen edellisiin arvoihin (sininen viiva). Se osoittaa kiintolevyn arvioitua heikentymistä tulevaisuudessa: jos attribuutin arvo pienenee kuten edellä, voi helposti nähdä kynnyksen ylityspäivän (kun arvo saavuttaa kynnystason).

Esimerkiksi (katso kuva yllä) on mahdollista nähdä, että kiintolevy on ensi kerran tutkittu 28. lokakuuta 2006. Tällöin uudelleenvarattujen sektorien arvo oli 100. 9. marraskuuta 2006 tämä arvo oli vain 95 (johtuen monista uudelleenvaratuista sektoreista arvo muuttui 100:sta 95:een). Jos tämä suuntaus jatkuu, tämä attribuutti saavuttaa kynnyksensä (36) 31. maaliskuuta 2007 (se näkyy myös oikealla puolella, jolloin se on helpompi nähdä). Se tarkoittaa että sinä päivänä (tai pikemmin) kiintolevy täytyy korvata johtuen kiintolevyvikojen enenevästä määrästä.

Kahden metodin väliset erot kuvataan täällä.

Huomautus SCSI-kiintolevyihin liittyen. S.M.A.R.T. -paneeli sisältää SCSI-kiintolevyn tarjoamia tilastollisia tietoja (esim. luetut/kirjoitetut tavut yhteensä, luku/kirjoitusvirheiden yhteismäärä jne.). Listan alla olevaa graafia voi käyttää minkä tahansa sellaisen attribuutin suuntauksen tutkimiseen.

Napsauta S.M.A.R.T. -taulukon ja graafin välillä sekä vedä hiirellä muuttaaksesi paneelien kokoa.


Tiedot

Sivulla Tiedot näkyy paljon tarkkoja tietoja kiintolevystä. Näihin kuuluvat monien muiden lisäksi: valmistaja ja mallin tyyppi, päivitys (sisäinen versio) ja kiintolevyn sarjanumero. Näitä voi käyttää todentamaan ja identifioimaan kiintolevy.

Levyyn assosioidut loogiset asemat ovat nähtävissä. Tästä voi olla apua, kun asennettuina on paljon kiintolevyjä ja järjestelmässä on monia loogisia asemia.

Hiiren oikeaa painiketta käyttäen on mahdollista kopioida leikepöydälle taukossa esitetyt tiedot. Myöhemmin on mahdollista liittää nämä tiedot tekstitiedostoon, s-postiin tai dokumenttiin.

IDE, Serial ATA -kiintolevy

IDE ja Serial ATA -kiintolevyjä kontrolloidaan ja identifioidaan via ATA-liitäntä. Hard Disk Sentinel paljastaa ja näyttää fyysiset ominaispiirteet (esim. sektorien yhteismäärän, virheenkorjaustavut jne.). Puskurin koko voi olla tärkeä: se on sisäisen levyvälimuistin koko. Kun suoritusteho on tärkeää, on suositettavaa käyttää suuremman puskurikoon kiintolevyjä.

Maximum ja parhaillaan valittu Ultra DMA -moodi ovat nähtävissä. Jälkimmäinen määrittää nykyisen teoreettisen datan maksimisiirtonopeuden levyn ja isännän välillä. Suurempi arvo on tietysti parempi.

Jos tämän hetkinen Ultra DMA -moodi on (0), järjestelmä ei käytä Ultra DMA -siirtomoodia ja toimii vain PIO (Programmed I/O) -moodissa. Tämä vähentää drastisesti levyn ja koko järjestelmän suoritustehoa, koska prosessorin täytyy odottaa joka luku/kirjoitustoiminnon valmistumista. On suositettavaa tutkia asetukset ja korjata tämä ongelma (esim. järjestelemällä uudelleen kiintolevyt ja optiset laitteet tai käyttämällä uusia kaapeleita). Ultra DMA -moodi 33 (2) tarkoittaa, että jossain liitetyssä vanhassa IDE-kaapelissa on vain 40 johdinta, kun sen sijaan uudemmissa IDE-kaapeleissa on 80 johdinta. Ei ole suositettavaa käyttää pyöreitä tai liian pitkiä kaapeleita.

Huomaa: joillain ohjaimilla tai järjestelmillä on mahdollista, että asema toimii PIO-moodissa, vaikka aiemmin valittiin Ultra DMA -moodi ja tämä näkyy tässä ikkunassa. Ellet ole varma, mutta havaitset suoritustehon hitaaksi, todenna nykyinen asetus laitehallinnassa valitsemalla (IDE-) ohjaimen ominaisuudet.

Huomaa: Hard Disk Sentinel tarkistaa, onko ATA-tietojen taulukko täydellinen ja taulukon tarkiste oikein. Jälkimmäinen varmistaa että selvitetyt ja esitetyt tiedot ovat oikein. Ellei tämä ole tosi, on mahdollista että jotkin kiintolevyn raportoimat arvot eivät ehkä ole oikein (esim. suoritustehon arvo, UDMA-siirtomoodi ja sarja-ATA-ominaisuudet). Näissä tapauksissa näkyy varoitus:

ATA control bytes

Epäkelpo ATA-ohjaustavu tai ATA-tarkistearvo eivät vaikuta kunnon ja lämpötila-arvojen selvittämiseen ja näyttämiseen.

Äänitason hallinta

Acoustic management of disks

On mahdollista tarkastella ja modifoida äänitason asetuksia, jos kiintolevy tukee tätä ominaisuutta. Korkeammat äänitasot mahdollistavat nopeamman (mutta äänekkäämmän). Asetus alemmalle tasolle tekee levystä hitaamman ja hiljaisemman (luku-kirjoituspään liike hidastuu ja hiljenee). Äänitason asetuksella ei ole vaikutusta aseman pyörintänopeuteen. Jos asema tukee äänitason hallintaa, on mahdollista muuttaa tasoa napsauttamalla Säädä.

Tärkeimmät ATA-ominaisuudet ovat nähtävissä, joten voi tarkastella lisätoimintoja (esim. turvamuotoa, virranhallintaa jne.).

S.M.A.R.T. -yksityiskohdat

S.M.A.R.T. self tests (hardware tests)

Kiintolevyn laiteitsetestien tulokset ja yksityiskohdat näkyvät tässä osastossa. Tuetut itsetestit voi suorittaa täällä napsauttamalla Aloita napsauttaen. Itsetestien arvioitu aika näkyy (valmistajan tuottamina arvioina), mutta itsetestit saattavat viedä paljon enemmän aikaa valmistuakseen, mitä esitetään. Lyhyt itsetesti testaa kiintolevyn pääkomponenttien (pään, servon, elektroniikan) toimivuutta. Valinnat Laajennettu itsetesti ja Tiedonsiirtoitsetesti (jos tuetut) suorittavat valmistajan määrittämät testivaiheet. Laajennettu itsetesti todentaa kiintolevyn koko pinnan. Tämän operaation aikana todennetaan ongelmalliset alueet (jos on), joten on suositettavaa suorittaa tämä testi ajoittain.

Testin aikana näytetään levyn tilaa osoittava ikkuna. Kun testi on valmis, näytetään onko levy kunnossa vai vialla (ja viallinen elemenentti, joka voi olla servo, elektroniikka, pää jne.). Itsetestin aikana kiintolevyä voi käyttää. Yleensä HDD:n LED on pimeänä, mutta voi palaa kiintolevyn toimiessa. Luku-/kirjoitustoiminnot testin aikana voivat hidastaa testiä - ja päinvastoin: testistä johtuen luku-/kirjoitustoiminnot voivat olla hitaampia, joten on suositettavaa suorittaa testi toimettomina kausina.

Huomaa: Laajennettuja ja Tiedonsiirron itsetestejä (jos tuetut) voi käyttää vain rekisteröidyssä versiossa.

SCSI-kiintolevy

Kiintolevyn identifiointiin vaadittavat tiedot SCSI-kiintolevylle ovat nähtävissä. Valmistajan tuottamat vianennakointitoiminnon merkkijono ja tila näytetään myös selvitetyin raw ASC- ja ASCQ-arvoin.


Äänitasot

Acoustic level configuration

On mahdollista katsoa tai muokata IDE/sarja-ATA-kiintolevyn ääniasetuksia, jos levy tukee tätä ominaisuutta. Korkeammat äänitasot mahdollistavat nopeamman (mutta äänekkäämmän) toiminnan. Säätö matalammalle tasolle tekee levystä hitaamman ja hiljaisemman (luku/kirjoituspään liikkeestä tulee hitaampi ja hiljaisempi). Äänitason säätö ei vaikuta aseman pyörintänopeuteen.

Jos levy tukee on mahdollista modifoida äänitasoa tässä ikkunassa. Liukusäätimellä käyttäjä voi valita, mikä on tärkeää hänelle (hiljaisen tai nopean toiminnan tai hän voi valita tasapainon ääripäiden välillä). Suositettu äänitaso (valmistajan määrittämä) on nähtävissä. Äänitason säätö ei vaikuta kiintolevyn kuntoon.

Jos kahta tai useampaa kiintolevyä testataan ja vertaillaan (esim. benchmark-vertailutestissä), kaikilla levyillä pitää olla säädettynä sama äänitaso (esim. nopein tai hitain) tarkkojen tulosten saamiseksi.

Huomaa: äänitason säätö riippuu suuresti isännän (ohjaimen, emolevyn) kyvyistä ja asennetuista ajureista. Jos ohjain tai ajuri ei tue tätä ominaisuutta, näkyy virheilmoitus ja äänitaso ei muutu. Toivottavasti yhä useammat valmistajat kehittävät tämän ominaisuuden ohjaimiin ja ajureihin.


Loki

Hard Disk Sentinel ylläpitää lokia jokaisesta järjestelmään asennetusta kinntolevystä. Tähän lokiin tallennetaan tärkeimpien S.M.A.R.T. -attribuuttien datakentän heikkenemiset. Näitä attribuutteja ovat:

  • 5: Uudelleenvarattujen sektorien määrä.

  • 10: Pyörinnän uudelleenyritysten määrä.

  • 196: Uudelleenvaraustapahtumien määrä.

  • 197: Epävakaiden sektorien nykyinen määrä.

  • 198: Offline-korjauskelvottomien sektorien määrä.

  • 199: Ultra ATA CRC -virheiden määrä (tiedonsiirtovirheet).

Ellei kiintolevy vastaa Hard Disk Sentinelin kyselyyn pitkään aikaan, sekin kirjataan (jos tämä toiminto aktivoidaan lisävalinnat-sivulla).

Kaikilla syötteillä on tarkka päiväys ja aika, attribuutin tunniste sekä attribuutin aiemmat ja uudet raw-arvot. On mahdollista että kaksi tai useampia attribuutteja on muuttunut edellisen havainnoinnin jälkeen (etenkin jos Hard Disk Sentinel käynnistetään vain satunnaisesti) luoden kaksi tai useampia syötteitä samaan aikaan.

On mahdollista säätää sovellus lähettämään/tekemään hälytys, jos lokiin on lisätty uusi merkintä. Tällä tavoin jos Hard Disk Sentinel on paljastanut jonkin uuden ongelman (joka voi muuttaa levyn kuntoa), se voi antaa siitä käyttäjälle hälytyksen. Tämä ominaisuus on käytettävissä vain rekisteröidyssä versiossa.

On mahdollista passivoida joitain attribuutteja levyn S.M.A.R.T. -sivulla käyttäen sarakkeen "Aktivoi" alla olevaa valintaa. Passivoitujen attribuuttien muutoksia ei tallenneta lokiin (ne eivät synnytä hälytyksiä) eivätkä ne vaikuta levyn kuntoarvoon.

Huomaa: Lokin nykyinen versio tallentaa vain 50 viimeisintä ongelmaa. Tämän jälkeen vanhimmat ongelmat poistetaan lokista.


Tosiaikainen suoritusteho

Tällä sivulla näkyy siirretyn (luetun ja kirjoitetun) datan määrä sekä nykyisessä sessiossa että asennuksen jälkeen. Tätä käyttäen näkyvät myös päivittäisen kirjoituksen ja lukemisen määrän keskimääräiset arvot.

Hard Disk Sentinel tarkkailee jatkuvasti nykyisiä kirjoitus- ja lukunopeuksia ja tarkistaa, miten nykyinen käyttöaste stressaa kiintolevyä. Tämä näytetään prosenttiarvona (%), aivan kuten käyttäjä voi tarkastella CPU:n käyttöä tehtävienhallinnassa.

Kun Hard Disk Sentinel havaitsee kirjoitustoiminnon, näkyvät punainen "led" ja nykyinen kirjoitusnopeus. Lukutoiminnon tapauksessa näkyvät lukunopeus ja vihreä "led". Nämä värit eivät tietenkään riipu kiintolevyn kuntotilasta.

Pohjautuen nykyiseen siirtonopeuteen ja nykyiseen levyn käyttöasteeseen sovellus arvioi mahdollisen (teoreettisen) maksimisiirtonopeuden, mikä voidaan saavuttaa lyhytaikaisena piikkinä. Tämä arvo lasketaan tällä kaavalla: (arvioitu maksimisiirtonopeus) = (nykyinen siirtonopeus) / (nykyinen levyn käyttöaste %). Esim. jos levy siirtää dataa 20 MB/s ja nykyinen levyn käyttöaste on 50%, niin arvioitu maksimisiirtonopeus on 40 MB/s. Tarkkuuden lisäämiseksi levyn matalalla käyttöasteella lasketut arvot jätetään automaattisesti huomiotta. Tämä on teoreettinen maksimiarvo. Jotkin laitteet, välimuistit tai muut sovellukset voivat vaikuttaa tähän arvoon.

Nykyinen levyn siirtonopeus- ja levyn käyttöastegraafit voivat olla hyödyksi monissa tapauksissa. Esimerkiksi:

  • Käytettäessä kahta tai useampaa kiintolevyä voidaan tutkia, mitkä levyt ovat aktiiviset ja millä nopeudella ne toimivat. Esim. jos järjestelmä on asennettu ensimmäiselle kiintolevylle ja toisella kiintolevyllä on sovellus, joka synnyttää valtaisan liikenteen, sovelluksen käyttöasteen voi tarkistaa helposti. Jatkuvan kuormituksen alaisen järjestelmäkiintolevyn nykyistä käyttöastetta voi myös tutkia paljastaen näennäimuistin liian suuren käytön.

  • Kahden eri kiintolevyn välisen kopioinnin aikana voi vertailla näiden kahden levyn siirto- ja yleistä nopeutta ja tämä saattaa paljastaa, kumpi asema toista hitaampi.

  • Poltettaessa dataa optiseen tallentimeen voi todentaa datan todellisen siirtonopeuden (polttonopeuden) ja tarkistaa, miten suuri levyn käyttöaste on. Matalahko levyn käyttöaste merkitsee, että voidaan valita korkeampi polttonopeus.

  • Palvelimessa (valtavasti kuormitetussa tiedosto- tai tietokantapalvelimessa) on mahdollista tutkia levy(je)n käyttöastetta ja siirtonopeutta. Tämä auttaa ylläpitäjää päättämään, tarvitaanko uusi (nopeampi) kiintolevy siinä tapauksessa, että lisätään uusia asiakkaita.

  • Jos jatkuvan nopean operaation aikana (esim. poltettaessa DVD:tä) levyn käyttöaste nousee ja laskee jatkuvasti (graafissa on monta piikkiä), kiintolevyn data voi olla hyvin pirstaloitunutta ja eheytys on suositettavaa (myös liian korkea näennäimuistin käyttö voi aiheuttaa tämän ongelman).

Huomaa: tosiaikaisen suoritustehon tarkkailu riippuu nykyisestä käyttöjärjestelmästä. Se ei ole käytettävissä Windows 95/98/ME:ssä. Tämä toiminto ei ole tuettu joissain ulkoisissa levyissä (esim. muistitikussa ja muistikortissa).


Hälytykset

Kiintolevyn tuottamat hälytykset on listattu tälle sivulle.

Lista sisältää sekä tapahtumatyypin (ylikuumeneminen, alhainen kunto, ennakoitu virhe jne.) että tapahtumapäivän.

Vain tapahtumat joihin on assosioitu ainakin yksi hälytys (äänihälytys, s-post jne.) kirjautuvat ja näkyvät tässä listassa.


Looginen asema

Logical drive information

Valitun loogisen aseman tarkat tiedot näkyvät paneelissa Tiedot sisältäen assosioidut fyysiset kiintolevyt (raitasarjoitetun tai peilatun taltion kyseen ollen looginen asema voidaan assosioida useampiin fyysisiin levyihin). Näitä tietoja ovat taltion tyyppi, nimi ja sarjanumero. Tässä ikkunassa ovat myös tiedot kokonais- ja vapaasta tilasta.


Asetukset

Tätä ikkunaa käyttäen on mahdollista muokata Hard Disk Sentinelin valintoja. Valinnat on järjestetty eri kategorioihin, jotka näkyvät ikkunan vasemmassa reunassa. Jonkin kategorian napsautus tuo esiin vastaavat valinnat oikealla puolella ohjaussivulla. Kategoriat ovat:

  • Kiintolevyasemat

  • Valinnat

  • Tilaikkuna

  • Kynnykset / ilmaisinaluekuvake

  • Hälytykset

  • Viestiasetukset

  • S-postin asetukset

  • Rekisteröinti

  • Päivitys

  • Lisävalinnat

  • Levyn hallinta

  • Pikanäppäimet

  • Operaatiot (vain jos PROFESSIONAL-versio on asennettu)

  • Integrointi

  • Testiraportin lähetys


Asetukset: Kiintolevyasemat

Hard disk configuration

Tällä sivulla näkyvät kaikki löydetyt kiintolevyt. Valitsemalla kiintolevyn numeron edessä olevan ruudun on mahdollista säätää, mitkä levyt näkyvät tilaikkunassa. Minkä tahansa kiintolevyn napsautus lisää/poistaa kyseisen kiintolevyn ilmaisinaluekuvakkeen.

On mahdollista näyttää vain yksi ainoa ylintä lämpötilaa osoittava ilmaisinaluekuvake. Näin kuvake voi vaihtua ja kuvastaa eri kiintolevyjä (koska lämpötila-arvot voivat vaihdella). Jos aktivoi tämän valinnan ja aktivoi myös kuntotilan merkin näyttämisen, näkyy alimman kuntotila-arvon symboli (vaikkei alimman kuntoarvon omaava kiintolevy olekaan sama kuin ylimmän lämpötilan omaava kiintolevy).

Huomaa: jos vie hiiriosoittimen ilmaisinaluekuvakkeiden päälle, assosioidun kiintolevyn tarkat tiedot näytetään pienessä vihjeikkunassa.

Napsauttamalla hiiren oikealla painikkeella mitä vain kiintolevyä, näytetään kiintolevyn paikallinen valikko (katso kuva yllä). Tästä valikosta on mahdollista näyttää tai piilottaa levyn kuvake ilmaisinalueella tai saada kiintolevyn tarkat tiedot (mikä tahansa tietosivu). Lisäksi tästä valikosta voi avata äänitason hallinnan (jos kiintolevy tukee tätä ominaisuutta).


Asetukset: Valinnat

On mahdollista säädellä Hard Disk Sentinelin joitain yleisvalintoja.

Näytä tilaikkuna käynnistettäessä: tilaikkunan tulisi tai ei tulisi ilmestyä automaattisesti, kun sovellus käynnistyy. Tilaikkunan piilotus tai näyttö muuttaa myös tämän valinnan (jos ikkuna on piilotettu ja sovellus käynnistetään uudelleen, tilaikkuna ei näy automaattisesti).

Lataa Windowsin mukana: tulisiko Hard Disk Sentinelin käynnistyä joka kerta, kun Windows käynnistyy. On suositettavaa käyttää tätä toimintoa, koska näin kiintolevyjen tilaa analysoidaan jatkuvasti.

Näytä pääikkuna käynnistettäessä: näytä automaattisesti pääikkuna, kun sovellus käynnistyy. Huomaa: tämän valinnan voi passivoida vain rekisteröidyssä versiossa. Rekisteröimättömässä versiossa pääikkuna ilmestyy automaattisesti joka kerta käynnistettäessä.

Näytä sovellus sekä tehtäväpalkissa että ilmoitusalueella: jos Hard Disk Sentinelin mikä tahansa ikkuna on auki (paitsi tilaikkuna), sovellus näkyy tehtäväpalkissa muiden aktiivisten sovellusten vieressä. Jos valinta poistetaan, vain ilmaisinaluekuvakkeet näkyvät kellon vieressä, vaikka sovelluksen yksi tai useampia ikkunoita olisi auki.

On mahdollista valita kieli, jota käyttävät liittymä ja kaikki raportit, s-postit ja ilmoitukset. Lämpötilayksikkö (Celsius tai Fahrenheit) voidaan valita ja on mahdollista valita siirrettävän datan yksikkö (MB, GB or TB), jota käytetään kaikkien kiintolevyjen tietosivulla suoritusteho.


Asetukset: Tilaikkuna

Status window configuration

Tilaikkunan ulkoasua voi muokata tällä sivulla. Käyttäjä voi valita minkä tahansa värin tai kuvan käyttääkseen sitä tilaikkunan taustana. Valinnan voi tehdä käyttäen sopivaa "Valitse" -nappia. Valittu väri tai kuva näkyy esikatseluna oikeassa yläkulmassa. Huomaa: kun käytetään kuvaa taustana, kuva venytetään automaattisesti tilaikkunaan sopivaksi.

Jos valinta Tartu näytön reunoihin on aktivoitu, tilaikkunaa ei voi siirtää näytön ulkopuolelle. Sen sijaan ikkuna tasautuu näytön reunaan siirrettäessä lähelle jotain reunaa. Jos tämä valinta poistetaan, ikkuna voidaan siirtää (osittain tai täysin) näytön ulkopuolelle.

On mahdollista säätää tilaikkunan läpinäkyvyys (jos käyttöjärjestelmä tukee tätä) ja käyttäjä voi valita mieleisensä fontin tyypin, koon ja värin. On suositettavaa käyttää harkittuja asetuksia helposti luettavuuden takia (ottaen huomioon käyttäjän mieltymykset sekä ympäristön valon ja kontrastin), mutta ikkunan koko ei saisi häiritä käyttäjää työssään.

On mahdollista lähettää hiirinapsautukset tilaikkunan alla olevaan ikkunaan. Näin tilaikkuna ei ota vastaan mitään hiirinapsautuksia ja vetotoimintoja. On parasta yhdistää tämä valinta läpinäkyvyys-valinnan kanssa - tällöin on mahdollista napsauttaa tilaikkunan alla olevaa ikkunaa. Huomaa: jos aktivoidaan tämä valinta, tilaikkunaa ei voi siirtää tai valita. Ilmaisinaluekuvaketta voi käyttää sovelluksen ominaisuuksiin käsiksi pääsemiseen.

Kaikki tilaikkunan tiedot voi näyttää suoraan työpöydällä. Data näkyy kaikkien muiden ikkunoiden "alla" ja tietoja voi tarkastella napsauttamalla kuvaketta Näytä työpöytä. Käyttämällä X ja Y -koordinaatteja, on mahdollista säätää tietojen sijainti. Huomaa: tiedot näkyvät työpöydän pikakuvakkeiden ja kuvakkeiden päällä, joten on suositettavaa määrittää tiedoille tyhjä alue. Valinnat "active desktop" ja "näytä web-sivu" tulisi poistaa tämän ominaisuuden käyttämiseksi. Huomaa: tämä toiminto saattaa käyttää intensiivisesti prosessoria , joten ei ole suositettavaa käyttää sitä hitaammissa tietokoneissa.

Valitsemalla Täysin läpinäkyvä tausta tilaikkunan tausta voi olla täysin läpinäkyvä - jolloin tilaikkunan alla oleva ikkuna on näkyvissä kirjainten ja kuvakkeiden välitse. Jos tämä valinta aktivoidaan, tilaikkunaa ei ehkä voi piilottaa napsauttamalla punaista X:ää, mutta pikanäppäimiä voi käyttää näyttämään/piilottamaan ikkuna.

Tilaikkunassa olevasta jokaisesta kiintolevystä on näyttää lista mahdollisia kohtia. Huomaa: säädellyt kohdat näkyvät myös vihjeikkunassa, jos hiiri viedään ilmaisinaluekuvakkeen päälle.

Windows Vistassa on mahdollista käyttää Vista gadgetia (vimpainta) näyttämään kiintolevyn tietoja (esim. lämpötila ja kunto). Gadgetin visuaalista ulkoasua (väri, fontti, näytettävät kiintolevyt) voi säätää tilaikkunan valinnoilla.


Asetukset: Kynnykset / ilmaisinaluekuvake

Configuration: Asetukset: Kynnykset / ilmaisinaluekuvake

Thresholds and tray icon settings

Tällä sivulla on mahdollista säätää ilmaisinaluekuvakkeiden visuaalinen ulkoasu. Oletuksena kuvake näyttää kiintolevyn nykyisen lämpötila-arvon (ja kuntosymbolin: Alerts vaihtuen jos kuntoarvo on alle säädetyn kynnyksen).

Värit voi säätää kolmelle eri portaalle: on mahdollista säätää edusta- ja taustaväri matalalle lämpötilalle (vihreä taso), korkealle lämpötilalle (punainen taso) sekä matalan ja korkean asetuksen väliselle lämpötilalle (keltainen taso). Kynnysarvoja matalalle ja korkealle lämpötilalle voi säädellä tällä sivulla. Mikä vain tausta- tai edustaväri voi olla läpinäkyvä. Tästä syystä määritä Pun=254, Vihr=254, Sin=255 valintaikkunassa "Määritä mukautetut värit". Tästä väristä tulee läpinäkyvä sekä tilaikkunassa että ilmaisinaluekuvakkeessa.

On mahdollista näyttää myös kuntoa osoittava symboli ilmaisinaluekuvakkeessa. Se voi olla Green (täydellinen, kun kunto erinomainen), Red (kehno, kun kunto alhainen) tai Yellow (tyydyttävä, kahden kynnyksen välillä). On mahdollista valita, milloin näyttää kuntosymboli - esim. vain jos kunto on liian alhainen.

Jos sekä lämpötilan että kuntosymbolin näyttö aktivoidaan, nämä kaksi kuvaa näkyvät vuoroin (yksi sekunti lämpötilan näyttöön ja yksi sekunti nykyisen kuntoarvon näyttöön). Tämä "välkyntä" saattaa kiinnittää käyttäjän huomion - mutta se voi olla häiritsevää. On suositettavaa säilyttää oletusasetus: välkyttää ilmaisinaluekuvaketta vain ongelmatapauksessa.


Asetukset: Hälytykset

Hard Disk Sentinelin tärkeimpiä ominaisuuksia on tehdä hälytyksiä tai suorittaa tehtäviä, kun paljastuu ongelma. Näin ongelmat voi tunnistaa ja välttää sekä käyttäen automaattisia tehtäviä tiedostot voi arkistoida datan menetyksen estämiseksi. Monet eri tehtävät voi yhdistää mihin tahansa ongelmaan.

Kun vaurio odotettavissa: tämä tapahtuu kiintolevyllä, jos jokin kriittinen S.M.A.R.T. -parametri on ylittänyt valmistajan määrittämän kynnyksen. Tässä vaiheessa kiintolevy pitäisi välittömästi korvata. Huomaa: tällöin kiintolevyn kunto on jo alentunut 0%:iin. Huomaa: tämä toiminto on käytettävissä vain rekisteröidyssä versiossa.

Kun levyn kunto on alhainen: tämä tapahtuu kiintolevyllä, jos kuntoarvo on alempi kuin säädetty keltainen tai punainen taso. Huomaa: tämä toiminto on käytettävissä vain rekisteröidyssä versiossa. Rekisteröimättömässä versiossa voi valita vain keltaisen tason aiheuttamaan hälytyksen.

Kun lämpötila on korkea: tämä tapahtuu kiintolevyllä, jos lämpötila nousee yli säädetyn keltaisen tai punaisen tason. Huomaa: tämä toiminto on käytettävissä vain rekisteröidyssä versiossa. Rekisteröimättömässä versiossa voi valita vain keltaisen tason aiheuttamaan hälytyksen.

Kun lisätään uusi lokimerkintä: tämä tapahtuu kiintolevyllä, kun kriittinen S.M.A.R.T. -attribuutti alenee ja tämä ongelma kirjautuu kiintolevyn lokiin. Huomaa: tämä toiminto on käytettävissä vain rekisteröidyssä versiossa.

Kun vapaata levytilaa on niukasti: tämä tapahtuu loogisella asemalla, jos vapaan tilan määrä on alle säädetyn kynnyksen. Huomaa: tämä toiminto on käytettävissä vain rekisteröidyssä versiossa. On mahdollista säätää vapaan levytilan kynnys yleisesti (yksi asetus kaikille loogisille asemille) tai on mahdollista asettaa eri vapaan levytilan kynnykset kullekin loogiselle asemalle (käyttäen %:a tai megatavua yksikkönä):

Free space thresholds

On mahdollista valita käytettävä äänihälytys. Tämä voi olla mikä tahansa järjestelmän tukema äänitiedosto (esim. wav, mid, mp3, wma) ja Hard Disk Sentinel tulee käyttämään sitä hälytyksenä.

Jos aktivoidaan Toista äänihälytys, sovellus toistaa äänihälytystä jatkuvasti, kunnes käyttäjä vahvistaa äänihälytyksen poistamalla äänihälytykset (pikavalikosta tai pääikkunasta). Näin näytetään äänihälytysten syy(t) ja käyttäjä voi tutkia niitä, ennen kuin hän voi passivoida enemmät äänihälytykset. Tämän toiminnon käyttöä suositetaan palvelimissa, missä ei ole paikallista käyttäjää - mutta ihmiset saattavat huomata äänihälytyksen eikä etähälytys ole mahdollinen.

Valinta Käytä PC:n kaiutinta aktivoi sisäisen PC-kaiuttimen ("piipparin") käytön äänikortin sijaan. Näin ei ole tarpeen liittää ulkoisia kaiuttimia tietokoneeseen. Tämän toiminnon käyttö on suositettavaa palvelimissa (yhdistettynä edelliseen valintaan). Huomaa: jos tämä toiminto aktivoidaan, äänihälytys tulee olemaan kaksinkertainen 1000 Hz:n "piip-piip" ulkoisilla kaiuttimilla soitetun äänitiedoston sijaan. Huomaa: joissain tietokoneissa (etenkään kannettavissa) ei ehkä ole PC-kaiutinta. Varmistu aina että järjestelmässäsi on kuultavissa äänihälytys.

Käyttämällä nappia Testaa äänihälytys on mahdollista testata säädetty äänihälytys (soita äänitiedosto tai käytä PC-kaiutinta). Ellei hälytystä kuulu, saattaa olla tarpeen tarkastaa kaapelit ja kaiuttimet tai muuttaa asetuksia.

On mahdollista lähettää ajoitetusti tilan s-posti, joka sisältää nykyiset asetukset ja kaikkien kiintolevyjen kuntotilan. Hard Disk Sentinel lähettää automaattisesti s-postin myöhemmin, ellei s-postia voi lähettää säädettyyn aikaan johtuen siitä, että tietokone ei ollut toiminnassa tai verkko-ongelman vuoksi. Huomaa: tämä toiminto on käytettävissä vain rekisteröidyssä versiossa.

Jos valintaa Lähetä/näytä viesti käytetään mihin tahansa ongelmaan, viesti näytetään ja/tai välitetään riippuen säädetyistä viestiasetuksista.

Jos valinta Hätävarmistus aktivoidaan, säädetyt tehtävät suoritetaan automaattisesti, kun havaitaan jokin ongelma. On mahdollista määrittää eri tehtäviä koskien ongelmallista kiintolevyä. Huomaa: Tämä toiminto on käytettävissä vain PROFESSIONAL-versiossa.

Jos aktivoidaan valinta Sammuta, tietokone suljetaan (sammutetaan) automaattisesti enempien ongelmien estämiseksi. Tietysti sovellus odottaa muiden tehtävien valmistumista ennen tietokoneen sammutusta. On yksi minuutti aikaa jäljellä ennen sammutusta ja on mahdollista peruuttaa sammutus kyseisenä aikana.

Tärkeää: joka sessiossa kunkin kiintolevyn jokainen ongelma voi aiheuttaa hälytyksen vain kerran. Toisin sanoen jos kiintolevyn lämpötila saavuttaa keltaisen tason ja hälytys on aktivoitu keltaiselle tasolle, hälytykset suoritetaan (esim. soitetaan äänihälytys tai lähetetään s-posti jne.). Jos kiintolevy viilenee alle kynnyksen ja sitten lämpiää taas keltaiselle tasolle, mistä kiintolevy ei synnytä enää hälytystä. Näin on mahdollista välttää liiat hälytykset (esim. liian monien s-postien lähetyksen), jos kiintolevy on lähellä kynnystasoja. Tietysti jos jokin muu kiintolevy lämpiää keltaiselle tasolle - synnytetään uusi hälytys.

Aiemmin käsiteltyjen hälytysten lista tyhjätään joka päivä keskiyöllä. Se tarkoittaa että pitkän aikaa (ehkäpä viikkoja) käynnissä oleva tietokone (palvelin) saattaa tehdä hälytyksen per kiintolevy joka ongelmasta joka päivä.

Aiemmin käsiteltyjen hälytysten lista voidaan tyhjätä milloin vain pääikkunasta.


Asetukset: Viestiasetukset

Kun havaitaan ongelma, Hard Disk Sentinel voi lähettää tai näyttää hälytyksensen. Tällä sivulla on mahdollista säädellä sellaisten hälytysten tyypit. Valintojem kaikki yhdistelmät ovat mahdollisia. Huomaa: ainakin yksi hälytystyyppi pitää valita.

Lähetä s-posti: ongelmatilanteessa Hard Disk Sentinel lähettää ongelmaa kuvaavan s-postin. S-posti lähetetään sivulla s-postiaseukset säädetyllä tavalla. On mahdollista valita numeerisesti oletusinternetyhteys ennen lähetystä (se voi olla välttämätöntä käytettäessä numerovalinta- tai DSL-modeemia) ja on mahdollista sulkea (katkaista) yhteys viestin lähetyksen jälkeen. Huomaa: jos sulje yhteys -valinta aktivoidaan, mutta yhteys on jo muodostettu ennen s-postin lähetystä (tietokone on jo yhdistetty), yhteys EI sulkeudu.

Käyttäjä voi valita s-postin tyypin. Tämä voi olla täydellinen HTML-raportti (sisältäen kuvia, kuitenkin alle 50 ktavua yhdestä kiintolevystä), täydellinen tekstiraportti (vain pelkkäteksti) tai lyhyt tekstiraportti. Jälkimmäinen on hyvin pieni ja nopea - käytännöllinen jos viesti on määrä välittää via s-posti -> SMS-yhdyskäytävä. Huomaa: valittu raporttityyppi lähetetään päivittäisen tilan s-postina. Myös valittu raporttityyppi (HTML tai teksti) tallennetaan tai lähetetään, kun käyttäjä napsauttaa vastaavaa pikapainiketta pääikkunassa.

On mahdollista säädellä yksityiskohtaiseen teksti- tai HTML-raporttiin sisällytettäviä elementtejä (jos käytössä on rekisteröity versio). Huomaa: huolimatta säädetyistä elementeistä XML-raportti sisältää kaikki kohdat.

Lähetä viesti etäkoneeseen: Hälytyksen voi lähettää verkon mihin tahansa tietokoneeseen (aivan kuin käytettäessä komentoa NET SEND). Sellaisten viestien lähettämiseksi tai vastaanottaniseksi viestipalvelun täytyy olla käynnissä sekä lähettäjä- että vastaanottajakoneessa. Käyttämällä nappia Valitse on mahdollista valita vastaanottajakone paikallisesta verkosta. Tämä voi olla hidasta suurissa verkoissa ja saattaa olla nopeampaa määrittää tietokoneen nimi suoraan (ilman \\ etuliitettä). On mahdollista lähettää testiviesti etätietokoneeseen yhteyden todentamiseksi.

Tärkeää: ellei etätietokoneeseen saa yhteyttä (se ei vastaa johtuen verkkokatkoksesta tai virtahäiriöstä), Hard Disk Sentinel lähettää viestit automaattisesti uudelleen joka 5. minuutti, kunnes välitys onnistuu (nykyisessä sessiossa). Jos käyttäjä käynnistää sovelluksen uudelleen, tämä uudelleenlähetystoiminto peruuntuu.

Huomaa: viestipalvelu tukee vain lyhyitä viestejä (254 merkkiin asti). Yleensä vastaanottaja (useimmiten käytönvalvoja) voi tästä infosta saada tietää vain ongelman kuvauksen ja lähettäjätietokoneen. Tällöin käytönvalvojan tulisi selvittää lähettäjätietoneen ongelmat. On suositettavaa ensin tarkistaa HDS_problem_log.txt-tiedosto Hard Disk Sentinelin kansiossa, koska siinä on tietoja aiemmista hälytyksistä. On mahdollista että jotkin (ei-standardit ASCII-)merkit näkyvät väärin välitetyssä viestissä).

Näytä viesti ruudulla: käyttämällä tätä valintaa viesti näytetään ruudulla. Valinnaisesti voidaa näyttää mukautettu viesti ennen ongelman kuvausta. Hard Disk Sentinel lukee tämän mukautetun viestin tekstitiedostosta ennen hälytyksen näyttämistä. Se on suositettavaa tietokoneissa, jotka eivät ole yhdistetyt verkkoon ja joissa etälähetysmetodit eivät ole mahdollisiaIt. Esim. mukautettu viesti voi olla "Voisitko soittaa käytönvalvojalle puhelimitse XX-XXXXX-XXX ja kertoa hänelle seuraavat tiedot:".

Huomaa: päivittäisen tilan s-posti voi olla vain s-posti huolimatta tällä sivulla valituista viestityypeistä.


Asetukset: S-postiasetukset

Tällä sivulla voit säätää s-postiviestin lähetykseen tarvittavat asetukset. Vaadittavat asetukset ovat:

  • Lähettäjän nimi: tämä tulee näkymään lähettäjänä (esim. tietokeen käyttäjän nimi).

  • Lähettäjän s-posti: lähettäjän s-postiosoite (esim. tietokoneen käyttäjän s-postiosoite).

  • SMTP-palvelin: käytettävän SMTP-palvelimen IP-osoite.

  • Vastaanottajan s-posti: ongelma/tila -sähköpostien lukijan (esim. käytönvalvojan) s-postiosoite. On mahdollista antaa kaksi tai useampia osoitteita pilkuin erotettuina (,)

  • Portti: ellei SMTP-palvelin käytä standardiporttia (25), sen voi määrittää tässä.

  • Käyttäjänimi, Salasana: jos vaaditaan todennus, kun lähetetään s-posti (sitä vaativat monet Internet-palveluiden tarjoajat), nämä tiedot voi syöttää tänne. Ellei todennus ole tarpeen, jätä nämä kentät tyhjiksi.

Kenttään S-postitili on mahdollista valita aiemmin muokattu Outlook- tai Outlook Express -sähköpostitili. Jos valitaan tili, niin kentät lähettäjän nimi, s-postiosoite, SMTP-palvelin ja käyttäjänimi (jos tarpeen) täytetään automaattisesti koskien s-postitilin asetuksia. Näin vaaditaan vain vastaanottajan s-postiosoite - ja salasana jos vaaditaan todentamista (turvasyistä salasana-kenttää ei täytetä automaattisesti).

Huomaa: on mahdollista ettei kaikkia määritettyjä s-postitilejä näytetä.

Huomaa: kaikkien valintojen asetuksen jälkeen on suositettavaa käyttää painiketta Postitustesti asetusten testaamiseksi tai paljastamaan mahdollisia s-postin lähetysongelmia.


Asetukset: Rekisteröinti

Kun rekisteröity versio on ostettu, rekisteröintikoodi lähetetään automaattisesti käyttäjälle. Tällä sivulla voi antaa rekisteröintikoodin Hard Disk Sentinelin rekisteröimiseksi ja aktivoimiseksi - sovelluksen kaikkien ominaisuuksien lukitusten poistuessa. Huomaa: peruslisenssi on saatavissa vain perusversioon. Se ei käy PRO-version aktivointiin. Päinvastoin, käytettäessä PRO-rekisteröintikoodia on mahdollista käyttää sekä perus- että PRO-version kaikkia ominaisuuksia.

Käyttäjän pitää valita ja antaa käyttäjänimi. Tämä voi olla mikä tahansa, kuten hänen oikea nimensä, lempinimensä, yhtiönsä nimi jne. Tämä nimi näkyy Tietoja-ruudussa rekisteröityneenä käyttäjänä. Tämän nimen voi vapaasti vaihtaa myöhemmin koska vain antamalla uudelleen rekisteröintikoodin ja painamalla mitä tahansa nappia "Rekisteröinti". Koska sovellus on jo aktivoitu, ei ole tarvetta mihinkään verkkoyhteydenottoon tai tiedostonsiirtoon.

Hard Disk Sentinel todentaa itse rekisteröintikoodin ja sitten koodi todennetaan online-rekisteröintipalvelimessa (tätä menettelyä kutsutaan aktivoinniksi). Sovellus rekisteröidään ja aktivoidaan, jos sekä sovellus itse että online-palvelin hyväksyvät koodin. Tämä on tarpeen estämään Hard Disk Sentinelin piraattikäyttö.

Jos tietokoneessa on Internet-yhteys, on suositettavaa käyttää online-aktivointimenetelmää. Tämän tekemiseksi napsauta painiketta Rekisteröinti ja aktivointi online sen jälkeen, kun käyttäjänimi ja (kelvollinen) rekisteröintikoodi on annettu. Aktivointi ei vie enempää kuin muutaman sekunnin, vaikka käytössä olisi kapeampikin kaistaleveys.

Ellei online-aktivointimenetelmä ole mahdollinen, pitää käyttää valintaa Rekisteröinti ja aktivointi s-postitse (sen jälkeen kun on annettu käyttäjänimi ja (kelvollinen) rekisteröintikoodi). Näin Hard Disk Sentinel luo tiedoston ja käyttäjän pitää lähettää se tiedosto (toisesta tietokoneesta) sähköpostissa osoitteeseen info@hdsentinel.hu ja lisänä vastaanotettu rekisteröintikoodi. Me lähetämme takaisin aktivoidun avaintiedoston, joka pitää kopioida Hard Disk Sentinelin asennuskansioon. Kun sovellus on käynnistetty uudelleen, kaikki rekisteröidyt ominaisuudet tulevat olemaan käytettävissä.

Huomaa: ellei rekisteröintikoodiasi ole toimittanut yhtiömme (ei kelvollinen) ja online-aktivointi tuottaa virheilmoituksen, älä yritä menetelmää aktivoida s-postitse. Rekisteröintipyynnöt virheellisin rekisteröintikoodein (tai täysin ilman rekisteröintikoodia) hylätään automaattisesti.

Huomaa: jos käyttäjän täytyy asentaa uudelleen käyttöjärjestelmä, Hard Disk Sentinelin voi asentaa ja aktivoida uudelleen niin monta kertaa, kuin käyttäjä haluaa, jos ensimmäisenäf asennettu kiintolevy on sama joka kerralla. Jos tämä (ensimmäinen) kiintolevy täytyy korvata, niin laillisesti sallittujen uudelleenaktivointien määrä vähenee yhdellät. Sen jälkeen tälle (uudelle) kiintolevylle käyttäjä voi taas asentaa ja aktivoida uudelleen niin monta kertaa, kuin hän haluaa. Hard Disk Sentinel voidaan yhdistää 5 (viiteen) eri ensisijaiseen kiintolevyyn (jos sinun pitää korvata ensimmäinen kiintolevysi kuudenteen, ota meihin yhteyttä jatkaaksesi lisenssiäsi). Toinen, kolmas tai mitkään lisälevyt tai muut komponentit eivät vaikuta mitenkään sovelluksen rekisteröintitilaan. Käyttäjä voi vapaasti lisätä/poistaa/korvata toisen tai lisäkiintolevyt.

Jos kaksi tai useampia käyttöjärjestelmiä asennetaan samaan tietokoneeseen, Hard Disk Sentinel voidaan asentaa, rekisteröidä ja aktivoida kaikissa näissä järjestelmissä.

Huomaa: CORPORATE-version käyttö tekee tästä asetussivusta tarpeettoman. Ei ole mahdollista muuttaa käyttäjänimeä tai napsauttaa mitään "Rekisteröi ja aktivoi" -painiketta, koska sovellus on jo rekisteröity ja aktivoitu heti asennuksen päätyttyä.

Jos asennuslisenssi voi vanhentua, päättymispäivä näkyy tässä ikkunassa. Ota yhteyttä tekijään jatkaaksesi lisenssiäsi, jos se on vanhentunut.


Asetukset: Päivitys

Hard Disk Sentinel voi päivittyä online-palvelimesta, jos päivitysversio on ladattavissa. Käyttäjä voi päättää käyttää automaattista (viikoittaista) päivitystä ja on mahdollista käyttää painiketta Tarkista uusi versio nyt päivitetyn version tarkistamiseksi ja lataamiseksi automaattisesti. Nähtävissä on päivämäärä, jolloin sovellus on viimeksi tarkistanut uuden version.

Sovellus sulkeutuu päivityksen ajaksi (ja tarkistettaessa uutta versiota). Ilmaisinaluekuvake, tilaikkuna ja kaikki muut avoimet ikkunat sulkeutuvat siksi ajaksi, kun päivitysmoduuli tarkistaa viimeisimmän version ja lataa sen, jos se on asennettua uudempi:

Updater is checking latest version

Huomaa: rekisteröitäessä ja aktivoitaessa PROFESSIONAL-versiota tämä moduuli on käynnissä ladatakseen arkistomoduulin. Myöhemmin myös tämä moduuli päivittyy, koska sovellus on jo rekisteröity.

Huomaa: onnistuneen päivityksen jälkeen käynnistyy uusi versio. Aiemmin käsiteltyjen hälytysten lista tyhjätään, jolloin mitkä tahansa säädellyt hälytykset voidaan lähettää taas.

Huomaa: päivitysmoduuli lataa vain viimeisimmät lopulliset (ei beta) versiot. Arviointi- (beta) versiot pitää ladata ja asentaa manuaalisesti.

Huomaa: rekisteröidyt käyttäjät voivat vapaasti päivittää uudempiin versioihin, samalla kun sovellus pysyy päivitysprosessin jälkeen rekisteröitynä (jos käytetään kelvollista rekisteröintikoodia sen rekisteröintiin).

On mahdollista varmistaa ja palauttaa nykyiset asetukset. Varmistus tallentaa nykyiset asetukset sisältäen kaikki valinnat ja projektiasetukset, aiemmat tilastot, lokit ja rekisteröintitiedot (rekisteröidyn käyttäjän ja aktivointitiedoston). Näin täydellisen uudelleenasennuksen jälkeen käyttäjän tarvitsee vain palauttaa aiemmat asetukset - ohjelma rekisteröityy automaattisesti ja kaikki aiemmat asetukset ja tilastot toimivat kuin ennen. On suositettavaa varmistaa säännöllisesti asetukset ja tilastot siirrettävälle medialle, mitä voi käyttää täydellisen uudelleenasennuksen yhteydessä.

Huomaa: jos laitteiston asetuksia muutetaan, on ehkä tarpeen aktivoida ohjelma uudelleen.

Huomaa: valinta varmista asetukset on käytettävissä vai rekisteröidyssä versiossa.


Asetukset: Lisävalinnat

Näitä valintoja tulisi modifioida vain kokeneiden asiantuntijoiden, koska nämä valinnat saattavat aiheuttaa järjestelmän virheellistä tai epäasianmukaista toimintaa.

Havainnointitaajuus: kiintolevyn tietojen kahden peräkkäisen havainnon välinen aika (selvitettäessä S.M.A.R.T. -tietoja lämpötilan, kunnon jne. näyttämiseksi). Oletuksena Hard Disk Sentinel selvittää näitä tietoja kerran 5 minuutissa. Liian monet kiintolevyt tai hitaat laitteet saattavat alentaa sovelluksen suoritustehoa ja kasvattaa vasteaikoja. Tällöin on suositettavaa vetää liukusäädin oikealle, This case it is recommended to drag the slider to right, mutta on mahdollista myös havainnoida taajempaankin. Huomaa: hyvin taajaan toistuvat havainnot (yksi per joka 1 - 5 sekunti) voivat alentaa suoritustehoa.

Kunnon laskentametodi: käyttäjä voi valita metodin laskea kunnon ja suoritustehon arvot kullekin kiintolevylle. On suositettavaa käyttää valintaa "Analysoi datakenttä" tai valintaa täsmällisempi analyysi datan turvallisuuden parantamiseksi. Täsmällisempää metodia suositetaan palvelimille, kannettaville tai tietokoneille, joissa on korkea levyn käyttöaste tai erittäin tärkeitä tietoja.

Aktivoi varoitus ellei kiintolevy vastaa: ellei kiintolevy vastaa Hard Disk Sentinelin paljastuksiin, luodaan lokimerkintä (mikä voi johtaa hälytykseen, ellei passivoitu). Sivulla levyn tiedot näkyy keltainen ja sitten punainen nimike ja ongelma. Tämän valinnan käyttöä ei suositeta kaikissa tapauksissa, vain kun se on todella tarpeellista (esim. jos käytössä Windows 98/ME).

Poista käytöstä automaattinen scandisk: tätä valintaa käyttäen on mahdollista poistaa käytöstä automaattinen levyn tarkistusproseduuri, joka ehkä käynnistyy Windowsin mukana. Tämä saattaa estää vioittuneen levypään tavoittavan virheellisesti ja vioittavan levyn stabiileja alueita.

Viive ennen scandiskia: jos aktivoidaan automaattinen levyn tarkastus, on mahdollista säätää, kuinka monta sekuntia järjestelmän tulisi odottaa ennen tämän toiminnon alkua. Tänä aikana käyttäjä voi perua levyn tarkastuksen painamalla mitä vain näppäintä.

Synkronoi tietokoneen kello atomikellon kanssa: tietokoneen kello synkronoidaan etäaikapalvelimeen käyttäen NTP:tä (Network Time Protocol) näyttämään oikeaa päivämäärää ja aikaa. Tämä on hyödyllinen määritettäessä hälytysten tarkkaa päivämäärää ja aikaa. Tämän valinnan käyttöä suositetaan, jos on asennettu PROFESSIONAL-versio ja säädetään aloittamaan ajoitetut varmistusprojektit. Huomaa: jos käytetään rekisteröimätöntä versiota, tämä valinta poistuu automaattisesti käytöstä sen jälkeen, kun kello on synkronoitu ensi kerran.

Luo ja päivitä XML-tiedosto: jos tämä aktivoidaan, niin kiintolevyn tarkat tiedot viedään automaattisesti erityiseen XML-tiedostoon, jota voi käsitellä toisella ohjelmalla. Oletuksena käytetään tiedostoa HDSentinel.xml, mutta se voidaan vaihtaa painamalla nappia Valitse. Viimeinen edellispäivänä tallennettu XML-tiedosto tallentuu varmistuskopiona BAK-tiedostopäätteellä. Huomaa: tätä toimintoa voi käyttää vain rekisteröidyssä versiossa.


Asetukset: Levyn hallinta

Hard Disk Sentinel tutkii jatkuvasti loogisten asemien (osioiden) käytettyä ja vapaata tilaa. Näillä tiedoilla on mahdollista näyttää käytetyn tilan määrä asemakuvakkeissa. Lisäksi nykyistä levyn kuntoa kuvaava merkki näkyy asemakuvakkeissa.

Muokkaa oletuskiintolevykuvakkeita: tällä valinnalla on mahdollista yleisesti aktivoida/passivoida kiintolevyjen laajennettujen kuvakkeiden käyttö. Jos tämä valinta on pois käytöstä, käytetään alkuperäisiä Windowsin asemakuvakkeita. Aktivoituna käytetään laajennettuja kuvakkeita: kuvakkeissa näkyvät käytetyn tilan määrä ja levyn kunto. Nämä kuvakkeet näkyvät kaikissa sovelluksissa mukaan lukien Resurssienhallinta.

Tarkkaile levytilaa verkkolevyillä: on mahdollista tarkkailla vapaan tilan tietoja myös etälevyillä ja päivittää nämä tiedot automaattisesti loogisten asemien paneeliin pääikkunassa.

Vaihda verkkolevyjen oletusjärjestelmäkuvake: verkko- (etä-) asemien kuvake kuvastaa selvityksen jälkeen niiden käytetyn tilan määrää.

Tarkkaile levytilaa siirrettävillä levyillä: on mahdollista tarkkailla vapaan tilan tietoja myös siirrettävillä levyillä (esim. muistitikuilla, ulkoisilla kiintolevyillä ja kortinlukijoilla) ja päivittää nämä tiedot automaattisesti loogisten asemien paneeliin pääikkunassa.

Vaihda siirrettävien levyjen oletusjärjestelmäkuvake: siirrettävien asemien kuvake kuvastaa selvityksen jälkeen niiden käytetyn tilan määrää.

Huomaa: etä- ja useimmilla siirrettävillä asemilla ei ole mahdollista selvittää S.M.A.R.T. -tietoja. Näin kuvake kertoo vain käytetystä/vapaasta tilasta muttei kunnosta.

Huomaa: etä- ja siirrettävien asemien levytilan tarkastus saattaa olla hidasta (etenkin ellei verkkoasema ole tavoitettavissa tai ellei kortinlukijaan ole asetettu korttia). On suositettavaa käyttää näitä valintoja vain, elleivät ne alenna järjestelmän ja sovelluksen suoritustehoa.

On mahdollista määrittää, mitkä asemat tulisi poissulkea levytilan tarkastuksesta ja minkä asemien tulisi säilyttää oletuslevykuvake. Listaa näiden asemien kirjaimet (ilman merkkiä : tai välilyöntejä) asianomaiseen kenttään.

Huomaa: Hard Disk Sentinel voi havaita ja modifoida kuvakkeita vain ollessaan käynnissä. Jos sovellus on suljettu, näkyvät aiemmat asemakuvakkeet (alkuperäiset järjestelmäkuvakkeet tai modifoidut kuvakkeet, jos jokin kolmannen tahon sovellus on ne muokannut).

Humaa: jotkin käyttöjärjestelmät (esim. Windows XP SP1) eivät ehkä näytä oikein kiintolevyjen kuvakkeita. Päivitä viimeisimpään huoltopakettiin (service pack) jos kohtaat tämän ongelman.

Valintaa Levykuvakkeen asetus käytetään määrittämään kiintolevykuvakkeiden tyyppi (XP tai Vista) käytettäväksi Resurssienhallinnassa. Kuvakkeet ilmaisevat kiintolevyn kuntotilan ja käytetyn levytilan.


Asetukset: Pikanäppäimet

Hot key configuration

On mahdollista suorittaa Hard Disk Sentinelin eräät toiminnot käyttäen pikanäppäimiä. Nämä ovat järjestelmän laajuisia pikanäppäimiä ja ne toimivat, vaikka olisi valittu ja aktivoitu toinen sovellus (paitsi jotkin sovellukset, esim. pelit saattavat estää pikanäppäinten käytön).

Käytännöllisimpiä ominaisuuksia pikanäppäimin tehtäviksi ovat näyttää tai piilottaa tilaikkuna, näyttää pääikkuna tai asetukset-ikkuna.

Pikanäppäimet ovat käytettävissä vain rekisteröidyssä versiossa.

Huomaa: jotkin pikanäppäinyhdistelmät eivät ehkä toimi kaikissa käyttöjärjestelmissä. Esim. Vista voi torjua näppäinyhdistelmät CTRL+ALT+Fx.


Operaatiot

Hard Disk Sentinel PROFESSIONAL pystyy luomaan automaattisia (varmistus-) operaatioita, ajoittamaan ne ja suorittamaan ne vikatilanteessa. Tätä ominaisuutta kuvataan seuraavissa luvuissa:

  • Projektit

  • Ajoitus

  • Paniikkivarmistus


Asetukset: Operaatiot

Nämä toiminnot ovat käytettävissä vain PROFESSIONAL-versiossa.

Käytettäessä Hard Disk Sentinel PRO -versiota on mahdollista määrittää monenlaisia tehtäviä (projekteja) ja ajoittaa ne säännöllisest suoritettaviksi. Määritetyt projektit voidaan suorittaa eräiden seikkojen tapahtuessa, esim. levyn kuntoarvon painuessa alhaiseksi. On mahdollista suorittaa kaksi tai useampia eri projekteja samanaikaisesti tai peräkkäin (ajaa projekti kun toinen projekti on valmistunut). Projektit ovat yleensä datan arkistointioperaatioita, mutta on mahdollista määrittää myös toisenlaisia projekteja.

Ensinnäkin, varmistusprojektille vaaditaan lyhyt, tiivistetty nimi (tätä ei voi muuttaa myöhemmin). Napsauttamalla nappia Uusi käyttäjä voi antaa tämän nimen ja projektin lähemmät annettavat tiedot ilmestyvät - kentät ovat nyt tyhjiä.

Käytettäessä nappia Poista juuri esillä olevan projektin voi poistaa projektien listasta, ellei sitä enää tarvita. Huomaa: jos projekti on assosioitu yhteen tai useampaan päivämäärään tai tapahtumaan, käyttäjän täytyy vahvistaa poisto-operaatio. Ole huolellinen poistaessasi projektin, johon on linkittynyt muita projekteja tietyssä järjestyksessä.

Käyttäjä voi antaa jonkin sanallisen kuvauksen projektin todellisesta toiminnosta kenttään Kommentti. Jos projekti vaatii vahvistuskysymyksen ennen toimeenpanoa, nimi ja tämä kommentti näytetään käyttäjälle - joka voi päättää, voiko projektin suorittaa vai tulisiko projekti perua.

Projektin tyyppi voi olla:

  • Aja ulkoinen sovellus tai eräajotiedosto: projekti käynnistää määritetyn ulkoisen sovelluksen, sisäisen komennon (esim. COPY) tai eräajotiedoston (BAT). Voidaan käyttää esim. pakkaamaan kansioita millä tahansa pakkausohjelmalla ja/tai polttamaan tiedostoja optiselle levylle käyttäen komentoriviltä ajettavaa CD/DVD-polttosovellusta. Sitä voi käyttää myös käynnistämään mikä tahansa muu sovellus esim. päivittämään jonkin antivirus-sovelluksen datakanta. Sovellus pitää määrittää kaikkine komentoriviparametreineen. On mahdollista valita sovellus käyttäen nappia Selaa. Sovelluksen nimi ja polku täytyy määrittää lainausmerkkien (") väliin, jos sovelluksen nimi tai sen polku sisältää yhden tai useampia välilyöntejä. Lisäparametrit voidaan määrittää sovelluksen nimen jälkeisen viimeisen lainausmerkin jälkeen. Esim.: "C:\Program Files\OmatOhjelmat kansio\OmaOhjelma.exe" parametri1 parametri2

    Jos käyttäjä valitsee Käynnistä piilossa näyttämättä ikkunaa, sovellus ajetaan hiljaisesti (näyttämättä sen ikkunaa).

    Jos valinta Hälytä virheestä aktivoidaan, annetaan hälytys ( Viestiasetusten) mukaisesti, jos ulkoinen sovellus tai BAT-tiedosto tuottaa muun lopetuskoodin kuin 0. Huomaa: käytettäessä BAT-tiedostoa komentoa EXIT xx voidaan käyttää määrittämään lopetuskoodi. Jos BAT-tiedosto sisältää lausekkeet if .. then, tätä voidaan käyttää määrittämään oikeat lopetuskoodit BAT-tiedoston eri kohtiin. Lopetuskoodi 0 merkitsee virheetöntä (ongelmatonta) valmistumista. Mikä tahansa muu koodi aiheuttaa hälytyksen johtuen tuotetusta lopetuskoodista (jos tämä valinta on aktivoitu). Tässä tapauksessa mikään muu tästä ongelmallisesta projektista riippuvainen projekti ei käynnisty.

  • Siirrä tiedostoja ja kansioita: tässä tapauksessa sisäistä arkistomoduulia käytetään varmistamaan tiedostoja. Käyttäen tätä moduulia on mahdollista säätää eri arkistointivalintoja ja luoda tiettyjä eri varmistustehtäviä. Napsauttaen painiketta Asetukset käyttäjä voi määrittää varmistusprojektin valinnat. Huomaa: tämä toiminto on käytettävissä vain rekisteröidyssä versiossa.

  • Polta CD/DVD sovelluksella NERO: Hard Disk Sentinel käyttää Ahead Software AG:n sovellusta NERO (TM) arkistoimaan minkä tahansa tietyn kansion sisällön optiselle levylle.

    Burn CD/DVD with Nero

    NEROCMD.EXE-tiedoston (NERO:n komentoriviversion) sijainti on tarpeen määrittää käyttäen nappia Valitse sovellus. Ellei tätä ole määritetty, mutta projekti on koostettu, Hard Disk Sentinel pyytää määrittämään puuttuvan sovelluksen sijainnin.

    Suoritettavan komentorivin voi tarkastaa kaikkine parametreineen. Painamalla CTRL+C on mahdollista kopioida tämän ikkunan sisältö leikepöydälle.

    On määritettävä lähdekansio. Se voi sisältää muuttujia (esim. %USER%, %LAST% jne.) ja muuttujien tarkat tiedot on kuvattu kansion asetuksissa. Jos käyttää muuttujaa %LAST%, määritetyn kansion (joka on meidän tapauksessamme L:\BACKUP) viimeisintä kansiota (luotu käyttäen päiväystä ja aikaa) käytetään lähdekansiona. Tätä tulisi käyttää, kun jokin toinen projekti on aiemmin tallentanut dataa kohteeseen L:\BACKUP ja valinta Käytä nykyistä päiväystä kansion nimenä ja säilytä viimeiset XX valmista arkistoa on aktivoitu kyseiselle projektille.

    On myös valittava polttava asema (silloin mikäli tietokoneeseen on asennettu kaksi tai useampia optisia asemia) ja kirjoitusnopeus. Kirjoitusnopeus säätyy automaattisesti polttajan ja asennetun median ominaisuuksien mukaan. Myös median tyyppi (CD tai DVD) pitää valita. Valinnat Puskurin alivuoto (Burn-proof) -suojaus ja todenna kirjoituksen jälkeen voidaan aktivoida tai poistaa.

    On mahdollista määrittää mitkä tahansa muut komentoriviparametrit. Ne lähetetään NEROCMD.EXE:lle. Näitä parametrejä voi olla --disable_eject, mikä passivoi levyn poiston. Parametrien täydellisen listan voi nähdä käyttämällä komentoa NEROCMD /?.

    On mahdollista aloittaa polttoprosessi hiljaisesti (näyttämättä mitään ikkunaa) ja aktivoida virheenkäsittely kuten valitaan projektit tyyppiä Aja ulkoinen sovellus tai eräajotiedosto. Tarkista NEROCMD-käyttöoppaasta NEROCMD:n täydellinen lista mahdollisia lopetuskoodeja.

    Huomaa: tämä toiminto on käytettävissä vain rekisteröidyssä versiossa.

  • Pakkaa tiedostoja sovelluksella RAR/7-Zip: Hard Disk Sentinel voi käyttää RarSoftin sovellusta WINRAR (TM) tai ilmaista sovellusta 7-Zip pakkaajana. Käytettävissä olevien valintojen lista on sama molemmilla pakkaajilla. Huomaa: 7-Zipin vanhemmat versiot eivät tue monitaltioarkistojen luomista.

    Archive (compress) files

    On määritettävä (komentoriviltä ajettavan pakkaussovelluksen) RAR.EXE- tai 7Z.EXE-tiedoston sijainti käyttäen nappia Valitse sovellus. Ellei tätä määritetä, mutta projekti on muokattu, Hard Disk Sentinel pyytää määrittämään puuttuvan sovelluksen sijainnin.

    Suoritettavan komentorivin voi tarkastaa kaikkine parametreineen. Painamalla CTRL+C on mahdollista kopioida tämän ikkunan sisältö leikepöydälle.

    Arkiston pakkaamiseksi on määritettävä lähdekansio. Se voi sisältää muuttujia (esim. %USER%, %LAST%, muuttujien tarkat tiedot on kuvattu kansion asetuksissa).

    On myös määritettävä kohdetiedosto pakatun arkiston tallentamiseen. Tarjolla on valinta luoda monitaltioarkistoja ja säätää taltion koon yksiköksi ktavu (1024 tavua).

    Mitä tahansa muita komentoriviparametrejä voi säätää käytettäviksi, kun RAR- tai 7Z-sovellus käynnistetään. Näitä parametrejä voivat olla: -mXXX pakkausmetodin määrittämiseen, -pXXX salasanan määrittämiseen tai -sfx itsepurkautuvan arkiston luomiseen. Täydellisen listan parametreistä voi nähdä käyttämällä komentoa WINRAR /? tai 7Z (ilman mitään parametrejä).

    On mahdollista aloittaa pakkausprosessi hiljaisesti (näyttämättä mitään ikkunaa) ja aktivoida virheenkäsittely kuten valitaan projektit tyyppiä Aja ulkoinen sovellus tai eräajotiedosto. Tarkista WINRAR- tai 7-Zip-käyttöoppaasta sovelluksen täydellinen lista mahdollisia lopetuskoodeja.

    Huomaa: tämä toiminto on käytettävissä vain rekisteröidyssä versiossa.

  • Vie rekisterikohteita: määritetyt rekisteriavaimet viedään tiedostoon (tiedoston nimi voi sisältää myös muuttujia).

    Export registry items

    Huomaa: tämä toiminto on käytettävissä vain rekisteröidyssä versiossa.

  • Virta PÄÄLLE tietokoneeseen: Kytke virta (käynnistä) etätietokoneeseen paikallisalueverkossa lähettämällä herätyspaketti kohdetietokoneeseen. On määritettävä kohdetietokoneen MAC-osoite (on mahdollista löytää se esim. Hard Disk Sentinel-raportista kohdetietokoneessa). Valinnaisesti ohjelma voi odottaa, kunnes tietokone pn valmis (vastaa PING:iin), muttei odota kuin määrätyn maksimiajan. On suositettavaa todentaa palomuurin, tietokoneen (wake-on-lan (LAN-herätys) pitää olla aktivoitu) ja verkon asetukset.

    Power on remote computers on network

    Huomaa: tämä toiminto on käytettävissä vain rekisteröidyssä versiossa.

  • Virta POIS tietokoneesta: Paikallinen tai etätietokone voidaan pysäyttää (sammuttaa) tai käynnistää (alkuladata) uudelleen. Paikalliselle tietokoneelle voidaan myös lähettää käsky mennä valmius- tai lepotilaan.

    Power off remote computer on network

    Huomaa: tämä toiminto on käytettävissä vain rekisteröidyssä versiossa.

  • Lähetä tiedostoja s-postissa: Tällä toiminnolla voi siirtää s-posteissa tiedostoja (tai kokonaisia kansioita kaikkine tiedostoineen tai alikansioineen). Oikean tyypin (tiedostojen tai kansioiden) valinnan jälkeen tiedostot/kansiot on määritettävä ja erotettava puolipistein (;). Lähettäjä-, s-postipalvelin- ja todennusvalintoja sivulla s-postiasetukset käytetään s-postien lähetyksessä.

    Send files in e-mail

    On mahdollista lähettää kaikki tiedostot eri s-posteissa (lähettäen yhden tiedoston per postitus). Tämä valinta on ihanteellinen lähetettäessä yksittäisiä tiedostoja (arkistoja), jotka eivät ole liian isoja lähettää s-posteissa. Moniin pienempiin tiedostoihin nähden on mahdollista koota tiedostoja, kunnes minimiraja on saavutettu, ja lähettää tiedostot yhdellä kertaa s-postissa. Näin kaikki s-postit sisältävät esim. 2000 ktavua dataa paitsi viimeinen, joka sisältää loput tiedostot. Ennen tämän valinnan käyttöä on suositettavaa todentaa datan määrä ja saatavilla oleva tila s-postipalvelimessa (verkkopalvelun tuottajan tarjoama).

    Huomaa: tämä toiminto on käytettävissä vain rekisteröidyssä versiossa.

  • Tiedostojen siirto FTP:llä: Tällä valinnalla on mahdollista lähettää tiedostoja tai kokonaisia kansioita FTP-palvelimeen. Oikean tyypin (tiedostojen tai kansioiden) valinnan jälkeen tiedostot/kansiot on määritettävä ja erotettava puolipistein (;).

    Upload files to FTP server

    Tiedostojen siirtoon vaaditaan (etä-) FTP-palvelimen nimi tai IP-osoite, käyttäjän nimi ja salasana. Valinnaisesti voi määrittää myös siirtoportin (oletus = 21, standardi FTP-portti), passiivimoodin valinnan ja etäkansion. Painike Asetukset avaa ikkunan lisävalinnoin ohjata siirtoa mukaan lukien tuetut arkistointivalinnat sekä FTP:n aikakatkaisun ja uudelleenyritysten maksimimäärän.

    Huomaa: Valintaa "säilytä viimeiset XX valmista arkistoa" voi käyttää FTP-siiron yhteydessä. Jatkaminen (REST) ei ole tuettu.

    Huomaa: tämä toiminto on käytettävissä vain rekisteröidyssä versiossa.

  • Testaa kiintolevy(t): On mahdollista tutkia ja testata kiintolevyt käyttäen laiteitsetesti -toimintoja (tuetut IDE ja S-ATA-kiintolevyillä). Testattavat levyt listataan ja voidaan valita tai on mahdollista testata samanaikaisesti kaikki asennetut kiintolevyt.

    Jos vie hiiren kiintolevyn päälle, näytetään tuetut testit vihjeenä. Valitse testityyppi tuetuista testeistä.

    On mahdollista lähettää raportti testin valmistuttua (aina tai nimenomaan virheen tapahduttua). Raportti sisältää testin yksityiskohdat mukaan lukien kaikki havaitut uudet ongelmat (esim. uusia huonoja sektoreita).

    Huomaa: tämä toiminto on käytettävissä vain rekisteröidyssä versiossa.

Huomaa: seuraavissa versioissa saattaa olla lisää eri projektityyppejä.

Painiketta Aloita nyt voi käyttää käynnistämään projekti välittömästi. Käytä aina painiketta Tallenna ennen tämän painikkeen napsautusta tallentaaksesi mitkä tahansa projektin modifioidut valinnat.

Käyttämällä painiketta Create shortcut for project on the desktop Hard Disk Sentinel luo työpöydälle nykyisen valitun projektin pikakuvakkeen. Pikakuvakkeella voi käynnistää siihen assosioidun projektin (vaikkei Hard Disk Sentinel olisi aktiivinen). Huomaa: jos projekti sisältää muuttujia, muuttujat huomioidaan pikakuvakkeen luontihetken mukaan. Ei siis ole suositettavaa käyttää muuttujia projekteissa, jotka on suunniteltu ajettaviksi manuaalisesti tai käyttämään vain pysyviä muuttujia (esim. %COMPUTER%).

Huomaa: tämä toiminto on käytettävissä vain rekisteröidyssä versiossa.

Nappia Tallenna on käytettävä tallentamaan modifioidut asetukset. Tämä tallentaa nykyisen projektilistan, This will save the current list of projects, määritettyjen ajoitusten listan ja määritettyjen tapahtumien listan. On suositettavaa käyttää tätä nappia usein, koska jotkin valinnat ovat käytettävissä vain, jos varmistusasetukset on tallennettu. Käyttämällä nappia Palauta oletusprojektit, on mahdollista ladata uudelleen aiemmin tallennetut varmistusasetukset. Tämä saattaa olla hyödyksi palautettaessa vahingossa tapahtuneen poiston tai modifioinnin johdosta.

Sen jälkeen kun varmistusprojektit on määritetty, ne tulisi liittää eri ajankohtiin eri päivinä sivulla Ajoitus tai eri tapahtumiin. Sellainen tapahtuma voi olla hätävarmistus. Se suoritetaan, jos mikä tahansa ongelma löytyy miltä tahansa kiintolevyltä ja jos kyseiseen ongelmaan liittyvän hätävarmistuksen käynnistysvalinta on aktivoitu sivulla Hälytykset.


Asetukset: Operaatiot, Ajoitus

Nämä toiminnot ovat käytettävissä vain PROFESSIONAL-versiossa.

Schedule of projects

Joka viikonpäivälle voi määrittää eri projektin. Pikavalikosta Käynnistyspäivä käyttäjä voi valita viikonpäivän, jolle määritettyjä projekteja voi tarkastella ja lisätä/tarkistaa asetuksia.

Käyttäen valintaa Peruuta seuraavan vastaavan päivän osalta on mahdollista passivoida seuraavan viikon vastaavan valitun päivän kaikki projektitit. Esim. jos valitaan ja näytetään nyt oleva vaikkapa tiistai ja käytetään tätä valintaa, tiistaille ajoitettuja projekteja ei suoriteta seuraavana tiistaina. Näin on mahdollista väliaikaisesti passivoida suunnitellun palvelun projektit. Sen jälkeen kun päivä on ohi (esim. seuraavan tiistain jälkeen), sovellus palautuu automaattisesti normaaliin moodiin ja kaikki projektit toimivat kuin ennenkin. Näin järjestelmänvalvojan ei tarvitse huolehtia passivoimasta ja sitten aktivoimasta projekteja uudelleen manuaalisesti, kun palvelu on edennyt päätökseen.

Punaista X:ää sarakkeessa Poista voi käyttää poistamaan vastaava projekti listasta. Tietenkään itse projektia ei poisteta, se voidaan valita uudelleen milloin vain myöhemmin lisättäväksi projektilistaan. Seuraavana näkyy (vasemmalta oikealle) projektin numero. Tämä on tärkeä vain, jos käyttäjä haluaa luoda projektiketjun (suorittaa projekteja peräkkäin, toinen toisensa perään).

Sarakkeessa Projekti näkyy projektin nimi. Käyttäjä voi valita suoritettavan projektin aiemmin luotujen projektien listasta.

Sarakkeeseen Käynnistä on mahdollista säätää, milloin projekti tulee suorittaa. Mahdolliset valinnat ovat:

  • Kiinteä aika: projekti suoritetaan sarakkeessa Aika (tunti:minuutti) määritettyyn aikaan. Ellei projektia ollut mahdollista ajaa säädettyyn aikaan (esim. järjestelmä ei ole valmiina johtuen virtaongelmasta), projekti voidaan ajaa myöhempänä (mutta ensimmäisenä mahdollisena) ajankohtana. Tätä voi ohjailla valinnalla Voidaan ajaa myöhemmin. Suositettavaa suoritettaessa kiinteitä, pitempikestoisiksi ajoitettuja projekteja (esim. täydellinen varmistus yön aikana).

  • Latauksen jälkeen: käynnistä projekti sen jälkeen, kun Hard Disk Sentinel on käynnistetty ja ennaltamääritetty viive on ohi. Viipeen voi määrittää sarakkeessa Aika (tunti:minuutti). Projekti suoritetaan Hard Disk Sentinelin joka uudelleenkäynnistyksen jälkeen. Jos järjestelmä täytyy käynnistää säännöllisesti uudelleen, projektin voi ajaa useasti per päivä. Suositettavaa pikavarmistuksiin (esim. tallennettaessa uusia tai muokattuja dokumentteja, kuvia).

  • Latauksen jälkeen 1/päivä: käynnistä projekti sen jälkeen, kun Hard Disk Sentinel on käynnistetty ja ennaltamääritetty viive on ohi. Viipeen voi määrittää sarakkeessa Aika (tunti:minuutti). Projekti suoritetaan vain Hard Disk Sentinelin ensimmäisen käynnistyksen jälkeen kunakin päivänä, joten se ajetaan enintään kerran päivässä. Suositettavaa tehtävissä jotka suoritetaan enintään kerran per päivä, esim. päivitettäessä antivirus-datakantaa.

  • Toistuva: toista projekti säädetyn ajanjakson jälkeen. Ajanjakson voi määrittää sarakkeessa Aika (tunti:minuutti). Suositettavaa tallennettaessa usein modifioitavaa dataa, usein saapuvia tiedostoja, kuvia.

  • X:n jälkeen: käynnistä projekti kun toinen projekti numerolla X on valmistunut. Käytettävissä vain jos on tallennettu projektin X sisältävä projektilista. Huomaa: jos käyttäjä peruu minkä tahansa projektin ketjussa tai käyttäjä on kieltänyt projektia käynnistymästä, kun hänen olisi pitänyt sallia se, mitkään tästä perutusta riippuvaisista lisäprojekteista eivät käynnisty. On mahdollista yhdistää yksi tai useampia projekteja aiemmin valmistuneeseen projektiin (jos projekteille on valittu sama "X:n jälkeen" -valinta). Näin nämä projektit ajetaan samanaikaisesti, heti kun toinen projekti (numerolla X) on valmistunut. Suositettavaa näille: pakattaessa arkistoituja tiedostoja, poltettaessa tiedostoja optiselle medialle.

Jos valinta Kysy ennen ajoa on valittu, projektia ei suoriteta automaattisesti. Sen sijaan ilmestyy vahvistusikkuna, jossa ovat projektin nimi sekä kommentti ja käyttäjän täytyy sallia projektin käynnistys. Näin voi viivyttää projektin suoritusta (ja kaikkien tästä riippuvaisten projektien) odottamalla ennen napin painallusta. Jos hän peruu suorituksen, kyseinen projekti ja mitkään siitä riippuvat projektit eivät käynnisty. Huomaa: tämän valinnan voi poistaa vain rekisteröidyssä versiossa. Rekisteröimätön versio vaatii aina vahvistuksen projektin suoritukselle.

Poistamalla valinnan Aktivoitu projekti passivoidaan eikä se käynnisty. Näin projektin voi passivoida pitemmäksi aikaa - poistamatta projektilistalta. Huomaa: jos yksi tai useampi projekti riippuu passivoidusta projektista, näitäkään projekteja ei suoriteta. Hard Disk Sentinel näyttää tässä tilanteessa varoituksen ja käyttäjä voi tarkistaa asetukset.

Napsauta tekstiä Lisää uusi projekti listaan listan lopussa lisätäksesi uuden projektin päivittäisajoitukseen.


Asetukset: Operaatiot, Paniikkivarmistus

Nämä toiminnot ovat käytettävissä vain PROFESSIONAL-versiossa.

Panic backup: start project on problem

On mahdollista yhdistää projektin suoritus eri tapahtumiin kuten ajoitussivulla. Esim. jos minkä tahansa kiintolevyn kuntoarvo on liian matala tai lämpötila on liian korkea projektin suorittamiseen. Käyttäjän täytyy aktivoida eri ongelmatyypit sivulla Hälytykset, kun projekti on määrä käynnistää.

On mahdollista määrittää yleinen projektilista. Tämän listan kaikki projektit suoritetaan, jos millä tahansa kiintolevyllä on ongelma (ja "paniikkivarmistus" on aktivoitu kyseiselle ongelmalle sivulla Hälytykset). Lisäksi käyttäjä voi luoda eri projektilistan kullekin asennetulle kiintolevylle. Näin on mahdollista säätää, että dataa tulee arkistoida ensimmäiseltä kiintolevyltä toiselle säännöllisesti ja milloin ensimmäisen kiintolevyn kuntoarvo on alhainen; ja jos toisen kiintolevyn kanssa on ongelma, dataa tulee kopioda ulkoiselle levylle tai etäpalvelimeen.

Pikavalikosta Levy on mahdollista valita vastaava levy tai yleinen projektilista (käyttäen valintaa "mikä tahansa kiintolevy").

Punaista X:ää sarakkeessa Poista voi käyttää poistamaan vastaava projekti listasta. Tietenkään itse projektia ei poisteta, sen voi valita uudelleen milloin vain lisättäväksi myöhemmin projektilistaan. Seuraavana (vasemmalta oikealle) näkyy projektin numero. Tämä on tärkeä vain, jos käyttäjä haluaa luoda projektiketjun (suorittaa projekteja peräkkäin, toinen toisensa perään).

Sarakkeessa Projekti näkyy projektin nimi. Käyttäjä voi valita suoritettavan projektin aiemmin luotujen projektien listasta.

Sarakkeessa Käynnistä on mahdollista säätää, milloin projekti tulee suorittaa. Mahdolliset valinnat ovat:

  • Automaattisesti: käynnistä projekti välittömästi, kun on havaittu ongelma.

  • X:n jälkeen: käynnistä projekti kun toinen projekti numerolla X on valmistunut. Käytettävissä vain jos on tallennettu projektin X sisältävä projektilista. Huomaa: jos käyttäjä on perunut minkä tahansa projektin ketjussa tai käyttäjä on kieltänyt projektin käynnistymisen, kun hänen olisi tullut sallia se, niin mitkään kyseisestä perutusta riippuvat projektit eivät käynnisty. On mahdollista yhdistää yksi tai useampia projekteja aiemmin valmistuneeseen projektiin (jos projekteille on valittu sama "X:n jälkeen" -valinta). Näin nämä projektit ajetaan samanaikaisesti, heti kun toinen projekti (numerolla X) on valmistunut.

Jos valinta Kysy ennen ajoa on valittu, projektia ei suoriteta automaattisesti. Sen sijaan ilmestyy vahvistusikkuna, jossa ovat projektin nimi sekä kommentti ja käyttäjän täytyy sallia projektin käynnistys. Näin voi viivyttää projektin suoritusta (ja kaikkien tästä riippuvaisten projektien) olemalla painamatta mitään nappia, jos projekti on määrä suorittaa myöhemmin. Jos hän peruu suorituksen, kyseinen projekti ja mitkään siitä riippuvat projektit eivät käynnisty. Huomaa: tämän valinnan voi poistaa vain rekisteröidyssä versiossa. Rekisteröimätön versio vaatii aina vahvistuksen projektin suoritukselle.

Poistamalla valinnan Aktivoitu projekti passivoidaan eikä se käynnisty. Näin projektin voi passivoida pitemmäksi aikaa - poistamatta projektilistalta. Huomaa: jos yksi tai useampi projekti riippuu passivoidusta projektista, näitäkään projekteja ei suoriteta. Hard Disk Sentinel näyttää tässä tilanteessa varoituksen ja käyttäjä voi tarkistaa asetukset.

Napsauta tekstiä Lisää uusi projekti listaan listan lopussa lisätäksesi uuden projektin päivittäisajoitukseen.


Tiedostojen siirto

Rekisteröidyssä Hard Disk Sentinel PROFESSIONAL-versiossa on sisäinen arkistointimoduuli. Se sisältää lukuisia säätelyominaisuuksia ja tätä moduulia käyttäen on mahdollista luoda nykytilanteeseen sopivia eri varmistusoperaatioita. Asetuksia ja toimintoa kuvataan seuraavissa luvuissa:

  • Operaatiot

  • Kansioiden asetukset

  • Yleisasetukset

  • Projektivalinnat

  • Tiedostojen siirto (prosessointi)


Asetukset: Operaatiot, tiedostojen siirto

Nämä toiminnot ovat käytettävissä vain rekisteröidyssä PROFESSIONAL-versiossa.

Modify project settings

Tiedostojen ja kansioiden siirrossa tärkein asia on määrittää lähde- ja kohdekansiot.

Painikkeen Uusi painallus tuo esiin kansioiden valinta -ikkunan, missä nämä kansiot voi määrittää. Painike Muokkaa avaa tämän ikkunan ja aiemmin määritettyjä arvoja voi modifioida (myös minkä tahansa tämän listan merkinnän kaksoisnapsautus avaa tämän ikkunan. Käyttämällä nappia Poista juuri valittu merkintä poistetaan listasta.

Sivulla Yleisasetukset on mahdollista säätää kaikkien "tiedostojen ja kansioiden siirto" -projektien yleisiä valintoja. Sivulla Projektivalinnat on monia valintoja hienosäätää nykyistä valittua projektia.


Asetukset:Operaatiot, tiedostojen siirto, kansioiden asetukset

Nämä toiminnot ovat käytettävissä vain rekisteröidyssä PROFESSIONAL-versiossa.

Modify project settings

Tiedostojen ja kansioiden siirrossa tärkein asia on määrittää lähde- ja kohdekansiot.

On mahdollista valita tai syöttää manuaalisesti lähdekansio ja kohdekansio. On mahdollista käyttää useampaa kuin yhtä kohdekansiota (jopa eri asemissa tai eri tietokoneissa). Tiedostot kopioidaan lähdekansiosta kaikkiin näihin kohdekansioihin. On mahdollista säätää mitä tahansa (yksi tai useampia) muuttujia määritettäessä kohdekansiota. Esim. on mahdollista luoda eri kansioita pohjautuen käyttäjän nimeen, tietokoneen nimeen tai IP-osoitteeseen. Hard Disk Sentinel luo automaattisesti kansion ennen arkistointia jos tarpeen.

Muuttuja %LAST=folder% korvautuu määritetyn "kansion" viimeksi päivitetyn alikansion nimellä. Tämä on käytännöllistä, jos käyttäjä haluaa tallentaa useita eri varmistusvaiheita, mutta viimeisimmät tiedostot tarvitsevat lisäkäsittelyä (esim. viimeisimpien tiedostojen polton optiselle levylle). Tätä toimintoa ja sen asetuksia kuvataan sivulla projektivalinnat.

On mahdollista käyttää tämän valinnan lyhyempää muotoa: määrittää vain %LAST%. Tällöin kansiosta ennen kansiota %LAST% etsitään viimeisintä arkistoitua kansiota. Esim. C:\BACKUP\%LAST=C:\BACKUP% ja C:\BACKUP\%LAST% sisältävät saman (uusimman arkiston kansiosta C:\BACKUP). Jos on tarpeen polttaa CD/DVD ja jotkin näistä esimerkeistä käytetään lähdekansiona, viimeisin kansio kopioidaan optiselle levylle.

Huomaa: kansioita %LAST=folder% ja %LAST% voi käyttää vain jos on aktivoitu valinta Käytä nykyistä päiväystä kansion nimenä ja säilytä viimeiset XX valmista arkistoa.

Huomaa: kansioiden nimet voivat viitata paikallisiin tai etä- (verkko-) asemiin. On myös mahdollista määrittää UNC (Universal Naming Convention) -polkuja (esim. \\palvelin\jako\kansio). Varmistu että vastaavat verkkoresurssit ovat sovelluksen käytettävissä.


Asetukset: Operaatiot, tiedostojen siirto, yleisasetukset

Nämä toiminnot ovat käytettävissä vain rekisteröidyssä PROFESSIONAL-versiossa.

Modify project settings

On mahdollista määrittää, mitä tiedostoja (määritettyihin tiedostomaskeihin täsmääviä) ei tule huomioida. Näitä tiedostoja ei arkistoida.

Huomaa: Tämä valinta vaikuttaa kaikkien varmistusprojektien suoritukseen.


Asetukset: Operaatiot, tiedostojen siirto, projektivalinnat

Nämä toiminnot ovat käytettävissä vain rekisteröidyssä PROFESSIONAL-versiossa.

Modify project settings

Käyttäen näitä valintoja käyttäja voi mukauttaa varmistusprojektin.

Laske kopioitavan datan määrä: Hard Disk Sentinel voi laskea arkistoitavan datan kokonaismäärä ennen arkistointiprosessin käynnistystä. Tämä voi viedä huomattavan paljon aikaa, jos varmistettavina on runsaasti tiedostoja ja kansioita - joten tämän toiminnon voi poistaa käytöstä. Jos projekti on laadittu olemaan "paniikkivarmistus" -projekti, tämä toiminto tulee poistaa käytöstä arkistoinnin alkamiseksi niin pian kuin mahdollista. Jos tämä valinta on aktivoitu, eteneminen ja arvioitu jäljelläoloaika näkyvät varmistusoperaation aikana.

Älä aloita jos datan määrä on alle XX ktavua: älä aloita arkistointia, jos lähdekansio ei sisällä määritettyä datamäärää. Tätä valintaa käyttäen on mahdollista säilyttää olemassa olevat varmistukset ja välttää varmistamasta tyhjiä kansioita tai vajaasisältöisiä kansioita.

Anna hälytys ellei tarpeeksi dataa: tee hälytys jos datan määrä on alle määritetyn kynnyksen. Tämä voi olla s-posti, verkkoviesti tai näytölle ilmestyvä hälytysikkuna perustuen viestiasetuksiin. On mahdollista synnyttää myös äänihälytys (katso alla).

Todenna kopioitu data: varmistusoperaation aikana Hard Disk Sentinel luo automaattisesti CRC-tarkistearvon kaikista tiedostoista ja tallentaa nämä arvot yhdessä arkistoitujen tiedostojen kanssa (näillä tiedoilla palautusmoduuli (saatavissa tulevaisuudessa) voi todentaa kaikkien arkistoitujen tiedostojen yhtenäisyyden ja palauttaa tiedostot automaattisesti). Jos tämä valinta aktivoidaan, arkistoitujen tiedostojen yhtenäisyys todennetaan arkistoinnin jälkeen. Jos arkistoitujen tiedostojen määrä on suuri, tämä prosessi voi viedä kauan aikaa (jopa kauemmin kuin varmistusprosessi).

Kopioi vain uudet ja päivitetyt tiedostot: arkistoi vain viime varmistusoperaation jälkeiset uudet tai päivitetyt tiedostot.

Tyhjää kopioitujen tiedostojen arkistobitti: Hard Disk Sentinel tyhjää varmistuksen jälkeen kaikkien tiedostojen arkistobitin. Tämä takaa tiedostot arkistoidaan. On suositettavaa käyttää tätä valintaa edellisen kanssa.

Poista lähdetiedostot onnistuneen kopioinnin jölkeen: poista kaikki lähdetiedostot, kun arkistointiprosessi on valmis. Käytä tätä toimintoa vain erityistapauksissa (esim. varmista pienen kapasiteetin tallentimesta ja tyhjää laite). Huomaa: (tyhjiä) kansioita ei poisteta.

Tallenna alikansiot: on mahdollista aktivoida lähdekansioiden alaisten kaikkien alikansioiden kaikkien tiedostojen arkistointi.

Tallenna myös lähdekansion nimi ja sisältö: jos aktivoi tämän valinnan, myös lähdekansion nimi (lähdepolun ylin kansio) luodaan kohdekansioon ja lähdekansion kaikki tiedostot ja alikansiot tallennetaan tähän kansioon. Jos valinta poistetaan, lähdekansion sisältö tallennetaan suoraan kohdekansioon.

Älä näytä tallennuksen tilaikkunaa: normaalisti kopioinnin etenemisikkuna näkyy arkistointiprosessin aikana. Jos valinta poistetaan, ikkuna ei näy. Vain välkkyvä ilmaisinaluekuvake osoittaa, että meneillään on varmistusprosessi.

Käytä nykyistä päiväystä kansion nimenä ja säilytä viimeiset XX valmista arkistoa: kun tämä valinta aktivoidaan, lähdekansioiden sisällöt tallennetaan useammin kuin kerran kohdekansioihin. Näin on mahdollista saada monta eri valmista varmistusarkistoa. Esim. jos varmistusprojekti on säädetty ajettavaksi päivittäin ja tämä valinta aktivoidaan 7 valmiiksi eri arkistoksi, kaikki tiedostot tallennetaan viikoksi taannehtivasti (kaikki tiedostot tallennetaan 7 kertaa, yksi varmistuskopio kunakin päivänä). Nykyisen päiväyksen ja ajan omaava kansio luodaan automaattisesti kohdekansion alaisuuteen ja lähdetiedostot arkistoidaan sinne. Jos kohdekansio sisältää jo määritetyn määrän valmiita arkistoja, vanhin arkisto poistetaan automaattisesti. Käyttäen tätä valintaa on mahdollista palauttaa ongelma- tai datan menetystapauksessa minkä tahansa edellisen päivän vakaasta arkistosta. Mutta sillä on haittapuolensa: se vaatii paljon enemmän tallennustilaa kuin yksinkertainen varmistus.

On mahdollista luoda raportti varmistusprosessin suorituksen jälkeen. Raportin voi luoda kaikissa tapauksissa (virheen/ongelman sattuessa tai kun projekti valmistunut virheittä) tai vain kun on havaittu ongelma. On myös mahdollista täysin poistaa käytöstä raportin luonti kyseisestä projektista. Raportti voi olla viestiasetusten mukaisesti s-posti, verkkoviesti tai näytöllä esitettävä hälytysikkuna. Valinnaisesti voi aktivoida äänihälytyksen havaittaessa ongelman.

Aktivoimalla valinnan Äänihälytys ongelman ilmetessä luodaan äänihälytys sivun Hälytykset ääniasetusten mukaisesti.

On mahdollista säätää operaation prioriteetti. Asettamalla "maksimi" -prioriteetin, projekti suoritetaan niin pian kuin mahdollista. Tämä saattaa alentaa muiden aktiivisten sovellusten suoritustehoa, mutta näin tiedostot voi arkistoida nopeammin. On suositettavaa käyttää "maksimia" paniikkivarmistusoperaatioissa, mutta toimetonta tai normaalia muissa projekteissa.


Tiedostojen siirto

Jos projekti säädetään "siirtämään tiedostoja ja kansioita" ikkunassa projektin asetukset, sisäistä arkistointimoduulia käytetään arkistointiin. Prosessin ajaksi ilmestyy etenemisikkuna ajankohtaisine vaiheineen (esim. tiedostojen siirto, arkiston todennus jne.) ja myös kyseisen hetken tila sekä jäljellä oleva aika näytetään - jos on aktivoitu valinta Laske kopioitavan datan määrä.

Project is running (archiving files)

Suorituksen voi perua painikkeella Peruuta. Siinä tapauksessa Hard Disk Sentinel luo raportin (jos on aktivoitu valinta raportin luonti) siitä, että käyttäjä on perunut sen hetkisen ajettavan projektin. Mitkään muut perutusta projektista riippuvat projektit eivät käynnisty. Huomaa: joissain tapauksissa prosessi saattaa silti jatkua muutaman sekunnin ennen pysähtymistä.

Nappia X (sulje) voi käyttää sulkemaan (piilottamaan) tämän etenemisikkunan. Tämä ei pysäytä käynnissä olevaa operaatiota. Välkkyvä levykuvake ilmaisinalueella ilmaisee, että operaatio jatkuu yhä:

Showing backup status on tray

Hard Disk Sentinel näyttää ajankohtaisen operaation, vaiheen ja etenemisen, jos hiiriosoitin viedään ilmaisinaluekuvakkeen päälle. Täydellisen etenemisikkunan voi nähdä napsauttamalla hiiren vasemmalla painikkeella (ja tällä myös piilottaa ilmaisinaluekuvakkeen).

Huomaa: sen jälkeen kun projektin suoritus on päättynyt, kuntotila- tai ongelmatiedot tallentuvat project_log.txt-tiedostoon Hard Disk Sentinel -kansiossa. On suositettavaa tutkia tätä tiedostoa ongelmatapauksessa.


Asetukset: Integrointi

Tällä sivulla on mahdollista säätää miten integroida sovellus järjestelmään. Vain kokeneiden käyttäjien tulisi käyttää käyttää näitä valintoja ja ominaisuuksia.

Suojaus

Sovellus voidaan suojata salasanalla. Tietämättä salasanaa käyttäjä ei pysty tarkistamaan ja modifioimaan nykyisiä asetuksia. Valinnaisesti voidaan suojata myös päätietoikkuna, joten ei ole mahdollista tarkastella kiintolevyn tarkkoja tietoja ilman salasanaa.

Kun aktivoidaan suojaus, järjestelmänvalvoja voi avata vastaavan ikkunan antamatta oikeaa salasanaa. Ohjelma muistaa salasanan tieto- tai asetusikkunan sulkemisen jälkeen. Käyttäjän ei tarvitse antaa sitä enää - paitsi jos on aktivoitu automaattinen uloskirjaus. Tässä tapauksessa määritetyn aikakatkaisuarvon umpeuduttua Hard Disk Sentinel kysyy salasanaa uudelleen.

Järjestelmänvalvoja voi käyttää painiketta Kirjaudu ulos nyt milloin vain kirjautuakseen ulos asetusten todennuksen ja modifioinnin jälkeen. Tämä suojaa käyttäjäliittymän taas salasanalla.

Huomaa: Tämä toiminto on käytettävissä vain rekisteröidyssä versiossa.

Palvelu

Hard Disk Sentinel voi toimia kahdessa eri moodissa. Se voi toimia Sovelluksena tai Palveluna. Oletuksena se toimii sovellus-moodissa: ohjelma käynnistyy kun käyttäjä (vaadittavin järjestelmänvalvojan oikeuksin) on kirjautunut sisään. Ennen versiota 2.02 tämä oli ainoa moodi.

Ajettaessa Hard Disk Sentineliä NT-palveluna ohjelma käynnistyy käyttöjärjestelmän mukana ja toimii, vaikkei yhtään käyttäjää olisi kirjautunut sisään, tai jos käyttäjällä olisi vain rajoitetut oikeudet. Näin Hard Disk Sentinel toimii riippumatta kulloisestakin käyttäjästä: se voi ohjata ja todentaa kiintolevyn kuntotilan, käynnistää varmistusoperaatioita - aivan kuin toinenkin moodi.

Vain järjestelmänvalvoja voi asentaa, poistaa ja hallita palveluja. Siten järjestelmänvalvojan tulee säädellä sovellusta (esim. asettaa kynnykset ja hälytysvalinnat) ja sitten vaihtaa palvelu-moodiin. On suositettavaa käyttää aiempaa (Suojaus-) ominaisuutta myös estämään luvaton asetusten muuttaminen.

Huomioita palvelumoodista:

  • Tämä ominaisuus on käytettävissä vain NT-pohjaisissa käyttöjärjestelmissä (Windows 2000, XP, 2003, Vista).

  • Sovellus noudattaa samaa toimintatapaa palvelu- ja sovellusmoodissa.

  • Palvelun nimi on: HardDiskSentinelService ja se toimii "Paikallisen järjestelmän" turvakontekstissa. Järjestelmänvalvoja voi muuttaa tätä tarvittaessa käyttäen Ohjauspaneeli > Valvontatyökalut > Palvelut-ikkunaa (esim. aktivoimaan pääsyn etäasemiin ja resursseihin). Säädetyille varmistusprojekteille ja ulkoisille sovelluksille siirtyvät nämä määritetyt oikeudet.

  • Palvelun voi käynnistää ja pysäyttää Hard Disk Sentinel-ohjelmaryhmästä käyttäen sopivaa pikakuvaketta. Palvelun pysäyttämisen jälkeen on mahdollista poistaa se täysin ja vaihtaa takaisin sovellusmoodiin. Käyttäjällä pitää olla järjestelmänvalvojan oikeudet ja hänen pitää antaa oikea salasana tehdäkseen tämän (jos Suojaus-ominaisuus on aktivoitu).

  • On mahdollista käyttää ohjelmaa "piilossa"-moodissa (näyttämättä ikkunoita, ilmaisinaluekuvakkeita ja viestejä), jos valinta "Palvelu voi käyttää työpöytää" on pois käytöstä (käyttöjärjestelmän kunkin eri palvelun ikkunassa "Palvelu/Ominaisuudet/Sisäänkirjautuminen"). Tässä tapauksessa käyttäjällä ei ole pääsyä päätiedot- ja asetukset-ikkunoihin käyttäen pikapainiketta "Stop Service" (Keskeytä palvelu). Windows Vistassa ei näytetä mitään vuorovaikutteisten palvelujen käyttäjäliittymää, joten tässä tapauksessa käyttäjällä ei ole pääsyä päätiedot- ja asetukset-ikkunoihin - paitsi jos hän keskeyttää palvelun Hard Disk Sentinel, jolloin palvelu toimii kyseisessä "piilossa"-moodissa Vistan alaisena.

  • Käytettäessä ohjelmaa palvelumoodissa "päivitys"-toiminto ei ole käytettävissä eikä ohjelmaa voi sulkea. Palvelu tulee keskeyttää pikakuvakkeella Hard Disk Sentinel-ryhmässä.

  • Palvelu keskeytyy ja käynnistyy automaattisesti järjestelmän mukana. Käyttäjän ei tarvitse keskeyttää sitä ennen tietokoneen sammutusta.

  • Järjestelmänvalvojan pitäisi poistaa käytöstä pääsy Hard Disk Sentinel -kansioon käyttäjiltä, joilla on rajoitetut oikeudet. Näin käyttäjät eivät pysty tutkimaan tai modifioimaan asetuksia ja tietoja sovelluksen ulkopuolelta.

  • Jotkin järjestelmät, sovellukset tai työpöytäteemat saattavat saada aikaan, etteivät jotkin osat käyttöliittymää (tilaikkuna, tiedot työpöydällä) näy lainkaan tai osittain.

  • Kun käytetään automaattista päivitystä päivittämään versiosta 2.00 tai aiemmasta, pikakuvakkeet "Start Service" (Käynnistä palvelu) ja "Stop Service" (Keskeytä palvelu) eivät ole käytettävissä Hard Disk Sentinel -ohjelmaryhmässä. On suositettavaa asentaa versio 2.05 (tai myöhempi) manuaalisesti näiden pikakuvakkeiden luomiseksi.

  • On mahdollista käynnistää ja keskeyttää palvelu käyttäen ikkunaa Ohjauspaneeli > Valvontatyökalut > Palvelut. Napsauta oikealla nimeä HardDiskSentinelService ja esiin ilmestyy ponnahdusikkuna komennoin Käynnistä ja Keskeytä. Tämä on mahdollista myös etätietokoneesta, jos käyttäjällä on vaadittavat oikeudet.

  • Kun palvelu on keskeytetty, on mahdollista asentaa tai poistaa palvelu käyttäen komentoja HDSentinel.exe /INSTALL tai HDSentinel.exe /UNINSTALL Hard Disk Sentinel -asennuskansiossa.

Etäohjaus

Aktivoi WebTila: jos aktivoitu, on mahdollista tarkastella kiintolevyn kuntotilaa paikallisesta tai etätietokoneesta/matkapuhelimesta/PDA:sta käyttäen web-selainta. Valinnaisesti voi käyttää salasanaa estämään luvaton pääsy. Näin mitä tahansa käyttäjän nimeä ja salasanaa Suojaus-paneelissa voi käyttää luomaan yhteys.

On mahdollista määrittää mikä tahansa HTTP-portti ajankohtaisten verkkoasetusten mukaisesti.

Huomaa: tämä toiminto on käytettävissä vain rekisteröidyssä versiossa.

Kun tämä valinta aktivoidaan, seuraavia kyselyjä voidaan käyttää web-selaimessa:

  • http://palvelin:port/tila : koko tilaikkuna kaikkine sisältöineen (tarkalleen näin säädettynä), mikä päivittyy säännöllisesti, kun määritetty aika on kulunut. Ikkunalla ei ole rajoja ja reunuksia ja sen voi sijoittaa sisäiseen kehykseen IFRAME.

  • http://palvelin:port/statuswin.bmp : tilaikkuna (vain kuva)

  • http://palvelin:port/report : yksityiskohtainen HTML-raportti joka sisältää säädetyt raporttikohdat

  • http://palvelin:port/xml : valmis XML-raportti

Huomaa: tilaikkunan ei tarvitse näkyä tietokoneessa (palvelimessa) tämän ominaisuuden käyttämiseksi.

Esim.: jos kyseinen valinta aktivoidaan paikallisessa tietokoneessa ja käytetään oletusasetuksia, syötä http://localhost:61220/status selaimeen tarkastellaksesi kiintolevyn tietoja.

Huomaa: kaikki kyselyt kirjautuvat IP:n ja päiväyksen kera tiedostoon "NetLog.txt" file. Muut kuin yllä olevat kyselyt tuottavat 403 Forbidden (Kielletty) virheilmoituksen selaimessa. EI ole mahdollista saada pääsyä tiedostojärjestelmään tai muihinkaan tietoihin käyttäen tätä ominaisuutta.

Huomaa: jos tietokoneella (palvelimella) on dynaaminen IP-osoite, on käytettävä dynaamisen DNS-tarjoajan palvelua (joka kääntää dynaamisen IP-osoitteen kiinteäksi verkkotunnukseksi) saamaan etäyhteys tietokoneeseen. Tämä palvelu on vapaasti käytettävissä (esim.) osoitteissa http://www.no-ip.com ja http://www.dyndns.com .

    Hard Disk Status displayed in a remote browser (PDA)
    Hard Disk Status displayed in a remote browser (PDA)Hard Disk Status displayed in a remote browser (PDA)

Kahden tai useamman tietokoneen Hard Disk Sentinel tilaikkunan voi helposti yhdistää yhdeksi websivuksi (joka päivittyy automaattisesti heijastamaan sen hetkistä tilaa). Näin on mahdollista tarkastella eri asetuskohteiden tilaa etätoimintona avaamalla selaimessa tämän sivun (HTML-tiedosto joka voi olla tiedostopalvelimessa tai itse PC/puhelin/PDA:ssa). Esimerkkejä:

    <html>
<head>
<title>Hard Disk Sentinel Status</title>
</head>
<body>
<center>
<iframe src="http://192.168.2.101:61220/status" width=220
height=61 frameborder=0></iframe><br>PC #1<br><br>
<iframe src="http://192.168.2.102:61220/status" width=220
height=61 frameborder=0></iframe><br>PC #2<br><br>
<iframe src="http://192.168.2.103:61220/status" width=220
height=61 frameborder=0></iframe><br>PC #3<br><br>
</body>
</html>
    Näyttää 3 tilaikkunaa IFRAME-kehyksin (automaattisesti paivittyen, erillään).
    <html>
<head>
<title>Hard Disk Sentinel Status</title>
<META HTTP-EQUIV="Refresh" CONTENT="300">
<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">
<META HTTP-EQUIV="CACHE-CONTROL" CONTENT="NO-CACHE">
</head>
<body>
<center>
<a href="http://192.168.2.101:61220/report"><img
src="http://192.168.2.101:61220/statuswin.bmp" border=0></a><br>PC #1<br><br>
<img src="http://192.168.2.102:61220/statuswin.bmp"><br>PC #2<br><br>
<img src="http://192.168.2.103:61220/statuswin.bmp"><br>PC #3<br><br>
</body>
</html>
    Näyttää 3 tilaikkunaa ja päivittää kaikki joka 300. sekunti. Kun napsauttaa ensimmäistä ikkunaa, ilmestyy kyseisen tietokoneen täydellinen raportti.
    Hard Disk Status displayed in a remote browser (PDA)
    Yllä oleva tallentuu HTML-tiedostoon PDA:ssa ja avautuu selaimessa.

Hyväksy etäyhteydet palvelimesta: Hard Disk Sentinel Enterprisea voi käyttää etätoimisesti analysoimaan kiintolevyongelmia, todentamaan kiintolevyn kuntotilan ja testaamaan kiintolevyjä tietokoneissa, jotka käyttävät Hard Disk Sentinelia -asiakasta. Jos tämä valinta aktivoidaan, palvelin voi lähettää komentoja ja paljastaa tietoja tästä tietokoneesta.

Aktivoi DynDNS-, No-IP- tai Custom Dynamic DNS -palvelu: näitä palveluja käyttäen on mahdollista määrittää kiinteäksi verkkotunnukseksi tietokoneen vaihtuva (dynaaminen) IP-osoite. Tällä kiinteällä verkkotunnuksella tietokeeseen saa etäyhteyden, jolloin etähallinta (webtila, etäyhteydet) on mahdollista.

Tämän säätämiseksi vaaditaan rekisteröinti yhteen yllä mainituista palveluista. Tämän jälkeen Hard Disk Sentinelissa pitää määrittää kyseinen rekisteröity verkkotunnus. Myöhemmin kun sovellus huomaa , että tietokoneen IP-osoite on muuttunut, se päivittää automaattisesti assosioidun isännän IP:n 1 minuutin sisään. Näin etäkäyttö on mahdollinen, kun tietokone yhdistetään uudelleen verkkoon.

Painiketta "Asetukset" tulee käyttää määrittämään käyttäjänimi, salasana ja määritetyn dynaamisen DNS-tarjoajan verkkotunnus. IP:n päivityksen jälkeen palvelimen viimeinen vastaus voidaan tarkistaa viemällä hiiriosoitin vastaavan Dynamic DNS -valinnan päälle. Tämä palvelimen vastaus on hyödyllinen diagnosoitaessa mitä tahansa ongelmaa (esim. virheellistä käyttäjänimeä).


Asetukset: Testiraportin lähetys

Tällä sivulla on mahdollista luoda testiraportti yksityiskohtaisin havainnointitiedoin ja lähettää se suunnittelijalle. Sellaisessa raportissa voi olla enemmän tietoja (verrattuna täydelliseen mutta alustettuun HTML- tai tekstiraporttiin) löydetyistä kiintolevyistä, niiden tyypistä ja yksityiskohdista. Nämä tiedot voivat auttaa tutkimaan mahdollisia ongelmia tai parantamaan sovellusta, joten ole hyvä ja lähetä sellaiset raportit osoitteeseen reports@hdsentinel.hu.

Raportin voi lähettää välittömästi sen luonnin jälkeen. Näin Hard Disk Sentinel lähettää sen automaattisesti osoitteeseen www.hdsentinel.com. Ellei käytössä ole aktiivista internetyhteyttä, raportin voi tallentaa tiedostoon painikkeella Tallenna ja käyttäjä voi lähettää sen myöhemmin (toisesta tietokoneesta).


Kiintolevytestit

Seuraavilla sivuilla kuvataan Hard Disk Sentinelissa käytettäviisä olevia eri levytestejä. On suositettavaa lukea huolella nämä sivut (etenkin yleistiedot) ennen näiden testien käyttöä.

  • Yleistiedot, vastauksia levytestikysymyksiin

  • Laiteitsetestit: lyhyt, laajennettu ja tiedonsiirtotesti

  • Hajahakutesti

  • Pintatesti


Testit - Yleistietoja

Kuinka on mahdollista, että kiintolevyn kunto on alhainen, sanallinen kuvaus kertoo huonoista sektoreista, mutta testit eivät osoita olevan mitään ongelmia?

Kun kiintolevy havaitsee huonon sektorin, se yrittää tallentaa (uudelleenvarata) sektorin sisällön erityisvaratulle alueelle. Kun tämä on saatettu loppuun, sektorin alkuperäinen sijainti merkitään eikä levy enää käytä sitä: kaikki myöhemmät luku- ja kirjoitustoiminnot uudelleenohjataan erityisvaratulle sektorille. Näin vain testeillä (mikä ei tarkoita vain tämän ohjelman testejä) voi olla pääsy tälle modifioidulle pinnalle. Optimaalisessa tilanteessa pinta on todella täydellinen - ongelmat on korjattu, huonoja alueita ei enää käytetä. Ongelma voi aiheutua vain, jos huono alue on suhteellisen laaja (jolloin kunto on alhainen) ja syntyy yhä lisää ongelmia (esim. heikkoja ja huonoja sektoreita). Näiden ongelmien korjaamiseksi on suositettavaa käyttää Hard Disk Sentinelin sisäänrakennettuja testejä, koska ne voivat todentaa ja korjata ongelmia kontrolloidussa ympäristössä. Saadaksesi lisätietoja ongelmista tutustu jaksoon sanallinen kuvaus.

Kaikki testit on suunniteltu paljastamaan ongelmia. Kunto lasketaan kiintolevyltä löytyneiden ongelmien perusteella ja testi saattaa aiheuttaa kunnon alenemista. Kunto voisi kohota vain, jos ongelmia "piilotettaisiin" (muttei korjattaisi!). Tämä ei ole mahdollista - paitsi jos asemassa olisi heikkoja sektoreita ennen testiä ja niiden määrä voisi aleta (jopa takaisin nollaan). Kiintolevyn paljastamien (ja korjaamien) muiden ongelmien määrä ei voi aleta eikä olisi hyvä, mutta käyttäen saraketta "siirtymä" S.M.A.R.T. -sivulla, nämä ongelmat voi jättää huomiotta, jos levyn tila on vakaa. Saadaksesi lisätietoja tutustu jaksoihin sanallinen kuvaus ja lämpötilan kalibrointi.

Miksi testi löytää enemmän tai vähemmän huonoja dektoreita, kuin sanallisessa kuvauksessa esitetään?

Kiintolevy on jo uudelleenvarannut sanallisessa kuvauksessa mainitut huonot sektorit, joita ei enää käytetä. Testin paljastamat huonot sektorit ovat yhä aktiivisella pinnalla, joten nämä voivat mahdollisesti aiheuttaa datan katoamista. Tavoitteenamme on pakottaa kiintolevy uudelleenvaraamaan nämä sektorit ja myös estämään niiden tuleva käyttö. Yleensä levy toimii paremmin (jopa sen kuntoarvo saattaa aleta uudelleenvarauksen vuoksi).

Voiko kuntoa parantaa? Voiko sen palauttaa 100 %:iin?

Jos kiintolevyllä olisi heikkoja sektoreita, niiden tilaa voi parantaa testien aikana. Tämä saattaa johtaa kohonneeseen kuntoarvoon - jopa 100 %:iin, ellei levyltä löytyisi muita ongelmia. Kaikissa muissa tapauksissa kunto voi aleta, ellei aseman tila ole vakaa eikä uudempia paljastu.

Jos asema on vakaa: ellei kunto muutu edes monien kirjoitustestien jälkeen, aiemmat ongelmat voi tyhjätä sivulla S.M.A.R.T. käyttäen Siirtymä-saraketta. Näin kunnon voi palauttaa 100 %:iin.

Takuukorvaus on mahdollinen vain, kun kunto on 0 %. Jos kunto on korkeampi (mutta silti alhainen), on suositettavaa käynnistää testit (jopa monta kertaa) toistaiseksi havaitsemattomien lisäongelmien paljastamiseksi.

Miksi on hyvä käyttää Hard Disk Sentinelin levytestejä? Miksi ei riitä yksinkertaisesti vain kopioida tiedostoja (pakottaa uudelleenvaraus)?

Ohjelman suorittamien testien aikana kiintolevyt ovat paremman kontrollin ja tarkkailun alaisia verrattuna pelkkiin tiedostotoimintoihin. Tiedostojärjestelmä kytketään toiminnasta käyttöjärjestelmän ja muiden ohjelmien estämiseksi käyttämästä levyä eikä tiedostojärjestelmän tilakaan (esim. pirstaleisuus) vaikuta testiin. Lohkojen suoritusteho, yritysten määrä sekä levyn kunto ja lämpötila ovat kaikki tekijöitä, joita jatkuvasti tarkkaillaan testien aikana. On jopa mahdollista tutkia milloin vain sektorien sisältöä. Kuten kirurgia on mahdollista vain sairaalassa - kiintolevyn testauksella ja korjauksella on oma kontrolloitu ympäristönsä.

Testityypit

Yleisesti ottaen saatavilla on kahdenlaisia testejä: laiteitsetestejä ja ohjelmallista testausta (molemmat ovat käytettävissä Hard Disk Sentinelissa). Jälkimmäinen kategoria sisältää myös hajahakuaikatestin, mikä on erikoistesti, koska se ei todenna pintaa, vain aseman hakukyvyt.

Laitetestit voivat olla parempia kuin ohjelmalliset menetelmät, koska ne voivat tutkia levyn järjestelmää ja komponentteja (esim. päitä, servoa, elektroniikkakomponentteja jne.) erityisellä tavalla, mikä ei ole mahdollista ohjelmallisin menetelmin. Se ei vaikuta tallennettuihin tietoihin, joten niitä voi käyttää milloin vain (IDE- ja S-ATA-kiintolevyillä, jotka tukevat niitä) ilman mitään erityisvalmisteluja tai varmistusta. Laitetestien käyttöä suositetaan aika ajoin, etenkin täydellisille (tai lähes täydellisille) levyille paljastamaan mitä tahansa piilo-ongelmia.

Joissain tapauksissa näma laitetestit eivät ole käytettävissä, eivät tuettuja tai ne päättyvät nopeasti virhetulokseen jopa suhteellisen pienen ongelmamäärän tullen. Lisätietoja tuloksesta ei saa, esim. ei ole mahdollista listata vioittuneita sektoreita. Sellaisessa tapauksessa on tarpeen kunnollinen ohjelmallinen testaus.

Kun puhutaan ohjelmallisesta testauksesta, on tärkeää tietää, että KIRJOITUStoiminnon vaikutus levyn pintaan on tärkeintä: se pakottaa kiintolevyn todentamaan datasektorin yhtenäisyyden, uudelleenvaraamaan sen jos tarpeen ja korjaamaan heikot sektorit. Tästä syystä kaikki LUKUtyypin testejä (esim. scandisk muttei myöskään format (alusta)) ei voi käyttää korjaamaan levyongelmia (ja monissa tapauksissa ne eivät edes voi paljastaa tällaisia ongelmia). Scandisk todentaa ja korjaa vain loogisia virheitä (tiedostojärjestelmään liittyviä virheitä), jotka eivät todellisuudessa liity fyysisen levyn tilaan ja virheisiin (siksi ne tavallisesti katoavat levyn täydellisen uudelleenosioinnin ja -alustuksen jälkeen).

KIRJOITUStestit ovat yleensä tuhoavia, koska niiden pitää yliKIRJOITTAA tallennettu data. Kaikissa tapauksissa ole hyvin varovainen ennen minkään sellaisten levytestien aloitusta. On tärkeää varmistaa kaikki data!

Ohjelmallisia testejä suositetaan käytettäviksi harvemmin verrattuina laitetesteihin. Ohjelmalliset testit ovat käytannöllisiä, kun

  • uusi tyhjä kiintolevy asennetaan järjestelmään
  • laiteitsetestit päättyvät virheeseen
  • kiintolevy on epäilyttävä (esim. tuottaessaan outoa melua) ja/tai sen kunto muuttuu
  • on tarpeen päivittää tallennettu data kiintolevyllä tai SSD/flash-laitteella (poistamatta dataa), mikä on suositettavaa tehdä ajoittain estämään soluja "unohtamasta" tallennettuja tietoja. Sen taajuus perustuu laitteen tosiasialliseen käyttöön.

Tällaisissa tapauksissa on suositettavaa käyttää ensin lukutestiä, mikä ei vaikuta tallennettuihin tietoihin. Lukutesti ei pysty korjaamaan mitään virheitä, mutta voi osoittaa, mitkä aseman alueet ovat täydellisiä, vioittuneita ja/tai hitaasti saavutettavissa ja osoittavat aseman lämpötilan ja suoritustehon tyypillisiä piirteitä. Virheiden varsinainen todennus ja korjaus on mahdollista myöhemmin sopivalla kirjoitustestillä. Lisäongelmien tullen on suositettavaa varmistaa data ja käyttää levyn pinnan uudelleenalustustestiä (jopa tasoa 3 tai korkeampaa). Toisissa ohjelmissa saatetaan (virheellisesti) kutsua tämän testin yksinkertaisempaa versiota matalan tason alustukseksi.

TÄRKEÄÄ: Suunnittelija ei tarjoa mitään takuuta tallennettuun dataan nähden millään levyillä! Kaikissa olosuhteissa on suositettavaa varmistaa KAIKKI DATA ja lukea huolellisesti testien kuvaus ennen minkään testin käynnistystä.


Laiteitsetestit

IDE- ja sarja-ATA-kiintolevyjen sisäänrakennetut laiteitsetestit ovat täydellinen ratkaisu testata kiintolevyjen kuntotila nopeasti tai erittäin yksityiskohtaisesti. Yleensä kiintolevyt tukevat lyhyitä ja laajennettuja itsetestejä, mutta jotkin mallit tukevat myös muita (tiedonsiirto)itsetestejä. Lista kaikista tuetuista itsetesteistä ja tällaisten testien arvioiduista kestoista näkyy kiintolevyn sivulla Tiedot.

Itsetestit ovat ei-tuhoavia. Ne eivät vaikuta kiintolevylle tallennettuun dataan. Testin aikana kiintolevy on yhä käytettävissä, mutta saattaa olla hitaampi (ja toisin päin: kiintolevyn käyttö voi paljon pidentää testiä. Se voi olla tärkeää järjestelmäkiintolevylle, millä käyttöjärjestelmä tai muu ohjelma voi suorittaa paljon luku/kirjoitustoimintoja).

Lyhyt itsetesti todentaa kiintolevyn pääkomponentit (luku/kirjoituspäät, servon, elektroniikan, sisäisen muistin jne.). Tämä testi vie vain joitain minuutteja.

Laajennettu itsetesti suorittaa yllämainitut ja täydellisen pinnan skannauksen, mikä paljastaa ongelmalliset alueet (jos niitä on) ja pakottaa huonojen sektorien uudelleenvarauksen. On suositettavaa aika ajoin käyttää tätä testiä todentamaan levyn kunto - etenkin kiintolevyllä jonka kunto on alle 100%.

Tiedonsiirron itsetesti (jos tuettu) suorittaa valmistajakohtaiset testivaiheet. Yleensä tämä todentaa kiintolevyn mekaaniset osat varmistaakseen, ettei ole tapahtunut mitään käsittelyvauriota.

Viime itsetestien päiväys ja tulokset (kunnossaolon todennus tai kiintolevyn elementin vikahavainto) näkyvät sivulla Tiedot. Tältä sivulta voi käynnistää kaikki tuetut kiintolevytestit manuaalisesti - tai on mahdollista säätää automaattiset (ajoitetut) kiintolevytestit sivulla Operaatiot (vain Professional-versiossa).


Hajahakutesti

Tällä testillä on mahdollista todentaa etenkin kovassa käytössä olevan levyn melutaso, uralta uralle hakuaika ja lämpötasot.

Testi on erityisen käyttökelpoinen äänitason muuttamisen jälkeen todentamaan, miten modifioitu asetus vaikuttaa meluun ja hakuaikaan. Tämän todennuksen voi tehdä lyhyellä (pika)testillä.

Testiä voi käyttää todentamaan levyn vakaus ja lämpötilan nousu pitempijaksoisen käytön aikana. On mahdollista että testin aikana lämpötila voi nousta 10-15 celsiusastetta (verrattuna toimettomana olon lämpötilaan), joten jos kiintolevy on ollut liian kuuma ennen testin alkua, on suositettavaa valvoa testausta ja peruuttaa se saavutettaessa kriittinen lämpötaso.

Testi suositettava käyttö: uuden kiintolevyn asennuksen jälkeen. Pitempikestoista testiä (8 tuntia tai kauemmin) voi käyttää stressitestinä todentamaan levyn vakauscan.

Testiä voi käyttää, vaikka laiteitsetesti pysähtyisi virheeseen tai ellei kiintolevy tukisi sitä. Testi on turvallinen, se ei vaikuta tallennettuun dataan, vain levyn luku/kirjoituspäiden sijainteihin.

Huomaa: rekisteröimätön versio sallii vain lyhimmän test (2 minuuttia) ja vain kerran samalle levylle.


Pintatesti

Käyttäen tätä testiä kiintolevyn pinnan voi tarkastaa eri menetelmin. Jotkin näistä menetelmistä ovat turvallisia tallennetulle datalle, mutta toiset ovat tuhoavia: tallennetut tiedot pyyhkiytyvät pysyvästi testioperaation aikana.

Ensiksi täytyy valita kiintolevy ja käynnistettävä testityyppi. Testin yksityiskohtainen kuvaus näkyy valittaessa ja ohjelma näyttää, miten testi vaikuttaa tallennettuun dataan. On erittäin suositettavaa lukea nämä tiedot huolella ennen testin käynnistystä.

Seuraavat testit ovat mahdollisia:

  • Lukutesti - Lukee levyn pinnan todentaakseen, ovatko kaikki sektorit saavutettavissa ja luettavissa.

    Testi on turvallinen, se ei vaikuta tallennettuun dataan.

    Levyongelmia saattaa jäädä piiloon ja paljastuneita ongelmia EI korjata (kuten tekee ScanDisk).

  • KIRJOITUStesti - Ylikirjoittaa levyn pinnan säädettävin mallein. Pakottaa jokaisen heikon sektorin analyysin ja todentaa jokaisen piilo-ongelman sekä korjaa ne uudelleenvaraamalla huonot sektorit (tämä on aseman uudistusta).

    Mahdollistaa levyjen paremman käytön, koska testin jälkeen käytetään erityisvarattua aluetta jonkin ongelmallisen sektorin sijaan.

  • KIRJOITUS + luku -testi - Ylikirjoittaa levyn pinnan säädettävin mallein ja lukee sitten sektorien sisällöt uudelleen todentaakseen, ovatko ne saavutettavissa ja yhtenäiset . Pakottaa jokaisen heikon sektorin analyysin ja todentaa jokaisen piilo-ongelman sekä korjaa ne uudelleenvaraamalla huonot sektorit (tämä on aseman uudistusta).

    Mahdollistaa levyjen paremman käytön, koska testin jälkeen käytetään erityisvarattua aluetta jonkin ongelmallisen sektorin sijaan.

  • Luku + KIRJOITUS + luku -testi (päivittää data-alueen) - Lukee tallennetun datan jokaisesta lohkosta, kirjoittaa takaisin sisällöt ja lukee lopuksi tiedot sekä vertaa alkuperäisiä sisältöjä. Laajennetussa testissä käytetään lisäkirjoitussykliä ennen sisältöjen takaisinkirjoitusta parantamaan virheenkorjauksen tehokkuutta (aseman uudistusta).

    Operaatio on yleensä turvallinen tallennetuille tiedoille, mutta datan menetystä saattaa tapahtua, ellei järjestelmä ole vakaa ja/tai uhkina ovat virtahäiriöt, ylikellotus, muisti/tehonlähde/kaapeliongelmat ja muut tekijät.

    Testiä voi käyttää päivittämään tallentimen data-alue tarvitsematta täysin tyhjentää, mutta silti on suositettavaa varmistaa tärkeä data ennen tätä testiä.

  • Levyn pinnan uudelleenalustus - Ylikirjoittaa levyn pinnan erityisellä alustusmallilla palauttaakseen sektorit oletus- (tyhjään) tilaan ja lukee uudelleen sektorien sisällöt todentaakseen, ovatko ne saavutettavissa ja yhtenäiset. . Pakottaa jokaisen heikon sektorin analyysin ja todentaa jokaisen piilo-ongelman sekä korjaa ne uudelleenvaraamalla huonot sektorit (tämä on aseman uudistusta).

    Mahdollistaa levyjen paremman käytön, koska testin jälkeen käytetään erityisvarattua aluetta jonkin ongelmallisen sektorin sijaan.
    Hyvin intensiivinen ja aikaa vievä testi, etenkin jos taso (ylikirjoitussyklien määrä) asetetaan korkeaksi.

    Tämän testin yksinkertaista versiota toiset työkalut kutsuvat yleensä (virheellisesti) matalan tason formatoinniksi. Sitä voi tehokkaasti käyttää pysyvästi tuhoamaan tallennetut tiedot (Navso P-5239-26 standardin datan tuhoaminen).

    Kullakin testillä on omat säätövalinnat:

    Yleisesti katsoen on mahdollista säätää testattavien lohkojen järjestys ja valinnaisesti voi säätää toistomäärän (jolloin ohjelma ajaa saman testin levyllä kahdesti tai useammin) ja on mahdollista poistaa kaikkien loogisten taltioiden (osioiden) asennus testin aikanat. Jälkimmäinen on erittäin suositettavaa estämään muita ohjelmia ja käyttöjärjestelmää käyttämästä levyä testin aikana. Järjestelmäasemaa (joka sisältää käyttöjärjestelmän, käyttäjän juurikansion ja Windowsin heittovaihtotiedoston) ei voi lukita näin.Johtuen varsinaisen järjestelmän käynnissäolosta vain lukutestiä (joka ei vaikuta tallennettuun dataan) voi käyttää järjestelmäasemassa.

    Huomaa: jotkin testit ja asetukset ovat käytettävissä vain ohjelman Professional-versiossa.

    Huomaa: luvattomien henkilöiden estämiseksi käyttämästä testejä (etenkin kirjoitustestejä) ohjelma kysyy määritettyä salasanaa ennen testi-ikkunan avausta.

    Testiyksityiskohdat

    Ohjelma jakaa data-alueen 10 000 lohkoon, tämä on levyn pintakartta. Kun napsauttaa mitä tahansa lohkoa hiirellä, esiin ilmestyy kyseiseen lohkoon kuuluvan sektorin sisältö. Näin on mahdollista tarkastella tallennettua dataa ja/tai kirjoitettua dataa kirjoitustestin suorituksen jälkeen. On mahdollista tutkia sektorin sisältöä (ja ladata takaisin aiemmin tallennetun testin tulokset) käynnistämättä testiä napsauttamalla painiketta Näytä. Tämä on turvallista levylle tallennetulle datalle.

    Testien aikana Hard Disk Sentinel todentaa näytettyihin lohkoihin kuuluvien kaikkien sektorien yhtenäisyyden. Jos lohkot ovat saavutettavissa ja käsiteltävissä ilman virheitä, ne näkyvät vihreän värisinä. Tummempi vihreä väri tarkoittaa, että sektorit ovat hitaampia ja vaikeampia käsitellä. Ohjelma suodattaa nähtäviin hitaampien siirtoaikojen vaikutuksen levyjen loppuun. Jos sektorit ovat vaikeampia saavuttaa ja niitä voi käsitellä vasta useiden yritysten jälkeen, niin lohkot ovat vioittuneita mutta korjattuja ja ohjelma esittää kyseiset lohkot keltaisina. PunainenRed väri merkitsee, että sektorien lohkoa ei voi käsitellä (lukea tai kirjoittaa - riippuen valitusta testistä). Myöhempi KIRJOITUStesti saattaa olla tarpeen pakottaa asema uudelleenvaraamaan lohkon ongelmalliset sektorit.

    Mikäli on löytynyt vioittuneita tai huonoja lohkoja, on suositettavaa tarkastaa koko datapinta yhdellä tai useammalla KIRJOITUStestillä. Kirjoitustestien aikana ohjelma pakottaa kiintolevyn todentamaan pinnassa olevien sektorien kuntotilan ja uudelleenvaraamaan ne erityisvaratulle alueelle. Näin alkuperäistä (huonoa) sektoria ei enää käytetä ja myöhemmät luku- ja kirjoitustoiminnot uudelleenohjataan erityisvaratulle alueelle. Tätä kutsutaan uudistamiseksi. Tuloksena oleva kiintolevy toimii paremmin, on jopa mahdollista, että seuraavissa testeissä se näyttää vain hyviä (vihreitä) lohkoja, koska huonot sektorit eivät enää ole käytössä. Uudistuksen sivuvaikutus on, että aseman kunto saattaa heiketä, koska yhä enemmän ongelmia paljastuu. Näin uudistus ei yleensä paranna kuntoa (paitsi jos on löytynyt heikkoja sektoreita ja niiden tila vakiintuu).

    Jos testien aikana löytyy huonoja sektoreita, on mahdollista ettei ohjelma ja/tai käyttöjärjestelmä vastaa uudelleenvarauksen aikana. Tämä voi viedä joitain minuutteja tai jopa tunteja - riippuen käsiteltävän pinnan koosta. Ei ole suositettavaa peruuttaa operaatio ja resetoida tietokone tai katkaista siitä virta. On mahdollista että levynohjain tai sen ajuri saattaa kytkeä irti vastaamattoman levyn, jolloin se katoaa järjestelmästä. Tämä on luultavimmin mahdollista USB-liitännän yhteydessä. Jos näin tapahtuu, on suositettavaa liittää kiintolevy suoraan emolevyyn tai eri ohjaimeen ja käynnistää testi uudelleen.

    Testien suositettava käyttö: käynnistä laajennettu kirjoitustesti (esim. "levyn pinnan uudelleenalustus") todentaaksesi, onko levyn pinta kunnossa ja pakottaaksesi tällöin joka sektorin todennuksen ja uudelleenvarauksen. Kuten hajahakutestissä ohjelma mittaa lämpötasot näiden testien aikana, joten tämän äärimmäisen kuormituksen aikana voi tarkistaa korkeimman mahdollisen lämpötilan. Testit voi käynnistää muunkin tyyppisillä tallentimilla (ei vain kiintolevyillä), esim. SSD-laitteet, FLASH-muistikortit ja muistitikut voi myös testata - ja "luku - kirjoitus - luku" -testiä voi tehokkaasti käyttää estämään muistisolujen "unohtamis"-ilmiöstä johtuvaa datan katoamista.

    Testit voivat olla hyödyllisiä, vaikkakin laitetestit saattavat pysähtyä virheilmoitukseen ei tuettu tai ei käytettävissä.

    Huomaa: rekisteröimättömässä versiossa ei voi käynnistää mitään testejä. Rekisteröimättömissä versioissa on mahdollista vain tarkastella sektorien sisältöä.

    Huomaa: testien aikana taustalla käynnissä olevat ohjelmat tai käyttöjärjestelmä voivat vaikuttaa kunkin lohkon suoritustehoon (ja siis tuloksena olevaan väriin). Tämän ilmiön minimoimiseksi ohjelma estää näytönsäästäjää käynnistymästä, estää tietokonetta menemästä valmiustilaan tai alempaan virranhallintamuotoon ja käyttämästä korkeampaa prioriteettia. Joka tapauksessa on suositettavaa sulkea kaikki taustatoiminnot testin ajaksi ja toistaa testi, jos suoritustehon aleneminen vaikuttaa suurempaan alueeseem (ei vain 1-1 -lohkoihin). Ohjelmassa on valinta toistaa testi tämän hetkellisen suoritustehon alenemisen minimoimiseksi.

    Esimerkkejä

    Käyttökelpoisen data-alueen loppuosa on huono. Huonot lohkot muodostavat yhtenäisiä alueita saaden epäilemään vakavaa pintaongelmaa. Huomaa keltainen vioittunut lohko lähellä vasenta alakulmaa: se on huonon lohkon vieressä ja muuttuu huonoksi myöhemmässä käytössä. Jopa vioittumattomat lohkot ovat hyvin hitaasti saavutettavissa. On suositettavaa tarkistaa hiiriosoittimella ensimmäisen ongelmallisen lohkon sijainti ja luoda osio(ita), jotka eivät käytä seuraavaa aluetta.

    Kiintolevy osoittaa monia ongelmia. Se on pysähtynyt luku- ja kirjoitustoimintojen aikana ja sen kunto on suhteellisen alhainen (30 %). Levyllä on erinäisiä huonoja, vioittuneita ja hitaasti saavutettavia lohkoja.

    Sama levy monien "Levyn pinnan uudelleenalustus" -testien jälkeen. Heikot sektorit on korjattu ja huonot sektorit on uudelleenvarattu (kunto alentunut 20%:iin), mutta kokonaispinta on parantunut ja levyä voi yhä käyttää jonkin aikaa (muttei ole suositettavaa tallentaa tärkeää dataa ongelmien vuoksi).

    Tyypillinen huonokuntoinen (22 %) kiintolevy. Monet kirjoitustestit (varsinkin pinnan uudelleenalustustesti) voivat parantaa tilaa, muttei ole suositettavaa käyttää tämän aseman ensimmäistä puoliskoa (luoden osioita), vain toista puoliskoa).


Lisäys

Yleistietoja S.M.A.R.T. -teknologiasta ja Hard Disk Sentinelin toiminnoista kuvataan seuraavissa luvuissa:

  • Valmistajakohtaiset vs raw-arvot

  • Kunnon arviointi

  • Suoritustehon arviointi

  • Virran päälläoloaikaPower on time

  • Lämpötilan kalibrointi

  • Tunnetut S.M.A.R.T. -attribuutit


Valmistajakohtaiset vs raw-arvot

Kuten kiintolevyjen S.M.A.R.T. -sivulla kuvataan, voit nähdä että attribuuttien arviointi on mahdollista käyttäen valmistajakohtaista metodia (tarkistaen arvo- ja huonoimmat alueet) tai käyttäen eri metodia, joka ei riipu valmistajasta (tarkistaen data-alueen). Miten nämä eri metodit toimivat ja mikä on ero?

Valmistajakohtaiset arvot

Kiintolevyn nykyistä kuntotilaa tarkkailevat jatkuvasti monet anturit. Mitatut raw-arvot tallentuvat (vastaavan S.M.A.R.T. -attribuutin "data"-alueelle) ja niitä arvioi eräs (kiintolevyn laitteistoon sisäisesti koodattu) algoritmi.

Tämän arvioinnin jälkeen attribuutin valmistajakohtainen tulos tallentuu arvoalueelle. Se ilmaisee miten "hyvä" attribuutti on (verrattuna lukemaan kynnysalueella). Kun kiintolevy on uusi (ei koskaan ennen käytetty) tällä arvolla on teoreettinen maksimiarvo ja sitten se alenee - kunnes se saavuttaa kynnystason.

Näin jokin attribuutti on täydellinen, jos seuraava epäyhtälö on TOSI:

A - f(r) >= C

Missä:

  • A - teoreettinen maksimiarvo, kyseisen attribuutin "paras" mahdollinen arvo.

  • f - raw- (r) arvoihin perustuva funktio alenemisen laskemiseen. Yleensä se on lineaarinen funktio, joten r kerrotaan vakiolla B.

  • C - valmistajakohtainen kynnystaso. Tätä tasoa alempaa attribuuttia pidetään ongelmallisena.

Tämän metodin käytöllä on joitain haittapuolia. Arvoja A, B, C, (eli funktiota f) ei määritetä tarkasti (nämä voivat vaihdella samalla valmistajalla mallista malliin jopa kahdella saman mallin kiintolevyllä). Toinen haittapuoli on, että attribuutteja arvioidaan itsenäisesti, niiden keskinäistä suhdetta ei huomioida.

Todellisuudessa on mahdollista havaita ei-realistisia arvoja, jotka voivat ilmentää kiintolevyn viallisuutta. Jotkin kiintolevyvalmistajat saattavat määrittää 60-70 vuotta tai jopa enemmän kiintolevyn kokonaiseliniäksi, kun tutkitaan vastaavaa attribuuttia. On myös mahdollista, että tarvitaan monia tuhansia huonoja sektoreita, ennen kuin kiintolevy osoittautuu ongelmalliseksi, jos käytetään yllä selostettua metodia. Tietenkin monia ongelmia voi ilmetä kauan aikaa ennen tämän kynnyksen saavuttamista. Esim. datan tutkiminen ja uudelleenvaraus data-alueen huonoilta (vioittuneilta) sektoreilta voi viedä paljon aikaa (jopa tunteja) - eikä se ehkä valmistu ongelmitta. Tämän prosessin aikana järjestelmä ei yleensä vastaa, joten ongelmallinen kiintolevy, joka tuottaa ongelmia yhä uudelleen, saattaa huomattavasti heikentää järjestelmän yleisvakautta.

Useimmat kiintolevyjen analysointisovellukset käyttävät yllä kuvattua metodia kiintolevyn kuntotilan määrityksessä. Monissa tapauksissa kiintolevyn esitetty tila on paljon parempi kuin todellinen johtuen väljistä kynnysarvoista. Jotkin valmistajat voivat muuttaa arvoja esittääkseen levynsä kuntotilan paremmaksi kuin muiden. Tämä saattaa harhauttaa joitain ohjelmia tai käyttäjiä.

On tärkeää että sen jälkeen, kun jokin S.M.A.R.T. -attribuutti saavuttaa kynnystason, kiintolevyn tulisi kestää 24 tuntia (mahdollisen varmistuksen ajamiseksi). Useimmiten se ei riitä ja vain osa dataa voidaan tallentaa tänä aikana. Datan pelastus ongelmalliselta, lähes toimimattomalta kiintolevyltä voi olla hyvin tuskallinen, pitkä ja kallis prosessi. On parasta identifioida ongelma ja valmistautua siihen kauan ennen katastrofaalista tilannettaon.

Raw-arvojen analysointi

Hard Disk Sentinel on suunniteltu selvittämään tämä tilanne. Oletusarviointimetodit tarkistavat S.M.A.R.T. -attribuuttien raw-arvot. Näin on mahdollista määrittää kiintolevyn kunto riippumatta valmistajista ja malleista. Huomaa: on mahdollista valita valmistajakohtainen arviointimetodi kunnon laskemiseen, mutta tämän metodin jatkuva käyttö ei ole suositettavaa (johtuen yllä kuvatuista ongelmista), koska se saattaa antaa virheellisiä tuloksia.

Kun arvioidaan raw-arvoja, attribuuteille ei ole ennaltamääritettyjä (valmistajakohtaisia) kynnyksiä, mutta lisääntyvät ongelmat alentavat levyn kuntoa (jatkuvasti ja jyrkästi) ja tämä ennakoi mahdollista vauriota ja datan menetystä.

Laskentametodien yksityiskohtainen selvitys on kuvattu täällä.


Kunnon arviointi

On mahdollista valita monia eri kunnon laskentametodeja lisävalinnoissa. Näiden arviointimetodien väliset erot:

Analysoi datakenttä

Jos valitaan tämä valinta, mitattuja (vastaavien S.M.A.R.T. -attribuuttien Data-sarakkeessa näkyviä ) raw-lukemia käytetään määrittämään kiintolevyn kuntoa. Kehitettäessä laskentametodia seuraavat aspektit olivat tärkeitä:

  • Sen tulisi heijastaa todellista tilaa. Ei tulisi riippua ajasta tai entisistä arvoista. Määrittää tulos käyttämättä pitkää aikaa analysoimaan tai testaamaan metodeja.

  • Sen ei tulisi enetä ajan myötä - ei näyttää kuntotilaa paremmaksi jonkin ajan kuluttua (paitsi jos on onnistuttu testaamaan joitain epävakaita sektoreita ja niitä voi käyttää, koska niissä ei ole ongelmia).

  • Sen tulisi heijastaa pieniäkin muutoksia ja heikentymisiä. Jatkuvasti lisääntyvien ongelmien määrän tulisi jatkuvasti heikentää tulosta.

  • Sen tulisi laskea attribuuttien välistä suhdetta. Useiden eri ongelmien tulisi heikentää tulosta paljon jyrkemmin kuin yhden ainoan ongelmallisen attribuutin.

  • Tuloksen tulisi olla sama kahdella (tai useammalla) samat ongelmat omaavalla kiintolevyllä, vaikka kiintolevyt olisivat eri mallisia, eri valmistajilta.

  • Tulosta tulisi kontrolloida joissain tilanteissa. Esim. ongelmallisen virtalähteen korvaamisen jälkeen aiemmin kohdattuja ongelmia ei tulisi huomioida. Viallista anturiakaan ei tulisi huomioida tai sitten sen antamaa arvoa tulisi modifioida (katso tähän nähden kohtaa lämpötilan kalibrointi).

Kiintolevyllä on alun perin 100% kunto. Kaikki kriittiset kuntoon liittyvät S.M.A.R.T. -parametrit (jos niitä on saatavilla, se riippuu valmistajasta) alentavat tätä arvoa. Näillä attribuuteilla on ennaltamääritetty paino- ja maksimiraja-arvo (jälkimmäinen määrittää attribuutin kuntoarvon maksimiheikennyksen). Yleiskunnon prosenttiarvo lasketaan jäljellä olevilla prosenttiarvoilla (100 - heikennys %).

Tällä hetkellä Hard Disk Sentinelissä on kaksi sellaista metodia. Käytettäessä oletusmetodia painotukset ja rajat (katso alla) ovat väljempiä. Jos käytetään tiukempaa, palvelimille suositettavaa valintaa, arvot ovat paljon tiukemmat, jolloin ongelmat saattavat alentaa kuntoa hyvin jyrkästi.

Seuraavat taulukot sisältävät kuntoon liittyvät (kriittiset) S.M.A.R.T. -attribuutit, jotka vaikuttavat kuntoarvoon painotuksineen ja maksimirajoineen:

Oletuslaskentametodin painotukset ja rajat:

S.M.A.R.T. -attribuutti | Painotus | Raja %
Uudelleenvarattujen sektorien määrä | 1 | 70
Hakuvirheiden määrä | 0.5 | 20
Pyörinnän uudelleenyritysten määrä | 3 | 60
Uudelleenvaraustapausten määrä | 0.6 | 30
Nykyisten epävakaiden sektorien määrä | 0.6 | 48
Offline-korjauskelvottomien sektorien määrä | 1 | 70

Tiukemman laskentametodin painotukset ja rajat:

S.M.A.R.T. -attribuutti | Painotus | Raja %
Uudelleenvarattujen sektorien määrä | 6 | 60
Hakuvirheiden määrä | 2 | 20
Pyörinnän uudelleenyritysten määrä | 6 | 40
Uudelleenvaraustapausten määrä | 4 | 30
Nykyisten epävakaiden sektorien määrä | 4 | 30
Offline-korjauskelvottomien sektorien määrä | 6 | 60

Lukemat on määritetty tutkimalla saapuneer raportit ja datan palautuksen vuoksi vastaanotettujen (käyttökelvottomien) kiintolevyjen S.M.A.R.T. -tila.

Huomaa: sarake Data sisältää heksadesimaaliarvoja. Näma tulee muuntaa desimaaleiksi ennen laskemista. Alimpia 16 bittiä (oikeanpuoleiset 4 merkkiä) käytetään laskentametodissa.

Esim.: käytettäessä oletuslaskentametodia. Jos "Uudelleenvarattujen sektorien määrä" -attribuutilla on 0002 sarakkeessa "Data", kuntoarvo = 100 x ( 100 - 2x1 ) % = 98 %

Jos "Nykyisten epävakaiden sektorien määrä" -attribuutilla on 0005 sarakkeessa "Data" myös samalla kiintolevyllä, kunto on = 98 x ( 100 - 5x0.6) % = 95 %. Tiukempi laskentametodi antaa kuntoarvon tulokseksi 100 x (100 - 2x6) % x (100 - 5x4) % = 70 % .

Raja- % määrittää kuinka monta % attribuutti voi alentaa yleistä kuntoarvoa. Esim. jos attribuutilla "Offline-korjauskelvottomat sektorit" on sarakkeessa "Data" 0200 (joka on 512 desimaaliarvoksi muunnettuna), kunnon tulisi pudota 512 x 1 = 512 %, mutta tämän attribuutin raja on vain 70 %. Toisin sanoen jos "Offline korjauskelvottomien sektorien" arvo on korkea, levyn kuntoarvo ei voi olla yli 30 %. Muut ongelmat voivat alentaa kuntoarvoa enemmän.

Analysoi valmistajakohtaiset arvot

Jos käyttää tätä valintaa, arvioidaan kuntoon liittyviä S.M.A.R.T. -attribuutteja. Kaikilla sellaisilla attribuuteilla tulee olemaan vähäinen kuntoarvo, laskennallisesti välillä 0 - 100% ja perustuen nykyiseen arvoon, kynnykseen ja teoreettiseen maksimiarvoon (jälkimmäisen määrittää Hard Disk Sentinel valmistajan ja mallin pohjalta). Näistä arvoista saadaan laskien selville kiintolevyn yleiskuntoarvo.

Esim.: "Uudelleenvarattujen sektorien määrän" kynnys on 36, arvo on 84 ja tämän attribuutin alkuarvo oli 100. Tämän attribuutin kuntoarvo on: (1 - (100-84)/(100-36)) x 100 = 75 %. Jos (samalla kiintolevyllä) "Hakuvirheiden määrän" kynnys on 30, arvo on 60 ja alkuarvo on 90, tämän attribuutin kunto on 50 % ja kiintolevyn yleiskunto on 37.5 %.

Huomaa: 1.40 ja aiemmat Hard Disk Sentinelin versiot käyttävät vain laskentametodia tiukempi, suositetaan palvelimille. Päivitys versiosta 1.40 tai vanhemmasta saattaa johtaa eri kuntoarvon esittämiseen. Sivulla lisävalinnat on mahdollista milloin vain modifioida laskentametodia.

Huomaa: valittu laskentametodi tallentuu raportteihin sekaannuksen estämiseksi.

Huomaa: yleensä eri kuntoarvot noudattavat kaavaa:

Valmistajakohtainen >= Oletus>= Tiukempi

Käyttämällä metodia "tiukempi" kuntoarvo alenee jyrkästi pienenkin ongelman ilmetessä, joten tämän metodin käyttöä suositetaan vain, kun mitään (pientäkään) ongelmaa ei sallita.


Suoritustehon laskenta

Kiintolevyn suoritustehon arvon voi laskea erikseen (kuten kuntoarvonkin). Laskentametodin valinta lisävalinnat-paneelissa määrittää myös suoritustehoarvon laskennassa käytettävän metodin.

Analysoi datakenttä

Hard Disk Sentinel yhdistää eri arvoja määrittäessään tätä arvoa. S.M.A.R.T. -attribuuttein liittyvän suoritustehon raw-arvot (esim. hakuaika) vaikuttavat yleiseen suoritustehoon enintään 25%. Viimeisen kuukauden aikana havaittujen datansiirtovirheiden (ultra ATA CRC -virheiden) määräkin saattaa alentaa suoritustehon arvoa 25%. Nämä siirtovirheet eivät sinänsä ilmaise kiintolevyongelmaa, mutta ne voivat heikentää järjestelmän vakautta ja suoritustehoa.

Loput 50% suoritustehon arvosta lasketaan tutkimalla parhaillaan käytettävää DMA-siirtomoodia ja käytettävissä olevaa maksimisiirtomoodia. Jos kiintolevy toimii vain PIO- (ohjelmoidussa I/O) moodissa, tämä osa kuntoarvoa on 0 50:n sijaan.

Esim.: jos siirtonopeus on vain Ultra DMA -moodi 2 (33 MB/s) sen käytettävissä olevan maksimisiirtonopeuden Ultra DMA -moodi 5:n (100 MB/s) sijaan, mutta suoritustehoon liittyvät S.M.A.R.T. -attribuutit ovat kunnossa eikä datansiirtovirheitä ole havaittu viimeisen kuukauden aikana, yleiskuntoarvo tulee olemaan 25 + 25 + (2/5) x 50 = 70 %. Tässä esimerkissä ongelma on luultavasti aiheutunut käytettäessä vanhaa vain 40-johtimista IDE-kaapelia.

Analysoi valmistakohtaiset arvot

Jos käyttää tätä valintaa, arvioidaan suoritustehoon liittyviä S.M.A.R.T. -attribuutteja. Kaikkien sellaisten attribuuttien laskennallinen arvo on välillä 0 - 100% pohjautuen nykyiseen arvoon, kynnykseen ja teoreettiseen maksimiarvoon (jälkimmäisen määrittää Hard Disk Sentinel perustuen valmistajaan ja malliin). Näistä arvoista saadaan laskien selville kiintolevyn yleiskuntoarvo.


Virran päälläoloaika

Kiintolevyn virran päälläoloajan voi määrittää tutkimalla kiintolevyn "Virran päälläoloajan" S.M.A.R.T. -attribuuttia #9 . Tätä arvoa tukevat useimmat uudenaikaiset IDE- ja S-ATA-kiintolevyt.

Tämän attribuutin raw-arvo kasvaa jatkuvasti, kun kiintolevyssä on virta (toiminnassa muttei välttämättä suorita luku- tai kirjoitusoperaatiota). Aikayksikkö riippuu valmistajasta. Se voi olla tunteja (arvo kasvaa kerran per joka tunti), minuutteja tai puolia minuutteja. Eri yksikötkin voivat olla mahdollisia ja saman valmistajan kahdella kiintolevyllä ei ehkä ole samat aikayksiköt.

Asennuksen jälkeen Hard Disk Sentinel alkaa tutkia tätä attribuuttia. Se tarkistaa tämän attribuutin raw-arvon kahden peräkkäisen lisäyksen välillä kuluneen ajan. Tämän testin aikana näkyy arvioitu virran päälläoloarvo (harmaan värisenä) eikä se ehkä ole tarkka. Tämä testi voi kestää jopa 20 minuuttia. Jos käyttäjä sulkee sovelluksen testin aikana, se käynnistyy automaattisesti uudelleen Hard Disk Sentinelin seuraavassa käynnistyksessä, kunnes se voi määrittää kaikilla kiintolevyillä käytetyn aikayksikön. Onnistuneen mittauksen jälkeen yksikkö tallentuu ja sitä voi käyttää myöhemmin automaattisesti. Tällä mittauksella ei ole vaikutusta kiintolevyn tai tietokoneen suoritustehoon.

Mittauksen jälkeen (tai ellei se ole tarpeen) näkyy (mustan värisenä) virran päälläoloajan arvo eikä tekstiä "arvioitu arvo" näy. Jos esitetty arvo näyttää virheelliseltä (liian matala tai korkea), voi käyttää nappia "Toista testi".

Kun mittaus on valmis, on suositettavaa lähettää testiraportti. Saapuneet raportit auttavat jatkokehittelyssä ja on mahdollista, että myöhemmässä versiossa näkyy virran päälläolon tarkka lukema ensi kerrasta alkaen (tarvitsematta mitata).

Virran päälläoloajan viereinen arvo ilmaisee aseman kokonaiskäynnissäoloajan (virroitettu). Toimeton aikakin (kun ei ole ollut luku- tai kirjoitustoimintaa) lisää tätä arvoa, mutta valmiustila-aika ei lisää tätä aikaa. Yksi esitetty päivä tarkoitta 24 tuntia. Esim. kaksi vuotta vanha kiintolevy, jota on käytetty 12 tuntia joka päivä, näyttää samaa "virran päälläoloaikaa" kuin vuoden vanha kiintolevy, jota on käytetty 24/7-moodissa (kuten 8 tuntia joka päivä toiminut 3 vuotta vanha kiintolevy).

Huomaa: virran päälläoloajan esitys ei ehkä ole virheetön joissain malleissa.

Arvioitu jäljellä oleva elinaika

Analysoi datakenttä

Jos käyttää valintaa "Analysoi datakenttä" kuten valitaan kunnon laskentametodi lisävalinnat-sivulla, jäljellä oleva elinaika lasketaan seuraavalla metodilla:

  • Oletuksena kiintolevyn täydellisen kunnon odotettu kokonaiselinaika on määritetty 5 vuodeksi (toimiessaan joka päivä päivin öin). Tämä on yhtä kuin 1825 päivää 24/7-moodissa eli 43800 tuntia.

  • Kulunut virran päälläoloaika alentaa tätä arvoa.

  • Tulos heikkenee niiden päivien mukaan, jolloin lämpötila on ollut liian korkea. Jos maksimilämpötila(piikki) on ollut korkea, se ei ole niin kriittistä, mutta jos keskimääräinen lämpötila on ollut liian korkea (tarkoittaa lämpötilan olleen korkea kauemman aikaa), tulos heikkenee jyrkästi.

  • Tulos kerrotaan levyn kuntoarvon neliöllä.

Huomaa: Hard Disk Sentinel näyttää 1000 päivän jäljellä olevan elinajan maksimiarvoksi. Tietenkään ihanteellisessa tilanteessa tämä arvo ei alene edes satojen päivien jälkeen.

Esim.: kiintolevy on toiminnassa 600 päivää (600 x 24 tuntia) eikä sen lämpötila ole ollut liian korkea (ei ole ollut liian korkean keskimääräisen lämpötilan päiviä) ja kunto on 70%. Jäljellä oleva kokonaiselinaika on 1225 x 0.7 x 0.7 = 600 päivää ja 6 tuntia.

Kuten voit nähdä, kuntoarvo määrää radikaalisti kiintolevyn jäljellä olevan arvioidun elinajan. Jos kuntoarvo on matala, jäljellä oleva elinajan näyttö pysyy muuttumattomana monia päiviä, vaikka virran päälläoloajan arvo kasvaa. Esim. jonkin levyn kuntoarvo on 25%, 16 päivää tarvitaan (olettaen että kiintolevy on toiminnassa 24 tuntia päivittäin) lyhentämään jäljellä olevaa elinaikaa yhdellä ainoalla päivällä (koska 16 x 0.25 x 0.25 = 1).

Huomaa: arvioitu jäljellä oleva elinaika riippuu monista tekijöistä (lämpötila, kunto), joten on suositettavaa suorittaa lämpötilan kalibroinnin vaiheet ja valita nykyiseen tilanteeseen perustuva sopiva kunnon laskentametodi ja käyttää sopivia S.M.A.R.T. -attribuuttien siirtymäarvoja jos tarpeen. Vain kokeneiden käyttäjien tulisi käyttää ja modifioida näitä valintoja, koska asetusten väärä yhdistelmä saattaa ilmetä joidenkin arvojen virheellisenä esityksenä.

Analysoi valmistajakohtaiset arvot

Jos käyttää asetusta "Analysoi valmistajakohtaiset arvot", arvioidun elinajan määrittää kynnyspäivämäärän ylittävä kriittinen S.M.A.R.T. -attribuutti, joka saavuttaa kynnyksen ennen kiintolevyn mitään muita kriittisiä S.M.A.R.T. -attribuutteja. Tällaisia kynnyksen ylityspäivämääriä on esillä kiintolevyn S.M.A.R.T. -attribuuttien graafeissa (jos käytetään valintaa "näytä valmistajakohtaiset arvot" graafin vieressä).

Humaa: tämä metodi on luotettava vain, jos Hard Disk Sentinel analysoi jatkuvasti kiintolevyjä hyvin pitkän aikaa (tämä voi olla viikkoja tai jopa kuukausia). Toisissa tapauksissa on mahdollista tehdä virheellisä ennusteita attribuuttien pienen heikentymisen perusteella (esim. kynnyksen ylitysajankohta tulisi olemaan tammikuu 2100. Tietenkään tämä ei ole reaalista, mutta tällaisia arvoja saattaa esiintyä muissa kiintolevyjen tarkkailusovelluksissa). Tämän tilanteen välttämiseksi Hard Disk Sentinel näyttää 1000 päivää arvioidun jäljellä olevan elinajan maksimiarvoksi. Tietenkään ihanteellisessa tilanteessa tämä arvo ei vähene edes satojen päivien jälkeen.


Lämpötilan kalibrointi

Useimpiin uudenaikaisiin kiintolevyihin sisäänrakennettu lämpötila-anturi voi antaa virheellisiä tuloksia. Ero mitatun ja todellisen lämpötilan välillä voi olla 7-9 celsiusastetta tai jopa enemmän.

Tämän ongelman korjaamiseksi on mahdollista (ja suositettavaa) mitata kiintolevyn todellinen lämpötila käyttäen ulkoista infrapunalämpömittaria tai lämpötila-anturilla varustettua etupaneelia ja säätää ero mitatun lämpötilan ja Hard Disk Sentinelin näyttämän (aseman itsensä raportoiman) lämpötilan välillä lämpötilan siirtymäksi. Tätä kutsutaan kalibroinniksi.

Sen jälkeen kun lämpötila on mitattu (lämpömittarilla tai ulkoisella lämpötila-anturilla), voidaan laskea siirtymä vähentäen ohjelman raportoima arvo mitatusta arvosta. Tämä siirtymä voi olla positiivinen (ohjelma raportoi todellista alempaa lämpötilaa) tai negatiivinen (ohjelma raportoi todellista korkeampaa lämpötilaa).

Tämän siirtymän voi säätää kiintolevyn S.M.A.R.T. -sivulla attribuutin #194 (kiintolevyn lämpötila) valinnan jälkeen ja käyttäen näppäimiä + / - (napsauttaen kuvakkeiden välistä numeroa siirtymäarvon voi antaa suoraan celsiusyksikköinä).

S.M.A.R.T. attributes, details and trends

Hard Disk Sentinel ylentää (tai alentaa) automaattisesti kaikkia kiintolevyn raportoimia lämpötiloja säädetyllä siirtymäarvolla. Näin näytetään oikea (todellinen) lämpötila ja sitä käytetään kaikissa yhteyksissä (esim. tarkistettaessa kiintolevyn lämpötila kynnykseen nähden ja tallennettaessa raportteja jne.)

On suositettavaa suorittaa lämpötilan kalibrointi kaikille asennetuille kiintolevyille jos mahdollista. Saman tyyppiset kiintolevyt saattavat vaatia eri lämpötilasiirtymät.

Huomaa: ellei kalibrointi ole mahdollinen (tietokoneen koteloa ei voi avata), arviosiirtymäarvon voi määrittää tarkistamalla ensiksi näytetyn lämpötilan välittömästi tietokoneen käynnistyksen jälkeen ja vertaamalla arvoa ympäristön (huoneen, toimiston) lämpötilaan. Sillä hetkellä CPU, videokortti tai muut komponentit eivät ole liian lämpimiä eivätkä vaikuta kiintolevyn lämpötilaan. Tietysti tämä on totta vain, jos tietokoneella on ollut tarpeeksi aikaa viiletä ympäristön lämpötilaan (siinä ei ole ollut virta päällä ainakaan 8 tuntiin).

Esim. jos kiintolevyn lämpötilaksi näytetään 17 celsiusastetta (välittömästi tietokoneen käynnistyksen jälkeen) ja huoneen lämpötila on 22 celsiusastetta, +5 voidaan säätää siirtymäarvoksi (koska kiintolevy ei voi olla viileämpi kuin huoneen lämpötila). Tämä siirtymä on parempi kuin ei mitään, mutta tietenkin ulkoinen lämpömittari on tarpeen määritettäessä oikeaa lämpötilan siirtymäarvoa.

Huomaa: lämpötilan siirtymä tulee säätää celsiusyksikköinä huolimatta valitusta mittauksen lämpötilayksiköstä (Celsius tai Fahrenheit).

Huomaa: rekisteröimätön versio palauttaa automaattisesti kaikki siirtymäarvot 0:aan, kun käyttäjä käynnistää Hard Disk Sentinelin uudelleen.


S.M.A.R.T. -attribuutit

S.M.A.R.T. -attribuuttilista (ATA)

Tämä on lista kaikista tunnetuista IDE ja Serial ATA -kiintolevyjen tukemista attribuuteista. Huomaa: jotkin valmistajat voivat käyttää attribuutteja myös eri tarkoituksiin. Tässä listaamattomat attribuutit ovat "valmistajakohtaisia" attribuutteja (niiden tarkoitusta ei tunneta).

1 | Raw Read Error Rate | Raw-dataa levyltä luettaessa sattuneet virheet Viittaavat ongelmaan levyn pinnassa tai luku/kirjoituspäissä. Kriittinen attribuutti
2 | Throughput Performance | Yleinen kiintolevyn tehollinen suorituskyky Viittaa ongelmaan moottorissa, servossa tai laakereissa.
3 | Spin Up Time | Levyaseman tarvitsema aika kiihdyttää täyteen RPM:ään Viittaa ongelmaan moottorissa tai laakereissa. Kriittinen attribuutti
4 | Start/Stop Count | Levyaseman käynnistys/pysäytyssyklien määrä Tämä arvo ei suoranaisesti vaikuta aseman kuntoon.
5 | Reallocated Sector Count (Reallocated Sectors Count) | Erityisvaratulle alueelle siirrettyjen sektorien määrä Viittaa ongelmaan levyn pinnassa tai luku/kirjoituspäissä. Kriittinen attribuutti
6 | Read Channel Margin | Kanavan marginaali luettaessa dataa Tämän attribuutin tarkkaa toimintoa ei ole määritetty.
7 | Seek Error Rate | Luku/kirjoituspäiden sijoitusvirheiden määrä Viittaa ongelmaan servon tai pään kanssa. Korkea lämpötila voi myös aiheuttaa tämän ongelman.. Kriittinen attribuutti
8 | Seek Time Performance | Päiden hakutoimintojen keskimääräinen aika Viittaa ongelmaan servon kanssa. Kriittinen attribuutti
9 | Power-On Time Count | Aseman virran päälläolon kokonaisaika Mittausyksikkö riippuu valmistajasta.
10 | Spin Retry Count | Pyörimisyritysten määrä Viittaa ongelmaan moottorin, laakerien tai virtalähteen kanssa. Kriittinen attribuutti
11 | Drive Calibration Retry Count | Aseman kalibrointiyritysten määrä Viittaa ongelmaan moottorin, laakerien tai virtalähteen kanssa.
12 | Drive Power Cycle Count | Täysien virta päälle/pois-syklien määrä Tämä arvo ei suoraan vaikuta aseman kuntoon.
13 | Soft Read Error Rate | Ohjelman lukuvirheiden määrä Korjauskelvottomien lukuvirheiden määrä.
184 | End-to-End error | Pariteettivirheiden määrä siirrettäessä RAM-välimuistin ja isännän välillä.
187 | Reported Uncorrectable Errors | Virheet joita ei voitu korjata käytettäessä laitteiden virheenkorjausmenetelmiä.
188 | Command Timeout | HDD:n aikakatkaisusta johtuvien pysäytettyjen operaatioiden määrä. Nollaa suurempi arvo voi viitata virtalähde- tai datakaapeliliitosongelmiin.
189 | High Fly Writes | Epäturvallisten kirjoitusoperaatioiden määrä pään normaalin liikkumisalueen ulkopuolella.
190 | Airflow Temperature | Ilmavirran lämpötila Kiintolevyn kotelon sisäilman lämpötila.
191 | Mechanical Shock | Mekaanisten tärähdysvirheiden määrä Nopea liike (esim. putoaminen) voi aiheuttaa mekaanisen tärähdyksen.
192 | Power off Retract Cycle | Virran katkaisusyklien määrä Tämä arvo ei suoraan vaikuta aseman kuntoon.
193 | Load/Unload Cycle Count | Liike/laskeutumissyklien määrä Pään laskeutumisasemaan siirtymisistä johtuvien syklien määrä.
194 | HDD Temperature | Levyn lämpötila Kiintolevyn kotelon sisälämpötila.
195 | Hardware ECC Recovered | Korjattavissa olleiden virheiden määrä Sisäisen virheiden korjausmekanismin korjaamien virheiden määrä.
196 | Reallocation Event Count | Sektorien uudelleenmääritysoperaatioiden määrä Kaikkien (onnistuneiden ja epäonnistuneiden) uudelleenmääritysoperaatioiden määrä.. Kriittinen attribuutti
197 | Current Pending Sector Count | Epävakaiden sektorien määrä Nämä käsiteltävät sektorit voidaan uudelleenmäärittää erityisvaratulle alueelle. Kriittinen attribuutti
198 | Off-Line Uncorrectable Sector Count | Luettaessa/kirjoitettaessa havaittujen korjauskelvottomien virheiden määrä Viittaa ongelmaan levyn pinnassa tai luku/kirjoituspäissä. Critical attribute
199 | Ultra ATA CRC Error Count | Virheiden määrä siirrettäessä dataa levyn ja isännän välillä Viittaa ongelmaan virtalähteen tai datakaapelin kanssa.
200 | Write Error Rate | Raw-dataa levyltä kirjoitettaessa sattuneet virheet Viittaa ongelmaan levyn pinnassa tai luku/kirjoituspäissä.
201 | Soft Read Error Rate | Ohjelman lukuvirheiden määrä Korjauskelvottomien lukuvirheiden määrä.
202 | Data Address Mark Errors | Datan osoitemerkintävirheiden määrä Virheellisten tai kelpaamattomien osoitemerkintöjen määrä.
203 | Run Out Cancel | Datan korjausvirheiden määrä Virheitä korjattaessa havaittu kelpaamaton virheiden tarkiste.
204 | Soft ECC Correction | Korjattujen datavirheiden määrä Sisäisen virheiden korjausmekanismin korjaamat virheet.
205 | Thermal Asperity Rate | Lämpöongelmien määrä Korkean lämpötilan aiheuttamien ongelmien kokonaismäärä.
206 | Flying Height | Pään liikkeen korkeus Levypäiden korkeus levyn pinnan yläpuolella.
207 | Spin High Current | Virtateho kiihdytettäessä Aseman kiihdytykseen tarvittava virta.
208 | Spin Buzz | Kiihdytykseen tarvittavien syklien määrä Yritysten määrä kiihdytettäessä johtuen saatavissa olevan virran heikkoudesta..
209 | Offline Seek Performance | Aseman suoritusteho offline-operaatioiden aikana Aseman hakuteho sisäisten itsetestien aikana.
211 | Vibration During Write | Kirjoitusoperaatioiden aikana havaittu värinä
212 | Shock During Write | Kirjoitusoperaatioiden aikana havaittu tärinä.
220 | Disk Shift | Levyn etäisyys levyakseliin nähden on muuttunut Virheellinen levyn pyörintä voi johtua mekaanisesta tärähdyksestä tai korkeasta lämpötilasta..
221 | G-Sense Error Rate | Mekaanisten virheiden määrä Tärinästä tai värinästä johtuvien virheiden määrä.
222 | Loaded Hours | Virran päälläolon tuntimäärä Tämä arvo kasvaa jatkuvasti (kerran joka tunti).
223 | Load/Unload Retry Count | Pään liike/laskeutumisoperaatioiden määrä Aseman pään data-alueelle siirtymisten/jättämisten määrä.
224 | Load Friction | Mekaanisen hankauksen aste Mekaanisten osien välisen hankauksen aste. Viittaa ongelmaan aseman mekaanisessa alijärjestelmässä.
226 | Load-in Time | Päiden liikkeessäolon kokonaisaika Aika jolloin luku/kirjoituspäät ovat data-alueella.
227 | Torque Amplification Count | Vääntömomentin kasvun aste Vääntömomentin kasvu kiintolevyn kiihdytysoperaation aikana.
228 | Power-off Retract Count | Virran päältämenosyklien määrä Virtakatkoista johtuneiden pään vetäytymiskertojen määrä.
230 | GMR Head Amplitude | Pään sijoittumisten vaihteluväli Pään liike-etäisyydet operaatioiden välillä.
231 | Hard Disk Temperature | Levyn lämpötila Kiintolevyn kotelon sisälämpötila.
240 | Head Flying Hours | Pään sijoittumisten tuntimäärä Aseman päiden sijoittumisiin kulunut aika.
250 | Read Error Retry Rate | Yritysten määrä lukuoperaatioiden aikana Havaittujen virheiden määrä luettaessa sektoria levyn pinnasta.
254 | Free Fall Event Count | Kiihtyvyysmittarin anturin havaitsemien vapaiden putoamistapahtumien määrä.

S.M.A.R.T. -attribuuttilista (SCSI)

Tämä on lista kaikista tunnetuista SCSI -kiintolevyjen tukemista attribuuteista. Huomaa: jotkin valmistajat voivat käyttää attribuutteja myös eri tarkoituksiin. Tässä listaamattomat attribuutit ovat "valmistajakohtaisia" attribuutteja (niiden tarkoitusta ei tunneta).

01 | Puskurin yli/alivuotolaskureita
02_0000 | Ilman oleellista viivettä korjattuja kirjoitusvirheitä
02_0001 | Mahdollisin viivein korjattuja kirjoitusvirheitä
02_0002 | Yhteensä kirjoitusvirheitä
02_0003 | Yhteensä korjattuja kirjoitusvirheitä
02_0004 | Yhteensä algoritmin korjaamia kirjoitusvirheitä
02_0005 | Yhteensä kirjoitettuja tavuja
02_0006 | Yhteensä korjaamattomia kirjoitusvirheitä
03_0000 | ECC-laitemenetelmän korjaamia lukuvirheitä
03_0001 | Mahdollisin viivein korjattuja lukuvirheitä
03_0002 | Yhteensä lukuvirheitä
03_0003 | Yhteensä korjattuja lukuvirheitä
03_0004 | Yhteensä algoritmin korjaamia lukuvirheitä
03_0005 | Yhteensä luettuja tavuja
03_0006 | Yhteensä korjaamattomia lukuvirheitä
04_0000 | ECC-laitemenetelmän korjaamia read reverse -lukuvirheitä
04_0001 | Mahdollisin viivein korjattuja read reverse -lukuvirheitä
04_0002 | Yhteensä read reverse -lukuvirheitä
04_0003 | Yhteensä korjattuja read reverse -lukuvirheitä
04_0004 | Yhteensä algoritmin korjaamia read reverse -lukuvirheitä
04_0005 | Yhteensä read reverse -tavuja
04_0006 | Yhteensä korjaamattomia read reverse -virheitä
05_0000 | Todenna ilman oleellista viivettä korjatut virheet
05_0001 | Todenna mahdollisin viivein korjatut virheet
05_0002 | Yhteensä todennusvirheitä
05_0003 | Yhteensä korjattuja todennusvirheitä
05_0004 | Yhteensä algoritmin korjaamia todennusvirheitä
05_0005 | Yhteensä todennettuja tavuja
05_0006 | Yhteensä korjaamattomia todennusvirheitä
06_0000 | Ei-keskitason virheitä
07 | Viime virhetapahtuma
0B | Viime viivästynyt virhe tai tahdistamaton tapahtuma
0D_0000 | Lämpötila
0D_0001 | Vertailulämpötila
0E_0001 | Valmistuspäiväys (vuosi/viikko)
0E_0002 | Käyttöönottopäiväys
0E_0003 | Määritetty syklimäärä laitteen elinaikana
0E_0004 | Kertynyt start-stop -syklejä
0F | Sovellusavustajan parametrien data
10 | Itsetestien tulosloki
18 | Protokollakohtainen porttiloki
37_0000 | Initiaattorille lähetettyjä lohkoja
37_0001 | Initiaattorilta vastaanotettuja lohkoja
37_0002 | Välimuistista luettuja ja initiaattorille lähetettyjä lohkoja
37_0003 | Segmentin kokoa pienempiä I/O-komentoja
37_0004 | Segmentin kokoa suurempia I/O-komentoja
3E_0000 | Virran päälläoloaika
3E_0008 | Minuutteja jäljellä ennen seuraavaa sisäistä testiä


Sanallinen kuvaus

Hard Disk Sentinel analysoi levyn tarjoamat S.M.A.R.T. -attribuutit ja näitä arvioimalla luo sekä esittää sanallisen arvion. Se saattaa sisältää kiintolevyn elinaikana kohdattujen ongelmien määrän, kiihdytysongelmat, datansiirtovirheet jne. Tämän alueen väri (vihreä, keltainen, punainen) viittaa levyn kuntoon. Seuraava alue saattaa sisältää vinkkejä ongelmien korjaamiseen, joten on suositettavaa lukea yksityiskohdat.

Mikä on seuraava vaihe?

Jos levyn kuntotaso on alle 100%, se ei välttämättä merkitse katastrofia. Esitetty kuntoarvo on laskettu levyn elinaikana tähän hetkeen mennessä havaittujen kaikkien ongelmien perusteella. Kaikki sellaiset ongelmat tallentuvat levyn sisäiseen datakantaan (S.M.A.R.T. -taulukkoon) ja Hard Disk Sentinel -ohjelma lukee ja näyttää ne.

Ensimmäiseksi on todennettava, ovatko nämä ongelmat yhä ajankohtaisia - vai onko ne jo korjattu vai onko tilanne jo parantunut. Esim. jos näytetään huonoja sektoreita, kiintolevy ei käytä niitä enää ja eikä niihin ole pääsyä millään keinoin (käytössä on erityisvarattu alue ongelmallisten sektorien sijaan). Siksi pinnan skannaussovellukset (esim. scandisk) eivät näytä mitään ongelmia, koska ne testaavat myös erityisvaratun alueen (katso alempana).

Jos näytetään myös kiihdytysongelmia (joita voivat aiheuttaa huono virtalähde tai ongelmat päävirtajohdossa) ja nämä on jo korjattu (esim. virtalähde on korvattu tai asennettu UPS (Uninterruptible Power Supply)), sellaiset ongelmat eivät ole enää merkitseviä.

Tärkeintä on varmistua, onko kiintolevyn tila vakaa vai ei: miten kuntoarvo muuttuu suuren kuormituksen ja pitkäaikaisessa käytössä. Ellei kuntoarvo ole kovin korkea, mutta on vakaa (ei muutu), aiemmat ongelmat voi jättää huomiotta , koska levy ei enää käytä uudelleenvarattuja sektoreita eikä uusia huonoja/heikkoja sektoreita löydy (jos tämä sisältyy sanalliseen kuvaukseen).

Paras metodi on datalle turvallinen levyn laiteitsetesti, joka voi todentaa, onko nykyinen tilanne vakaa. Eri testit voi käynnistää valikosta Tiedosto. Kumpikin tutkii levyn komponentteja (päitä, servoa, laitteistoa, sisäistä muistia) ja laajennettu testi myös todentaa aseman koko pinta-alueen. Jos nämä testit valmistuvat ongelmitta (vaikka aseman kunto olisi alle 100%), niin tilannetta voi pitää vakaana.

Jos toinen (tai kumpikin) testi raportoi ongelmista, on suositettavaa käyttää eri metodia laajaan testaukseen. Hyvä esimerkki olisi ylikirjoittaa levyn koko pinta (ei vai suorittaa lukutesti). Tämän voi tehdä Hard Disk Sentineliin sisältyvillä pintatesteillä. Paras keino on käyttää metodia Uudelleenalusta levyn pinta, mutta muitakin testejä on käytettävissä levyn pinnan todentamiseen. Kirjoitustestit ovat parempia, koska ne voivat tehokkaasti paljastaa ja korjata ongelmia.

Jos kuntoarvo ja esitetty sanallinen kuvaus ovat vakio, eivät muutu testien jälkeen ja pitkään aikaan, nykyiset ongelmat voi tyhjätä. Näin ohjelma ei enää näytä niitä, ottaa lukuun uusia ongelmia vain tulevassa käytössä - ja siksi kunnes ongelmia havaitaan, kuntoarvoksi palautetaan 100%.
Olemassa olevien ongelmien tyhjäämiseksi avaa levyn "SMART"-sivu ja etsi mitä vain ongelmia ilmaisevat attribuutit (nämä on osoitettu merkillä !). Napsauta saraketta "Siirtymä" ja syötä negatiivinen arvo, sama jonka voit nähdä tällä rivillä sarakkeessa "Data" (ja aseman sanallisessa kuvauksessa). Esim. jos ilmoitetaan 5 uudelleenvarattua sektoria, niin määritä "-5" kyseisen attribuutin Siirtymä-sarakkeeseen. Tarkista sivulta lämpötilan kalibrointi lisätietoja siirtymien käytöstä.

Joka tapauksessa on suositettavaa tarkkailla tällaisia levyjä, etenkin jos sanallisessa kuvauksessa esitetään kaksi tai useampia ongelmia ja/tai heikkoja sektoreita. Tällainen tarkkailu saattaa paljastaa mitä vain (jopa pieniä) uusia ongelmia ja suo mahdollisuuden suorittaa varmistus sellaisissa tapauksissa. Ohjelman PRO-versio voi tehdä tämän automaattisesti.

Jos kunto on alhainen mutta yli 0 %, ei ole mahdollista pyytää korvausta takuuehtojen puitteissa. Tässä vaiheessa (huolimatta nykyisestä kunnosta tai testituloksista) levyllä lienee "liian vähän" ongelmia valmistajan näkökulmasta - joten yleensä he kieltäytyvät takuukorvauksesta.
Yleisesti katsoen takuukorvaus on mahdollinen vain, jos ongelmien määrä on suurempi ja saavuttaa valmistajan määrittämän kynnystason. Tällöin kunto putoaa 0 %:iin.

Tärkeää tietää että rasitustestaus (ja etekin laitetestit) saattaa kohottaa esiin lisää ongelmia ja voi näin alentaa lisää kuntoa.

On ehkä mahdollista käyttää valmistajan tuottamaa testisovellusta todentamaan levyn tila. On tärkeää tietää, että jotkin näistä eivät tosiasiassa korjaa, vaan ainoastaan kätkevät ongelmia, jotka voivat ilmaantua uudelleen myöhemmässä käytössä. Siksi on erittäin suositettavaa jatkuvasti tarkkailla levyä sen jälkeen, kun valmistajan testisovellus on suorittanut tehtävän - etenkin jos kuntoarvo muuttuu mihin suuntaan tahansa.

Huonot sektorit?

Mikä on "huono sektori"? Miten niitä syntyy ja miten ne voi korjata? Käyttäjät ovat ymmällään, koska levyn pinnan todennus ohjelmalla (esim. käyttäen Windows Scandiskia) ei raportoi mistään ongelmista tai huonoista sektoreista.

S.M.A.R.T. analysoi jatkuvasti levyn pintaa normaalien toimintojen aikana. Jos se löytää ongelmallisen alueen (yhden tai useamman sektorin mistä dataa on vaikea lukea tai kirjoittaa), se yrittää lukea datan ja kopioida sen (uudelleenvarata) erityisvaratulle alueelle. Alkuperäinen sijainti merkitään sitten (sisäisesti) huonoksi ja kaikki myöhemmät alkuperäiseen sijaintiin osoittavat luku/kirjoitustoiminnot uudelleenohjataan erityisvaratulle alueelle.

Kun operaatio on valmis, alkuperäinen (huono) alue on tämän jälkeen ohjelmien saavuttamattomissa. Edes uudelleenasennus tai täydellinen uudelleenalustus eivät aiheuta ongelmia, koska alkuperäistä huonoa aluetta ei enää käytetä. Siksi ohjelmat (esim. Windows' Scandisk) eivät löydä ongelmallisia sektoreita. Vain laitteiston turvapyyhintätoiminto pääsee tälle alueelle (myös tyhjäämään nämä sektorit).

Siksi esim. DOS:in "format"-komento ei koskaan ilmoita huonoista sektoreista useimmilla uudenaikaisilla kiintolevyillä johtuen S.M.A.R.T. -toiminnoista (paitsi jos erityisvarattu alue on täysi, mutta on todella vaikea löytää sellaista kiintolevyä).

Sektorien uudelleenvaraus voi tapahtua joidenkin virheiden kera tai ilman (kiintolevyt toimivat nykyään paljon paremmin verrattuna vanhempiin malleihin), mutta uudelleenvarausproseduuri saattaa aiheuttaa järjestelmän epävakautta, jos se vie liikaa aikaa.

Käyttäjän ei tulisi huomata mitään yllä kuvatuista vaiheista - vasta kun huonojen sektorien määrä on kyllin suuri (kynnys saavutettu) ja silloin S.M.A.R.T. ennustaa mahdollista vauriota.

Hyvin vähäinen naarmu tai pölyhiukkanen levyn pinnalla voi aikaansaada joitain huonoja sektoreita. Yleensä jos huonojen sektorien määrä on pieni, ne eivät aiheuta isoja ongelmia, mutta jos niiden määrä lisääntyy jatkuvasti (esitetty kuntoarvo alenee), nämä voivat johtaa vaurioon. Sinun on suositettavaa tarkkailla kiintolevyäsi jatkuvasti, jos sen kunto ei ole täydet 100%.

Kiintolevytesti

On suositettavaa aika ajoin analysoida ja todentaa levyn kuntotila (etenkin ellei kiintolevyn kunto ole täydellinen, vaan on alle 100%). Paras metodi on käynnistää laitetoiminen Laajennettu itsetesti, joka voi analysoida kiintolevyn komponentit ja koko pinnan. Muut (ohjelmalliset) testit eivät pysty testaamaan kiintolevyä yhtä yksityiskohtaisesti. Tämän (ja muut tuetut laitetestit) voi käynnistää manuaalisesti sivulta Tiedot tai automaattisesti (ajoitetusti) sivulta Operaatiot (vain Professional-versiossa).